ProcessFlowDebugRun Methods

The methods of the ProcessFlowDebugRun class are listed below. For a complete list of ProcessFlowDebugRun class members, see the ProcessFlowDebugRun Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | This method must be called before any other member of the class is accessed
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnFormLoad | This method handles the Form's Load Event and can be overriden by sub-classes as required
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugRun.ApplySkin Method

protected virtual void ApplySkin();

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugRun.Config Method

This method must be called before any other member of the class is accessed

public virtual void Config(
AptifyApplication Application,
Int64 ProcessFlowID,
Boolean HideProcessFlowField
);

Parameters

Application
ProcessFlowID
HideProcessFlowField

Remarks

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugRun.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugRun.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowDebugRun.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugRun.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugRun.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowDebugRun.DoAction Overload List


ProcessFlowDebugRun.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowDebugRun.DoAction Overload List


ProcessFlowDebugRun.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowDebugRun.DoAction Overload List


ProcessFlowDebugRun.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowDebugRun.DoAction Overload List


ProcessFlowDebugRun.OnFormLoad Method

This method handles the Form's Load Event and can be overriden by sub-classes as required

protected virtual void OnFormLoad(
Object sender,
EventArgs e
);

Parameters

sender
e

Remarks

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowEngine Class

Aptify Process Flow Engine Component - This class is the base class for executing any process flow defined in Aptify meta-data.

For a list of all members of this type, see ProcessFlowEngine Members.

System.Object
ProcessFlowEngine

public class ProcessFlowEngine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessFlowEngine Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowEngine Members

ProcessFlowEngine overview

Public Static Fields

DefaultComponentResultCode_Failure
DefaultComponentResultCode_Success

Public Static Methods

ClearCache | This method clears the cache. Use this method in debug environments where it is necessary to ensure that cached versions of a process flow are not being executed.
ExecuteProcessFlow | Overloaded. Executes a process flow synchronously
ExecuteProcessFlowRun | Overloaded.
ReplaceStringMarkup | Overloaded.

Public Instance Constructors

ProcessFlowEngine Constructor Initializes a new instance of the ProcessFlowEngine class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowEngine Constructor

Initializes a new instance of the ProcessFlowEngine class.

public ProcessFlowEngine();

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowEngine Fields

The fields of the ProcessFlowEngine class are listed below. For a complete list of ProcessFlowEngine class members, see the ProcessFlowEngine Members topic.

Public Static Fields

DefaultComponentResultCode_Failure
DefaultComponentResultCode_Success

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowEngine.DefaultComponentResultCode_Failure Field

public const DefaultComponentResultCode_Failure DefaultComponentResultCode_Failure = "FAILED";

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowEngine.DefaultComponentResultCode_Success Field

public const DefaultComponentResultCode_Success DefaultComponentResultCode_Success = "SUCCESS";

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowEngine Methods

The methods of the ProcessFlowEngine class are listed below. For a complete list of ProcessFlowEngine class members, see the ProcessFlowEngine Members topic.

Public Static Methods

ClearCache | This method clears the cache. Use this method in debug environments where it is necessary to ensure that cached versions of a process flow are not being executed.
ExecuteProcessFlow | Overloaded. Executes a process flow synchronously
ExecuteProcessFlowRun | Overloaded.
ReplaceStringMarkup | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowEngine.ClearCache Method

This method clears the cache. Use this method in debug environments where it is necessary to ensure that cached versions of a process flow are not being executed.

public static void ClearCache();

Remarks

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ExecuteProcessFlow Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowEngine.ExecuteProcessFlow Method

Executes a process flow synchronously

Overload List

Executes a process flow synchronously

public static ProcessFlowResult ExecuteProcessFlow(AptifyApplication,Int64);

public static ProcessFlowResult ExecuteProcessFlow(AptifyApplication,Int64,AptifyContext);

public static ProcessFlowResult ExecuteProcessFlow(AptifyApplication,Int64,AptifyContext,Boolean);

Executes a process flow synchronously

public static ProcessFlowResult ExecuteProcessFlow(AptifyApplication,Int64,ProcessFlowDebugInfo);

Executes a process flow synchronously

public static ProcessFlowResult ExecuteProcessFlow(AptifyApplication,Int64,ProcessFlowDebugInfo,AptifyContext);

Executes a process flow synchronously

public static ProcessFlowResult ExecuteProcessFlow(AptifyApplication,Int64,ProcessFlowDebugInfo,AptifyContext,Boolean);

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowEngine.ExecuteProcessFlow Method (AptifyApplication, Int64)

Executes a process flow synchronously

public static ProcessFlowResult ExecuteProcessFlow(
AptifyApplication Application,
Int64 ProcessFlowID
);

Parameters

Application
ProcessFlowID

Return Value

Remarks

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowEngine.ExecuteProcessFlow Overload List


ProcessFlowEngine.ExecuteProcessFlow Method (AptifyApplication, Int64, AptifyContext)

public static ProcessFlowResult ExecuteProcessFlow(
AptifyApplication Application,
Int64 ProcessFlowID,
AptifyContext Context
);

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowEngine.ExecuteProcessFlow Overload List


ProcessFlowEngine.ExecuteProcessFlow Method (AptifyApplication, Int64, AptifyContext, Boolean)

public static ProcessFlowResult ExecuteProcessFlow(
AptifyApplication Application,
Int64 ProcessFlowID,
AptifyContext Context,
Boolean ForceSynchronousExecution
);

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowEngine.ExecuteProcessFlow Overload List


ProcessFlowEngine.ExecuteProcessFlow Method (AptifyApplication, Int64, ProcessFlowDebugInfo)

Executes a process flow synchronously

public static ProcessFlowResult ExecuteProcessFlow(
AptifyApplication Application,
Int64 ProcessFlowID,
ProcessFlowDebugInfo DebugInfo
);

Parameters

Application
ProcessFlowID
DebugInfo
This parameter refers to an instance of ProcessFlowDebugInfo class which can be used to set the state of debug data for a given process flow execution.

Return Value

Remarks

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowEngine.ExecuteProcessFlow Overload List


ProcessFlowEngine.ExecuteProcessFlow Method (AptifyApplication, Int64, ProcessFlowDebugInfo, AptifyContext)

Executes a process flow synchronously

public static ProcessFlowResult ExecuteProcessFlow(
AptifyApplication Application,
Int64 ProcessFlowID,
ProcessFlowDebugInfo DebugInfo,
AptifyContext Context
);

Parameters

Application
ProcessFlowID
DebugInfo
This parameter refers to an instance of ProcessFlowDebugInfo class which can be used to set the state of debug data for a given process flow execution.
Context

Return Value

Remarks

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowEngine.ExecuteProcessFlow Overload List


ProcessFlowEngine.ExecuteProcessFlow Method (AptifyApplication, Int64, ProcessFlowDebugInfo, AptifyContext, Boolean)

Executes a process flow synchronously

public static ProcessFlowResult ExecuteProcessFlow(
AptifyApplication Application,
Int64 ProcessFlowID,
ProcessFlowDebugInfo DebugInfo,
AptifyContext Context,
Boolean ForceSynchronousExecution
);

Parameters

Application
ProcessFlowID
DebugInfo
This parameter refers to an instance of ProcessFlowDebugInfo class which can be used to set the state of debug data for a given process flow execution.
Context
ForceSynchronousExecution

Return Value

Remarks

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowEngine.ExecuteProcessFlow Overload List


ExecuteProcessFlowRun Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowEngine.ExecuteProcessFlowRun Method

Overload List

public static ProcessFlowResult ExecuteProcessFlowRun(AptifyApplication,Int64);

public static ProcessFlowResult ExecuteProcessFlowRun(AptifyApplication,Int64,ProcessFlowDebugInfo);

public static ProcessFlowResult ExecuteProcessFlowRun(AptifyApplication,Int64,ProcessFlowDebugInfo,AptifyContext);

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowEngine.ExecuteProcessFlowRun Method (AptifyApplication, Int64)

public static ProcessFlowResult ExecuteProcessFlowRun(
AptifyApplication Application,
Int64 ProcessFlowRunID
);

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowEngine.ExecuteProcessFlowRun Overload List


ProcessFlowEngine.ExecuteProcessFlowRun Method (AptifyApplication, Int64, ProcessFlowDebugInfo)

public static ProcessFlowResult ExecuteProcessFlowRun(
AptifyApplication Application,
Int64 ProcessFlowRunID,
ProcessFlowDebugInfo DebugInfo
);

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowEngine.ExecuteProcessFlowRun Overload List


ProcessFlowEngine.ExecuteProcessFlowRun Method (AptifyApplication, Int64, ProcessFlowDebugInfo, AptifyContext)

public static ProcessFlowResult ExecuteProcessFlowRun(
AptifyApplication Application,
Int64 ProcessFlowRunID,
ProcessFlowDebugInfo DebugInfo,
AptifyContext Context
);

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowEngine.ExecuteProcessFlowRun Overload List


ReplaceStringMarkup Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowEngine.ReplaceStringMarkup Method

Overload List

public static string ReplaceStringMarkup(String,AptifyContext);

public static string ReplaceStringMarkup(String,DataRow);

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowEngine.ReplaceStringMarkup Method (String, AptifyContext)

public static string ReplaceStringMarkup(
String InputString,
AptifyContext Context
);

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowEngine.ReplaceStringMarkup Overload List


ProcessFlowEngine.ReplaceStringMarkup Method (String, DataRow)

public static string ReplaceStringMarkup(
String InputString,
DataRow DataRow
);

See Also

ProcessFlowEngine Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowEngine.ReplaceStringMarkup Overload List


ProcessFlowExecutionRule Class

Class used by the Process Flow engine to determine if process flows should be executed based on a number of environmental conditions. In the event these conditions are not sufficient, the class can be extended through inheritance.

For a list of all members of this type, see ProcessFlowExecutionRule Members.

System.Object
ProcessFlowExecutionRule

public class ProcessFlowExecutionRule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessFlowExecutionRule Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule Members

ProcessFlowExecutionRule overview

Public Instance Constructors

ProcessFlowExecutionRule Constructor Initializes a new instance of the ProcessFlowExecutionRule class.

Public Instance Properties

ErrorDescription | Property used to return a description of errors encountered during the rule check.
ResultReason | Property used to return an error condition type that represents a number of specific failure types.

Public Instance Methods

CanExecuteProcessFlow | Method called to determine the availability of a process flow based on a number of environmental conditions.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetConnectionState | Method used to configure the connection state object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_ConnState
m_ErrorDescription
m_Results

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetPermissions | Protected method used to determine the process flow permissions for a user.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule Constructor

Initializes a new instance of the ProcessFlowExecutionRule class.

public ProcessFlowExecutionRule();

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule Fields

The fields of the ProcessFlowExecutionRule class are listed below. For a complete list of ProcessFlowExecutionRule class members, see the ProcessFlowExecutionRule Members topic.

Protected Instance Fields

m_ConnState
m_ErrorDescription
m_Results

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule.m_ConnState Field

protected m_ConnState m_ConnState;

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule.m_ErrorDescription Field

protected m_ErrorDescription m_ErrorDescription;

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule.m_Results Field

protected m_Results m_Results;

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule Properties

The properties of the ProcessFlowExecutionRule class are listed below. For a complete list of ProcessFlowExecutionRule class members, see the ProcessFlowExecutionRule Members topic.

Public Instance Properties

ErrorDescription | Property used to return a description of errors encountered during the rule check.
ResultReason | Property used to return an error condition type that represents a number of specific failure types.

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ErrorDescription Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowExecutionRule.ErrorDescription Property

Property used to return a description of errors encountered during the rule check.

public virtual String ErrorDescription {get;}

Property Value

Remarks

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ResultReason Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowExecutionRule.ResultReason Property

Property used to return an error condition type that represents a number of specific failure types.

public virtual ProcessFlowExecutionRule.ExecutionRuleResultReasons ResultReason {get;}

Property Value

Remarks

Errors in this sense do not represent system exceptions as such. They represent specific conditions which were encountered.

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule Methods

The methods of the ProcessFlowExecutionRule class are listed below. For a complete list of ProcessFlowExecutionRule class members, see the ProcessFlowExecutionRule Members topic.

Public Instance Methods

CanExecuteProcessFlow | Method called to determine the availability of a process flow based on a number of environmental conditions.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetConnectionState | Method used to configure the connection state object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetPermissions | Protected method used to determine the process flow permissions for a user.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule.CanExecuteProcessFlow Method

Method called to determine the availability of a process flow based on a number of environmental conditions.

public virtual ExecutionRuleResults CanExecuteProcessFlow(
AptifyApplication Application,
Int64 ProcessFlowID,
Int64 UserID,
AptifyContext Context
);

Parameters

Application
ProcessFlowID
The ID of the process flow.
UserID
The ID of the current user.
Context
The context object representing the current context of the process flow execution.

Return Value

Remarks

This method is overriden when extended rulesets are desired by the specifics of the implementation.

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule.GetPermissions Method

Protected method used to determine the process flow permissions for a user.

protected virtual PermissionTypes GetPermissions(
Int64 ProcessFlowID,
Int64 UserID
);

Parameters

ProcessFlowID
The ID of the process flow.
UserID
The Aptify User ID to validate permissions on.

Remarks

No base implementation is provided.

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule.SetConnectionState Method

Method used to configure the connection state object.

public virtual void SetConnectionState(
UserCredentials UserCredentials
);

Parameters

UserCredentials
User Credentials object used to confugire the Connection State Object.

Remarks

See Also

ProcessFlowExecutionRule Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule.ExecutionRuleResultReasons Enumeration

Defines a set of known failure results.

public enum ProcessFlowExecutionRule.ExecutionRuleResultReasons

Remarks

Members

Member Name | Description
NoFailure | None specified.
Permissions | The failure occurred as a result of permissions.
ConnectionState | The failure occurred as a result of the current connection state.
Custom | The failure occurred as a result of a custom rule implemented by a subclass.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule.ExecutionRuleResults Enumeration

Defines a set of results to be used by the process flow engine in determining how to execute a process flow.

public enum ProcessFlowExecutionRule.ExecutionRuleResults

Remarks

In cases where the resulting value No, the programmer should query the ErrorString property to obtain any resultant errors from the object.

Members

Member Name | Description
YesSyncAndAsync | Indicates that the process flow can be executed in either synchronous or asynchronous mode.
YesAsyncOnly | Indicates that the process flow can be executed in asynchronous mode only.
NoWithFailover | Indicates that the process flow cannot be executed. However, a failover process flow has been defined. The programmer should query the FailoverProcessFlowID property to obtain the proper failover process flow.
No | Indicates that the process flow cannot be executed.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowExecutionRule.PermissionTypes Enumeration

Defines a set characteristics of a user's ability to execute the process flow.

public enum ProcessFlowExecutionRule.PermissionTypes

Remarks

Members

Member Name | Description
CanExecuteSync | Current user can execute this process flow synchronously.
CanExecuteAsync | Current user can execute this process flow asynchronously, only.
CanExecuteSyncAndAsync | Current user can execute this process flow both synchronously and asynchronously.
CannotExecute | Current user cannot execute this process flow.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowResult Structure

The result of a Process Flow run.

For a list of all members of this type, see ProcessFlowResult Members.

System.Object
ValueType
ProcessFlowResult

public struct ProcessFlowResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessFlowResult Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowResult Members

ProcessFlowResult overview

Public Instance Fields

IsSuccess | Boolean result of the process flow.
ResultCode | The string based representation of the Process Flow's result.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ProcessFlowResult Structure | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowResult Fields

The fields of the ProcessFlowResult structure are listed below. For a complete list of ProcessFlowResult structure members, see the ProcessFlowResult Members topic.

Public Instance Fields

IsSuccess | Boolean result of the process flow.
ResultCode | The string based representation of the Process Flow's result.

See Also

ProcessFlowResult Structure | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowResult.IsSuccess Field

Boolean result of the process flow.

public IsSuccess IsSuccess;

Remarks

This will be true if the result is considered a successfull result in the overall context of the Process Flow. This will be false if the result can be considered a failure.

See Also

ProcessFlowResult Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowResult.ResultCode Field

The string based representation of the Process Flow's result.

public ResultCode ResultCode;

Remarks

See Also

ProcessFlowResult Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowsEntity Class

For a list of all members of this type, see ProcessFlowsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ProcessFlowsEntity

public class ProcessFlowsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessFlowsEntity Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowsEntity Members

ProcessFlowsEntity overview

Public Instance Constructors

ProcessFlowsEntity Constructor Initializes a new instance of the ProcessFlowsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Overrides the GE's Save method to remove the Process Pipeline's Info from the InfoCache
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ProcessFlowsEntity Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowsEntity Constructor

Initializes a new instance of the ProcessFlowsEntity class.

public ProcessFlowsEntity();

See Also

ProcessFlowsEntity Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowsEntity Methods

The methods of the ProcessFlowsEntity class are listed below. For a complete list of ProcessFlowsEntity class members, see the ProcessFlowsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Overrides the GE's Save method to remove the Process Pipeline's Info from the InfoCache
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ProcessFlowsEntity Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowsEntity.Save Method

Overrides the GE's Save method to remove the Process Pipeline's Info from the InfoCache

Overload List

Overrides the GE's Save method to remove the Process Pipeline's Info from the InfoCache

public override bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Inherited from AptifyGenericEntity.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ProcessFlowsEntity Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowsEntity.Save Method ()

Overrides the GE's Save method to remove the Process Pipeline's Info from the InfoCache

public override bool Save();

Return Value

Remarks

See Also

ProcessFlowsEntity Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowsEntity.Save Overload List


ProcessFlowUnsuccessful Class

For a list of all members of this type, see ProcessFlowUnsuccessful Members.

System.Object
Exception
ApplicationException
BaseApplicationException
ProcessPipeLineException
ProcessFlowUnsuccessful

public class ProcessFlowUnsuccessful : ProcessPipeLineException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessFlowUnsuccessful Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowUnsuccessful Members

ProcessFlowUnsuccessful overview

Public Instance Constructors

ProcessFlowUnsuccessful Overloaded. Initializes a new instance of the ProcessFlowUnsuccessful class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
ProcessFlowID |
ProcessStepID |
ResultCode |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowUnsuccessful Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowUnsuccessful Constructor

Overload List

public ProcessFlowUnsuccessful(SerializationInfo,StreamingContext);

public ProcessFlowUnsuccessful(String,Int64,Int64,String);

public ProcessFlowUnsuccessful(String,Int64,Int64,String,Exception);

See Also

ProcessFlowUnsuccessful Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowUnsuccessful Constructor (String, Int64, Int64, String)

public ProcessFlowUnsuccessful(
String Message,
Int64 ProcessFlowID,
Int64 ProcessStepID,
String ResultCode
);

See Also

ProcessFlowUnsuccessful Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowUnsuccessful Constructor Overload List


ProcessFlowUnsuccessful Constructor (String, Int64, Int64, String, Exception)

public ProcessFlowUnsuccessful(
String Message,
Int64 ProcessFlowID,
Int64 ProcessStepID,
String ResultCode,
Exception InnerException
);

See Also

ProcessFlowUnsuccessful Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowUnsuccessful Constructor Overload List


ProcessFlowUnsuccessful Constructor (SerializationInfo, StreamingContext)

public ProcessFlowUnsuccessful(
SerializationInfo Info,
StreamingContext Context
);

See Also

ProcessFlowUnsuccessful Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowUnsuccessful Constructor Overload List


ProcessFlowUnsuccessful Properties

The properties of the ProcessFlowUnsuccessful class are listed below. For a complete list of ProcessFlowUnsuccessful class members, see the ProcessFlowUnsuccessful Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
ProcessFlowID |
ProcessStepID |
ResultCode |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ProcessFlowUnsuccessful Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowUnsuccessful.ProcessFlowID Property

public Int64 ProcessFlowID {get;}

See Also

ProcessFlowUnsuccessful Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessStepID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowUnsuccessful.ProcessStepID Property

public Int64 ProcessStepID {get;}

See Also

ProcessFlowUnsuccessful Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ResultCode Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowUnsuccessful.ResultCode Property

public String ResultCode {get;}

See Also

ProcessFlowUnsuccessful Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowUnsuccessful Methods

The methods of the ProcessFlowUnsuccessful class are listed below. For a complete list of ProcessFlowUnsuccessful class members, see the ProcessFlowUnsuccessful Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowUnsuccessful Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowUnsuccessful.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

ProcessFlowUnsuccessful Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessPipeLineException Class

For a list of all members of this type, see ProcessPipeLineException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
ProcessPipeLineException
ProcessEngineException
ProcessFlowCompileException
ProcessFlowUnsuccessful

public class ProcessPipeLineException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessPipeLineException Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessPipeLineException Members

ProcessPipeLineException overview

Public Instance Constructors

ProcessPipeLineException Overloaded. Initializes a new instance of the ProcessPipeLineException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessPipeLineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessPipeLineException Constructor

Overload List

public ProcessPipeLineException(SerializationInfo,StreamingContext);

public ProcessPipeLineException(String);

public ProcessPipeLineException(String,Exception);

See Also

ProcessPipeLineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessPipeLineException Constructor (String)

public ProcessPipeLineException(
String Message
);

See Also

ProcessPipeLineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessPipeLineException Constructor Overload List


ProcessPipeLineException Constructor (String, Exception)

public ProcessPipeLineException(
String Message,
Exception InnerException
);

See Also

ProcessPipeLineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessPipeLineException Constructor Overload List


ProcessPipeLineException Constructor (SerializationInfo, StreamingContext)

public ProcessPipeLineException(
SerializationInfo Info,
StreamingContext Context
);

See Also

ProcessPipeLineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessPipeLineException Constructor Overload List


ResultCode Class

This class is used to get the result of Script based Steps.

For a list of all members of this type, see ResultCode Members.

System.Object
ResultCode

public class ResultCode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ResultCode Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ResultCode Members

ResultCode overview

Public Instance Constructors

ResultCode Constructor Initializes a new instance of the ResultCode class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ResultCode Constructor

Initializes a new instance of the ResultCode class.

public ResultCode();

See Also

ResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ResultCode Properties

The properties of the ResultCode class are listed below. For a complete list of ResultCode class members, see the ResultCode Members topic.

Public Instance Properties

Value

See Also

ResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

ResultCode.Value Property

public Object Value {get; set;}

See Also

ResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SaveGEObject Class

For a list of all members of this type, see SaveGEObject Members.

System.Object
GenericCRUDBase
SaveGEObject

public class SaveGEObject : GenericCRUDBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: EntityCRUDProcessComponents (in EntityCRUDProcessComponents.dll)

See Also

SaveGEObject Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SaveGEObject Members

SaveGEObject overview

Public Instance Constructors

SaveGEObject Constructor Initializes a new instance of the SaveGEObject class.

Public Instance Properties

EntityName (inherited from GenericCRUDBase) | This member returns the name of the entity being operated upon by the component instance
ParentGE (inherited from GenericCRUDBase) | This property is a strongly typed return for the ParentGEObject (or ParentGE) property in the AptifyProperties context object for this control. This member returns the ParentGE object.
ProcessComponentID (inherited from GenericCRUDBase) | Returns the Process Component ID in use for the current instance of the class
Properties (inherited from GenericCRUDBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config (inherited from GenericCRUDBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType (inherited from GenericCRUDBase) | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application (inherited from GenericCRUDBase) | Aptify Application Object
InitData (inherited from GenericCRUDBase) | This method returns the InitData string for processing as required by ParseInitData() or other methods.
InitDataItems (inherited from GenericCRUDBase) | This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".
InitDataXMLDoc (inherited from GenericCRUDBase) | This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.
SaveRecordProperty (inherited from GenericCRUDBase) | This member provides a type-specific access for reading the value of the Save Record Input Property for the Process Flow Step. The Save Record Input Property has two possible values in the Process Flow meta-data, Yes and No as text strings. This member translates those text values to Boolean type values as a utility for functionality that requires checks against this process flow input property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject (inherited from GenericCRUDBase) | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from GenericCRUDBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields (inherited from GenericCRUDBase) | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

SaveGEObject Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SaveGEObject Constructor

Initializes a new instance of the SaveGEObject class.

public SaveGEObject();

See Also

SaveGEObject Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SaveGEObject Methods

The methods of the SaveGEObject class are listed below. For a complete list of SaveGEObject class members, see the SaveGEObject Members topic.

Public Instance Methods

Config (inherited from GenericCRUDBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType (inherited from GenericCRUDBase) | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject (inherited from GenericCRUDBase) | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from GenericCRUDBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields (inherited from GenericCRUDBase) | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

SaveGEObject Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SaveGEObject.Run Method

public override string Run();

Implements

IProcessComponent.

See Also

SaveGEObject Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SingleStepView Class

For a list of all members of this type, see SingleStepView Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
SingleStepView

public class SingleStepView : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: ProcessFlowDebugHarness (in ProcessFlowDebugHarness.dll)

See Also

SingleStepView Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SingleStepView Members

SingleStepView overview

Public Instance Constructors

SingleStepView Constructor Initializes a new instance of the SingleStepView class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
LoadStep |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SingleStepView Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SingleStepView Constructor

Initializes a new instance of the SingleStepView class.

public SingleStepView();

See Also

SingleStepView Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SingleStepView Properties

The properties of the SingleStepView class are listed below. For a complete list of SingleStepView class members, see the SingleStepView Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SingleStepView Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

SingleStepView.UserCredentials Property

public UserCredentials UserCredentials {get; set;}

See Also

SingleStepView Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SingleStepView Methods

The methods of the SingleStepView class are listed below. For a complete list of SingleStepView class members, see the SingleStepView Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
LoadStep |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SingleStepView Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SingleStepView.ApplySkin Method

protected virtual void ApplySkin();

See Also

SingleStepView Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SingleStepView.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SingleStepView Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SingleStepView.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SingleStepView Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | SingleStepView.Dispose Overload List


SingleStepView.LoadStep Method

public void LoadStep(
ProcessFlowDebugInfo.StepExecutionLog StepInfo
);

See Also

SingleStepView Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepLog Class

For a list of all members of this type, see StepLog Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
StepLog

public class StepLog : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: ProcessFlowDebugHarness (in ProcessFlowDebugHarness.dll)

See Also

StepLog Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepLog Members

StepLog overview

Public Instance Constructors

StepLog Constructor Initializes a new instance of the StepLog class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StepLog |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadLog |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StepLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepLog Constructor

Initializes a new instance of the StepLog class.

public StepLog();

See Also

StepLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepLog Properties

The properties of the StepLog class are listed below. For a complete list of StepLog class members, see the StepLog Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StepLog |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

StepLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepLog Property

Aptify 5.0 Software Development Kit (SDK)

StepLog.StepLog Property

public virtual List<T> StepLog {get;}

See Also

StepLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

StepLog.UserCredentials Property

public UserCredentials UserCredentials {get; set;}

See Also

StepLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepLog Methods

The methods of the StepLog class are listed below. For a complete list of StepLog class members, see the StepLog Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadLog |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StepLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepLog.ApplySkin Method

protected virtual void ApplySkin();

See Also

StepLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

StepLog.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

StepLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepLog.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

StepLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | StepLog.Dispose Overload List


StepLog.LoadLog Method

public void LoadLog(
List<T> StepLog
);

See Also

StepLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepLog.Refresh Method

public override void Refresh();

See Also

StepLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueCheckerBase Class

Base class for Aptify Generic Value Retriever and Value Tester Process Components

For a list of all members of this type, see ValueCheckerBase Members.

System.Object
ValueCheckerBase
ValueRetriever

public class ValueCheckerBase : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: ValueCheckerProcessComponents (in ValueCheckerProcessComponents.dll)

See Also

ValueCheckerBase Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueCheckerBase Members

ValueCheckerBase overview

Public Instance Constructors

ValueCheckerBase Constructor Initializes a new instance of the ValueCheckerBase class.

Public Instance Properties

Application | Aptify Application Object
DataAction | Aptify DataAction Object
Properties | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueCheckerBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueCheckerBase Constructor

Initializes a new instance of the ValueCheckerBase class.

public ValueCheckerBase();

See Also

ValueCheckerBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueCheckerBase Properties

The properties of the ValueCheckerBase class are listed below. For a complete list of ValueCheckerBase class members, see the ValueCheckerBase Members topic.

Public Instance Properties

Application | Aptify Application Object
DataAction | Aptify DataAction Object
Properties | Aptify Properties Collection used for Input and Output Properties for the component.

See Also

ValueCheckerBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ValueCheckerBase.Application Property

Aptify Application Object

public virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

ValueCheckerBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

ValueCheckerBase.DataAction Property

Aptify DataAction Object

public virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

ValueCheckerBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

ValueCheckerBase.Properties Property

Aptify Properties Collection used for Input and Output Properties for the component.

public virtual AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

ValueCheckerBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueCheckerBase Methods

The methods of the ValueCheckerBase class are listed below. For a complete list of ValueCheckerBase class members, see the ValueCheckerBase Members topic.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueCheckerBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueCheckerBase.Config Method

This method must be called before any other member of this class is accessed

public virtual void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

ValueCheckerBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueCheckerBase.Run Method

public abstract string Run();

Implements

IProcessComponent.

See Also

ValueCheckerBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueRetriever Class

This class is used to retrieve values from either a GE object or from an entity, or the context object. Simply provide the Entity Object or Entity Name and Record ID, and provide the field name to be retrieved and the value will be returned as the RESULT CODE for the component

For a list of all members of this type, see ValueRetriever Members.

System.Object
ValueCheckerBase
ValueRetriever
ValueTester

public class ValueRetriever : ValueCheckerBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: ValueCheckerProcessComponents (in ValueCheckerProcessComponents.dll)

See Also

ValueRetriever Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueRetriever Members

ValueRetriever overview

Public Instance Constructors

ValueRetriever Constructor Initializes a new instance of the ValueRetriever class.

Public Instance Properties

Application (inherited from ValueCheckerBase) | Aptify Application Object
DataAction (inherited from ValueCheckerBase) | Aptify DataAction Object
Properties (inherited from ValueCheckerBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config (inherited from ValueCheckerBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Process Component Input Properties 1) Mode - Either Database, GEObject, or Value, defaults to Database 2) GEObject - Only used if Mode=GEObject 3) EntityName - only used if Mode=Database 4) RecordID - only used if Mode=Database 5) FieldName - name of field in the entity to return as the RESULT CODE. Used when Mode=GEObject and Mode=Database. 6) UseOldValue - Optional - If set to 0(default), the object returns the current value. If set to 1, returns the last prior value, ONLY available when Mode=GEObject and when the object is called before a save occurs. 7) Value - Used only if Mode=Value - bypasses using GE or Database and just checks a known value in the context object. 8) ResultCodeMode - Optional - Two possible settings - "Value" or "Success/Failed". If set to Value, the actual value retrieved is returned, otherwise SUCCESS or FAILED is returned and the value can be obtained from the output property. Defaults to Value Output Properties 1) FieldValue - This output property will contain the value requested. This process component returns the value requested as a result code and also returns it as an output property called FieldValue
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DoDatabase | This method handles the database lookup side of the logic
DoGEObject | This method handles the GE object side of the logic
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueRetriever Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueRetriever Constructor

Initializes a new instance of the ValueRetriever class.

public ValueRetriever();

See Also

ValueRetriever Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueRetriever Methods

The methods of the ValueRetriever class are listed below. For a complete list of ValueRetriever class members, see the ValueRetriever Members topic.

Public Instance Methods

Config (inherited from ValueCheckerBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Process Component Input Properties 1) Mode - Either Database, GEObject, or Value, defaults to Database 2) GEObject - Only used if Mode=GEObject 3) EntityName - only used if Mode=Database 4) RecordID - only used if Mode=Database 5) FieldName - name of field in the entity to return as the RESULT CODE. Used when Mode=GEObject and Mode=Database. 6) UseOldValue - Optional - If set to 0(default), the object returns the current value. If set to 1, returns the last prior value, ONLY available when Mode=GEObject and when the object is called before a save occurs. 7) Value - Used only if Mode=Value - bypasses using GE or Database and just checks a known value in the context object. 8) ResultCodeMode - Optional - Two possible settings - "Value" or "Success/Failed". If set to Value, the actual value retrieved is returned, otherwise SUCCESS or FAILED is returned and the value can be obtained from the output property. Defaults to Value Output Properties 1) FieldValue - This output property will contain the value requested. This process component returns the value requested as a result code and also returns it as an output property called FieldValue
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DoDatabase | This method handles the database lookup side of the logic
DoGEObject | This method handles the GE object side of the logic
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueRetriever Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueRetriever.DoDatabase Method

This method handles the database lookup side of the logic

protected virtual string DoDatabase(
String FieldName
);

Return Value

Remarks

See Also

ValueRetriever Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueRetriever.DoGEObject Method

This method handles the GE object side of the logic

protected virtual string DoGEObject(
String FieldName
);

Return Value

Remarks

See Also

ValueRetriever Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueRetriever.Run Method

Process Component Input Properties 1) Mode - Either Database, GEObject, or Value, defaults to Database 2) GEObject - Only used if Mode=GEObject 3) EntityName - only used if Mode=Database 4) RecordID - only used if Mode=Database 5) FieldName - name of field in the entity to return as the RESULT CODE. Used when Mode=GEObject and Mode=Database. 6) UseOldValue - Optional - If set to 0(default), the object returns the current value. If set to 1, returns the last prior value, ONLY available when Mode=GEObject and when the object is called before a save occurs. 7) Value - Used only if Mode=Value - bypasses using GE or Database and just checks a known value in the context object. 8) ResultCodeMode - Optional - Two possible settings - "Value" or "Success/Failed". If set to Value, the actual value retrieved is returned, otherwise SUCCESS or FAILED is returned and the value can be obtained from the output property. Defaults to Value Output Properties 1) FieldValue - This output property will contain the value requested. This process component returns the value requested as a result code and also returns it as an output property called FieldValue

public override string Run();

Return Value

The value of the FieldName process component input property

Implements

IProcessComponent.

Remarks

See Also

ValueRetriever Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueTester Class

This class is capable of testing any value against another value. It is useful for doing quick checks against database or context object values to determine workflow logic.

For a list of all members of this type, see ValueTester Members.

System.Object
ValueCheckerBase
ValueRetriever
ValueTester

public class ValueTester : ValueRetriever

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: ValueCheckerProcessComponents (in ValueCheckerProcessComponents.dll)

See Also

ValueTester Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueTester Members

ValueTester overview

Public Instance Constructors

ValueTester Constructor Initializes a new instance of the ValueTester class.

Public Instance Properties

Application (inherited from ValueCheckerBase) | Aptify Application Object
DataAction (inherited from ValueCheckerBase) | Aptify DataAction Object
Properties (inherited from ValueCheckerBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

CompareDateTimeValues | This method compares the two provided numeric values and returns either TRUE or FALSE
CompareNumericValues | This method compares the two provided numeric values and returns either TRUE or FALSE
CompareTextValues | This method compares the two provided text values and returns either TRUE or FALSE
Config (inherited from ValueCheckerBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CompareValues |
DoDatabase (inherited from ValueRetriever) | This method handles the database lookup side of the logic
DoGEObject (inherited from ValueRetriever) | This method handles the GE object side of the logic
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDataType | This method determines the data type of the current field being tested and returns it
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueTester Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueTester Constructor

Initializes a new instance of the ValueTester class.

public ValueTester();

See Also

ValueTester Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueTester Methods

The methods of the ValueTester class are listed below. For a complete list of ValueTester class members, see the ValueTester Members topic.

Public Instance Methods

CompareDateTimeValues | This method compares the two provided numeric values and returns either TRUE or FALSE
CompareNumericValues | This method compares the two provided numeric values and returns either TRUE or FALSE
CompareTextValues | This method compares the two provided text values and returns either TRUE or FALSE
Config (inherited from ValueCheckerBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CompareValues |
DoDatabase (inherited from ValueRetriever) | This method handles the database lookup side of the logic
DoGEObject (inherited from ValueRetriever) | This method handles the GE object side of the logic
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDataType | This method determines the data type of the current field being tested and returns it
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueTester Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueTester.CompareDateTimeValues Method

This method compares the two provided numeric values and returns either TRUE or FALSE

public virtual string CompareDateTimeValues(
DateTime Value1,
DateTime Value2,
String OperatorName
);

Parameters

Value1
Value2
OperatorName

Return Value

Remarks

See Also

ValueTester Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueTester.CompareNumericValues Method

This method compares the two provided numeric values and returns either TRUE or FALSE

public virtual string CompareNumericValues(
Decimal Value1,
Decimal Value2,
String OperatorName
);

Parameters

Value1
Value2
OperatorName

Return Value

Remarks

See Also

ValueTester Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueTester.CompareTextValues Method

This method compares the two provided text values and returns either TRUE or FALSE

public virtual string CompareTextValues(
String Value1,
String Value2,
String OperatorName
);

Parameters

Value1
Value2
OperatorName

Return Value

Remarks

See Also

ValueTester Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueTester.CompareValues Method

protected virtual string CompareValues(
String Value1,
String Value2,
String OperatorName
);

See Also

ValueTester Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueTester.GetDataType Method

This method determines the data type of the current field being tested and returns it

protected virtual FieldGenericDataType GetDataType(
String Value1,
String Value2
);

Return Value

Remarks

See Also

ValueTester Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ValueTester.Run Method

public override string Run();

Implements

IProcessComponent.

See Also

ValueTester Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarBase Class

Base class for Aptify Generic vCalendar Writer and Reader

For a list of all members of this type, see vCalendarBase Members.

System.Object
vCalendarBase
vCalendarReader
vCalendarWriter

public class vCalendarBase : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: vCalendarProcessComponents (in vCalendarProcessComponents.dll)

See Also

vCalendarBase Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarBase Members

vCalendarBase overview

Public Instance Constructors

vCalendarBase Constructor Initializes a new instance of the vCalendarBase class.

Public Instance Properties

Application | Aptify Application Object
DataAction | Aptify DataAction Object
Properties | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vCalendarBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarBase Constructor

Initializes a new instance of the vCalendarBase class.

public vCalendarBase();

See Also

vCalendarBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarBase Properties

The properties of the vCalendarBase class are listed below. For a complete list of vCalendarBase class members, see the vCalendarBase Members topic.

Public Instance Properties

Application | Aptify Application Object
DataAction | Aptify DataAction Object
Properties | Aptify Properties Collection used for Input and Output Properties for the component.

See Also

vCalendarBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

vCalendarBase.Application Property

Aptify Application Object

public virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

vCalendarBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

vCalendarBase.DataAction Property

Aptify DataAction Object

public virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

vCalendarBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

vCalendarBase.Properties Property

Aptify Properties Collection used for Input and Output Properties for the component.

public virtual AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

vCalendarBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarBase Methods

The methods of the vCalendarBase class are listed below. For a complete list of vCalendarBase class members, see the vCalendarBase Members topic.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vCalendarBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarBase.Config Method

This method must be called before any other member of this class is accessed

public virtual void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

vCalendarBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarBase.Run Method

public abstract string Run();

Implements

IProcessComponent.

See Also

vCalendarBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarReader Class

This class is NOT implemented, and will in the future contain an implementation to read the contents of a vCalendar file and parse the file into properties.

For a list of all members of this type, see vCalendarReader Members.

System.Object
vCalendarBase
vCalendarReader

public class vCalendarReader : vCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: vCalendarProcessComponents (in vCalendarProcessComponents.dll)

See Also

vCalendarReader Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarReader Members

vCalendarReader overview

Public Instance Constructors

vCalendarReader Constructor Initializes a new instance of the vCalendarReader class.

Public Instance Properties

Application (inherited from vCalendarBase) | Aptify Application Object
DataAction (inherited from vCalendarBase) | Aptify DataAction Object
Properties (inherited from vCalendarBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vCalendarReader Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarReader Constructor

Initializes a new instance of the vCalendarReader class.

public vCalendarReader();

See Also

vCalendarReader Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarReader Methods

The methods of the vCalendarReader class are listed below. For a complete list of vCalendarReader class members, see the vCalendarReader Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vCalendarReader Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarReader.Config Method

public override void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

vCalendarReader Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarReader.Run Method

public override string Run();

Implements

IProcessComponent.

See Also

vCalendarReader Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarWriter Class

This class is used to create a vCalendar file based on the provided input properties

For a list of all members of this type, see vCalendarWriter Members.

System.Object
vCalendarBase
vCalendarWriter

public class vCalendarWriter : vCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: vCalendarProcessComponents (in vCalendarProcessComponents.dll)

See Also

vCalendarWriter Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarWriter Members

vCalendarWriter overview

Public Instance Constructors

vCalendarWriter Constructor Initializes a new instance of the vCalendarWriter class.

Public Instance Properties

Application (inherited from vCalendarBase) | Aptify Application Object
DataAction (inherited from vCalendarBase) | Aptify DataAction Object
Properties (inherited from vCalendarBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config (inherited from vCalendarBase) | This method must be called before any other member of this class is accessed
CreateVCalFile | This method calls the GetVCalText() method and creates a file with the output.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FormatUTCTime |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVCalText | This method returns vCalendar text for use wherever needed by the caller of the object. The format supported by the base class uses the provided properties. An example of the output format is shown below BEGIN:VCALENDAR PRODID:-//Aptify Corporation//Aptify 4.0 MIMEDIR//EN VERSION:1.0 BEGIN:VEVENT DTSTART:20060907T170000Z DTEND:20060907T173000Z DESCRIPTION;ENCODING=QUOTED-PRINTABLE:Description of Event Goes Here in Detail! SUMMARY;ENCODING=QUOTED-PRINTABLE:Event Title Goes Here CLASS:PRIVATE END:VEVENT END:VCALENDAR
Run | Process Component Input Properties 1) OutputFileName - Optional, File Name to create the vCalendar File. If left blank, a file name is generated as a temp file and passed back as an output property 2) StartsOn - Start Date/Time for Event Entry 3) EndsOn - End Date/Time for Event Entry 4) Summary - Summary/Title for event entry 5) Description - Optional, Details/Description for the event entry 6) Private - Optional, Defaults to False, True/False - If set to True, entry marked as private Output Properties 1) OutputFileName - This output property will contain the name of the file for the vCalendar item generated 2) vCalendarText - This output property will contain the contents of the vCalendar file in text format
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vCalendarWriter Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarWriter Constructor

Initializes a new instance of the vCalendarWriter class.

public vCalendarWriter();

See Also

vCalendarWriter Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarWriter Methods

The methods of the vCalendarWriter class are listed below. For a complete list of vCalendarWriter class members, see the vCalendarWriter Members topic.

Public Instance Methods

Config (inherited from vCalendarBase) | This method must be called before any other member of this class is accessed
CreateVCalFile | This method calls the GetVCalText() method and creates a file with the output.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FormatUTCTime |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVCalText | This method returns vCalendar text for use wherever needed by the caller of the object. The format supported by the base class uses the provided properties. An example of the output format is shown below BEGIN:VCALENDAR PRODID:-//Aptify Corporation//Aptify 4.0 MIMEDIR//EN VERSION:1.0 BEGIN:VEVENT DTSTART:20060907T170000Z DTEND:20060907T173000Z DESCRIPTION;ENCODING=QUOTED-PRINTABLE:Description of Event Goes Here in Detail! SUMMARY;ENCODING=QUOTED-PRINTABLE:Event Title Goes Here CLASS:PRIVATE END:VEVENT END:VCALENDAR
Run | Process Component Input Properties 1) OutputFileName - Optional, File Name to create the vCalendar File. If left blank, a file name is generated as a temp file and passed back as an output property 2) StartsOn - Start Date/Time for Event Entry 3) EndsOn - End Date/Time for Event Entry 4) Summary - Summary/Title for event entry 5) Description - Optional, Details/Description for the event entry 6) Private - Optional, Defaults to False, True/False - If set to True, entry marked as private Output Properties 1) OutputFileName - This output property will contain the name of the file for the vCalendar item generated 2) vCalendarText - This output property will contain the contents of the vCalendar file in text format
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

vCalendarWriter Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarWriter.CreateVCalFile Method

This method calls the GetVCalText() method and creates a file with the output.

public virtual bool CreateVCalFile(
DateTime StartsOn,
DateTime EndsOn,
String Summary,
String Description,
Boolean IsPrivate,
ref String& OutputFileName,
ref String& OutputText
);

Parameters

StartsOn
EndsOn
Summary
Description
IsPrivate
OutputFileName
OutputText

Return Value

Remarks

See Also

vCalendarWriter Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarWriter.FormatUTCTime Method

public virtual string FormatUTCTime(
DateTime UTCDateTime
);

See Also

vCalendarWriter Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarWriter.GetVCalText Method

This method returns vCalendar text for use wherever needed by the caller of the object. The format supported by the base class uses the provided properties. An example of the output format is shown below BEGIN:VCALENDAR PRODID:-//Aptify Corporation//Aptify 4.0 MIMEDIR//EN VERSION:1.0 BEGIN:VEVENT DTSTART:20060907T170000Z DTEND:20060907T173000Z DESCRIPTION;ENCODING=QUOTED-PRINTABLE:Description of Event Goes Here in Detail! SUMMARY;ENCODING=QUOTED-PRINTABLE:Event Title Goes Here CLASS:PRIVATE END:VEVENT END:VCALENDAR

public virtual string GetVCalText(
DateTime StartsOn,
DateTime EndsOn,
String Summary,
String Description,
Boolean IsPrivate
);

Parameters

StartsOn
EndsOn
Summary
Description
IsPrivate

Return Value

Remarks

See Also

vCalendarWriter Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


vCalendarWriter.Run Method

Process Component Input Properties 1) OutputFileName - Optional, File Name to create the vCalendar File. If left blank, a file name is generated as a temp file and passed back as an output property 2) StartsOn - Start Date/Time for Event Entry 3) EndsOn - End Date/Time for Event Entry 4) Summary - Summary/Title for event entry 5) Description - Optional, Details/Description for the event entry 6) Private - Optional, Defaults to False, True/False - If set to True, entry marked as private Output Properties 1) OutputFileName - This output property will contain the name of the file for the vCalendar item generated 2) vCalendarText - This output property will contain the contents of the vCalendar file in text format

public override string Run();

Return Value

SUCCESS OR FAILED

Implements

IProcessComponent.

Remarks

See Also

vCalendarWriter Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


VirtualFieldUpdateProcessComponent Class

Updates linked virtual fields based on foreign key changes.

For a list of all members of this type, see VirtualFieldUpdateProcessComponent Members.

System.Object
VirtualFieldUpdateProcessComponent

public class VirtualFieldUpdateProcessComponent : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: VirtualFieldProcessComponent (in VirtualFieldProcessComponent.dll)

See Also

VirtualFieldUpdateProcessComponent Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


VirtualFieldUpdateProcessComponent Members

VirtualFieldUpdateProcessComponent overview

Public Instance Constructors

VirtualFieldUpdateProcessComponent Constructor Initializes a new instance of the VirtualFieldUpdateProcessComponent class.

Public Instance Properties

Properties Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Input Properties Supported: 1) GEObject - Required - generic entity object to be updated. 2) UpdateType - Required - extent of field update; choice of "ENTITY ONLY", or "ENTITY AND SUBTYPES". Defaults to "ENTITY ONLY" Possible Result Codes returned by component 1) SUCCESS 2) FAILED - this result code occurs when the update fails or throws and exception
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshLinkedFields |

See Also

VirtualFieldUpdateProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


VirtualFieldUpdateProcessComponent Constructor

Initializes a new instance of the VirtualFieldUpdateProcessComponent class.

public VirtualFieldUpdateProcessComponent();

See Also

VirtualFieldUpdateProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


VirtualFieldUpdateProcessComponent Properties

The properties of the VirtualFieldUpdateProcessComponent class are listed below. For a complete list of VirtualFieldUpdateProcessComponent class members, see the VirtualFieldUpdateProcessComponent Members topic.

Public Instance Properties

Properties Aptify Properties Collection used for Input and Output Properties for the component.

See Also

VirtualFieldUpdateProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

VirtualFieldUpdateProcessComponent.Properties Property

Aptify Properties Collection used for Input and Output Properties for the component.

public virtual AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

VirtualFieldUpdateProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


VirtualFieldUpdateProcessComponent Methods

The methods of the VirtualFieldUpdateProcessComponent class are listed below. For a complete list of VirtualFieldUpdateProcessComponent class members, see the VirtualFieldUpdateProcessComponent Members topic.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Input Properties Supported: 1) GEObject - Required - generic entity object to be updated. 2) UpdateType - Required - extent of field update; choice of "ENTITY ONLY", or "ENTITY AND SUBTYPES". Defaults to "ENTITY ONLY" Possible Result Codes returned by component 1) SUCCESS 2) FAILED - this result code occurs when the update fails or throws and exception
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshLinkedFields |

See Also

VirtualFieldUpdateProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


VirtualFieldUpdateProcessComponent.Config Method

This method must be called before any other member of this class is accessed

public virtual void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

VirtualFieldUpdateProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


VirtualFieldUpdateProcessComponent.RefreshLinkedFields Method

protected void RefreshLinkedFields(
ref AptifyGenericEntityBase& GE,
ref AptifyDataFieldBase& oFKeyField,
ref ArrayList& arrFieldList
);

See Also

VirtualFieldUpdateProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


VirtualFieldUpdateProcessComponent.Run Method

Input Properties Supported: 1) GEObject - Required - generic entity object to be updated. 2) UpdateType - Required - extent of field update; choice of "ENTITY ONLY", or "ENTITY AND SUBTYPES". Defaults to "ENTITY ONLY" Possible Result Codes returned by component 1) SUCCESS 2) FAILED - this result code occurs when the update fails or throws and exception

public virtual string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

VirtualFieldUpdateProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Aptify.Framework.BusinessLogic.ProcessPipeline.Components

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.ProcessPipeline.Components Namespace

This namespace contains standard components that an organization can use to create process flow.

Namespace hierarchy

Classes

Class | Description
CreateWorkBook | Provides functionality to export an Aptify View to an Excel spreadsheet.


CreateWorkBook Class

Provides functionality to export an Aptify View to an Excel spreadsheet.

For a list of all members of this type, see CreateWorkBook Members.

System.Object
CreateWorkBook

public class CreateWorkBook : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

For addtional information please refer to IProcessComponent. The properties that are used are EntityID, ColumnMode, Mode, Name, Link, File, and ViewSQL. Several options exist for this component MODE: Either View, Save, Save+View (later saves and then views) FILE: Only used with Save/Save+View - specifies file name to save to If left blank app.path & \ & viewname & \ Time$ is used NAME: Worksheet Name (optional) if left blank, will be Sheet1 LINK: Static or Dynamic - if Static, data is copied, if dynamic a link is established back to the rows ViewID: Optional - specifies ID of View ViewSQL: Optional - specifies a SQL query ENTITYID: ID of entity ColumnMode: Optional - specifies either FieldName or DisplayName to show for the column headers

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.Components

Assembly: AptifyExcelIntegration (in AptifyExcelIntegration.dll)

See Also

CreateWorkBook Members | Aptify.Framework.BusinessLogic.ProcessPipeline.Components Namespace


CreateWorkBook Members

CreateWorkBook overview

Public Instance Constructors

CreateWorkBook Constructor Initializes a new instance of the CreateWorkBook class.

Public Instance Properties

Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateWorkBook Class | Aptify.Framework.BusinessLogic.ProcessPipeline.Components Namespace


CreateWorkBook Constructor

Initializes a new instance of the CreateWorkBook class.

public CreateWorkBook();

See Also

CreateWorkBook Class | Aptify.Framework.BusinessLogic.ProcessPipeline.Components Namespace


CreateWorkBook Properties

The properties of the CreateWorkBook class are listed below. For a complete list of CreateWorkBook class members, see the CreateWorkBook Members topic.

Public Instance Properties

Properties

See Also

CreateWorkBook Class | Aptify.Framework.BusinessLogic.ProcessPipeline.Components Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CreateWorkBook.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

CreateWorkBook Class | Aptify.Framework.BusinessLogic.ProcessPipeline.Components Namespace


CreateWorkBook Methods

The methods of the CreateWorkBook class are listed below. For a complete list of CreateWorkBook class members, see the CreateWorkBook Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateWorkBook Class | Aptify.Framework.BusinessLogic.ProcessPipeline.Components Namespace


CreateWorkBook.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

CreateWorkBook Class | Aptify.Framework.BusinessLogic.ProcessPipeline.Components Namespace


CreateWorkBook.Run Method

public string Run();

Implements

IProcessComponent.

See Also

CreateWorkBook Class | Aptify.Framework.BusinessLogic.ProcessPipeline.Components Namespace


Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace

This namespace contains the objects responsible for the layout of the Process Flows form template.

Namespace hierarchy

Classes

Class | Description
ComponentSelector | Aptify Process Pipeline Component Selector - control is used to select the process component for a given process flow step
ComponentStep |
LabelProperties |
NewResultCodeForm |
ProcessFlowDiagram | Aptify Process Flow Diagram Visual Display Class
ProcessFlowEditorForm | Aptify Process Flow Editor Windows Form
ProcessFlowLabel |
ProcessFlowPropertySheet |
ProcessFlowResultCode |
ProcessFlowStep |
ProcessFlowStepBase |
ProcessFlowStepProperties |
ResultCodeList |
ResultCodeProperties |
RuleStep |
SubProcessStep |

Delegates

Delegate | Description
ComponentSelector.ComponentSelectedEventHandler |
ProcessFlowDiagram.SelectionChangedEventHandler |
ProcessFlowResultCode.BeforeDisconnectEventHandler |
ProcessFlowResultCode.CodeChangedEventHandler |
ProcessFlowResultCode.NextStepChangedEventHandler |
ProcessFlowStep.StepDescriptionChangedEventHandler |
ProcessFlowStep.StepNameChangedEventHandler |
ResultCodeList.BeforeDisconnectEventHandler |

Enumerations

Enumeration | Description
ProcessFlowStepBase.ShapeType |


ComponentSelector Class

Aptify Process Pipeline Component Selector - control is used to select the process component for a given process flow step

For a list of all members of this type, see ComponentSelector Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ComponentSelector

public class ComponentSelector : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ComponentSelector Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentSelector Members

ComponentSelector overview

Public Instance Constructors

ComponentSelector Constructor Initializes a new instance of the ComponentSelector class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
ComponentID |
ComponentImage |
ComponentName |
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetComponent |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ComponentSelected |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
dropdownButton |
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
txtComponent |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadImage | This method will load an image from the specified repository location and return the index into the Image List object that this image was loaded.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentSelector Constructor

Initializes a new instance of the ComponentSelector class.

public ComponentSelector();

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentSelector Properties

The properties of the ComponentSelector class are listed below. For a complete list of ComponentSelector class members, see the ComponentSelector Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
ComponentID |
ComponentImage |
ComponentName |
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
dropdownButton |
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
txtComponent |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentID Property

Aptify 5.0 Software Development Kit (SDK)

ComponentSelector.ComponentID Property

public Int64 ComponentID {get;}

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentImage Property

Aptify 5.0 Software Development Kit (SDK)

ComponentSelector.ComponentImage Property

public Image ComponentImage {get;}

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentName Property

Aptify 5.0 Software Development Kit (SDK)

ComponentSelector.ComponentName Property

public String ComponentName {get;}

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


dropdownButton Property

Aptify 5.0 Software Development Kit (SDK)

ComponentSelector.dropdownButton Property

protected virtual UltraDropDownButton dropdownButton {get; set;}

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


txtComponent Property

Aptify 5.0 Software Development Kit (SDK)

ComponentSelector.txtComponent Property

protected virtual TextBox txtComponent {get; set;}

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentSelector Methods

The methods of the ComponentSelector class are listed below. For a complete list of ComponentSelector class members, see the ComponentSelector Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetComponent |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadImage | This method will load an image from the specified repository location and return the index into the Image List object that this image was loaded.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentSelector.Config Method

public void Config(
AptifyApplication Application,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentSelector.LoadImage Method

This method will load an image from the specified repository location and return the index into the Image List object that this image was loaded.

protected int LoadImage(
String ImageRepositoryObject
);

Parameters

ImageRepositoryObject

Return Value

Remarks

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentSelector.SetComponent Method

public void SetComponent(
Int64 ComponentID,
String ComponentName
);

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentSelector Events

The events of the ComponentSelector class are listed below. For a complete list of ComponentSelector class members, see the ComponentSelector Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ComponentSelected |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentSelector.ComponentSelector.ComponentSelectedEventHandler Event

public event ComponentSelector.ComponentSelectedEventHandler ComponentSelected;

See Also

ComponentSelector Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentSelector.ComponentSelectedEventHandler Delegate

public delegate void ComponentSelector.ComponentSelectedEventHandler(
Int64 ComponentID,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentStep Class

For a list of all members of this type, see ComponentStep Members.

System.Object
SymbolBase
Symbol
ProcessFlowStepBase
ProcessFlowStep
ComponentStep

public class ComponentStep : ProcessFlowStep

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ComponentStep Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentStep Members

ComponentStep overview

Public Instance Constructors

ComponentStep Overloaded. Initializes a new instance of the ComponentStep class.

Public Instance Properties

Application (inherited from ProcessFlowStep)
AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Controller (inherited from ProcessFlowStep)
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description (inherited from ProcessFlowStepBase)
Edges (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesEntering (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FillStyle (inherited from ProcessFlowStepBase)
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Image (inherited from ProcessFlowStepBase)
ImageVisible (inherited from ProcessFlowStepBase)
IsFirstStep (inherited from ProcessFlowStepBase)
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
LineStyle (inherited from ProcessFlowStepBase)
LineVisible (inherited from ProcessFlowStepBase)
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Model (inherited from ProcessFlowStep)
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ProcessComponentID
ProcessFlowID (inherited from ProcessFlowStep)
ProcessFlowStepID (inherited from ProcessFlowStep)
ResultCodes (inherited from ProcessFlowStep)
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ShadowStyle (inherited from ProcessFlowStepBase)
Shape (inherited from ProcessFlowStepBase)
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
StepDescription (inherited from ProcessFlowStep)
StepGE (inherited from ProcessFlowStep)
StepName (inherited from ProcessFlowStep)
StepType
Text (inherited from ProcessFlowStepBase)
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Public Instance Methods

AcceptConnection (inherited from ProcessFlowStep) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType (inherited from ProcessFlowStepBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Save |
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage (inherited from ProcessFlowStepBase) |
SetImageFile (inherited from ProcessFlowStepBase) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Public Instance Events

StepDescriptionChanged (inherited from ProcessFlowStep)
StepNameChanged (inherited from ProcessFlowStep)

Protected Instance Fields

children (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
m_lblDescription (inherited from ProcessFlowStepBase)
m_lblName (inherited from ProcessFlowStepBase)
m_line (inherited from ProcessFlowStepBase)
m_oStepGE (inherited from ProcessFlowStep)
matrix (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
propertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from ProcessFlowStepBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from ProcessFlowStep) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

ComponentStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentStep Constructor

Initializes a new instance of the ComponentStep class.

Overload List

Initializes a new instance of the ComponentStep class.

public ComponentStep();

public ComponentStep(Controller,Model);

See Also

ComponentStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentStep Constructor ()

Initializes a new instance of the ComponentStep class.

public ComponentStep();

See Also

ComponentStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ComponentStep Constructor Overload List


ComponentStep Constructor (Controller, Model)

public ComponentStep(
Controller oController,
Model oModel
);

See Also

ComponentStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ComponentStep Constructor Overload List


ComponentStep Properties

The properties of the ComponentStep class are listed below. For a complete list of ComponentStep class members, see the ComponentStep Members topic.

Public Instance Properties

Application (inherited from ProcessFlowStep)
AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Controller (inherited from ProcessFlowStep)
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description (inherited from ProcessFlowStepBase)
Edges (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesEntering (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FillStyle (inherited from ProcessFlowStepBase)
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Image (inherited from ProcessFlowStepBase)
ImageVisible (inherited from ProcessFlowStepBase)
IsFirstStep (inherited from ProcessFlowStepBase)
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
LineStyle (inherited from ProcessFlowStepBase)
LineVisible (inherited from ProcessFlowStepBase)
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Model (inherited from ProcessFlowStep)
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ProcessComponentID
ProcessFlowID (inherited from ProcessFlowStep)
ProcessFlowStepID (inherited from ProcessFlowStep)
ResultCodes (inherited from ProcessFlowStep)
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ShadowStyle (inherited from ProcessFlowStepBase)
Shape (inherited from ProcessFlowStepBase)
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
StepDescription (inherited from ProcessFlowStep)
StepGE (inherited from ProcessFlowStep)
StepName (inherited from ProcessFlowStep)
StepType
Text (inherited from ProcessFlowStepBase)
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

See Also

ComponentStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessComponentID Property

Aptify 5.0 Software Development Kit (SDK)

ComponentStep.ProcessComponentID Property

public Int64 ProcessComponentID {get; set;}

See Also

ComponentStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


StepType Property

Aptify 5.0 Software Development Kit (SDK)

ComponentStep.StepType Property

public override String StepType {get;}

See Also

ComponentStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentStep Methods

The methods of the ComponentStep class are listed below. For a complete list of ComponentStep class members, see the ComponentStep Members topic.

Public Instance Methods

AcceptConnection (inherited from ProcessFlowStep) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType (inherited from ProcessFlowStepBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Save |
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage (inherited from ProcessFlowStepBase) |
SetImageFile (inherited from ProcessFlowStepBase) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from ProcessFlowStepBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from ProcessFlowStep) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

ComponentStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ComponentStep.Save Method

public override bool Save();

See Also

ComponentStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


LabelProperties Class

For a list of all members of this type, see LabelProperties Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
LabelProperties

public class LabelProperties : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

LabelProperties Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


LabelProperties Members

LabelProperties overview

Public Instance Constructors

LabelProperties Constructor Initializes a new instance of the LabelProperties class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Diagram |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableDataTransfer |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
Label |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

LabelProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


LabelProperties Constructor

Initializes a new instance of the LabelProperties class.

public LabelProperties();

See Also

LabelProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


LabelProperties Properties

The properties of the LabelProperties class are listed below. For a complete list of LabelProperties class members, see the LabelProperties Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Diagram |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableDataTransfer |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
Label |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

LabelProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

LabelProperties.Application Property

public AptifyApplication Application {get; set;}

See Also

LabelProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Diagram Property

Aptify 5.0 Software Development Kit (SDK)

LabelProperties.Diagram Property

public ProcessFlowDiagram Diagram {get; set;}

See Also

LabelProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


EnableDataTransfer Property

Aptify 5.0 Software Development Kit (SDK)

LabelProperties.EnableDataTransfer Property

public Boolean EnableDataTransfer {get; set;}

See Also

LabelProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Label Property

Aptify 5.0 Software Development Kit (SDK)

LabelProperties.Label Property

public ProcessFlowLabel Label {get; set;}

See Also

LabelProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


LabelProperties Methods

The methods of the LabelProperties class are listed below. For a complete list of LabelProperties class members, see the LabelProperties Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

LabelProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

LabelProperties.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

LabelProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


LabelProperties.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

LabelProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | LabelProperties.Dispose Overload List


LabelProperties.TransferDataToObject Method

public bool TransferDataToObject();

See Also

LabelProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


NewResultCodeForm Class

For a list of all members of this type, see NewResultCodeForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
NewResultCodeForm

public class NewResultCodeForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

NewResultCodeForm Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


NewResultCodeForm Members

NewResultCodeForm overview

Public Instance Constructors

NewResultCodeForm Constructor

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
ResultCode |
ResultCodeProperties |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

NewResultCodeForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


NewResultCodeForm Constructor

public NewResultCodeForm(
Boolean CreateResultCode
);

See Also

NewResultCodeForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


NewResultCodeForm Properties

The properties of the NewResultCodeForm class are listed below. For a complete list of NewResultCodeForm class members, see the NewResultCodeForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
ResultCode |
ResultCodeProperties |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

NewResultCodeForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCode Property

Aptify 5.0 Software Development Kit (SDK)

NewResultCodeForm.ResultCode Property

public ProcessFlowResultCode ResultCode {get; set;}

See Also

NewResultCodeForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeProperties Property

Aptify 5.0 Software Development Kit (SDK)

NewResultCodeForm.ResultCodeProperties Property

public ResultCodeProperties ResultCodeProperties {get;}

See Also

NewResultCodeForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


NewResultCodeForm Methods

The methods of the NewResultCodeForm class are listed below. For a complete list of NewResultCodeForm class members, see the NewResultCodeForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

NewResultCodeForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

NewResultCodeForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

NewResultCodeForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


NewResultCodeForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

NewResultCodeForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | NewResultCodeForm.Dispose Overload List


ProcessFlowDiagram Class

Aptify Process Flow Diagram Visual Display Class

For a list of all members of this type, see ProcessFlowDiagram Members.

System.Object
MarshalByRefObject
Component
Control
ScrollControl
Diagram
ProcessFlowDiagram

public class ProcessFlowDiagram : Diagram

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ProcessFlowDiagram Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram Members

ProcessFlowDiagram overview

Public Instance Constructors

ProcessFlowDiagram Constructor Initializes a new instance of the ProcessFlowDiagram class.

Public Instance Properties

AccelerateScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveController (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowIncreaseSmallChange (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AllowRaiseMouseMoveInOnDragOver (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AllowSizeGrip (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScrollBounds (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AutoScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollTimerEnable (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AutoSize (inherited from Control) | This property is not relevant for this class.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Syncfusion.Windows.Forms.ScrollControl) |
CanCopy (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CanCut (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanPaste (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CanRedo (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controller (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisableScrollWindow (inherited from Syncfusion.Windows.Forms.ScrollControl) |
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableIntelliMouse (inherited from Syncfusion.Windows.Forms.ScrollControl) |
FillSplitterPane (inherited from Syncfusion.Windows.Forms.ScrollControl) |
FirstStep | Gets/Sets the First Step of the Process Flow
FirstStepID |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForceSizeBox (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HasControlFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScrollTips (inherited from Syncfusion.Windows.Forms.ScrollControl) |
HorizontalThumbTrack (inherited from Syncfusion.Windows.Forms.ScrollControl) |
HScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
HScrollBar (inherited from Syncfusion.Windows.Forms.ScrollControl) |
HScrollIncrement (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IgnoreUICues (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InsideScrollBounds (inherited from Syncfusion.Windows.Forms.ScrollControl) |
InsideScrollMargins (inherited from Syncfusion.Windows.Forms.ScrollControl) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsActiveControl (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsDeactivated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsDisposing (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsMousePressed (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsScriptCompiled (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
IsScriptRunning (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
IsSplitterPaneClosed (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsSplitterPaneClosing (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsValidated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsValidating (inherited from Syncfusion.Windows.Forms.ScrollControl) |
LastMousePosition (inherited from Syncfusion.Windows.Forms.ScrollControl) |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
LayoutManager (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Model (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
MouseControllerDispatcher (inherited from Syncfusion.Windows.Forms.ScrollControl) |
MouseWheelScrollLines (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Name (inherited from Control) | Gets or sets the name of the control.
NeedToCompileScript (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NudgeIncrement (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Padding (inherited from Control) | Gets or sets padding within the control.
PaintPending (inherited from Syncfusion.Windows.Forms.ScrollControl) |
PaneDesc (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProcessFlowGE |
ProcessFlowID |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Script (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScriptEngine (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScriptingManager (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScriptSite (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScrollGranularity (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScrollTip (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollTipFormat (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SelectionList (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SizeGripStyle (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SmartSizeBox (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SmoothMouseWheelScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
StepCount |
SupportsThumbTrack (inherited from Syncfusion.Windows.Forms.ScrollControl) | Obsolete.
TabIndex (inherited from Syncfusion.Windows.Forms.ScrollControl) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UpdateOptions (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Updating (inherited from Syncfusion.Windows.Forms.ScrollControl) |
UseSharedScrollBars (inherited from Syncfusion.Windows.Forms.ScrollControl) |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScrollTips (inherited from Syncfusion.Windows.Forms.ScrollControl) |
VerticalThumbTrack (inherited from Syncfusion.Windows.Forms.ScrollControl) |
View (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
VScrollBar (inherited from Syncfusion.Windows.Forms.ScrollControl) |
VScrollIncrement (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

ActivateTool (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignBottom (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignCenter (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignLeft (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignMiddle (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignRight (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignTop (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AttachModel (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CancelUpdate (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ClearScriptSite (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CloseScriptEngine (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CompileScript (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateController (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateModel (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreatePrintDocument (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CreateView (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Cut (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Delete | Overloaded.
DetachContextMenu (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Dispose (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
EndUpdate (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
EnsurePaintCodeJitted (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteCommand (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ExportDiagramAsImage (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
FindForm (inherited from Control) | Retrieves the form that the control is on.
FlipHorizontal (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
FlipVertical (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InsertImage (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
InvokeScriptMethod (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
LastMousePositionToClient (inherited from Syncfusion.Windows.Forms.ScrollControl) |
LoadBinary (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
LoadProcessFlow | Overloaded.
LoadScript (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
LoadSoap (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
MoveNodes (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NotifyCancelMode (inherited from Syncfusion.Windows.Forms.ScrollControl) |
NudgeDown (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NudgeLeft (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NudgeRight (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NudgeUp (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
PageSetup |
Pan |
Paste (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
Print |
ProcessMouseWheel (inherited from Syncfusion.Windows.Forms.ScrollControl) |
QueryFocusInside (inherited from Syncfusion.Windows.Forms.ScrollControl) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
RedoCommand (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RegisterEventSource (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
RegisterGlobalInstance (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetInsideScrollMargins (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ResetMouseController (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ResetMouseWheelScrollLines (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ResetRightToLeft (inherited from Control) |
ResetScriptEngine (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
RotateFree |
RunScript (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SameHeight (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SameSize (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SameWidth (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SaveBinary (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
SaveProcessFlow |
SaveSoap (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
Scale (inherited from Control) | Overloaded.
ScrollWindow (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetMagnification | Overloaded.
SetMagnification (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
ShouldPrepareUpdate (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
ShouldSerializeMouseWheelScrollLines (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Show (inherited from Control) | Displays the control to the user.
SpaceAcross (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SpaceDown (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
UndoCommand (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateScrollBars (inherited from Syncfusion.Windows.Forms.ScrollControl) |
UpdateScrollRange (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Zoom |

Public Instance Events

AccelerateScrollingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AutoScrollingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AutoSizeChanged (inherited from Control) | This event is not relevant for this class.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BoundsChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CancelMode (inherited from Syncfusion.Windows.Forms.ScrollControl) |
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
CompileError (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlNodeInfo (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FillSplitterPaneChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
HorizontalScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
IntelliMouseDragScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MeasurementScaleChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
MeasurementUnitsChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
MouseWheelZoom (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Move (inherited from Control) | Occurs when the control is moved.
NodeClick (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeMoved (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeRotated (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeScaled (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
PropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
ScriptChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScrollbarsVisibleChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlHandledMouseDown (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlHandledMouseMove (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlHandledMouseUp (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlMouseDown (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlMouseMove (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlMouseUp (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollTipFeedback (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SelectionChanged |
ShowContextMenu (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
SplitterPaneClosed (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SplitterPaneClosing (inherited from Syncfusion.Windows.Forms.ScrollControl) |
StartAutoScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
UpdatingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VerticalScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.
WindowScrolled (inherited from Syncfusion.Windows.Forms.ScrollControl) |
WindowScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Syncfusion.Windows.Forms.ScrollControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Control) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
ImeModeBase (inherited from Control) |
PreJitPaint (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateDirectedLink |
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FixRenderOrigin (inherited from Syncfusion.Windows.Forms.ScrollControl) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HookControllerEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
HookModelEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
HookViewEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
InitializeScripting (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MVCDispose (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
MVCInit (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAccelerateScrollingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnAutoScrollingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBeginUpdateScrollBars (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCancelMode (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnControlGotFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnControlLostFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnControlRemoved (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCreateScrollTipWindow (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnDragEnter (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnDragLeave (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnDragOver (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEndUpdateScrollBars (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnEnsurePaintCodeJitted (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnEnter (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnFillSplitterPaneChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnFontChanged (inherited from Control) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnHandleCreated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHorizontalScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnHScroll (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnHScrollBarValueChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnIntelliMouseDragScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnInvalidated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnKeyDown |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLayoutUpdated (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnLeave (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnLocationChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnLostFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnModelBoundsChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelChildrenChangeComplete |
OnModelChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelClick (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelControlNodeInfo (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMeasurementScaleChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMeasurementUnitsChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMoved (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelRotated (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelScaled (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMouseUp (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMouseWheel (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMouseWheelZoom (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from Control) | Raises the PaddingChanged event.
OnPaint (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnPaintBackground (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
OnScrollbarsVisibleChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlHandledMouseDown (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlHandledMouseMove (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlHandledMouseUp (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlMouseDown (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlMouseMove (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlMouseUp (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollTipFeedback (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnSelectionListChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnSetCursor (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnShowContextMenu (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnSizeChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnSplitterPaneClosed (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnSplitterPaneClosing (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnStartAutoScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnToolActivate (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnToolDeactivate (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnUpdatingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnValidated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnValidating (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnValidatingLostFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnVerticalScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnViewMagnificationChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnViewOriginChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnViewPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnVisibleChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnVScroll (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnVScrollBarValueChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnWindowScrolled (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnWindowScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
ScaleCore (inherited from Control) |
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
StartAutoScrollTimer (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
UnhookControllerEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
UnhookModelEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
UnhookViewEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateScrollTips (inherited from Syncfusion.Windows.Forms.ScrollControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Syncfusion.Windows.Forms.ScrollControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram Constructor

Initializes a new instance of the ProcessFlowDiagram class.

public ProcessFlowDiagram();

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram Properties

The properties of the ProcessFlowDiagram class are listed below. For a complete list of ProcessFlowDiagram class members, see the ProcessFlowDiagram Members topic.

Public Instance Properties

AccelerateScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveController (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowIncreaseSmallChange (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AllowRaiseMouseMoveInOnDragOver (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AllowSizeGrip (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScrollBounds (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AutoScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollTimerEnable (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AutoSize (inherited from Control) | This property is not relevant for this class.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Syncfusion.Windows.Forms.ScrollControl) |
CanCopy (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CanCut (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanPaste (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CanRedo (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CanUndo (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controller (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisableScrollWindow (inherited from Syncfusion.Windows.Forms.ScrollControl) |
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableIntelliMouse (inherited from Syncfusion.Windows.Forms.ScrollControl) |
FillSplitterPane (inherited from Syncfusion.Windows.Forms.ScrollControl) |
FirstStep | Gets/Sets the First Step of the Process Flow
FirstStepID |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForceSizeBox (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HasControlFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScrollTips (inherited from Syncfusion.Windows.Forms.ScrollControl) |
HorizontalThumbTrack (inherited from Syncfusion.Windows.Forms.ScrollControl) |
HScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
HScrollBar (inherited from Syncfusion.Windows.Forms.ScrollControl) |
HScrollIncrement (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IgnoreUICues (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InsideScrollBounds (inherited from Syncfusion.Windows.Forms.ScrollControl) |
InsideScrollMargins (inherited from Syncfusion.Windows.Forms.ScrollControl) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsActiveControl (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsDeactivated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsDisposing (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsMousePressed (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsScriptCompiled (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
IsScriptRunning (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
IsSplitterPaneClosed (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsSplitterPaneClosing (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsValidated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
IsValidating (inherited from Syncfusion.Windows.Forms.ScrollControl) |
LastMousePosition (inherited from Syncfusion.Windows.Forms.ScrollControl) |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
LayoutManager (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Model (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
MouseControllerDispatcher (inherited from Syncfusion.Windows.Forms.ScrollControl) |
MouseWheelScrollLines (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Name (inherited from Control) | Gets or sets the name of the control.
NeedToCompileScript (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NudgeIncrement (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Padding (inherited from Control) | Gets or sets padding within the control.
PaintPending (inherited from Syncfusion.Windows.Forms.ScrollControl) |
PaneDesc (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProcessFlowGE |
ProcessFlowID |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Script (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScriptEngine (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScriptingManager (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScriptSite (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScrollGranularity (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScrollTip (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollTipFormat (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SelectionList (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SizeGripStyle (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SmartSizeBox (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SmoothMouseWheelScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
StepCount |
SupportsThumbTrack (inherited from Syncfusion.Windows.Forms.ScrollControl) | Obsolete.
TabIndex (inherited from Syncfusion.Windows.Forms.ScrollControl) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UpdateOptions (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Updating (inherited from Syncfusion.Windows.Forms.ScrollControl) |
UseSharedScrollBars (inherited from Syncfusion.Windows.Forms.ScrollControl) |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScrollTips (inherited from Syncfusion.Windows.Forms.ScrollControl) |
VerticalThumbTrack (inherited from Syncfusion.Windows.Forms.ScrollControl) |
View (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
VScrollBar (inherited from Syncfusion.Windows.Forms.ScrollControl) |
VScrollIncrement (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Syncfusion.Windows.Forms.ScrollControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Control) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
ImeModeBase (inherited from Control) |
PreJitPaint (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDiagram.Application Property

public AptifyApplication Application {get; set;}

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


FirstStep Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDiagram.FirstStep Property

Gets/Sets the First Step of the Process Flow

public ProcessFlowStep FirstStep {get; set;}

Property Value

Remarks

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


FirstStepID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDiagram.FirstStepID Property

public Int64 FirstStepID {get; set;}

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowGE Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDiagram.ProcessFlowGE Property

public AptifyGenericEntityBase ProcessFlowGE {get;}

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDiagram.ProcessFlowID Property

public Int64 ProcessFlowID {get; set;}

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


StepCount Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDiagram.StepCount Property

public Int32 StepCount {get;}

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram Methods

The methods of the ProcessFlowDiagram class are listed below. For a complete list of ProcessFlowDiagram class members, see the ProcessFlowDiagram Members topic.

Public Instance Methods

ActivateTool (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignBottom (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignCenter (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignLeft (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignMiddle (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignRight (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AlignTop (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
AttachModel (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CancelUpdate (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ClearScriptSite (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CloseScriptEngine (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CompileScript (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
Copy (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateController (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateModel (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreatePrintDocument (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CreateView (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Cut (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Delete | Overloaded.
DetachContextMenu (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Dispose (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
EndUpdate (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
EnsurePaintCodeJitted (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteCommand (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ExportDiagramAsImage (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
FindForm (inherited from Control) | Retrieves the form that the control is on.
FlipHorizontal (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
FlipVertical (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HitTest (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InsertImage (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
InvokeScriptMethod (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
LastMousePositionToClient (inherited from Syncfusion.Windows.Forms.ScrollControl) |
LoadBinary (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
LoadProcessFlow | Overloaded.
LoadScript (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
LoadSoap (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
MoveNodes (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NotifyCancelMode (inherited from Syncfusion.Windows.Forms.ScrollControl) |
NudgeDown (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NudgeLeft (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NudgeRight (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NudgeUp (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
PageSetup |
Pan |
Paste (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
Print |
ProcessMouseWheel (inherited from Syncfusion.Windows.Forms.ScrollControl) |
QueryFocusInside (inherited from Syncfusion.Windows.Forms.ScrollControl) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
RedoCommand (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RegisterEventSource (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
RegisterGlobalInstance (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetInsideScrollMargins (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ResetMouseController (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ResetMouseWheelScrollLines (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ResetRightToLeft (inherited from Control) |
ResetScriptEngine (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
RotateFree |
RunScript (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SameHeight (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SameSize (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SameWidth (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SaveBinary (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
SaveProcessFlow |
SaveSoap (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
Scale (inherited from Control) | Overloaded.
ScrollWindow (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectAll (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetMagnification | Overloaded.
SetMagnification (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
ShouldPrepareUpdate (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
ShouldSerializeMouseWheelScrollLines (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Show (inherited from Control) | Displays the control to the user.
SpaceAcross (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SpaceDown (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
UndoCommand (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateScrollBars (inherited from Syncfusion.Windows.Forms.ScrollControl) |
UpdateScrollRange (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Zoom |

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateDirectedLink |
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FixRenderOrigin (inherited from Syncfusion.Windows.Forms.ScrollControl) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HookControllerEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
HookModelEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
HookViewEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
InitializeScripting (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MVCDispose (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
MVCInit (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAccelerateScrollingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnAutoScrollingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBeginUpdateScrollBars (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCancelMode (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnControlGotFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnControlLostFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnControlRemoved (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCreateScrollTipWindow (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnDragEnter (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnDragLeave (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnDragOver (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEndUpdateScrollBars (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnEnsurePaintCodeJitted (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnEnter (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnFillSplitterPaneChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnFontChanged (inherited from Control) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnHandleCreated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHorizontalScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnHScroll (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnHScrollBarValueChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnIntelliMouseDragScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnInvalidated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnKeyDown |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLayoutUpdated (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnLeave (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnLocationChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnLostFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnModelBoundsChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelChildrenChangeComplete |
OnModelChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelClick (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelControlNodeInfo (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMeasurementScaleChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMeasurementUnitsChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMoved (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelRotated (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnModelScaled (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMouseUp (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMouseWheel (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMouseWheelZoom (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from Control) | Raises the PaddingChanged event.
OnPaint (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnPaintBackground (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
OnScrollbarsVisibleChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlHandledMouseDown (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlHandledMouseMove (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlHandledMouseUp (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlMouseDown (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlMouseMove (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollControlMouseUp (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnScrollTipFeedback (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnSelectionListChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnSetCursor (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnShowContextMenu (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnSizeChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnSplitterPaneClosed (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnSplitterPaneClosing (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnStartAutoScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnToolActivate (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnToolDeactivate (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnUpdatingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnValidated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnValidating (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnValidatingLostFocus (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnVerticalScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnViewMagnificationChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnViewOriginChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnViewPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnVisibleChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnVScroll (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnVScrollBarValueChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
OnWindowScrolled (inherited from Syncfusion.Windows.Forms.ScrollControl) |
OnWindowScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
ScaleCore (inherited from Control) |
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
StartAutoScrollTimer (inherited from Syncfusion.Windows.Forms.ScrollControl) | Overloaded.
UnhookControllerEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
UnhookModelEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
UnhookViewEvents (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateScrollTips (inherited from Syncfusion.Windows.Forms.ScrollControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Syncfusion.Windows.Forms.ScrollControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.CreateDirectedLink Method

protected Link CreateDirectedLink(
PointF[] pts
);

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Delete Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDiagram.Delete Method

Overload List

new public void Delete();

public void Delete(Boolean);

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.Delete Method ()

new public void Delete();

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowDiagram.Delete Overload List


ProcessFlowDiagram.Delete Method (Boolean)

public void Delete(
Boolean PromptUser
);

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowDiagram.Delete Overload List


LoadProcessFlow Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDiagram.LoadProcessFlow Method

Overload List

public void LoadProcessFlow(AptifyGenericEntityBase);

public void LoadProcessFlow(Int64);

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.LoadProcessFlow Method (AptifyGenericEntityBase)

public void LoadProcessFlow(
AptifyGenericEntityBase ProcessFlowGE
);

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowDiagram.LoadProcessFlow Overload List


ProcessFlowDiagram.LoadProcessFlow Method (Int64)

public void LoadProcessFlow(
Int64 lProcessFlowID
);

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowDiagram.LoadProcessFlow Overload List


ProcessFlowDiagram.OnKeyDown Method

protected override void OnKeyDown(
KeyEventArgs e
);

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.OnModelChildrenChangeComplete Method

protected override void OnModelChildrenChangeComplete(
Object sender,
NodeCollectionEventArgs evtArgs
);

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.PageSetup Method

public void PageSetup();

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.Pan Method

public void Pan();

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.Print Method

public void Print();

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.RotateFree Method

public void RotateFree();

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.SaveProcessFlow Method

public bool SaveProcessFlow(
AptifyGenericEntityBase ProcessFlowGE
);

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


SetMagnification Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDiagram.SetMagnification Method

Overload List

public void SetMagnification(Int32);

Inherited from Diagram.

public void SetMagnification(Int32,Int32);

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.SetMagnification Method (Int32)

public void SetMagnification(
Int32 MagnificationPercent
);

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowDiagram.SetMagnification Overload List


ProcessFlowDiagram.Zoom Method

public void Zoom();

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram Events

The events of the ProcessFlowDiagram class are listed below. For a complete list of ProcessFlowDiagram class members, see the ProcessFlowDiagram Members topic.

Public Instance Events

AccelerateScrollingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AutoScrollingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
AutoSizeChanged (inherited from Control) | This event is not relevant for this class.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
BoundsChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
CancelMode (inherited from Syncfusion.Windows.Forms.ScrollControl) |
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
CompileError (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlNodeInfo (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivated (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FillSplitterPaneChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
HorizontalScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
IntelliMouseDragScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MeasurementScaleChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
MeasurementUnitsChanging (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
MouseWheelZoom (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Move (inherited from Control) | Occurs when the control is moved.
NodeClick (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeMoved (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeRotated (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
NodeScaled (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
PropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
ScriptChanged (inherited from Syncfusion.Windows.Forms.Diagram.Controls.Diagram) |
ScrollbarsVisibleChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlHandledMouseDown (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlHandledMouseMove (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlHandledMouseUp (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlMouseDown (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlMouseMove (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollControlMouseUp (inherited from Syncfusion.Windows.Forms.ScrollControl) |
ScrollTipFeedback (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SelectionChanged |
ShowContextMenu (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
SplitterPaneClosed (inherited from Syncfusion.Windows.Forms.ScrollControl) |
SplitterPaneClosing (inherited from Syncfusion.Windows.Forms.ScrollControl) |
StartAutoScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
UpdatingChanged (inherited from Syncfusion.Windows.Forms.ScrollControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VerticalScroll (inherited from Syncfusion.Windows.Forms.ScrollControl) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.
WindowScrolled (inherited from Syncfusion.Windows.Forms.ScrollControl) |
WindowScrolling (inherited from Syncfusion.Windows.Forms.ScrollControl) |

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.ProcessFlowDiagram.SelectionChangedEventHandler Event

public event ProcessFlowDiagram.SelectionChangedEventHandler SelectionChanged;

See Also

ProcessFlowDiagram Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowDiagram.SelectionChangedEventHandler Delegate

public delegate void ProcessFlowDiagram.SelectionChangedEventHandler(
Object sender,
NodeCollectionEventArgs evtArgs
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowEditorForm Class

Aptify Process Flow Editor Windows Form

For a list of all members of this type, see ProcessFlowEditorForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ProcessFlowEditorForm

public class ProcessFlowEditorForm : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ProcessFlowEditorForm Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowEditorForm Members

ProcessFlowEditorForm overview

Public Instance Constructors

ProcessFlowEditorForm Constructor Initializes a new instance of the ProcessFlowEditorForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProcessFlowID |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowEditorForm Constructor

Initializes a new instance of the ProcessFlowEditorForm class.

public ProcessFlowEditorForm();

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowEditorForm Properties

The properties of the ProcessFlowEditorForm class are listed below. For a complete list of ProcessFlowEditorForm class members, see the ProcessFlowEditorForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProcessFlowID |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowEditorForm.Application Property

public AptifyApplication Application {get; set;}

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowEditorForm.ProcessFlowID Property

public Int64 ProcessFlowID {get; set;}

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowEditorForm Methods

The methods of the ProcessFlowEditorForm class are listed below. For a complete list of ProcessFlowEditorForm class members, see the ProcessFlowEditorForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowEditorForm.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(UserCredentials,String);

public void Config(UserCredentials,String,Int64);

public void Config(UserCredentials,String,String);

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowEditorForm.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase GE
);

Implements

IAptifyTopLevelViewer.

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowEditorForm.Config Overload List


ProcessFlowEditorForm.Config Method (UserCredentials, String)

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Implements

IAptifyTopLevelViewer.

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowEditorForm.Config Overload List


ProcessFlowEditorForm.Config Method (UserCredentials, String, Int64)

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Implements

IAptifyTopLevelViewer.

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowEditorForm.Config Overload List


ProcessFlowEditorForm.Config Method (UserCredentials, String, String)

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Implements

IAptifyTopLevelViewer.

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowEditorForm.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowEditorForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowEditorForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowEditorForm.Dispose Overload List


Show Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowEditorForm.Show Method

Overload List

new public void Show();

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowEditorForm.Show Method ()

new public void Show();

Implements

IAptifyTopLevelViewer.

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowEditorForm.Show Overload List


ProcessFlowEditorForm.Show Method (Form)

public void Show(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowEditorForm.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowEditorForm.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowEditorForm.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifyTopLevelViewer.

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowEditorForm.ShowDialog Overload List


ProcessFlowEditorForm.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

ProcessFlowEditorForm Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowEditorForm.ShowDialog Overload List


ProcessFlowLabel Class

For a list of all members of this type, see ProcessFlowLabel Members.

System.Object
SymbolBase
Symbol
ProcessFlowStepBase
ProcessFlowLabel

public class ProcessFlowLabel : ProcessFlowStepBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ProcessFlowLabel Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowLabel Members

ProcessFlowLabel overview

Public Instance Constructors

ProcessFlowLabel Overloaded. Initializes a new instance of the ProcessFlowLabel class.

Public Instance Properties

Application
AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description (inherited from ProcessFlowStepBase)
Edges (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesEntering (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FillStyle (inherited from ProcessFlowStepBase)
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Image (inherited from ProcessFlowStepBase)
ImageVisible (inherited from ProcessFlowStepBase)
IsFirstStep (inherited from ProcessFlowStepBase)
LabelID
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
LineStyle (inherited from ProcessFlowStepBase)
LineVisible (inherited from ProcessFlowStepBase)
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Model
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ProcessFlowGE
ProcessFlowID
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ShadowStyle (inherited from ProcessFlowStepBase)
Shape (inherited from ProcessFlowStepBase)
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Text (inherited from ProcessFlowStepBase)
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Public Instance Methods

AcceptConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType (inherited from ProcessFlowStepBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Load |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Save |
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage (inherited from ProcessFlowStepBase) |
SetImageFile (inherited from ProcessFlowStepBase) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Protected Instance Fields

children (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
m_lblDescription (inherited from ProcessFlowStepBase)
m_lblName (inherited from ProcessFlowStepBase)
m_line (inherited from ProcessFlowStepBase)
matrix (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
propertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from ProcessFlowStepBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowLabel Constructor

Overload List

Initializes a new instance of the ProcessFlowLabel class.

public ProcessFlowLabel();

public ProcessFlowLabel(ProcessFlowStepBase.ShapeType);

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowLabel Constructor (ShapeType)

public ProcessFlowLabel(
ProcessFlowStepBase.ShapeType ShapeType
);

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowLabel Constructor Overload List


ProcessFlowLabel Constructor ()

Initializes a new instance of the ProcessFlowLabel class.

public ProcessFlowLabel();

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowLabel Constructor Overload List


ProcessFlowLabel Properties

The properties of the ProcessFlowLabel class are listed below. For a complete list of ProcessFlowLabel class members, see the ProcessFlowLabel Members topic.

Public Instance Properties

Application
AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description (inherited from ProcessFlowStepBase)
Edges (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesEntering (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FillStyle (inherited from ProcessFlowStepBase)
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Image (inherited from ProcessFlowStepBase)
ImageVisible (inherited from ProcessFlowStepBase)
IsFirstStep (inherited from ProcessFlowStepBase)
LabelID
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
LineStyle (inherited from ProcessFlowStepBase)
LineVisible (inherited from ProcessFlowStepBase)
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Model
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ProcessFlowGE
ProcessFlowID
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ShadowStyle (inherited from ProcessFlowStepBase)
Shape (inherited from ProcessFlowStepBase)
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Text (inherited from ProcessFlowStepBase)
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowLabel.Application Property

public AptifyApplication Application {get; set;}

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


LabelID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowLabel.LabelID Property

public Int64 LabelID {get;}

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Model Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowLabel.Model Property

public Model Model {get; set;}

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowGE Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowLabel.ProcessFlowGE Property

public AptifyGenericEntityBase ProcessFlowGE {get; set;}

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowLabel.ProcessFlowID Property

public Int64 ProcessFlowID {get; set;}

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowLabel Methods

The methods of the ProcessFlowLabel class are listed below. For a complete list of ProcessFlowLabel class members, see the ProcessFlowLabel Members topic.

Public Instance Methods

AcceptConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType (inherited from ProcessFlowStepBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Load |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Save |
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage (inherited from ProcessFlowStepBase) |
SetImageFile (inherited from ProcessFlowStepBase) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from ProcessFlowStepBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowLabel.Load Method

public bool Load(
AptifyGenericEntityBase LabelGE
);

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowLabel.Save Method

public bool Save();

See Also

ProcessFlowLabel Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowPropertySheet Class

For a list of all members of this type, see ProcessFlowPropertySheet Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ProcessFlowPropertySheet

public class ProcessFlowPropertySheet : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ProcessFlowPropertySheet Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowPropertySheet Members

ProcessFlowPropertySheet overview

Public Instance Constructors

ProcessFlowPropertySheet Constructor Initializes a new instance of the ProcessFlowPropertySheet class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Diagram |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ResultCodeProperties |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedItem |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSelectedItem |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowPropertySheet Constructor

Initializes a new instance of the ProcessFlowPropertySheet class.

public ProcessFlowPropertySheet();

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowPropertySheet Properties

The properties of the ProcessFlowPropertySheet class are listed below. For a complete list of ProcessFlowPropertySheet class members, see the ProcessFlowPropertySheet Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Diagram |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ResultCodeProperties |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedItem |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowPropertySheet.Application Property

public AptifyApplication Application {get; set;}

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Diagram Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowPropertySheet.Diagram Property

public ProcessFlowDiagram Diagram {get; set;}

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeProperties Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowPropertySheet.ResultCodeProperties Property

public ResultCodeProperties ResultCodeProperties {get;}

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


SelectedItem Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowPropertySheet.SelectedItem Property

public INode SelectedItem {get;}

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowPropertySheet Methods

The methods of the ProcessFlowPropertySheet class are listed below. For a complete list of ProcessFlowPropertySheet class members, see the ProcessFlowPropertySheet Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSelectedItem |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowPropertySheet.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowPropertySheet.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowPropertySheet.Dispose Overload List


ProcessFlowPropertySheet.SetSelectedItem Method

public bool SetSelectedItem(
INode Value
);

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowPropertySheet.TransferDataToObject Method

public bool TransferDataToObject();

See Also

ProcessFlowPropertySheet Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode Class

For a list of all members of this type, see ProcessFlowResultCode Members.

System.Object
SymbolBase
Link
ProcessFlowResultCode

public class ProcessFlowResultCode : Link

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ProcessFlowResultCode Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode Members

ProcessFlowResultCode overview

Public Instance Constructors

ProcessFlowResultCode Overloaded. Initializes a new instance of the ProcessFlowResultCode class.

Public Instance Properties

Application
AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Controller
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description
EdgeWeight (inherited from Syncfusion.Windows.Forms.Diagram.Link)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
EndPoints (inherited from Syncfusion.Windows.Forms.Diagram.Link)
FillStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FromNode (inherited from Syncfusion.Windows.Forms.Diagram.Link)
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
HeadPort (inherited from Syncfusion.Windows.Forms.Diagram.Link)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ID
IsSuccess
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LineBridgeSize (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LineBridgingEnabled (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LineRoutingEnabled (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LineSegments (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LineStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
LocalPoints (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Model
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
NextStep
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
OwnerStep
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Points (inherited from Syncfusion.Windows.Forms.Diagram.Link)
PortFrom
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
PortTo
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
RoutableLine (inherited from Syncfusion.Windows.Forms.Diagram.Link)
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
TailPort (inherited from Syncfusion.Windows.Forms.Diagram.Link)
Text
ToNode (inherited from Syncfusion.Windows.Forms.Diagram.Link)
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Public Instance Methods

AcceptConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Link) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
Connect |
ConnectHead |
ConnectTail |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectResultCode |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
IsNodeEntering (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
IsNodeLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.Link) |

Public Instance Events

BeforeDisconnect
CodeChanged
NextStepChanged

Protected Instance Fields

bExcludeConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Link)
children (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
matrix (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
propertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
CreateHeadPort (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
CreateLinkShape (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateTailPort (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
DockConnections (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode Constructor

Overload List

Initializes a new instance of the ProcessFlowResultCode class.

public ProcessFlowResultCode();

public ProcessFlowResultCode(PointF[]);

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode Constructor (PointF[])

public ProcessFlowResultCode(
PointF[] pts
);

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowResultCode Constructor Overload List


ProcessFlowResultCode Constructor ()

Initializes a new instance of the ProcessFlowResultCode class.

public ProcessFlowResultCode();

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowResultCode Constructor Overload List


ProcessFlowResultCode Properties

The properties of the ProcessFlowResultCode class are listed below. For a complete list of ProcessFlowResultCode class members, see the ProcessFlowResultCode Members topic.

Public Instance Properties

Application
AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Controller
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description
EdgeWeight (inherited from Syncfusion.Windows.Forms.Diagram.Link)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
EndPoints (inherited from Syncfusion.Windows.Forms.Diagram.Link)
FillStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FromNode (inherited from Syncfusion.Windows.Forms.Diagram.Link)
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
HeadPort (inherited from Syncfusion.Windows.Forms.Diagram.Link)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ID
IsSuccess
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LineBridgeSize (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LineBridgingEnabled (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LineRoutingEnabled (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LineSegments (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LineStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
LocalPoints (inherited from Syncfusion.Windows.Forms.Diagram.Link)
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Model
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
NextStep
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
OwnerStep
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Points (inherited from Syncfusion.Windows.Forms.Diagram.Link)
PortFrom
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
PortTo
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
RoutableLine (inherited from Syncfusion.Windows.Forms.Diagram.Link)
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
TailPort (inherited from Syncfusion.Windows.Forms.Diagram.Link)
Text
ToNode (inherited from Syncfusion.Windows.Forms.Diagram.Link)
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowResultCode.Application Property

public AptifyApplication Application {get; set;}

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Controller Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowResultCode.Controller Property

public Controller Controller {get; set;}

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowResultCode.Description Property

public String Description {get; set;}

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowResultCode.ID Property

public Int64 ID {get; set;}

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


IsSuccess Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowResultCode.IsSuccess Property

public Boolean IsSuccess {get; set;}

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Model Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowResultCode.Model Property

public Model Model {get; set;}

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


NextStep Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowResultCode.NextStep Property

public ProcessFlowStep NextStep {get; set;}

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


OwnerStep Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowResultCode.OwnerStep Property

public ProcessFlowStep OwnerStep {get; set;}

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


PortFrom Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowResultCode.PortFrom Property

public String PortFrom {get; set;}

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


PortTo Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowResultCode.PortTo Property

public String PortTo {get; set;}

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Text Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowResultCode.Text Property

public String Text {get; set;}

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode Methods

The methods of the ProcessFlowResultCode class are listed below. For a complete list of ProcessFlowResultCode class members, see the ProcessFlowResultCode Members topic.

Public Instance Methods

AcceptConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Link) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
Connect |
ConnectHead |
ConnectTail |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectResultCode |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
IsNodeEntering (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
IsNodeLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.Link) |

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
CreateHeadPort (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
CreateLinkShape (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateTailPort (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
DockConnections (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.Link) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode.Connect Method

public override Connection Connect(
Port sourcePort,
Port targetPort
);

Implements

IPortContainer.

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode.ConnectHead Method

public override Connection ConnectHead(
Port port
);

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode.ConnectTail Method

public override Connection ConnectTail(
Port port
);

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode.DisconnectResultCode Method

public void DisconnectResultCode();

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode Events

The events of the ProcessFlowResultCode class are listed below. For a complete list of ProcessFlowResultCode class members, see the ProcessFlowResultCode Members topic.

Public Instance Events

BeforeDisconnect
CodeChanged
NextStepChanged

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode.ProcessFlowResultCode.BeforeDisconnectEventHandler Event

public event ProcessFlowResultCode.BeforeDisconnectEventHandler BeforeDisconnect;

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode.ProcessFlowResultCode.CodeChangedEventHandler Event

public event ProcessFlowResultCode.CodeChangedEventHandler CodeChanged;

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode.ProcessFlowResultCode.NextStepChangedEventHandler Event

public event ProcessFlowResultCode.NextStepChangedEventHandler NextStepChanged;

See Also

ProcessFlowResultCode Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode.BeforeDisconnectEventHandler Delegate

public delegate void ProcessFlowResultCode.BeforeDisconnectEventHandler(
ProcessFlowResultCode ResultCode,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode.CodeChangedEventHandler Delegate

public delegate void ProcessFlowResultCode.CodeChangedEventHandler(
ProcessFlowResultCode ResultCode
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowResultCode.NextStepChangedEventHandler Delegate

public delegate void ProcessFlowResultCode.NextStepChangedEventHandler(
ProcessFlowResultCode ResultCode
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep Class

For a list of all members of this type, see ProcessFlowStep Members.

System.Object
SymbolBase
Symbol
ProcessFlowStepBase
ProcessFlowStep
ComponentStep
RuleStep
SubProcessStep

public class ProcessFlowStep : ProcessFlowStepBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ProcessFlowStep Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep Members

ProcessFlowStep overview

Public Instance Constructors

ProcessFlowStep Overloaded. Initializes a new instance of the ProcessFlowStep class.

Public Instance Properties

Application
AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Controller
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description (inherited from ProcessFlowStepBase)
Edges (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesEntering (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FillStyle (inherited from ProcessFlowStepBase)
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Image (inherited from ProcessFlowStepBase)
ImageVisible (inherited from ProcessFlowStepBase)
IsFirstStep (inherited from ProcessFlowStepBase)
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
LineStyle (inherited from ProcessFlowStepBase)
LineVisible (inherited from ProcessFlowStepBase)
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Model
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ProcessFlowID
ProcessFlowStepID
ResultCodes
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ShadowStyle (inherited from ProcessFlowStepBase)
Shape (inherited from ProcessFlowStepBase)
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
StepDescription
StepGE
StepName
StepType
Text (inherited from ProcessFlowStepBase)
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Public Instance Methods

AcceptConnection |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType (inherited from ProcessFlowStepBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Save |
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage (inherited from ProcessFlowStepBase) |
SetImageFile (inherited from ProcessFlowStepBase) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Public Instance Events

StepDescriptionChanged
StepNameChanged

Protected Instance Fields

children (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
m_lblDescription (inherited from ProcessFlowStepBase)
m_lblName (inherited from ProcessFlowStepBase)
m_line (inherited from ProcessFlowStepBase)
m_oStepGE
matrix (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
propertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from ProcessFlowStepBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep Constructor

Initializes a new instance of the ProcessFlowStep class.

Overload List

Initializes a new instance of the ProcessFlowStep class.

public ProcessFlowStep();

public ProcessFlowStep(ProcessFlowStepBase.ShapeType);

public ProcessFlowStep(Controller,Model);

public ProcessFlowStep(Controller,Model,ProcessFlowStepBase.ShapeType);

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep Constructor ()

Initializes a new instance of the ProcessFlowStep class.

public ProcessFlowStep();

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowStep Constructor Overload List


ProcessFlowStep Constructor (ShapeType)

public ProcessFlowStep(
ProcessFlowStepBase.ShapeType ShapeType
);

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowStep Constructor Overload List


ProcessFlowStep Constructor (Controller, Model)

public ProcessFlowStep(
Controller oController,
Model oModel
);

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowStep Constructor Overload List


ProcessFlowStep Constructor (Controller, Model, ShapeType)

public ProcessFlowStep(
Controller oController,
Model oModel,
ProcessFlowStepBase.ShapeType ShapeType
);

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowStep Constructor Overload List


ProcessFlowStep Fields

The fields of the ProcessFlowStep class are listed below. For a complete list of ProcessFlowStep class members, see the ProcessFlowStep Members topic.

Protected Instance Fields

children (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
m_lblDescription (inherited from ProcessFlowStepBase)
m_lblName (inherited from ProcessFlowStepBase)
m_line (inherited from ProcessFlowStepBase)
m_oStepGE
matrix (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
propertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep.m_oStepGE Field

protected m_oStepGE m_oStepGE;

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepProperties Class

For a list of all members of this type, see ProcessFlowStepProperties Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ProcessFlowStepProperties

public class ProcessFlowStepProperties : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ProcessFlowStepProperties Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStep.Application Property

public virtual AptifyApplication Application {get; set;}

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Controller Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStep.Controller Property

public Controller Controller {get; set;}

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Model Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStep.Model Property

public Model Model {get; set;}

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStep.ProcessFlowID Property

public Int64 ProcessFlowID {get; set;}

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStep.ProcessFlowStepID Property

public Int64 ProcessFlowStepID {get; set;}

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodes Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStep.ResultCodes Property

public ResultCodeList ResultCodes {get;}

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


StepDescription Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStep.StepDescription Property

public String StepDescription {get; set;}

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


StepGE Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStep.StepGE Property

public AptifyGenericEntityBase StepGE {get;}

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


StepName Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStep.StepName Property

public String StepName {get; set;}

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


StepType Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStep.StepType Property

public abstract String StepType {get;}

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep Methods

The methods of the ProcessFlowStep class are listed below. For a complete list of ProcessFlowStep class members, see the ProcessFlowStep Members topic.

Public Instance Methods

AcceptConnection |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType (inherited from ProcessFlowStepBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Save |
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage (inherited from ProcessFlowStepBase) |
SetImageFile (inherited from ProcessFlowStepBase) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from ProcessFlowStepBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep.AcceptConnection Method

public override bool AcceptConnection(
Port sourcePort,
Port targetPort
);

Implements

IPortContainer.

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep.OnLabelsChangeComplete Method

protected override void OnLabelsChangeComplete(
LabelCollectionEventArgs evtArgs
);

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep.Save Method

public virtual bool Save();

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep Events

The events of the ProcessFlowStep class are listed below. For a complete list of ProcessFlowStep class members, see the ProcessFlowStep Members topic.

Public Instance Events

StepDescriptionChanged
StepNameChanged

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep.ProcessFlowStep.StepDescriptionChangedEventHandler Event

public event ProcessFlowStep.StepDescriptionChangedEventHandler StepDescriptionChanged;

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep.ProcessFlowStep.StepNameChangedEventHandler Event

public event ProcessFlowStep.StepNameChangedEventHandler StepNameChanged;

See Also

ProcessFlowStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep.StepDescriptionChangedEventHandler Delegate

public delegate void ProcessFlowStep.StepDescriptionChangedEventHandler();

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep.StepNameChangedEventHandler Delegate

public delegate void ProcessFlowStep.StepNameChangedEventHandler();

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase Class

For a list of all members of this type, see ProcessFlowStepBase Members.

System.Object
SymbolBase
Symbol
ProcessFlowStepBase
ProcessFlowLabel
ProcessFlowStep

public class ProcessFlowStepBase : Symbol

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ProcessFlowStepBase Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase Members

ProcessFlowStepBase overview

Public Instance Constructors

ProcessFlowStepBase Overloaded. Initializes a new instance of the ProcessFlowStepBase class.

Public Instance Properties

AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description
Edges (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesEntering (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FillStyle
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Image
ImageVisible
IsFirstStep
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
LineStyle
LineVisible
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ShadowStyle
Shape
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Text
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Public Instance Methods

AcceptConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage |
SetImageFile |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Protected Instance Fields

children (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
m_lblDescription
m_lblName
m_line
matrix (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
propertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase Constructor

Initializes a new instance of the ProcessFlowStepBase class.

Overload List

Initializes a new instance of the ProcessFlowStepBase class.

public ProcessFlowStepBase();

public ProcessFlowStepBase(ProcessFlowStepBase.ShapeType);

public ProcessFlowStepBase(Single,Single,Single,Single);

public ProcessFlowStepBase(Single,Single,Single,Single,ProcessFlowStepBase.ShapeType);

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase Constructor ()

Initializes a new instance of the ProcessFlowStepBase class.

public ProcessFlowStepBase();

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowStepBase Constructor Overload List


ProcessFlowStepBase Constructor (ShapeType)

public ProcessFlowStepBase(
ProcessFlowStepBase.ShapeType ShapeType
);

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowStepBase Constructor Overload List


ProcessFlowStepBase Constructor (Single, Single, Single, Single)

public ProcessFlowStepBase(
Single x,
Single y,
Single width,
Single height
);

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowStepBase Constructor Overload List


ProcessFlowStepBase Constructor (Single, Single, Single, Single, ShapeType)

public ProcessFlowStepBase(
Single x,
Single y,
Single width,
Single height,
ProcessFlowStepBase.ShapeType ShapeType
);

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowStepBase Constructor Overload List


ProcessFlowStepBase Fields

The fields of the ProcessFlowStepBase class are listed below. For a complete list of ProcessFlowStepBase class members, see the ProcessFlowStepBase Members topic.

Protected Instance Fields

children (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
m_lblDescription
m_lblName
m_line
matrix (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
propertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase.m_lblDescription Field

protected m_lblDescription m_lblDescription;

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase.m_lblName Field

protected m_lblName m_lblName;

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase.m_line Field

protected m_line m_line;

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase Properties

The properties of the ProcessFlowStepBase class are listed below. For a complete list of ProcessFlowStepBase class members, see the ProcessFlowStepBase Members topic.

Public Instance Properties

AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description
Edges (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesEntering (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FillStyle
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Image
ImageVisible
IsFirstStep
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
LineStyle
LineVisible
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ShadowStyle
Shape
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Text
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepBase.Description Property

public virtual String Description {get; set;}

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


FillStyle Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepBase.FillStyle Property

new public FillStyle FillStyle {get;}

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Image Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepBase.Image Property

public BitmapNode Image {get;}

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ImageVisible Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepBase.ImageVisible Property

public Boolean ImageVisible {get; set;}

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


IsFirstStep Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepBase.IsFirstStep Property

public virtual Boolean IsFirstStep {get; set;}

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


LineStyle Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepBase.LineStyle Property

new public LineStyle LineStyle {get;}

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


LineVisible Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepBase.LineVisible Property

public Boolean LineVisible {get; set;}

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ShadowStyle Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepBase.ShadowStyle Property

public virtual ShadowStyle ShadowStyle {get;}

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Shape Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepBase.Shape Property

public virtual FilledShape Shape {get;}

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Text Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepBase.Text Property

public virtual String Text {get; set;}

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase Methods

The methods of the ProcessFlowStepBase class are listed below. For a complete list of ProcessFlowStepBase class members, see the ProcessFlowStepBase Members topic.

Public Instance Methods

AcceptConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage |
SetImageFile |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase.GetShapeType Method

public ShapeType GetShapeType();

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase.OnBoundsChanged Method

protected override void OnBoundsChanged(
BoundsEventArgs evtArgs
);

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase.SetImage Method

public void SetImage(
Image img
);

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase.SetImageFile Method

public void SetImageFile(
String sFile
);

See Also

ProcessFlowStepBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepBase.ShapeType Enumeration

public enum ProcessFlowStepBase.ShapeType

Members

Member Name | Description
Rectangle |
RoundRectangle |
Ellipse |

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepProperties Members

ProcessFlowStepProperties overview

Public Instance Constructors

ProcessFlowStepProperties Constructor Initializes a new instance of the ProcessFlowStepProperties class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Diagram |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProcessFlowStep |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InputMapIsValid |
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetColorForRequiredProperties |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DetermineUniqueStepName |
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepProperties Constructor

Initializes a new instance of the ProcessFlowStepProperties class.

public ProcessFlowStepProperties();

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepProperties Properties

The properties of the ProcessFlowStepProperties class are listed below. For a complete list of ProcessFlowStepProperties class members, see the ProcessFlowStepProperties Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Diagram |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProcessFlowStep |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepProperties.Application Property

public AptifyApplication Application {get; set;}

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Diagram Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepProperties.Diagram Property

public ProcessFlowDiagram Diagram {get; set;}

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStep Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepProperties.ProcessFlowStep Property

public ProcessFlowStep ProcessFlowStep {get; set;}

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepProperties Methods

The methods of the ProcessFlowStepProperties class are listed below. For a complete list of ProcessFlowStepProperties class members, see the ProcessFlowStepProperties Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InputMapIsValid |
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetColorForRequiredProperties |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DetermineUniqueStepName |
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepProperties.ApplySkin Method

protected virtual void ApplySkin();

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepProperties.DetermineUniqueStepName Method

protected virtual string DetermineUniqueStepName(
ProcessFlowStep CurrentStep,
String ProposedName
);

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepProperties.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepProperties.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ProcessFlowStepProperties.Dispose Overload List


ProcessFlowStepProperties.InputMapIsValid Method

public string InputMapIsValid();

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepProperties.SetColorForRequiredProperties Method

public void SetColorForRequiredProperties();

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ProcessFlowStepProperties.TransferDataToObject Method

public bool TransferDataToObject();

See Also

ProcessFlowStepProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeList Class

For a list of all members of this type, see ResultCodeList Members.

System.Object
ArrayList
ResultCodeList

public class ResultCodeList : ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ResultCodeList Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeList Members

ResultCodeList overview

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
DeletedResultCodes |
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread safe).
Item | Overloaded.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add | Overloaded.
Add (inherited from ArrayList) | Overloaded. Adds an object to the end of the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList.
Remove | Overloaded.
Remove (inherited from ArrayList) | Overloaded. Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the entire ArrayList.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in the entire ArrayList using the IComparable implementation of each element.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new Object array.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Public Instance Events

BeforeDisconnect

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeList Properties

The properties of the ResultCodeList class are listed below. For a complete list of ResultCodeList class members, see the ResultCodeList Members topic.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
DeletedResultCodes |
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread safe).
Item | Overloaded.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


DeletedResultCodes Property

Aptify 5.0 Software Development Kit (SDK)

ResultCodeList.DeletedResultCodes Property

public ArrayList DeletedResultCodes {get;}

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

ResultCodeList.Item Property

public ProcessFlowResultCode this[
Int32 index
] {get; set;}

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeList Methods

The methods of the ResultCodeList class are listed below. For a complete list of ResultCodeList class members, see the ResultCodeList Members topic.

Public Instance Methods

Add | Overloaded.
Add (inherited from ArrayList) | Overloaded. Adds an object to the end of the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList.
Remove | Overloaded.
Remove (inherited from ArrayList) | Overloaded. Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the entire ArrayList.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in the entire ArrayList using the IComparable implementation of each element.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new Object array.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

ResultCodeList.Add Method

Overload List

public ProcessFlowResultCode Add();

public int Add(ProcessFlowResultCode);

Inherited from ArrayList.

public virtual int Add(Object);

public ProcessFlowResultCode Add(Single,Single,Single,Single);

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeList.Add Method ()

public ProcessFlowResultCode Add();

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ResultCodeList.Add Overload List


ResultCodeList.Add Method (ProcessFlowResultCode)

public int Add(
ProcessFlowResultCode value
);

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ResultCodeList.Add Overload List


ResultCodeList.Add Method (Single, Single, Single, Single)

public ProcessFlowResultCode Add(
Single x,
Single y,
Single width,
Single height
);

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ResultCodeList.Add Overload List


Remove Method

Aptify 5.0 Software Development Kit (SDK)

ResultCodeList.Remove Method

Overload List

public void Remove(ProcessFlowResultCode);

Inherited from ArrayList.

public virtual void Remove(Object);

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeList.Remove Method (ProcessFlowResultCode)

public void Remove(
ProcessFlowResultCode obj
);

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ResultCodeList.Remove Overload List


ResultCodeList Events

The events of the ResultCodeList class are listed below. For a complete list of ResultCodeList class members, see the ResultCodeList Members topic.

Public Instance Events

BeforeDisconnect

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeList.ResultCodeList.BeforeDisconnectEventHandler Event

public event ResultCodeList.BeforeDisconnectEventHandler BeforeDisconnect;

See Also

ResultCodeList Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeList.BeforeDisconnectEventHandler Delegate

public delegate void ResultCodeList.BeforeDisconnectEventHandler(
ProcessFlowResultCode ResultCode,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeProperties Class

For a list of all members of this type, see ResultCodeProperties Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ResultCodeProperties

public class ResultCodeProperties : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

ResultCodeProperties Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeProperties Members

ResultCodeProperties overview

Public Instance Constructors

ResultCodeProperties Constructor Initializes a new instance of the ResultCodeProperties class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
Code |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Diagram |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableDataTransfer |
EnableSuccessBit |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsSuccess |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
NewResultCodeMode |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ResultCode |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisableLinks |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeProperties Constructor

Initializes a new instance of the ResultCodeProperties class.

public ResultCodeProperties();

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeProperties Properties

The properties of the ResultCodeProperties class are listed below. For a complete list of ResultCodeProperties class members, see the ResultCodeProperties Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
Code |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Diagram |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableDataTransfer |
EnableSuccessBit |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsSuccess |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
NewResultCodeMode |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ResultCode |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ResultCodeProperties.Application Property

public AptifyApplication Application {get; set;}

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Code Property

Aptify 5.0 Software Development Kit (SDK)

ResultCodeProperties.Code Property

public String Code {get;}

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Diagram Property

Aptify 5.0 Software Development Kit (SDK)

ResultCodeProperties.Diagram Property

public ProcessFlowDiagram Diagram {get; set;}

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


EnableDataTransfer Property

Aptify 5.0 Software Development Kit (SDK)

ResultCodeProperties.EnableDataTransfer Property

public Boolean EnableDataTransfer {get; set;}

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


EnableSuccessBit Property

Aptify 5.0 Software Development Kit (SDK)

ResultCodeProperties.EnableSuccessBit Property

public Boolean EnableSuccessBit {get; set;}

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


IsSuccess Property

Aptify 5.0 Software Development Kit (SDK)

ResultCodeProperties.IsSuccess Property

public Boolean IsSuccess {get; set;}

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


NewResultCodeMode Property

Aptify 5.0 Software Development Kit (SDK)

ResultCodeProperties.NewResultCodeMode Property

public Boolean NewResultCodeMode {get; set;}

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCode Property

Aptify 5.0 Software Development Kit (SDK)

ResultCodeProperties.ResultCode Property

public ProcessFlowResultCode ResultCode {get; set;}

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeProperties Methods

The methods of the ResultCodeProperties class are listed below. For a complete list of ResultCodeProperties class members, see the ResultCodeProperties Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisableLinks |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeProperties.DisableLinks Method

public void DisableLinks();

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ResultCodeProperties.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


ResultCodeProperties.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | ResultCodeProperties.Dispose Overload List


ResultCodeProperties.TransferDataToObject Method

public bool TransferDataToObject();

See Also

ResultCodeProperties Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


RuleStep Class

For a list of all members of this type, see RuleStep Members.

System.Object
SymbolBase
Symbol
ProcessFlowStepBase
ProcessFlowStep
RuleStep

public class RuleStep : ProcessFlowStep

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

RuleStep Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


RuleStep Members

RuleStep overview

Public Instance Constructors

RuleStep Overloaded. Initializes a new instance of the RuleStep class.

Public Instance Properties

Application (inherited from ProcessFlowStep)
AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Controller (inherited from ProcessFlowStep)
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description (inherited from ProcessFlowStepBase)
Edges (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesEntering (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FillStyle (inherited from ProcessFlowStepBase)
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Image (inherited from ProcessFlowStepBase)
ImageVisible (inherited from ProcessFlowStepBase)
IsFirstStep (inherited from ProcessFlowStepBase)
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
LineStyle (inherited from ProcessFlowStepBase)
LineVisible (inherited from ProcessFlowStepBase)
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Model (inherited from ProcessFlowStep)
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ProcessFlowID (inherited from ProcessFlowStep)
ProcessFlowStepID (inherited from ProcessFlowStep)
ResultCodes (inherited from ProcessFlowStep)
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
RuleText
RuleType
ShadowStyle (inherited from ProcessFlowStepBase)
Shape (inherited from ProcessFlowStepBase)
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
StepDescription (inherited from ProcessFlowStep)
StepGE (inherited from ProcessFlowStep)
StepName (inherited from ProcessFlowStep)
StepType
Text (inherited from ProcessFlowStepBase)
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Public Instance Methods

AcceptConnection (inherited from ProcessFlowStep) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType (inherited from ProcessFlowStepBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Save |
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage (inherited from ProcessFlowStepBase) |
SetImageFile (inherited from ProcessFlowStepBase) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Public Instance Events

StepDescriptionChanged (inherited from ProcessFlowStep)
StepNameChanged (inherited from ProcessFlowStep)

Protected Instance Fields

children (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
m_lblDescription (inherited from ProcessFlowStepBase)
m_lblName (inherited from ProcessFlowStepBase)
m_line (inherited from ProcessFlowStepBase)
m_oStepGE (inherited from ProcessFlowStep)
matrix (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
propertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from ProcessFlowStepBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from ProcessFlowStep) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

RuleStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


RuleStep Constructor

Initializes a new instance of the RuleStep class.

Overload List

Initializes a new instance of the RuleStep class.

public RuleStep();

public RuleStep(Controller,Model);

See Also

RuleStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


RuleStep Constructor ()

Initializes a new instance of the RuleStep class.

public RuleStep();

See Also

RuleStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | RuleStep Constructor Overload List


RuleStep Constructor (Controller, Model)

public RuleStep(
Controller oController,
Model oModel
);

See Also

RuleStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | RuleStep Constructor Overload List


RuleStep Properties

The properties of the RuleStep class are listed below. For a complete list of RuleStep class members, see the RuleStep Members topic.

Public Instance Properties

Application (inherited from ProcessFlowStep)
AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Controller (inherited from ProcessFlowStep)
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description (inherited from ProcessFlowStepBase)
Edges (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesEntering (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FillStyle (inherited from ProcessFlowStepBase)
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Image (inherited from ProcessFlowStepBase)
ImageVisible (inherited from ProcessFlowStepBase)
IsFirstStep (inherited from ProcessFlowStepBase)
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
LineStyle (inherited from ProcessFlowStepBase)
LineVisible (inherited from ProcessFlowStepBase)
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Model (inherited from ProcessFlowStep)
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ProcessFlowID (inherited from ProcessFlowStep)
ProcessFlowStepID (inherited from ProcessFlowStep)
ResultCodes (inherited from ProcessFlowStep)
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
RuleText
RuleType
ShadowStyle (inherited from ProcessFlowStepBase)
Shape (inherited from ProcessFlowStepBase)
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
StepDescription (inherited from ProcessFlowStep)
StepGE (inherited from ProcessFlowStep)
StepName (inherited from ProcessFlowStep)
StepType
Text (inherited from ProcessFlowStepBase)
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

See Also

RuleStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


RuleText Property

Aptify 5.0 Software Development Kit (SDK)

RuleStep.RuleText Property

public String RuleText {get; set;}

See Also

RuleStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


RuleType Property

Aptify 5.0 Software Development Kit (SDK)

RuleStep.RuleType Property

public String RuleType {get; set;}

See Also

RuleStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


StepType Property

Aptify 5.0 Software Development Kit (SDK)

RuleStep.StepType Property

public override String StepType {get;}

See Also

RuleStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


RuleStep Methods

The methods of the RuleStep class are listed below. For a complete list of RuleStep class members, see the RuleStep Members topic.

Public Instance Methods

AcceptConnection (inherited from ProcessFlowStep) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType (inherited from ProcessFlowStepBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Save |
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage (inherited from ProcessFlowStepBase) |
SetImageFile (inherited from ProcessFlowStepBase) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from ProcessFlowStepBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from ProcessFlowStep) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

RuleStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


RuleStep.Save Method

public override bool Save();

See Also

RuleStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


SubProcessStep Class

For a list of all members of this type, see SubProcessStep Members.

System.Object
SymbolBase
Symbol
ProcessFlowStepBase
ProcessFlowStep
SubProcessStep

public class SubProcessStep : ProcessFlowStep

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Assembly: Visual Diagram (in Visual Diagram.dll)

See Also

SubProcessStep Members | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


SubProcessStep Members

SubProcessStep overview

Public Instance Constructors

SubProcessStep Overloaded. Initializes a new instance of the SubProcessStep class.

Public Instance Properties

Application (inherited from ProcessFlowStep)
AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Controller (inherited from ProcessFlowStep)
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description (inherited from ProcessFlowStepBase)
Edges (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesEntering (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FillStyle (inherited from ProcessFlowStepBase)
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Image (inherited from ProcessFlowStepBase)
ImageVisible (inherited from ProcessFlowStepBase)
IsFirstStep (inherited from ProcessFlowStepBase)
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
LineStyle (inherited from ProcessFlowStepBase)
LineVisible (inherited from ProcessFlowStepBase)
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Model (inherited from ProcessFlowStep)
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ProcessFlowID (inherited from ProcessFlowStep)
ProcessFlowStepID (inherited from ProcessFlowStep)
ResultCodes (inherited from ProcessFlowStep)
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ShadowStyle (inherited from ProcessFlowStepBase)
Shape (inherited from ProcessFlowStepBase)
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
StepDescription (inherited from ProcessFlowStep)
StepGE (inherited from ProcessFlowStep)
StepName (inherited from ProcessFlowStep)
StepType
SubProcessID
Text (inherited from ProcessFlowStepBase)
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Public Instance Methods

AcceptConnection (inherited from ProcessFlowStep) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType (inherited from ProcessFlowStepBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Save |
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage (inherited from ProcessFlowStepBase) |
SetImageFile (inherited from ProcessFlowStepBase) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Public Instance Events

StepDescriptionChanged (inherited from ProcessFlowStep)
StepNameChanged (inherited from ProcessFlowStep)

Protected Instance Fields

children (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
m_lblDescription (inherited from ProcessFlowStepBase)
m_lblName (inherited from ProcessFlowStepBase)
m_line (inherited from ProcessFlowStepBase)
m_oStepGE (inherited from ProcessFlowStep)
matrix (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
propertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from ProcessFlowStepBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from ProcessFlowStep) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

SubProcessStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


SubProcessStep Constructor

Initializes a new instance of the SubProcessStep class.

Overload List

Initializes a new instance of the SubProcessStep class.

public SubProcessStep();

public SubProcessStep(Controller,Model);

See Also

SubProcessStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


SubProcessStep Constructor ()

Initializes a new instance of the SubProcessStep class.

public SubProcessStep();

See Also

SubProcessStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | SubProcessStep Constructor Overload List


SubProcessStep Constructor (Controller, Model)

public SubProcessStep(
Controller oController,
Model oModel
);

See Also

SubProcessStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace | SubProcessStep Constructor Overload List


SubProcessStep Properties

The properties of the SubProcessStep class are listed below. For a complete list of SubProcessStep class members, see the SubProcessStep Members topic.

Public Instance Properties

Application (inherited from ProcessFlowStep)
AutoHidePorts (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Bounds (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
CenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ChildCount (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Connections (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Controller (inherited from ProcessFlowStep)
DefaultLabel (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
DefaultLabelName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Description (inherited from ProcessFlowStepBase)
Edges (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesEntering (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EdgesLeaving (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
EditStyle (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
FillStyle (inherited from ProcessFlowStepBase)
FullName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
GraphicsPath (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Height (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Image (inherited from ProcessFlowStepBase)
ImageVisible (inherited from ProcessFlowStepBase)
IsFirstStep (inherited from ProcessFlowStepBase)
Labels (inherited from Syncfusion.Windows.Forms.Diagram.Symbol)
LineStyle (inherited from ProcessFlowStepBase)
LineVisible (inherited from ProcessFlowStepBase)
LocalTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Location (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Model (inherited from ProcessFlowStep)
Name (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Nodes (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Parent (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ParentTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Ports (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ProcessFlowID (inherited from ProcessFlowStep)
ProcessFlowStepID (inherited from ProcessFlowStep)
ResultCodes (inherited from ProcessFlowStep)
Root (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ShadowStyle (inherited from ProcessFlowStepBase)
Shape (inherited from ProcessFlowStepBase)
Size (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
StepDescription (inherited from ProcessFlowStep)
StepGE (inherited from ProcessFlowStep)
StepName (inherited from ProcessFlowStep)
StepType
SubProcessID
Text (inherited from ProcessFlowStepBase)
Visible (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Width (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
WorldTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
X (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
Y (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)
ZOrderDepth (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase)

See Also

SubProcessStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


StepType Property

Aptify 5.0 Software Development Kit (SDK)

SubProcessStep.StepType Property

public override String StepType {get;}

See Also

SubProcessStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


SubProcessID Property

Aptify 5.0 Software Development Kit (SDK)

SubProcessStep.SubProcessID Property

public Int64 SubProcessID {get; set;}

See Also

SubProcessStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


SubProcessStep Methods

The methods of the SubProcessStep class are listed below. For a complete list of SubProcessStep class members, see the SubProcessStep Members topic.

Public Instance Methods

AcceptConnection (inherited from ProcessFlowStep) |
AddLabel (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) | Overloaded.
AfterCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AfterCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
AppendChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandDo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BeforeCommandUndo (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringForward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
BringToFront (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CalcLabelPosition (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ChangePropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Clone (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
Connect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Disconnect (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
DisconnectAll (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Draw (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildByName (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildIndex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenAtPoint (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenContainedBy (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetChildrenIntersecting (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConnectionsOnPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetDefaultPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetForeignPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLabelMaxSize (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
GetLabelTransform (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetLocalPortOnConnection (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPortAt (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyContainer (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyNames (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetShapeType (inherited from ProcessFlowStepBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
InsertChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionMove (inherited from Syncfusion.Windows.Forms.Diagram.Symbol) |
RemoveAllChildren (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveChild (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
RemoveProperty (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Rotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Save |
Scale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
SendBackward (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SendToBack (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetDefaultPropertyValues (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetImage (inherited from ProcessFlowStepBase) |
SetImageFile (inherited from ProcessFlowStepBase) |
SetPropertyValue (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
SetZOrder (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Translate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

Protected Instance Methods

CheckConstrainingRegion (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) | Overloaded.
Connections_ChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Connections_Changing (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ConvertLogicalUnits (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateCenterPort (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
CreateStyles (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
ForeignContainerAdd (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
ForeignContainerRemove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetObjectData (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
GetService (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyConnectionsOnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnBoundsChanged (inherited from ProcessFlowStepBase) |
OnChildrenChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnChildrenChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnConnectionsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeleteVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDeserialization (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnDoubleClick (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnInsertVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnLabelsChangeComplete (inherited from ProcessFlowStep) |
OnLabelsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseEnter (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMouseLeave (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMove (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnMoveVertex (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChangeComplete (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPortsChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanged (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnPropertyChanging (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnRotate (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |
OnScale (inherited from Syncfusion.Windows.Forms.Diagram.SymbolBase) |

See Also

SubProcessStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


SubProcessStep.Save Method

public override bool Save();

See Also

SubProcessStep Class | Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl Namespace


Aptify.Framework.BusinessLogic.Reporting

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.Reporting Namespace

This namespace contains objects related to Aptify's Report Wizard, including the Report Wizard form and interfaces to support printing, previewing, and exporting report data.

Namespace hierarchy

Classes

Class | Description
CrystalReportViewer | This wraps the Crystal Report Viewer.
MessageConstants |
ReportException | Allows a developer to catch exceptions that are specific to Aptify reports
ReportWizardEngine | This class is used to drive the functionality of Report Wizard from both the Windows and the Web. This class does not provide a user interface directly, but rather has the underlying functionality that is used to generate reports using the provided parameters.
ReportWizardForm |

Interfaces

Interface | Description
IReportExporter | Allows a developer to export a report
IReportPreviewer | Allows a developer to immediately display a report to the screen.
IReportPrinter | Allows a developer to immediately print a report.
IReportWizard |

Delegates

Delegate | Description
ReportWizardEngine.StatusUpdateEventHandler |
ReportWizardForm.ReportConfiguredEventHandler |

Enumerations

Enumeration | Description
ReportWizardEngine.EventType | This enumerated type is used by the StatusUpdate event to indicate the calling function that is driving the event.


CrystalReportViewer Class

This wraps the Crystal Report Viewer.

For a list of all members of this type, see CrystalReportViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
CrystalReportViewer

public class CrystalReportViewer : UserControl, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

It contains additional Logic that allows it to plug-in to different sections of the Aptify Framework

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizard (in AptifyReportWizard.dll)

See Also

CrystalReportViewer Members | Aptify.Framework.BusinessLogic.Reporting Namespace


CrystalReportViewer Members

CrystalReportViewer overview

Public Instance Constructors

CrystalReportViewer Constructor Initializes a new instance of the CrystalReportViewer class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CrystalReportViewer |
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Overloaded.
ConfigureExport |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExportCompletion |
ExportSelection |
ExportSetup |
ExportToFile |
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
Print |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


CrystalReportViewer Constructor

Initializes a new instance of the CrystalReportViewer class.

public CrystalReportViewer();

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


CrystalReportViewer Properties

The properties of the CrystalReportViewer class are listed below. For a complete list of CrystalReportViewer class members, see the CrystalReportViewer Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CrystalReportViewer |
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


CrystalReportViewer Property

Aptify 5.0 Software Development Kit (SDK)

CrystalReportViewer.CrystalReportViewer Property

public CrystalReportViewer CrystalReportViewer {get;}

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CrystalReportViewer.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

CrystalReportViewer.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CrystalReportViewer.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

CrystalReportViewer.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

CrystalReportViewer.UserCredentials Property

public UserCredentials UserCredentials {get; set;}

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


CrystalReportViewer Methods

The methods of the CrystalReportViewer class are listed below. For a complete list of CrystalReportViewer class members, see the CrystalReportViewer Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Overloaded.
ConfigureExport |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExportCompletion |
ExportSelection |
ExportSetup |
ExportToFile |
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
Print |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

CrystalReportViewer.Config Method

Overload List

public void Config(AptifyApplication,IDashboardArea,Int64,ComponentOrientation);

public void Config(ReportDocument);

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


CrystalReportViewer.Config Method (AptifyApplication, IDashboardArea, Int64, ComponentOrientation)

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Implements

IDashboardComponent.

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace | CrystalReportViewer.Config Overload List


CrystalReportViewer.Config Method (ReportDocument)

public void Config(
ReportDocument Report
);

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace | CrystalReportViewer.Config Overload List


CrystalReportViewer.ConfigureExport Method

public void ConfigureExport(
ExportFormatType FormatType,
String FileName
);

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CrystalReportViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


CrystalReportViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace | CrystalReportViewer.Dispose Overload List


CrystalReportViewer.ExportCompletion Method

public void ExportCompletion();

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


CrystalReportViewer.ExportSelection Method

public void ExportSelection();

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


CrystalReportViewer.ExportSetup Method

public void ExportSetup();

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


CrystalReportViewer.ExportToFile Method

public void ExportToFile(
ExportFormatType FormatType,
String FileName
);

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


CrystalReportViewer.Print Method

public void Print();

See Also

CrystalReportViewer Class | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportExporter Interface

Allows a developer to export a report

For a list of all members of this type, see IReportExporter Members.

public interface IReportExporter : IDisposable

Types that implement IReportExporter

Type | Description
ReportWizardForm |

Remarks

This interface can be implemented for any type of export needed.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizardInterfaces (in AptifyReportWizardInterfaces.dll)

See Also

IReportExporter Members | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportExporter Members

IReportExporter overview

Public Instance Methods

Export

See Also

IReportExporter Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportExporter Methods

The methods of the IReportExporter interface are listed below. For a complete list of IReportExporter interface members, see the IReportExporter Members topic.

Public Instance Methods

Export

See Also

IReportExporter Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportExporter.Export Method

void Export(
AptifyApplication ApplicationObject,
Int64 ViewID,
Int64 ReportID,
Int32 FormatType,
Object ExportOptions
);

See Also

IReportExporter Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportPreviewer Interface

Allows a developer to immediately display a report to the screen.

For a list of all members of this type, see IReportPreviewer Members.

public interface IReportPreviewer : IDisposable

Types that implement IReportPreviewer

Type | Description
ReportWizardForm |

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizardInterfaces (in AptifyReportWizardInterfaces.dll)

See Also

IReportPreviewer Members | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportPreviewer Members

IReportPreviewer overview

Public Instance Methods

ShowPreview Causes a preview of the report to be displayed.

See Also

IReportPreviewer Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportPreviewer Methods

The methods of the IReportPreviewer interface are listed below. For a complete list of IReportPreviewer interface members, see the IReportPreviewer Members topic.

Public Instance Methods

ShowPreview Causes a preview of the report to be displayed.

See Also

IReportPreviewer Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportPreviewer.ShowPreview Method

Causes a preview of the report to be displayed.

void ShowPreview(
Form Parent,
AptifyApplication ApplicationObject,
Int64 ViewID,
Int64 ReportID
);

Parameters

Parent
This should be the form that causes the report to be previewed. It can be a null reference.
ApplicationObject
ViewID
ReportID

See Also

IReportPreviewer Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportPrinter Interface

Allows a developer to immediately print a report.

For a list of all members of this type, see IReportPrinter Members.

public interface IReportPrinter : IDisposable

Types that implement IReportPrinter

Type | Description
ReportWizardForm |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizardInterfaces (in AptifyReportWizardInterfaces.dll)

See Also

IReportPrinter Members | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportPrinter Members

IReportPrinter overview

Public Instance Methods

Print Send a report to a printer

See Also

IReportPrinter Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportPrinter Methods

The methods of the IReportPrinter interface are listed below. For a complete list of IReportPrinter interface members, see the IReportPrinter Members topic.

Public Instance Methods

Print Send a report to a printer

See Also

IReportPrinter Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportPrinter.Print Method

Send a report to a printer

void Print(
AptifyApplication ApplicationObject,
Int64 ViewID,
Int64 ReportID,
Object PrintOptions
);

Parameters

ApplicationObject
An instantiated ApplicationObject
ViewID
The Id of the View that should be exported
ReportID
The Id if the report that should be exported.
PrintOptions
Depending on the implementation of this interface additional data may need to be provided to print the report.

Remarks

See Also

IReportPrinter Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportWizard Interface

For a list of all members of this type, see IReportWizard Members.

public interface IReportWizard : IDisposable

Types that implement IReportWizard

Type | Description
ReportWizardForm |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizardInterfaces (in AptifyReportWizardInterfaces.dll)

See Also

IReportWizard Members | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportWizard Members

IReportWizard overview

Public Instance Methods

Config |
Show |
ShowDialog | Overloaded.

See Also

IReportWizard Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportWizard Methods

The methods of the IReportWizard interface are listed below. For a complete list of IReportWizard interface members, see the IReportWizard Members topic.

Public Instance Methods

Config |
Show |
ShowDialog | Overloaded.

See Also

IReportWizard Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportWizard.Config Method

void Config(
AptifyApplication ApplicationObject,
Int64 ListID,
Int64 ViewID,
String CustomViewSQL,
Int64 EntityID,
String SelList,
IAptifyDataAction.DSLCacheSetting CacheSettings
);

See Also

IReportWizard Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportWizard.Show Method

void Show();

See Also

IReportWizard Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

IReportWizard.ShowDialog Method

Overload List

DialogResult ShowDialog();

DialogResult ShowDialog(Control);

See Also

IReportWizard Interface | Aptify.Framework.BusinessLogic.Reporting Namespace


IReportWizard.ShowDialog Method ()

DialogResult ShowDialog();

See Also

IReportWizard Interface | Aptify.Framework.BusinessLogic.Reporting Namespace | IReportWizard.ShowDialog Overload List


IReportWizard.ShowDialog Method (Control)

DialogResult ShowDialog(
Control Owner
);

See Also

IReportWizard Interface | Aptify.Framework.BusinessLogic.Reporting Namespace | IReportWizard.ShowDialog Overload List


MessageConstants Class

For a list of all members of this type, see MessageConstants Members.

System.Object
MessageConstants

public class MessageConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizard (in AptifyReportWizard.dll)

See Also

MessageConstants Members | Aptify.Framework.BusinessLogic.Reporting Namespace


MessageConstants Members

MessageConstants overview

Public Static Fields

FAILURE
FORMAT_NOT_SUPPORTED
NO_MATCHES_FOUND
NOT_ALLOWED
SUCCESS

Public Instance Constructors

MessageConstants Constructor Initializes a new instance of the MessageConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageConstants Class | Aptify.Framework.BusinessLogic.Reporting Namespace


MessageConstants Constructor

Initializes a new instance of the MessageConstants class.

public MessageConstants();

See Also

MessageConstants Class | Aptify.Framework.BusinessLogic.Reporting Namespace


MessageConstants Fields

The fields of the MessageConstants class are listed below. For a complete list of MessageConstants class members, see the MessageConstants Members topic.

Public Static Fields

FAILURE
FORMAT_NOT_SUPPORTED
NO_MATCHES_FOUND
NOT_ALLOWED
SUCCESS

See Also

MessageConstants Class | Aptify.Framework.BusinessLogic.Reporting Namespace


MessageConstants.FAILURE Field

public const FAILURE FAILURE = "The action was not successful: ";

See Also

MessageConstants Class | Aptify.Framework.BusinessLogic.Reporting Namespace


MessageConstants.FORMAT_NOT_SUPPORTED Field

public const FORMAT_NOT_SUPPORTED FORMAT_NOT_SUPPORTED = "That format is not supported.";

See Also

MessageConstants Class | Aptify.Framework.BusinessLogic.Reporting Namespace


MessageConstants.NO_MATCHES_FOUND Field

public const NO_MATCHES_FOUND NO_MATCHES_FOUND = "No matches were found for the value submitted.";

See Also

MessageConstants Class | Aptify.Framework.BusinessLogic.Reporting Namespace


MessageConstants.NOT_ALLOWED Field

public const NOT_ALLOWED NOT_ALLOWED = "You are not allowed to do this action.";

See Also

MessageConstants Class | Aptify.Framework.BusinessLogic.Reporting Namespace


MessageConstants.SUCCESS Field

public const SUCCESS SUCCESS = "The action was successful.";

See Also

MessageConstants Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportException Class

Allows a developer to catch exceptions that are specific to Aptify reports

For a list of all members of this type, see ReportException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
ReportException

public class ReportException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizardInterfaces (in AptifyReportWizardInterfaces.dll)

See Also

ReportException Members | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportException Members

ReportException overview

Public Instance Constructors

ReportException Overloaded. Initializes a new instance of the ReportException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReportException Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportException Constructor

Initializes a new instance of the ReportException class.

Overload List

Initializes a new instance of the ReportException class.

public ReportException();

public ReportException(SerializationInfo,StreamingContext);

public ReportException(String);

public ReportException(String,Exception);

See Also

ReportException Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportException Constructor ()

Initializes a new instance of the ReportException class.

public ReportException();

See Also

ReportException Class | Aptify.Framework.BusinessLogic.Reporting Namespace | ReportException Constructor Overload List


ReportException Constructor (String)

public ReportException(
String Message
);

See Also

ReportException Class | Aptify.Framework.BusinessLogic.Reporting Namespace | ReportException Constructor Overload List


ReportException Constructor (String, Exception)

public ReportException(
String Message,
Exception Inner
);

See Also

ReportException Class | Aptify.Framework.BusinessLogic.Reporting Namespace | ReportException Constructor Overload List


ReportException Constructor (SerializationInfo, StreamingContext)

public ReportException(
SerializationInfo Info,
StreamingContext Context
);

See Also

ReportException Class | Aptify.Framework.BusinessLogic.Reporting Namespace | ReportException Constructor Overload List


ReportWizardEngine Class

This class is used to drive the functionality of Report Wizard from both the Windows and the Web. This class does not provide a user interface directly, but rather has the underlying functionality that is used to generate reports using the provided parameters.

For a list of all members of this type, see ReportWizardEngine Members.

System.Object
ReportWizardEngine

public class ReportWizardEngine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizard (in AptifyReportWizard.dll)

See Also

ReportWizardEngine Members | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine Members

ReportWizardEngine overview

Public Instance Constructors

ReportWizardEngine Constructor Initializes a new instance of the ReportWizardEngine class.

Public Instance Properties

Application
DataAction

Public Instance Methods

Config | Overloaded. This overload should be used when a report is being run from a view that has a specific View ID
CreateReportList | This method will create a list that maps to the underlying set of data that should be included in a report based on the provide parameters. This method should only be called when a list needs to be generated for the specific report in question.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateListType | This method will return a list Type record ID that matches the specified List Type Name parameter for the given EntityID. In the event that no list type name exists for the given entity id, a new list type will be created and returned. This method in the base class definition utilizes the spDoCreateListType stored procedure for the functionality described above.
GetEntityAddToListSP | This method returns the name of the stored procedure that should be used to add records to a list for a given entity. For some entities, this is defined with a specialized stored procedure in the entity meta-data and that entity-specific SP is returned. In most cases, the generic spCreateListDetail is used when no entity-specific spAddToList meta-data is provided by the entity definition. This method returns spCreateListDetail if no entity-specific meta-data was provided.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetReportDetails | This method will return the details for a given report ID. Pass in the Report ID via the ReportID parameter, and the remaining OUT parameters will return information about the report including the Report Name, Assembly, Object and Prog ID attributes.
GetType (inherited from Object) | Gets the Type of the current instance.
KillFile | This method attempts to delete a file as specified by the FileName parameter and returns True if the file was deleted succesfully, False otherwise
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate This event is fired whenever the object is performing a long running process and provides a status update to the calling object as well as the ability to cancel the process by setting the Cancel parameter to True.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine Constructor

Initializes a new instance of the ReportWizardEngine class.

public ReportWizardEngine();

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine Properties

The properties of the ReportWizardEngine class are listed below. For a complete list of ReportWizardEngine class members, see the ReportWizardEngine Members topic.

Public Instance Properties

Application
DataAction

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardEngine.Application Property

public virtual AptifyApplication Application {get;}

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardEngine.DataAction Property

public virtual DataAction DataAction {get;}

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine Methods

The methods of the ReportWizardEngine class are listed below. For a complete list of ReportWizardEngine class members, see the ReportWizardEngine Members topic.

Public Instance Methods

Config | Overloaded. This overload should be used when a report is being run from a view that has a specific View ID
CreateReportList | This method will create a list that maps to the underlying set of data that should be included in a report based on the provide parameters. This method should only be called when a list needs to be generated for the specific report in question.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateListType | This method will return a list Type record ID that matches the specified List Type Name parameter for the given EntityID. In the event that no list type name exists for the given entity id, a new list type will be created and returned. This method in the base class definition utilizes the spDoCreateListType stored procedure for the functionality described above.
GetEntityAddToListSP | This method returns the name of the stored procedure that should be used to add records to a list for a given entity. For some entities, this is defined with a specialized stored procedure in the entity meta-data and that entity-specific SP is returned. In most cases, the generic spCreateListDetail is used when no entity-specific spAddToList meta-data is provided by the entity definition. This method returns spCreateListDetail if no entity-specific meta-data was provided.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetReportDetails | This method will return the details for a given report ID. Pass in the Report ID via the ReportID parameter, and the remaining OUT parameters will return information about the report including the Report Name, Assembly, Object and Prog ID attributes.
GetType (inherited from Object) | Gets the Type of the current instance.
KillFile | This method attempts to delete a file as specified by the FileName parameter and returns True if the file was deleted succesfully, False otherwise
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

ReportWizardEngine.Config Method

This overload should be used when a report is being run from a view that has a specific View ID

Overload List

This overload should be used when a report is being run from a view that has a specific View ID

public virtual void Config(AptifyApplication,Int64,String,IAptifyDataAction.DSLCacheSetting);

This overload should be used when a report is being run from a temporary view (view based on ViewSQL rather than a View ID)

public virtual void Config(AptifyApplication,String,String,IAptifyDataAction.DSLCacheSetting);

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine.Config Method (AptifyApplication, Int64, String, DSLCacheSetting)

This overload should be used when a report is being run from a view that has a specific View ID

public virtual void Config(
AptifyApplication Application,
Int64 ViewID,
String CustomViewSQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

Application
ViewID
CustomViewSQL
CacheSetting

Remarks

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace | ReportWizardEngine.Config Overload List


ReportWizardEngine.Config Method (AptifyApplication, String, String, DSLCacheSetting)

This overload should be used when a report is being run from a temporary view (view based on ViewSQL rather than a View ID)

public virtual void Config(
AptifyApplication Application,
String EntityName,
String ViewSQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

Application
EntityName
ViewSQL
CacheSetting

Remarks

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace | ReportWizardEngine.Config Overload List


ReportWizardEngine.CreateReportList Method

This method will create a list that maps to the underlying set of data that should be included in a report based on the provide parameters. This method should only be called when a list needs to be generated for the specific report in question.

public virtual long CreateReportList(
String ReportName
);

Parameters

ReportName
Name of the report to be used in the description for the new list that will be created

Return Value

Remarks

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine.GetCreateListType Method

This method will return a list Type record ID that matches the specified List Type Name parameter for the given EntityID. In the event that no list type name exists for the given entity id, a new list type will be created and returned. This method in the base class definition utilizes the spDoCreateListType stored procedure for the functionality described above.

public virtual long GetCreateListType(
String ListTypeName,
Int64 EntityID
);

Parameters

ListTypeName
EntityID

Return Value

Remarks

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine.GetEntityAddToListSP Method

This method returns the name of the stored procedure that should be used to add records to a list for a given entity. For some entities, this is defined with a specialized stored procedure in the entity meta-data and that entity-specific SP is returned. In most cases, the generic spCreateListDetail is used when no entity-specific spAddToList meta-data is provided by the entity definition. This method returns spCreateListDetail if no entity-specific meta-data was provided.

public virtual string GetEntityAddToListSP(
ref Int64& EntityID
);

Parameters

EntityID

Return Value

Remarks

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine.GetReportDetails Method

This method will return the details for a given report ID. Pass in the Report ID via the ReportID parameter, and the remaining OUT parameters will return information about the report including the Report Name, Assembly, Object and Prog ID attributes.

public virtual void GetReportDetails(
Int64 ReportID,
ref String& ReportName,
ref String& AssemblyName,
ref String& ObjectName,
ref String& ProgID
);

Parameters

ReportID
ReportName
AssemblyName
ObjectName
ProgID

Remarks

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine.KillFile Method

This method attempts to delete a file as specified by the FileName parameter and returns True if the file was deleted succesfully, False otherwise

public virtual bool KillFile(
String FileName
);

Parameters

FileName

Remarks

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine Events

The events of the ReportWizardEngine class are listed below. For a complete list of ReportWizardEngine class members, see the ReportWizardEngine Members topic.

Public Instance Events

StatusUpdate This event is fired whenever the object is performing a long running process and provides a status update to the calling object as well as the ability to cancel the process by setting the Cancel parameter to True.

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine.ReportWizardEngine.StatusUpdateEventHandler Event

This event is fired whenever the object is performing a long running process and provides a status update to the calling object as well as the ability to cancel the process by setting the Cancel parameter to True.

public event ReportWizardEngine.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

ReportWizardEngine Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine.EventType Enumeration

This enumerated type is used by the StatusUpdate event to indicate the calling function that is driving the event.

public enum ReportWizardEngine.EventType

Remarks

Members

Member Name | Description
CreateReportList |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizard (in AptifyReportWizard.dll)

See Also

Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardEngine.StatusUpdateEventHandler Delegate

public delegate void ReportWizardEngine.StatusUpdateEventHandler(
ReportWizardEngine.EventType EventType,
String Message,
Int32 PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizard (in AptifyReportWizard.dll)

See Also

Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm Class

For a list of all members of this type, see ReportWizardForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ReportWizardForm

public class ReportWizardForm : Form, IReportWizard, IReportPreviewer, IReportExporter, IReportPrinter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizard (in AptifyReportWizard.dll)

See Also

ReportWizardForm Members | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm Members

ReportWizardForm overview

Public Instance Constructors

ReportWizardForm Constructor Initializes a new instance of the ReportWizardForm class.

Public Instance Fields

optColSize
optDelimiter
optOrientation
optRecords
picExportPanels
picOutput
picPanels
ToolTip1

Public Instance Properties

_optColSize_0 |
_optColSize_1 |
_optDelimiter_0 |
_optDelimiter_1 |
_optDelimiter_2 |
_optOrientation_0 |
_optOrientation_1 |
_optRecords_0 |
_optRecords_1 |
_picExportPanels_0 |
_picExportPanels_1 |
_picOutput_0 |
_picOutput_1 |
_picPanels_0 |
_picPanels_1 |
_picPanels_2 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
chkColNames |
chkMultLines |
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
cmbExportType |
cmbPrinters |
cmdAddAll |
cmdAddOne |
cmdBack |
cmdBrowse |
cmdCancel |
cmdFinish |
cmdHelp |
cmdNext |
cmdRemoveAll |
cmdRemoveOne |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Frame1 |
frameDelimiter |
frameRecords |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Label1 |
Label2 |
Label3 |
Label4 |
Label5 |
Label6 |
Label7 |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
lblFields |
lblStatus |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Line1 |
Line2 |
Location (inherited from Form) |
lstAvailableFields |
lstSelected |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
pbarStatus |
picPage |
picPrinters |
picStatus |
Picture1 |
Picture2 |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
tabCategories |
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
txtColSize |
txtCopies |
txtDelimiter |
txtExportFile |
txtQualifier |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Configure the Report Wizard Form for use with a specific view/viewsql
ConfigureReportForDashboard |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Export | Exports a crystal report through the crystal report engine.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
Print | Tells the Crystal Report Viewer to print a Report.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
ShowPreview | Previews a report in the Crystal Report Viewer.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
ReportConfigured | This is fired after the report is configured if the ActionType is set to ConfigureOnly
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ReportEngine | Returns the internal instance of the Report Engine class that is being used by this report wizard form
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleEngineStatusUpdate |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm Constructor

Initializes a new instance of the ReportWizardForm class.

public ReportWizardForm();

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm Fields

The fields of the ReportWizardForm class are listed below. For a complete list of ReportWizardForm class members, see the ReportWizardForm Members topic.

Public Instance Fields

optColSize
optDelimiter
optOrientation
optRecords
picExportPanels
picOutput
picPanels
ToolTip1

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.optColSize Field

public optColSize optColSize;

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.optDelimiter Field

public optDelimiter optDelimiter;

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.optOrientation Field

public optOrientation optOrientation;

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.optRecords Field

public optRecords optRecords;

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.picExportPanels Field

public picExportPanels picExportPanels;

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.picOutput Field

public picOutput picOutput;

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.picPanels Field

public picPanels picPanels;

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.ToolTip1 Field

public ToolTip1 ToolTip1;

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm Properties

The properties of the ReportWizardForm class are listed below. For a complete list of ReportWizardForm class members, see the ReportWizardForm Members topic.

Public Instance Properties

_optColSize_0 |
_optColSize_1 |
_optDelimiter_0 |
_optDelimiter_1 |
_optDelimiter_2 |
_optOrientation_0 |
_optOrientation_1 |
_optRecords_0 |
_optRecords_1 |
_picExportPanels_0 |
_picExportPanels_1 |
_picOutput_0 |
_picOutput_1 |
_picPanels_0 |
_picPanels_1 |
_picPanels_2 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
chkColNames |
chkMultLines |
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
cmbExportType |
cmbPrinters |
cmdAddAll |
cmdAddOne |
cmdBack |
cmdBrowse |
cmdCancel |
cmdFinish |
cmdHelp |
cmdNext |
cmdRemoveAll |
cmdRemoveOne |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Frame1 |
frameDelimiter |
frameRecords |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Label1 |
Label2 |
Label3 |
Label4 |
Label5 |
Label6 |
Label7 |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
lblFields |
lblStatus |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Line1 |
Line2 |
Location (inherited from Form) |
lstAvailableFields |
lstSelected |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
pbarStatus |
picPage |
picPrinters |
picStatus |
Picture1 |
Picture2 |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
tabCategories |
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
txtColSize |
txtCopies |
txtDelimiter |
txtExportFile |
txtQualifier |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ReportEngine | Returns the internal instance of the Report Engine class that is being used by this report wizard form
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_optColSize_0 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._optColSize_0 Property

public virtual RadioButton _optColSize_0 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_optColSize_1 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._optColSize_1 Property

public virtual RadioButton _optColSize_1 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_optDelimiter_0 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._optDelimiter_0 Property

public virtual RadioButton _optDelimiter_0 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_optDelimiter_1 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._optDelimiter_1 Property

public virtual RadioButton _optDelimiter_1 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_optDelimiter_2 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._optDelimiter_2 Property

public virtual RadioButton _optDelimiter_2 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_optOrientation_0 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._optOrientation_0 Property

public virtual RadioButton _optOrientation_0 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_optOrientation_1 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._optOrientation_1 Property

public virtual RadioButton _optOrientation_1 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_optRecords_0 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._optRecords_0 Property

public virtual RadioButton _optRecords_0 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_optRecords_1 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._optRecords_1 Property

public virtual RadioButton _optRecords_1 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_picExportPanels_0 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._picExportPanels_0 Property

public virtual Panel _picExportPanels_0 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_picExportPanels_1 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._picExportPanels_1 Property

public virtual Panel _picExportPanels_1 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_picOutput_0 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._picOutput_0 Property

public virtual Panel _picOutput_0 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_picOutput_1 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._picOutput_1 Property

public virtual Panel _picOutput_1 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_picPanels_0 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._picPanels_0 Property

public virtual Panel _picPanels_0 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_picPanels_1 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._picPanels_1 Property

public virtual Panel _picPanels_1 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


_picPanels_2 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm._picPanels_2 Property

public virtual Panel _picPanels_2 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


chkColNames Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.chkColNames Property

public virtual CheckBox chkColNames {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


chkMultLines Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.chkMultLines Property

public virtual CheckBox chkMultLines {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmbExportType Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmbExportType Property

public virtual ComboBox cmbExportType {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmbPrinters Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmbPrinters Property

public virtual ComboBox cmbPrinters {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmdAddAll Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmdAddAll Property

public virtual Button cmdAddAll {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmdAddOne Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmdAddOne Property

public virtual Button cmdAddOne {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmdBack Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmdBack Property

public virtual Button cmdBack {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmdBrowse Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmdBrowse Property

public virtual Button cmdBrowse {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmdCancel Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmdCancel Property

public virtual Button cmdCancel {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmdFinish Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmdFinish Property

public virtual Button cmdFinish {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmdHelp Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmdHelp Property

public virtual Button cmdHelp {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmdNext Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmdNext Property

public virtual Button cmdNext {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmdRemoveAll Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmdRemoveAll Property

public virtual Button cmdRemoveAll {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


cmdRemoveOne Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.cmdRemoveOne Property

public virtual Button cmdRemoveOne {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Frame1 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Frame1 Property

public virtual GroupBox Frame1 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


frameDelimiter Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.frameDelimiter Property

public virtual GroupBox frameDelimiter {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


frameRecords Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.frameRecords Property

public virtual GroupBox frameRecords {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Label1 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Label1 Property

public virtual Label Label1 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Label2 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Label2 Property

public virtual Label Label2 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Label3 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Label3 Property

public virtual Label Label3 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Label4 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Label4 Property

public virtual Label Label4 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Label5 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Label5 Property

public virtual Label Label5 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Label6 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Label6 Property

public virtual Label Label6 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Label7 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Label7 Property

public virtual Label Label7 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


lblFields Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.lblFields Property

public virtual Label lblFields {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


lblStatus Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.lblStatus Property

public virtual Label lblStatus {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Line1 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Line1 Property

public virtual Label Line1 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Line2 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Line2 Property

public virtual Label Line2 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


lstAvailableFields Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.lstAvailableFields Property

public virtual ListBox lstAvailableFields {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


lstSelected Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.lstSelected Property

public virtual ListBox lstSelected {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


pbarStatus Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.pbarStatus Property

public virtual ProgressBar pbarStatus {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


picPage Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.picPage Property

public virtual PictureBox picPage {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


picPrinters Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.picPrinters Property

public virtual Panel picPrinters {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


picStatus Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.picStatus Property

public virtual Panel picStatus {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Picture1 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Picture1 Property

public virtual Panel Picture1 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Picture2 Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Picture2 Property

public virtual PictureBox Picture2 {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportEngine Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.ReportEngine Property

Returns the internal instance of the Report Engine class that is being used by this report wizard form

protected virtual ReportWizardEngine ReportEngine {get;}

Property Value

Remarks

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


tabCategories Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.tabCategories Property

public virtual TabControl tabCategories {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


txtColSize Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.txtColSize Property

public virtual TextBox txtColSize {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


txtCopies Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.txtCopies Property

public virtual TextBox txtCopies {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


txtDelimiter Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.txtDelimiter Property

public virtual TextBox txtDelimiter {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


txtExportFile Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.txtExportFile Property

public virtual TextBox txtExportFile {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


txtQualifier Property

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.txtQualifier Property

public virtual TextBox txtQualifier {get; set;}

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm Methods

The methods of the ReportWizardForm class are listed below. For a complete list of ReportWizardForm class members, see the ReportWizardForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Configure the Report Wizard Form for use with a specific view/viewsql
ConfigureReportForDashboard |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Export | Exports a crystal report through the crystal report engine.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
Print | Tells the Crystal Report Viewer to print a Report.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
ShowPreview | Previews a report in the Crystal Report Viewer.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HandleEngineStatusUpdate |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.Config Method

Configure the Report Wizard Form for use with a specific view/viewsql

public void Config(
AptifyApplication ApplicationObject,
Int64 ListID,
Int64 ViewID,
String CustomViewSQL,
Int64 EntityID,
String SelList,
IAptifyDataAction.DSLCacheSetting CacheSettings
);

Parameters

ApplicationObject
ListID
ViewID
CustomViewSQL
EntityID
SelList
CacheSettings

Implements

IReportWizard.

Remarks

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.ConfigureReportForDashboard Method

public void ConfigureReportForDashboard(
AptifyApplication ApplicationObject,
Int64 ViewID,
Int64 ReportID
);

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean Disposing
);

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace | ReportWizardForm.Dispose Overload List


ReportWizardForm.Export Method

Exports a crystal report through the crystal report engine.

public void Export(
AptifyApplication ApplicationObject,
Int64 ViewID,
Int64 ReportID,
Int32 FormatType,
Object ExportOptions
);

Parameters

ApplicationObject
ViewID
ReportID
FormatType
ExportOptions
This should be a string that represents a filename i.e. "c:\test.rtf"

Implements

IReportExporter.

Remarks

The current export format is a Rich Text Document.

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.HandleEngineStatusUpdate Method

protected virtual void HandleEngineStatusUpdate(
ReportWizardEngine.EventType EventType,
String Message,
Int32 PercentComplete,
ref Boolean& Cancel
);

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.Print Method

Tells the Crystal Report Viewer to print a Report.

public void Print(
AptifyApplication ApplicationObject,
Int64 ViewID,
Int64 ReportID,
Object PrintOptions
);

Parameters

ApplicationObject
ViewID
ReportID
PrintOptions
A string that represents the name of an installed printer can be used. If the parameter is not a string and it is not the name of an installed printer, then it will not be used.

Implements

IReportPrinter.

Remarks

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


Show Method

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.Show Method

Overload List

new public void Show();

Inherited from Form.

public void Show(IWin32Window);

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.Show Method ()

new public void Show();

Implements

IReportWizard.

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace | ReportWizardForm.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

ReportWizardForm.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Control);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IReportWizard.

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace | ReportWizardForm.ShowDialog Overload List


ReportWizardForm.ShowDialog Method (Control)

public DialogResult ShowDialog(
Control Owner
);

Implements

IReportWizard.

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace | ReportWizardForm.ShowDialog Overload List


ReportWizardForm.ShowPreview Method

Previews a report in the Crystal Report Viewer.

public void ShowPreview(
Form Parent,
AptifyApplication ApplicationObject,
Int64 ViewID,
Int64 ReportID
);

Parameters

Parent
ApplicationObject
ViewID
ReportID

Implements

IReportPreviewer.

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm Events

The events of the ReportWizardForm class are listed below. For a complete list of ReportWizardForm class members, see the ReportWizardForm Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
ReportConfigured | This is fired after the report is configured if the ActionType is set to ConfigureOnly
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.ReportWizardForm.ReportConfiguredEventHandler Event

This is fired after the report is configured if the ActionType is set to ConfigureOnly

public event ReportWizardForm.ReportConfiguredEventHandler ReportConfigured;

Remarks

This is mainly used from the Report Viewer Dashboard Component.

See Also

ReportWizardForm Class | Aptify.Framework.BusinessLogic.Reporting Namespace


ReportWizardForm.ReportConfiguredEventHandler Delegate

public delegate void ReportWizardForm.ReportConfiguredEventHandler(
ReportDocument Report
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.Reporting

Assembly: AptifyReportWizard (in AptifyReportWizard.dll)

See Also

Aptify.Framework.BusinessLogic.Reporting Namespace


Aptify.Framework.BusinessLogic.ScheduledTasks

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.ScheduledTasks Namespace

This namespace defines the Scheduled Tasks entity and the Windows Scheduler functionality required to create Scheduled Tasks records.

Namespace hierarchy

Classes

Class | Description
RemoteScheduler | The remote scheduler is responsible for sending a scheduling requests to an Application Server.
RemoteSchedulerDelete | Deletes a Scheduled Task based on a Scheduler and the TaskName.
RemoteSchedulerUpdate | Opens the Scheduled Task with a specific ScheduledTaskName, Changes the Scheduled Task Service Name, and Saves the record.
ScheduledTasksEntity | Entity object for the Scheduled Tasks Entity. This is the main business object for the Scheduled Tasks entity. It extends the Generic Entity functionality to manage tasks within the scheduler services.
ScheduleOnly |
WindowsScheduler | The Windows Scheduled Tasks implementation of the Scheduled Task Services interface. Scheduled Tasks that use the Windows Scheduler Scheduled Task Service will use the Scheduled Tasks functionality in Mircosoft Windows to trigger an executable that creates a Process Flow Runs record for immediate execution based on the information within the Scheduled Tasks record

Interfaces

Interface | Description
IAptifyScheduledTaskScheduler | Interface definition for Scheduled Task Service objects. Scheduled Task Service objects interact with a scheduling component, such as Windows Scheduled Tasks, to manage jobs created by Scheduled Tasks. Scheduled Task Service classes must implement this interface. Refer to Aptity.Framework.BusinessObjects.ScheduledTasks.WindowsScheduler for an example.

Enumerations

Enumeration | Description
AptifyDaysOfTheWeek | Represents individual days of the week values that are used to create a bit mask that identifies the days of the week where the task will execute. This is used by Weekly Scheduled Tasks.
AptifyMonthsOfTheYear | Represents individual months values that are used to create a bit mask that identifies the months where the task will execute. This is used by Monthly and Monthly Relative Scheduled Tasks.


AptifyDaysOfTheWeek Enumeration

Represents individual days of the week values that are used to create a bit mask that identifies the days of the week where the task will execute. This is used by Weekly Scheduled Tasks.

public enum AptifyDaysOfTheWeek

Remarks

Members

Member Name | Description
Monday |
Tuesday |
Wednesday |
Thursday |
Friday |
Saturday |
Sunday |

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks

Assembly: IAptifyScheduledTasks (in IAptifyScheduledTasks.dll)

See Also

Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


AptifyMonthsOfTheYear Enumeration

Represents individual months values that are used to create a bit mask that identifies the months where the task will execute. This is used by Monthly and Monthly Relative Scheduled Tasks.

public enum AptifyMonthsOfTheYear

Remarks

Members

Member Name | Description
January |
February |
March |
April |
May |
June |
July |
August |
September |
October |
November |
December |

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks

Assembly: IAptifyScheduledTasks (in IAptifyScheduledTasks.dll)

See Also

Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


IAptifyScheduledTaskScheduler Interface

Interface definition for Scheduled Task Service objects. Scheduled Task Service objects interact with a scheduling component, such as Windows Scheduled Tasks, to manage jobs created by Scheduled Tasks. Scheduled Task Service classes must implement this interface. Refer to Aptity.Framework.BusinessObjects.ScheduledTasks.WindowsScheduler for an example.

For a list of all members of this type, see IAptifyScheduledTaskScheduler Members.

public interface IAptifyScheduledTaskScheduler

Types that implement IAptifyScheduledTaskScheduler

Type | Description
RemoteScheduler | The remote scheduler is responsible for sending a scheduling requests to an Application Server.
ScheduleOnly |
WindowsScheduler | The Windows Scheduled Tasks implementation of the Scheduled Task Services interface. Scheduled Tasks that use the Windows Scheduler Scheduled Task Service will use the Scheduled Tasks functionality in Mircosoft Windows to trigger an executable that creates a Process Flow Runs record for immediate execution based on the information within the Scheduled Tasks record

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks

Assembly: IAptifyScheduledTasks (in IAptifyScheduledTasks.dll)

See Also

IAptifyScheduledTaskScheduler Members | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


IAptifyScheduledTaskScheduler Members

IAptifyScheduledTaskScheduler overview

Public Instance Properties

TaskNextRunTime Returns the next scheduled run time for a task.

Public Instance Methods

CreateTaskRecord | Creates a task or job within the scheduler.
DeleteTaskRecord | Deletes a task within the scheduler.
TaskExists | Searches for an existing task on a computer and returns true if the task is found.
UpdateTaskRecord | Updates an existing task within the scheduler.

See Also

IAptifyScheduledTaskScheduler Interface | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


IAptifyScheduledTaskScheduler Properties

The properties of the IAptifyScheduledTaskScheduler interface are listed below. For a complete list of IAptifyScheduledTaskScheduler interface members, see the IAptifyScheduledTaskScheduler Members topic.

Public Instance Properties

TaskNextRunTime Returns the next scheduled run time for a task.

See Also

IAptifyScheduledTaskScheduler Interface | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


TaskNextRunTime Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyScheduledTaskScheduler.TaskNextRunTime Property

Returns the next scheduled run time for a task.

DateTime this[
AptifyApplication Application,
String TaskName,
String TargetComputer
] {get;}

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
TaskName
The name of the Task.
TargetComputer
The name of the computer that will be searched for the task. All implementations should handle a computer name with or with the prefix \\ characters.

Property Value

Remarks

Returns the next scheduled execution of the task based on the TaskName and TargetComputer.

See Also

IAptifyScheduledTaskScheduler Interface | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


IAptifyScheduledTaskScheduler Methods

The methods of the IAptifyScheduledTaskScheduler interface are listed below. For a complete list of IAptifyScheduledTaskScheduler interface members, see the IAptifyScheduledTaskScheduler Members topic.

Public Instance Methods

CreateTaskRecord | Creates a task or job within the scheduler.
DeleteTaskRecord | Deletes a task within the scheduler.
TaskExists | Searches for an existing task on a computer and returns true if the task is found.
UpdateTaskRecord | Updates an existing task within the scheduler.

See Also

IAptifyScheduledTaskScheduler Interface | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


IAptifyScheduledTaskScheduler.CreateTaskRecord Method

Creates a task or job within the scheduler.

void CreateTaskRecord(
AptifyApplication Application,
AptifyGenericEntityBase ScheduledTask
);

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
ScheduledTask
The Scheduled Task Entity object that will be used to create the task.

Remarks

All implementation of this method should raise an exception if the task cannot be created in the scheduler.

See Also

IAptifyScheduledTaskScheduler Interface | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


IAptifyScheduledTaskScheduler.DeleteTaskRecord Method

Deletes a task within the scheduler.

void DeleteTaskRecord(
AptifyApplication Application,
String TaskName,
String TargetComputer
);

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
TaskName
The name of the task that should be deleted.
TargetComputer
The name of the computer where the task exists. All implementations should handle a computer name with or with the prefix \\ characters.

Remarks

All implementations should raise an exception if the task cannot be deleted.

See Also

IAptifyScheduledTaskScheduler Interface | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


IAptifyScheduledTaskScheduler.TaskExists Method

Searches for an existing task on a computer and returns true if the task is found.

bool TaskExists(
AptifyApplication Application,
String TaskName,
String TargetComputer
);

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
TaskName
The name of the task for which the method will search.
TargetComputer
The name of the computer that will be searched for the task. All implementations should handle a computer name with or with the prefix \\ characters.

Return Value

Returns true if a task matching TaskName on the TargetComputer exists. Otherwise, false is returned.

Remarks

See Also

IAptifyScheduledTaskScheduler Interface | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


IAptifyScheduledTaskScheduler.UpdateTaskRecord Method

Updates an existing task within the scheduler.

void UpdateTaskRecord(
AptifyApplication Application,
AptifyGenericEntityBase ScheduledTask
);

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
ScheduledTask
The Scheduled Tasks Entity object that contains the information that will be used to identify and update the task.

Remarks

All implementations should raise an exception if the task cannot be located or updated.

See Also

IAptifyScheduledTaskScheduler Interface | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteScheduler Class

The remote scheduler is responsible for sending a scheduling requests to an Application Server.

For a list of all members of this type, see RemoteScheduler Members.

System.Object
RemoteScheduler

public class RemoteScheduler : IAptifyScheduledTaskScheduler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks

Assembly: AptifyScheduledTasksSchedulers (in AptifyScheduledTasksSchedulers.dll)

See Also

RemoteScheduler Members | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteScheduler Members

RemoteScheduler overview

Public Instance Constructors

RemoteScheduler Constructor Initializes a new instance of the RemoteScheduler class.

Public Instance Properties

TaskNextRunTime The Remote Scheduler cannot determine this value.

Public Instance Methods

CreateUpdateTaskRecord | Sends a request to the specified application serverto create the Task.
DeleteTaskRecord | Sends a request to the specified Application Server to Delete the Task.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TaskExists | Returns the status of the Task
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteScheduler Constructor

Initializes a new instance of the RemoteScheduler class.

public RemoteScheduler();

See Also

RemoteScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteScheduler Properties

The properties of the RemoteScheduler class are listed below. For a complete list of RemoteScheduler class members, see the RemoteScheduler Members topic.

Public Instance Properties

TaskNextRunTime The Remote Scheduler cannot determine this value.

See Also

RemoteScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


TaskNextRunTime Property

Aptify 5.0 Software Development Kit (SDK)

RemoteScheduler.TaskNextRunTime Property

The Remote Scheduler cannot determine this value.

public DateTime this[
AptifyApplication Application,
String TaskName,
String TargetComputer
] {get;}

Parameters

Application
TaskName
TargetComputer

Property Value

The current Date.

Implements

IAptifyScheduledTaskScheduler.

Remarks

See Also

RemoteScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteScheduler Methods

The methods of the RemoteScheduler class are listed below. For a complete list of RemoteScheduler class members, see the RemoteScheduler Members topic.

Public Instance Methods

CreateUpdateTaskRecord | Sends a request to the specified application serverto create the Task.
DeleteTaskRecord | Sends a request to the specified Application Server to Delete the Task.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TaskExists | Returns the status of the Task
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteScheduler.CreateUpdateTaskRecord Method

Sends a request to the specified application serverto create the Task.

public void CreateUpdateTaskRecord(
AptifyApplication Application,
AptifyGenericEntityBase ScheduledTask
);

Parameters

Application
ScheduledTask

Implements

IAptifyScheduledTaskScheduler.

Remarks

Creates a process flow run record that will be run on the Application Server. The Process Flow that runs on the Application Server will re-save the Scheduled Task Record on the Application Server with the [Windows Scheduler] Scheduled Task Scheduler. It expects the [Update With Remote Scheduler] Process Flow to exist. If the SheduledTask contains a field named _SkipRemote and that field has a value of true, then the Remote Process Flow Run will not be created.

See Also

RemoteScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteScheduler.DeleteTaskRecord Method

Sends a request to the specified Application Server to Delete the Task.

public void DeleteTaskRecord(
AptifyApplication Application,
String TaskName,
String TargetComputer
);

Parameters

Application
TaskName
TargetComputer

Implements

IAptifyScheduledTaskScheduler.

Remarks

Creates a process flow run record that will be run on the Application Server. The Process Flow that runs on the Application Server will Delete the Scheduled Task Record on the Application Server with a different Scheduled Task Scheduler.

See Also

RemoteScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteScheduler.TaskExists Method

Returns the status of the Task

public bool TaskExists(
AptifyApplication Application,
String TaskName,
String TargetComputer
);

Parameters

Application
TaskName
TargetComputer

Return Value

True if the ScheduledTask record has been saved with a different Task Scheduler. False if it has not yet been saved with a different Scheduler.

Implements

IAptifyScheduledTaskScheduler.

Remarks

See Also

RemoteScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerDelete Class

Deletes a Scheduled Task based on a Scheduler and the TaskName.

For a list of all members of this type, see RemoteSchedulerDelete Members.

System.Object
RemoteSchedulerDelete

public class RemoteSchedulerDelete : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Input Properties supported: ScheduledTaskServiceNameScheduledTaskNameThis is the name of the task on the machine, not the Scheduled Task name in Aptify.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks

Assembly: AptifyScheduledTasksSchedulers (in AptifyScheduledTasksSchedulers.dll)

See Also

RemoteSchedulerDelete Members | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerDelete Members

RemoteSchedulerDelete overview

Public Instance Constructors

RemoteSchedulerDelete Constructor Initializes a new instance of the RemoteSchedulerDelete class.

Public Instance Properties

Properties Contains input properties used by the process component.

Public Instance Methods

Config | Configures the RemoteSchedulerDelete to run.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Attempts to Delete a Scheduled Task based on the Scheduled Task Service and the Scheduled Task name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteSchedulerDelete Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerDelete Constructor

Initializes a new instance of the RemoteSchedulerDelete class.

public RemoteSchedulerDelete();

See Also

RemoteSchedulerDelete Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerDelete Properties

The properties of the RemoteSchedulerDelete class are listed below. For a complete list of RemoteSchedulerDelete class members, see the RemoteSchedulerDelete Members topic.

Public Instance Properties

Properties Contains input properties used by the process component.

See Also

RemoteSchedulerDelete Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

RemoteSchedulerDelete.Properties Property

Contains input properties used by the process component.

public AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

RemoteSchedulerDelete Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerDelete Methods

The methods of the RemoteSchedulerDelete class are listed below. For a complete list of RemoteSchedulerDelete class members, see the RemoteSchedulerDelete Members topic.

Public Instance Methods

Config | Configures the RemoteSchedulerDelete to run.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Attempts to Delete a Scheduled Task based on the Scheduled Task Service and the Scheduled Task name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteSchedulerDelete Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerDelete.Config Method

Configures the RemoteSchedulerDelete to run.

public void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

RemoteSchedulerDelete Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerDelete.Run Method

Attempts to Delete a Scheduled Task based on the Scheduled Task Service and the Scheduled Task name.

public string Run();

Return Value

Success if the Task was deleted. Failure if the Task was not deleted.

Implements

IProcessComponent.

Remarks

See Also

RemoteSchedulerDelete Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerUpdate Class

Opens the Scheduled Task with a specific ScheduledTaskName, Changes the Scheduled Task Service Name, and Saves the record.

For a list of all members of this type, see RemoteSchedulerUpdate Members.

System.Object
RemoteSchedulerUpdate

public class RemoteSchedulerUpdate : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Input Properties supported: ScheduledTaskNameNewScheduledTaskServiceName

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks

Assembly: AptifyScheduledTasksSchedulers (in AptifyScheduledTasksSchedulers.dll)

See Also

RemoteSchedulerUpdate Members | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerUpdate Members

RemoteSchedulerUpdate overview

Public Instance Constructors

RemoteSchedulerUpdate Constructor Initializes a new instance of the RemoteSchedulerUpdate class.

Public Instance Properties

Properties Contains input properties used by the process component.

Public Instance Methods

Config | Configures the RemoteSchedulerUpdate to run.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Attempts to update the scheduled task
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteSchedulerUpdate Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerUpdate Constructor

Initializes a new instance of the RemoteSchedulerUpdate class.

public RemoteSchedulerUpdate();

See Also

RemoteSchedulerUpdate Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerUpdate Properties

The properties of the RemoteSchedulerUpdate class are listed below. For a complete list of RemoteSchedulerUpdate class members, see the RemoteSchedulerUpdate Members topic.

Public Instance Properties

Properties Contains input properties used by the process component.

See Also

RemoteSchedulerUpdate Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

RemoteSchedulerUpdate.Properties Property

Contains input properties used by the process component.

public AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

RemoteSchedulerUpdate Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerUpdate Methods

The methods of the RemoteSchedulerUpdate class are listed below. For a complete list of RemoteSchedulerUpdate class members, see the RemoteSchedulerUpdate Members topic.

Public Instance Methods

Config | Configures the RemoteSchedulerUpdate to run.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Attempts to update the scheduled task
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteSchedulerUpdate Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerUpdate.Config Method

Configures the RemoteSchedulerUpdate to run.

public void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

RemoteSchedulerUpdate Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


RemoteSchedulerUpdate.Run Method

Attempts to update the scheduled task

public string Run();

Return Value

Failure if the task was not updated. Success if the task was updated.

Implements

IProcessComponent.

Remarks

See Also

RemoteSchedulerUpdate Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduledTasksEntity Class

Entity object for the Scheduled Tasks Entity. This is the main business object for the Scheduled Tasks entity. It extends the Generic Entity functionality to manage tasks within the scheduler services.

For a list of all members of this type, see ScheduledTasksEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ScheduledTasksEntity

public class ScheduledTasksEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Example

'Assumes that m_oApplication contains a valid instance of the AptifyApplication object.
Dim geScheduledTask As Aptify.Framework.GenericEntity.AptifyGenericEntityBase

'Return an instance of an AptifyScheduledTasksEntity object configured as a new record.
geScheduledTask = m_oApplication.GetEntityObject("Scheduled Tasks", -1)

'Configure the record with information using SetValue method.

'Save the Scheduled Tasks record and display GUI, if necessary. (eg. Validation failure)
If geScheduledTask.Save(True, "","") Then
    'Scheduled Tasks record was successfully saved.
Else
    'Scheduled Tasks record save failed.
Endif

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks

Assembly: AptifyScheduledTasksEntity (in AptifyScheduledTasksEntity.dll)

See Also

ScheduledTasksEntity Members | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduledTasksEntity Members

ScheduledTasksEntity overview

Public Instance Constructors

ScheduledTasksEntity Constructor Initializes a new instance of the ScheduledTasksEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsScheduleOnly |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. Deletes a Scheduled Tasks record and the corresponding Task managed by the Scheduled Task Service.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves a Scheduled Tasks record and manages the Scheduled Task Service Task linked to the record.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Adds validation to determine if the type is Schedule Only. If so, it does not require application server or process flow in Scheduled Task record.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ScheduledTasksEntity Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduledTasksEntity Constructor

Initializes a new instance of the ScheduledTasksEntity class.

public ScheduledTasksEntity();

See Also

ScheduledTasksEntity Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduledTasksEntity Properties

The properties of the ScheduledTasksEntity class are listed below. For a complete list of ScheduledTasksEntity class members, see the ScheduledTasksEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsScheduleOnly |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ScheduledTasksEntity Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


IsScheduleOnly Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTasksEntity.IsScheduleOnly Property

public virtual Boolean IsScheduleOnly {get;}

See Also

ScheduledTasksEntity Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduledTasksEntity Methods

The methods of the ScheduledTasksEntity class are listed below. For a complete list of ScheduledTasksEntity class members, see the ScheduledTasksEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. Deletes a Scheduled Tasks record and the corresponding Task managed by the Scheduled Task Service.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves a Scheduled Tasks record and manages the Scheduled Task Service Task linked to the record.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Adds validation to determine if the type is Schedule Only. If so, it does not require application server or process flow in Scheduled Task record.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ScheduledTasksEntity Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


Delete Method

Aptify 5.0 Software Development Kit (SDK)

ScheduledTasksEntity.Delete Method

Deletes a Scheduled Tasks record and the corresponding Task managed by the Scheduled Task Service.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

Deletes a Scheduled Tasks record and the corresponding Task managed by the Scheduled Task Service.

public override bool Delete(String);

See Also

ScheduledTasksEntity Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduledTasksEntity.Delete Method (String)

Deletes a Scheduled Tasks record and the corresponding Task managed by the Scheduled Task Service.

public override bool Delete(
String TransactionID
);

Parameters

TransactionID
Used to identify a specific transaction that will be used for database operations within the method call. If sTransactionID is blank, the default transaction will be used and if no default transaction exists, one will be created. If sTransactionID is not blank, it must identify an active transaction and all database operations will participate in that transaction. In most cases, sTransactionID should be blank.

Return Value

Returns true if the delete operation is successful. Returns false if the delete operation failed. If the operation fails, check the LastError and/or LastUserError properties for information about the failure.

Remarks

1. Instantiates the Scheduled Task Scheduler object based on the Scheduled Tasks' ScheduledTaskServiceID. If the Scheduler can not be instantiated, the method returns false. 2. Uses the Scheduled Task Scheduler object to verify the existence of the Task within the Scheduler. 3. If the Task is not found by the Scheduled Task Scheduler, calls the Base Class' Delete method with the same signature and returns the result. 4. If the Task exists within the Scheduled Task Scheduler, the process begins a transaction. 5. Calls the Base Class' Delete method with the same signature. If the Base Class' Delete method returns false, the transaction is rolled back and the method returns false. 6. Using the Scheduled Task Scheduler object, deletes the Task from the Scheduler. If the Scheduler Delete operation fails, the transaction is rolled back and the method returns false.

See Also

ScheduledTasksEntity Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace | ScheduledTasksEntity.Delete Overload List


Save Method

Aptify 5.0 Software Development Kit (SDK)

ScheduledTasksEntity.Save Method

Saves a Scheduled Tasks record and manages the Scheduled Task Service Task linked to the record.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Saves a Scheduled Tasks record and manages the Scheduled Task Service Task linked to the record.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ScheduledTasksEntity Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduledTasksEntity.Save Method (Boolean, String&, String)

Saves a Scheduled Tasks record and manages the Scheduled Task Service Task linked to the record.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
Used by the method to know whether or not the method can interact with the user. If AllowGUI is true, the method can display user interface to inform the user or prompt the user for information. If AllowGUI is false, the method will not display information or request information from the user.
ErrorString
The message corresponding to any exceptions that may have been encountered. If the ErrorString is populated then this method will not attempt to save. It will attempt to display the ErrorString if AllowGUI is true and then it will return false.
TransactionID
Used to identify a specific transaction that will be used for database operations within the method call. If sTransactionID is blank, the default transaction will be used and if no default transaction exists, one will be created. If sTransactionID is not blank, it must identify an active transaction and all database operations will participate in that transaction. In most cases, sTransactionID should be blank.

Return Value

Returns true if the save is successful. Returns false if the save failed. If the operation fails, check the LastError and/or LastUserError properties for information about the failure.

Remarks

1. Validates the Scheduled Task data. Returns false if the information is not valid. 2. Instantiates the Scheduled Task Scheduler object based on the Scheduled Tasks' ScheduledTaskServiceID. If the Scheduler can not be instantiated, the method returns false. 3. Begins a Transaction. 4. Calls the Base Class' Save method that matches this method's signature. If the Base Class' Save method returns false, rollback the transaction and return false. 5. Using the Scheduled Task Scheduler object, creates (new record) or updates (existing record) the task within the scheduler. If the create or update task operation fails, rollback the transaction and return false. 6. Commit the Transaction.

See Also

ScheduledTasksEntity Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace | ScheduledTasksEntity.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ScheduledTasksEntity.Validate Method

Adds validation to determine if the type is Schedule Only. If so, it does not require application server or process flow in Scheduled Task record.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

Adds validation to determine if the type is Schedule Only. If so, it does not require application server or process flow in Scheduled Task record.

public override bool Validate(ref String&);

See Also

ScheduledTasksEntity Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduledTasksEntity.Validate Method (String&)

Adds validation to determine if the type is Schedule Only. If so, it does not require application server or process flow in Scheduled Task record.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

ScheduledTasksEntity Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace | ScheduledTasksEntity.Validate Overload List


ScheduleOnly Class

For a list of all members of this type, see ScheduleOnly Members.

System.Object
ScheduleOnly

public class ScheduleOnly : IAptifyScheduledTaskScheduler, ISupportsAttributes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks

Assembly: AptifyScheduledTasksSchedulers (in AptifyScheduledTasksSchedulers.dll)

See Also

ScheduleOnly Members | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduleOnly Members

ScheduleOnly overview

Public Instance Constructors

ScheduleOnly Constructor Initializes a new instance of the ScheduleOnly class.

Public Instance Properties

TaskNextRunTime Returns the next scheduled run time for a task.

Public Instance Methods

CreateTaskRecord | Creates a Windows Scheduled Task.
DeleteTaskRecord | Deletes a Windows Scheduled Task.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttribute | Method used to return attribute data related to this class.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TaskExists | Method used to determine if the task exists on the target system.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateTaskRecord | Stub routine implementing the interface: IAptifyScheduledTaskScheduler.UpdateTaskRecord

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScheduleOnly Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduleOnly Constructor

Initializes a new instance of the ScheduleOnly class.

public ScheduleOnly();

See Also

ScheduleOnly Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduleOnly Properties

The properties of the ScheduleOnly class are listed below. For a complete list of ScheduleOnly class members, see the ScheduleOnly Members topic.

Public Instance Properties

TaskNextRunTime Returns the next scheduled run time for a task.

See Also

ScheduleOnly Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


TaskNextRunTime Property

Aptify 5.0 Software Development Kit (SDK)

ScheduleOnly.TaskNextRunTime Property

Returns the next scheduled run time for a task.

public DateTime this[
AptifyApplication Application,
String TaskName,
String TargetComputer
] {get;}

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
TaskName
The name of the Task.
TargetComputer
The name of the computer where the Task is stored. The computer name can be specified with out without the prefix \\ characters.

Property Value

Implements

IAptifyScheduledTaskScheduler.

Remarks

This is a data-only implementation. No actual functionality is provided.

See Also

ScheduleOnly Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduleOnly Methods

The methods of the ScheduleOnly class are listed below. For a complete list of ScheduleOnly class members, see the ScheduleOnly Members topic.

Public Instance Methods

CreateTaskRecord | Creates a Windows Scheduled Task.
DeleteTaskRecord | Deletes a Windows Scheduled Task.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttribute | Method used to return attribute data related to this class.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TaskExists | Method used to determine if the task exists on the target system.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateTaskRecord | Stub routine implementing the interface: IAptifyScheduledTaskScheduler.UpdateTaskRecord

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScheduleOnly Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduleOnly.CreateTaskRecord Method

Creates a Windows Scheduled Task.

public void CreateTaskRecord(
AptifyApplication Application,
AptifyGenericEntityBase ScheduledTask
);

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
ScheduledTask
The Scheduled Tasks Entity object that contains the information that will be used to create the Windows Scheduled Task.

Implements

IAptifyScheduledTaskScheduler.

Remarks

See Also

ScheduleOnly Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduleOnly.DeleteTaskRecord Method

Deletes a Windows Scheduled Task.

public void DeleteTaskRecord(
AptifyApplication Application,
String TaskName,
String TargetComputer
);

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
TaskName
The name of the Task that should be deleted
TargetComputer
The name of the computer where the Task is stored. The computer name can be specified with out without the prefix \\ characters.

Implements

IAptifyScheduledTaskScheduler.

Remarks

See Also

ScheduleOnly Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduleOnly.GetAttribute Method

Method used to return attribute data related to this class.

public Attribute GetAttribute(
String Name
);

Parameters

Name

Return Value

Implements

ISupportsAttributes.

Remarks

This is a data-only implementation. No actual functionality is provided.

See Also

ScheduleOnly Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduleOnly.TaskExists Method

Method used to determine if the task exists on the target system.

public bool TaskExists(
AptifyApplication Application,
String TaskName,
String TargetComputer
);

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
TaskName
The name of the Task.
TargetComputer
The name of the computer where the Task is stored. The computer name can be specified with out without the prefix \\ characters.

Return Value

Implements

IAptifyScheduledTaskScheduler.

Remarks

This is a data-only implementation. No actual functionality is provided.

See Also

ScheduleOnly Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


ScheduleOnly.UpdateTaskRecord Method

Stub routine implementing the interface: IAptifyScheduledTaskScheduler.UpdateTaskRecord

public void UpdateTaskRecord(
AptifyApplication Application,
AptifyGenericEntityBase ScheduledTask
);

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
ScheduledTask
The Scheduled Tasks Entity object that contains the information that will be used to identify and update the task.

Implements

IAptifyScheduledTaskScheduler.

Remarks

This is a data-only implementation. No actual functionality is provided.

See Also

ScheduleOnly Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


WindowsScheduler Class

The Windows Scheduled Tasks implementation of the Scheduled Task Services interface. Scheduled Tasks that use the Windows Scheduler Scheduled Task Service will use the Scheduled Tasks functionality in Mircosoft Windows to trigger an executable that creates a Process Flow Runs record for immediate execution based on the information within the Scheduled Tasks record

For a list of all members of this type, see WindowsScheduler Members.

System.Object
WindowsScheduler

public class WindowsScheduler : IAptifyScheduledTaskScheduler, ISupportsAttributes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Supports the attribute, Aptify.Framework.BusinessLogic.ScheduledTasks.WindowsScheduler.CreateProcessFlowRunPath. This attribute defines the full path of the executable this is responsible for the creation of the Process Flow Runs record based on the Scheduled Tasks record that is being scheduled. The default filename for this executable is AptifyCreateProcessFlowRun.exe and it is typically located in the root folder of the Aptify application. The Windows Scheduled Task will trigger this executable when the Task is triggered.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks

Assembly: AptifyScheduledTasksSchedulers (in AptifyScheduledTasksSchedulers.dll)

See Also

WindowsScheduler Members | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


WindowsScheduler Members

WindowsScheduler overview

Public Instance Constructors

WindowsScheduler Constructor Initializes a new instance of the WindowsScheduler class.

Public Instance Properties

TaskNextRunTime Returns the next scheduled run time for a task.

Public Instance Methods

CreateTaskRecord | Creates a Windows Scheduled Task.
DeleteTaskRecord | Deletes a Windows Scheduled Task.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TaskExists |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateTaskRecord | Updates an existing Windows Scheduled Task.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WindowsScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


WindowsScheduler Constructor

Initializes a new instance of the WindowsScheduler class.

public WindowsScheduler();

See Also

WindowsScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


WindowsScheduler Properties

The properties of the WindowsScheduler class are listed below. For a complete list of WindowsScheduler class members, see the WindowsScheduler Members topic.

Public Instance Properties

TaskNextRunTime Returns the next scheduled run time for a task.

See Also

WindowsScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


TaskNextRunTime Property

Aptify 5.0 Software Development Kit (SDK)

WindowsScheduler.TaskNextRunTime Property

Returns the next scheduled run time for a task.

public DateTime this[
AptifyApplication Application,
String TaskName,
String TargetComputer
] {get;}

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
TaskName
The name of the Windows Scheduled Task.
TargetComputer
The name of the computer where the Windows Scheduled Task is stored. The computer name can be specified with out without the prefix \\ characters.

Property Value

Implements

IAptifyScheduledTaskScheduler.

Remarks

Returns the next scheduled execution of the Windows Scheduled Task based on the TaskName and TargetComputer.

See Also

WindowsScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


WindowsScheduler Methods

The methods of the WindowsScheduler class are listed below. For a complete list of WindowsScheduler class members, see the WindowsScheduler Members topic.

Public Instance Methods

CreateTaskRecord | Creates a Windows Scheduled Task.
DeleteTaskRecord | Deletes a Windows Scheduled Task.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TaskExists |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateTaskRecord | Updates an existing Windows Scheduled Task.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WindowsScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


WindowsScheduler.CreateTaskRecord Method

Creates a Windows Scheduled Task.

public void CreateTaskRecord(
AptifyApplication Application,
AptifyGenericEntityBase ScheduledTask
);

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
ScheduledTask
The Scheduled Tasks Entity object that contains the information that will be used to create the Windows Scheduled Task.

Implements

IAptifyScheduledTaskScheduler.

Remarks

See Also

WindowsScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


WindowsScheduler.DeleteTaskRecord Method

Deletes a Windows Scheduled Task.

public void DeleteTaskRecord(
AptifyApplication Application,
String TaskName,
String TargetComputer
);

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
TaskName
The name of the Windows Scheduled Task that should be deleted
TargetComputer
The name of the computer where the Windows Scheduled Task is stored. The computer name can be specified with out without the prefix \\ characters.

Implements

IAptifyScheduledTaskScheduler.

Remarks

See Also

WindowsScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


WindowsScheduler.TaskExists Method

public bool TaskExists(
AptifyApplication Application,
String TaskName,
String TargetComputer
);

Implements

IAptifyScheduledTaskScheduler.

See Also

WindowsScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


WindowsScheduler.UpdateTaskRecord Method

Updates an existing Windows Scheduled Task.

public void UpdateTaskRecord(
AptifyApplication Application,
AptifyGenericEntityBase ScheduledTask
);

Parameters

Application
A valid instance of the AptifyApplication class. The Application object provides configuration information for the Task Scheduler.
ScheduledTask
The Scheduled Tasks Entity object that contains the information that will be used to identify and update the Windows Scheduled Task.

Implements

IAptifyScheduledTaskScheduler.

Remarks

See Also

WindowsScheduler Class | Aptify.Framework.BusinessLogic.ScheduledTasks Namespace


Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace

This namespace defines the functionality that integrates with Windows Scheduled Tasks functionality to add and modify tasks in the Application Server's Scheduled Tasks folder. This includes a set of triggers that determine when a task should be run.

Namespace hierarchy

Classes

Class | Description
DailyTrigger | Trigger that fires at a specified time, every so many days.
MonthlyDOWTrigger | Trigger that fires at a specified time, on specified days of the week, in specified weeks of the month, during specified months of the year.
MonthlyTrigger | Trigger that fires at a specified time, on specified days of the month, on specified months of the year.
OnIdleTrigger | Trigger that fires when the system is idle for a period of time. Length of period set by IdleWaitMinutes.
OnLogonTrigger | Trigger that fires when a user logs on.
OnSystemStartTrigger | Trigger that fires when the system starts.
RunOnceTrigger | Trigger that fires once only.
ScheduledTasks | ScheduledTasks represents a computer's Scheduled Tasks folder. Using a ScheduledTasks object, you can discover the names of the tasks in the folder and you can open a task to work with it. You can also create or delete tasks.
StartableTrigger | Generalization of all triggers that have a start time.
Task | Represents an item in the Scheduled Tasks folder. There are no public constructors for Task. New instances are generated by a ScheduledTasks object using Open or Create methods. A task object holds COM interfaces; call its Close method to release them.
Trigger | Trigger is a generalization of all the concrete trigger classes, and any actual Trigger object is one of those types. When included in the TriggerList of a Task, a Trigger determines when a scheduled task will be run.
TriggerList | TriggerList is a collection of Triggers. Every Task has a TriggerList that is created and destroyed automatically along with the Task. There are no public constructors.
WeeklyTrigger | Trigger that fires at a specified time, on specified days of the week, every so many weeks.

Enumerations

Enumeration | Description
DaysOfTheWeek | Values for days of the week (Monday, Tuesday, etc.) These carry the Flags attribute so DaysOfTheWeek can be combined with | (or).
MonthsOfTheYear | Values for months of the year (January, February, etc.) These carry the Flags attribute so MonthsOfTheYEar can be combined with | (or).
Task.PropPages | Argument for DisplayForEdit to determine which property pages to display.
TaskFlags | Options for a task, used for the Flags property of a Task. Uses the "Flags" attribute, so these values are combined with |. Some flags are documented as Windows 95 only, but they have a user interface in Windows XP so that may not be true.
TaskStatus | Status values returned for a task. Some values have been determined to occur although they do no appear in the Task Scheduler system documentation.
WhichWeek | Values for week of month (first, second, ..., last)


DailyTrigger Class

Trigger that fires at a specified time, every so many days.

For a list of all members of this type, see DailyTrigger Members.

System.Object
Trigger
StartableTrigger
DailyTrigger

public class DailyTrigger : StartableTrigger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

DailyTrigger Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


DailyTrigger Members

DailyTrigger overview

Public Instance Constructors

DailyTrigger Overloaded. Initializes a new instance of the DailyTrigger class.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
DaysInterval | Gets/sets the number of days between successive firings.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.
StartHour (inherited from StartableTrigger) | Gets/sets hour of the day that trigger will fire (24 hour clock).
StartMinute (inherited from StartableTrigger) | Gets/sets minute of the hour (specified in StartHour) that trigger will fire.

Public Instance Methods

Clone (inherited from Trigger) | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals (inherited from Trigger) | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode (inherited from Trigger) | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Trigger) | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetStartTime (inherited from StartableTrigger) | Sets the start time of the trigger.
SyncTrigger (inherited from Trigger) | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

DailyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


DailyTrigger Constructor

Creates a DailyTrigger that fires only at an interval of so many days.

Overload List

Creates DailyTrigger that fires every day.

public DailyTrigger(Int16,Int16);

Creates a DailyTrigger that fires only at an interval of so many days.

public DailyTrigger(Int16,Int16,Int16);

See Also

DailyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


DailyTrigger Constructor (Int16, Int16, Int16)

Creates a DailyTrigger that fires only at an interval of so many days.

public DailyTrigger(
Int16 hour,
Int16 minutes,
Int16 daysInterval
);

Parameters

hour
Hour of day trigger will fire.
minutes
Minutes of the hour trigger will fire.
daysInterval
Number of days between task runs.

See Also

DailyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | DailyTrigger Constructor Overload List


DailyTrigger Constructor (Int16, Int16)

Creates DailyTrigger that fires every day.

public DailyTrigger(
Int16 hour,
Int16 minutes
);

Parameters

hour
Hour of day trigger will fire.
minutes
Minutes of hour (specified in "hour") trigger will fire.

See Also

DailyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | DailyTrigger Constructor Overload List


DailyTrigger Properties

The properties of the DailyTrigger class are listed below. For a complete list of DailyTrigger class members, see the DailyTrigger Members topic.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
DaysInterval | Gets/sets the number of days between successive firings.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.
StartHour (inherited from StartableTrigger) | Gets/sets hour of the day that trigger will fire (24 hour clock).
StartMinute (inherited from StartableTrigger) | Gets/sets minute of the hour (specified in StartHour) that trigger will fire.

See Also

DailyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


DaysInterval Property

Aptify 5.0 Software Development Kit (SDK)

DailyTrigger.DaysInterval Property

Gets/sets the number of days between successive firings.

public Int16 DaysInterval {get; set;}

See Also

DailyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


DaysOfTheWeek Enumeration

Values for days of the week (Monday, Tuesday, etc.) These carry the Flags attribute so DaysOfTheWeek can be combined with | (or).

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum DaysOfTheWeek

Members

Member Name | Description | Value
Sunday | Sunday | 1
Monday | Monday | 2
Tuesday | Tuesday | 4
Wednesday | Wednesday | 8
Thursday | Thursday | 16
Friday | Friday | 32
Saturday | Saturday | 64

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MonthlyDOWTrigger Class

Trigger that fires at a specified time, on specified days of the week, in specified weeks of the month, during specified months of the year.

For a list of all members of this type, see MonthlyDOWTrigger Members.

System.Object
Trigger
StartableTrigger
MonthlyDOWTrigger

public class MonthlyDOWTrigger : StartableTrigger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

MonthlyDOWTrigger Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MonthlyDOWTrigger Members

MonthlyDOWTrigger overview

Public Instance Constructors

MonthlyDOWTrigger Overloaded. Initializes a new instance of the MonthlyDOWTrigger class.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.
Months | Gets/sets months of the year in which trigger will fire.
StartHour (inherited from StartableTrigger) | Gets/sets hour of the day that trigger will fire (24 hour clock).
StartMinute (inherited from StartableTrigger) | Gets/sets minute of the hour (specified in StartHour) that trigger will fire.
WeekDays | Gets/sets days of the week on which trigger will fire.
WhichWeeks | Gets/sets weeks of the month in which trigger will fire.

Public Instance Methods

Clone (inherited from Trigger) | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals (inherited from Trigger) | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode (inherited from Trigger) | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Trigger) | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetStartTime (inherited from StartableTrigger) | Sets the start time of the trigger.
SyncTrigger (inherited from Trigger) | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

MonthlyDOWTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MonthlyDOWTrigger Constructor

Creates a MonthlyDOWTrigger that fires every month.

Overload List

Creates a MonthlyDOWTrigger that fires during specified months only.

public MonthlyDOWTrigger(Int16,Int16,DaysOfTheWeek,WhichWeek);

Creates a MonthlyDOWTrigger that fires every month.

public MonthlyDOWTrigger(Int16,Int16,DaysOfTheWeek,WhichWeek,MonthsOfTheYear);

See Also

MonthlyDOWTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MonthlyDOWTrigger Constructor (Int16, Int16, DaysOfTheWeek, WhichWeek, MonthsOfTheYear)

Creates a MonthlyDOWTrigger that fires every month.

public MonthlyDOWTrigger(
Int16 hour,
Int16 minutes,
DaysOfTheWeek daysOfTheWeek,
WhichWeek whichWeeks,
MonthsOfTheYear months
);

Parameters

hour
Hour of day trigger will fire.
minutes
Minute of the hour trigger will fire.
daysOfTheWeek
Days of the week trigger will fire.
whichWeeks
Weeks of the month trigger will fire.
months
Months of the year trigger will fire.

See Also

MonthlyDOWTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | MonthlyDOWTrigger Constructor Overload List


MonthlyDOWTrigger Constructor (Int16, Int16, DaysOfTheWeek, WhichWeek)

Creates a MonthlyDOWTrigger that fires during specified months only.

public MonthlyDOWTrigger(
Int16 hour,
Int16 minutes,
DaysOfTheWeek daysOfTheWeek,
WhichWeek whichWeeks
);

Parameters

hour
Hour of day trigger will fire.
minutes
Minute of the hour trigger will fire.
daysOfTheWeek
Days of the week trigger will fire.
whichWeeks
Weeks of the month trigger will fire.

See Also

MonthlyDOWTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | MonthlyDOWTrigger Constructor Overload List


MonthlyDOWTrigger Properties

The properties of the MonthlyDOWTrigger class are listed below. For a complete list of MonthlyDOWTrigger class members, see the MonthlyDOWTrigger Members topic.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.
Months | Gets/sets months of the year in which trigger will fire.
StartHour (inherited from StartableTrigger) | Gets/sets hour of the day that trigger will fire (24 hour clock).
StartMinute (inherited from StartableTrigger) | Gets/sets minute of the hour (specified in StartHour) that trigger will fire.
WeekDays | Gets/sets days of the week on which trigger will fire.
WhichWeeks | Gets/sets weeks of the month in which trigger will fire.

See Also

MonthlyDOWTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Months Property

Aptify 5.0 Software Development Kit (SDK)

MonthlyDOWTrigger.Months Property

Gets/sets months of the year in which trigger will fire.

public MonthsOfTheYear Months {get; set;}

See Also

MonthlyDOWTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


WeekDays Property

Aptify 5.0 Software Development Kit (SDK)

MonthlyDOWTrigger.WeekDays Property

Gets/sets days of the week on which trigger will fire.

public DaysOfTheWeek WeekDays {get; set;}

See Also

MonthlyDOWTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


WhichWeeks Property

Aptify 5.0 Software Development Kit (SDK)

MonthlyDOWTrigger.WhichWeeks Property

Gets/sets weeks of the month in which trigger will fire.

public Int16 WhichWeeks {get; set;}

See Also

MonthlyDOWTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MonthlyTrigger Class

Trigger that fires at a specified time, on specified days of the month, on specified months of the year.

For a list of all members of this type, see MonthlyTrigger Members.

System.Object
Trigger
StartableTrigger
MonthlyTrigger

public class MonthlyTrigger : StartableTrigger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

MonthlyTrigger Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MonthlyTrigger Members

MonthlyTrigger overview

Public Instance Constructors

MonthlyTrigger Overloaded. Initializes a new instance of the MonthlyTrigger class.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Days | Gets/sets days of the month when trigger will fire.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.
Months | Gets/sets months of the year when trigger will fire.
StartHour (inherited from StartableTrigger) | Gets/sets hour of the day that trigger will fire (24 hour clock).
StartMinute (inherited from StartableTrigger) | Gets/sets minute of the hour (specified in StartHour) that trigger will fire.

Public Instance Methods

Clone (inherited from Trigger) | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals (inherited from Trigger) | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode (inherited from Trigger) | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Trigger) | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetStartTime (inherited from StartableTrigger) | Sets the start time of the trigger.
SyncTrigger (inherited from Trigger) | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

MonthlyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MonthlyTrigger Constructor

Creates a MonthlyTrigger that fires only during specified months of the year.

Overload List

Creates a MonthlyTrigger that fires during any month.

public MonthlyTrigger(Int16,Int16,Int32[]);

Creates a MonthlyTrigger that fires only during specified months of the year.

public MonthlyTrigger(Int16,Int16,Int32[],MonthsOfTheYear);

See Also

MonthlyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MonthlyTrigger Constructor (Int16, Int16, Int32[], MonthsOfTheYear)

Creates a MonthlyTrigger that fires only during specified months of the year.

public MonthlyTrigger(
Int16 hour,
Int16 minutes,
Int32[] daysOfMonth,
MonthsOfTheYear months
);

Parameters

hour
Hour of day trigger will fire.
minutes
Minutes of hour (specified in "hour") trigger will fire.
daysOfMonth
Days of the month trigger will fire. (See Days property.)
months
Months of the year trigger will fire.

See Also

MonthlyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | MonthlyTrigger Constructor Overload List


MonthlyTrigger Constructor (Int16, Int16, Int32[])

Creates a MonthlyTrigger that fires during any month.

public MonthlyTrigger(
Int16 hour,
Int16 minutes,
Int32[] daysOfMonth
);

Parameters

hour
Hour of day trigger will fire.
minutes
Minutes of hour (specified in "hour") trigger will fire.
daysOfMonth
Days of the month trigger will fire. (See Days property.)

See Also

MonthlyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | MonthlyTrigger Constructor Overload List


MonthlyTrigger Properties

The properties of the MonthlyTrigger class are listed below. For a complete list of MonthlyTrigger class members, see the MonthlyTrigger Members topic.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Days | Gets/sets days of the month when trigger will fire.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.
Months | Gets/sets months of the year when trigger will fire.
StartHour (inherited from StartableTrigger) | Gets/sets hour of the day that trigger will fire (24 hour clock).
StartMinute (inherited from StartableTrigger) | Gets/sets minute of the hour (specified in StartHour) that trigger will fire.

See Also

MonthlyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Days Property

Aptify 5.0 Software Development Kit (SDK)

MonthlyTrigger.Days Property

Gets/sets days of the month when trigger will fire.

public Int32[] Days {get; set;}

Property Value

An array with one element for each day that the trigger will fire. The value of the element is the number of the day, in the range 1..31.

See Also

MonthlyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Months Property

Aptify 5.0 Software Development Kit (SDK)

MonthlyTrigger.Months Property

Gets/sets months of the year when trigger will fire.

public MonthsOfTheYear Months {get; set;}

See Also

MonthlyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MonthsOfTheYear Enumeration

Values for months of the year (January, February, etc.) These carry the Flags attribute so MonthsOfTheYEar can be combined with | (or).

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MonthsOfTheYear

Members

Member Name | Description | Value
January | January | 1
February | February | 2
March | March | 4
April | April | 8
May | May | 16
June | June | 32
July | July | 64
August | August | 128
September | September | 256
October | October | 512
November | November | 1024
December | December | 2048

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


OnIdleTrigger Class

Trigger that fires when the system is idle for a period of time. Length of period set by IdleWaitMinutes.

For a list of all members of this type, see OnIdleTrigger Members.

System.Object
Trigger
OnIdleTrigger

public class OnIdleTrigger : Trigger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

OnIdleTrigger Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


OnIdleTrigger Members

OnIdleTrigger overview

Public Instance Constructors

OnIdleTrigger Constructor Creates an OnIdleTrigger. Idle period set separately. See IdleWaitMinutes inherited property.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.

Public Instance Methods

Clone (inherited from Trigger) | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals (inherited from Trigger) | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode (inherited from Trigger) | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Trigger) | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SyncTrigger (inherited from Trigger) | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

OnIdleTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


OnIdleTrigger Constructor

Creates an OnIdleTrigger. Idle period set separately. See IdleWaitMinutes inherited property.

public OnIdleTrigger();

See Also

OnIdleTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


OnLogonTrigger Class

Trigger that fires when a user logs on.

For a list of all members of this type, see OnLogonTrigger Members.

System.Object
Trigger
OnLogonTrigger

public class OnLogonTrigger : Trigger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Triggers of this type fire when any user logs on, not just the user identified in the account information.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

OnLogonTrigger Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


OnLogonTrigger Members

OnLogonTrigger overview

Public Instance Constructors

OnLogonTrigger Constructor Creates an OnLogonTrigger.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.

Public Instance Methods

Clone (inherited from Trigger) | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals (inherited from Trigger) | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode (inherited from Trigger) | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Trigger) | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SyncTrigger (inherited from Trigger) | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

OnLogonTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


OnLogonTrigger Constructor

Creates an OnLogonTrigger.

public OnLogonTrigger();

See Also

OnLogonTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


OnSystemStartTrigger Class

Trigger that fires when the system starts.

For a list of all members of this type, see OnSystemStartTrigger Members.

System.Object
Trigger
OnSystemStartTrigger

public class OnSystemStartTrigger : Trigger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

OnSystemStartTrigger Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


OnSystemStartTrigger Members

OnSystemStartTrigger overview

Public Instance Constructors

OnSystemStartTrigger Constructor Creates an OnSystemStartTrigger.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.

Public Instance Methods

Clone (inherited from Trigger) | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals (inherited from Trigger) | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode (inherited from Trigger) | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Trigger) | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SyncTrigger (inherited from Trigger) | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

OnSystemStartTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


OnSystemStartTrigger Constructor

Creates an OnSystemStartTrigger.

public OnSystemStartTrigger();

See Also

OnSystemStartTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


RunOnceTrigger Class

Trigger that fires once only.

For a list of all members of this type, see RunOnceTrigger Members.

System.Object
Trigger
StartableTrigger
RunOnceTrigger

public class RunOnceTrigger : StartableTrigger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

RunOnceTrigger Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


RunOnceTrigger Members

RunOnceTrigger overview

Public Instance Constructors

RunOnceTrigger Constructor Create a RunOnceTrigger that fires when specified.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.
StartHour (inherited from StartableTrigger) | Gets/sets hour of the day that trigger will fire (24 hour clock).
StartMinute (inherited from StartableTrigger) | Gets/sets minute of the hour (specified in StartHour) that trigger will fire.

Public Instance Methods

Clone (inherited from Trigger) | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals (inherited from Trigger) | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode (inherited from Trigger) | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Trigger) | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetStartTime (inherited from StartableTrigger) | Sets the start time of the trigger.
SyncTrigger (inherited from Trigger) | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

RunOnceTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


RunOnceTrigger Constructor

Create a RunOnceTrigger that fires when specified.

public RunOnceTrigger(
DateTime runDateTime
);

Parameters

runDateTime
Date and time to fire.

See Also

RunOnceTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


ScheduledTasks Class

ScheduledTasks represents a computer's Scheduled Tasks folder. Using a ScheduledTasks object, you can discover the names of the tasks in the folder and you can open a task to work with it. You can also create or delete tasks.

For a list of all members of this type, see ScheduledTasks Members.

System.Object
ScheduledTasks

public class ScheduledTasks : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

A ScheduledTasks object holds a COM interface that can be released by calling Dispose.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

ScheduledTasks Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


ScheduledTasks Members

ScheduledTasks overview

Public Instance Constructors

ScheduledTasks Overloaded. Initializes a new instance of the ScheduledTasks class.

Public Instance Methods

CreateTask | Creates a new task on the system with the given name.
DeleteTask | Deletes the task of the given name.
Dispose | The internal COM interface is released. Further access to the object will throw null reference exceptions.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTaskNames | Return the names of all scheduled tasks. The names returned include the file extension ".job"; methods requiring a task name can take the name with or without the extension.
GetType (inherited from Object) | Gets the Type of the current instance.
OpenTask | Opens the task with the given name. An open task holds COM interfaces which are released by the Task's Close() method.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScheduledTasks Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


ScheduledTasks Constructor

Constructor to use Scheduled tasks of a remote computer identified by a UNC name. The calling process must have administrative privileges on the remote machine. May throw exception if the computer's task scheduler cannot be reached, and may give strange results if the argument is not in UNC format.

Overload List

Constructor to use Scheduled Tasks of the local computer.

public ScheduledTasks();

Constructor to use Scheduled tasks of a remote computer identified by a UNC name. The calling process must have administrative privileges on the remote machine. May throw exception if the computer's task scheduler cannot be reached, and may give strange results if the argument is not in UNC format.

public ScheduledTasks(String);

See Also

ScheduledTasks Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


ScheduledTasks Constructor (String)

Constructor to use Scheduled tasks of a remote computer identified by a UNC name. The calling process must have administrative privileges on the remote machine. May throw exception if the computer's task scheduler cannot be reached, and may give strange results if the argument is not in UNC format.

public ScheduledTasks(
String computer
);

Parameters

computer
The remote computer's UNC name, e.g. "\\DALLAS".

Exceptions

Exception Type | Condition
ArgumentException | The Task Scheduler could not be accessed.

See Also

ScheduledTasks Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | ScheduledTasks Constructor Overload List


ScheduledTasks Constructor ()

Constructor to use Scheduled Tasks of the local computer.

public ScheduledTasks();

See Also

ScheduledTasks Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | ScheduledTasks Constructor Overload List


ScheduledTasks Methods

The methods of the ScheduledTasks class are listed below. For a complete list of ScheduledTasks class members, see the ScheduledTasks Members topic.

Public Instance Methods

CreateTask | Creates a new task on the system with the given name.
DeleteTask | Deletes the task of the given name.
Dispose | The internal COM interface is released. Further access to the object will throw null reference exceptions.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTaskNames | Return the names of all scheduled tasks. The names returned include the file extension ".job"; methods requiring a task name can take the name with or without the extension.
GetType (inherited from Object) | Gets the Type of the current instance.
OpenTask | Opens the task with the given name. An open task holds COM interfaces which are released by the Task's Close() method.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScheduledTasks Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


ScheduledTasks.CreateTask Method

Creates a new task on the system with the given name.

public Task CreateTask(
String name
);

Parameters

name
Name for the new task.

Return Value

Instance of new task.

Remarks

Task names follow normal filename character restrictions. The name will become the name of the file used to store the task (with .job added).

Exceptions

Exception Type | Condition
ArgumentException | There is an existing task with the given name.

See Also

ScheduledTasks Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


ScheduledTasks.DeleteTask Method

Deletes the task of the given name.

public bool DeleteTask(
String name
);

Parameters

name
Name of task to delete.

Return Value

True if the task was deleted, false if the task wasn't found.

Remarks

If you delete a task that is open, a subsequent save will throw an exception. You can save to a filename, however, to create a new task.

See Also

ScheduledTasks Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


ScheduledTasks.Dispose Method

The internal COM interface is released. Further access to the object will throw null reference exceptions.

public void Dispose();

Implements

IDisposable.

See Also

ScheduledTasks Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


ScheduledTasks.GetTaskNames Method

Return the names of all scheduled tasks. The names returned include the file extension ".job"; methods requiring a task name can take the name with or without the extension.

public string[] GetTaskNames();

Return Value

The names in a string array.

See Also

ScheduledTasks Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


ScheduledTasks.OpenTask Method

Opens the task with the given name. An open task holds COM interfaces which are released by the Task's Close() method.

public Task OpenTask(
String name
);

Parameters

name
Name of task to open.

Return Value

An instance of a Task, or null if the task name couldn't be found.

Remarks

If the task does not exist, null is returned.

See Also

ScheduledTasks Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


StartableTrigger Class

Generalization of all triggers that have a start time.

For a list of all members of this type, see StartableTrigger Members.

System.Object
Trigger
StartableTrigger
DailyTrigger
MonthlyDOWTrigger
MonthlyTrigger
RunOnceTrigger
WeeklyTrigger

public class StartableTrigger : Trigger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

StartableTrigger serves as a base class for triggers with a start time. Note that this class is not intended for use outside of the Aptify Framework.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

StartableTrigger Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


StartableTrigger Members

StartableTrigger overview

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.
StartHour | Gets/sets hour of the day that trigger will fire (24 hour clock).
StartMinute | Gets/sets minute of the hour (specified in StartHour) that trigger will fire.

Public Instance Methods

Clone (inherited from Trigger) | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals (inherited from Trigger) | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode (inherited from Trigger) | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Trigger) | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetStartTime | Sets the start time of the trigger.
SyncTrigger (inherited from Trigger) | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

StartableTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


StartableTrigger Properties

The properties of the StartableTrigger class are listed below. For a complete list of StartableTrigger class members, see the StartableTrigger Members topic.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.
StartHour | Gets/sets hour of the day that trigger will fire (24 hour clock).
StartMinute | Gets/sets minute of the hour (specified in StartHour) that trigger will fire.

See Also

StartableTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


StartHour Property

Aptify 5.0 Software Development Kit (SDK)

StartableTrigger.StartHour Property

Gets/sets hour of the day that trigger will fire (24 hour clock).

public Int16 StartHour {get; set;}

See Also

StartableTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


StartMinute Property

Aptify 5.0 Software Development Kit (SDK)

StartableTrigger.StartMinute Property

Gets/sets minute of the hour (specified in StartHour) that trigger will fire.

public Int16 StartMinute {get; set;}

See Also

StartableTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


StartableTrigger Methods

The methods of the StartableTrigger class are listed below. For a complete list of StartableTrigger class members, see the StartableTrigger Members topic.

Public Instance Methods

Clone (inherited from Trigger) | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals (inherited from Trigger) | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode (inherited from Trigger) | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Trigger) | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetStartTime | Sets the start time of the trigger.
SyncTrigger (inherited from Trigger) | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

StartableTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


StartableTrigger.SetStartTime Method

Sets the start time of the trigger.

protected void SetStartTime(
UInt16 hour,
UInt16 minute
);

Parameters

hour
Hour of the day that the trigger will fire.
minute
Minute of the hour.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The hour is not between 0 and 23 or the minute is not between 0 and 59.

See Also

StartableTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task Class

Represents an item in the Scheduled Tasks folder. There are no public constructors for Task. New instances are generated by a ScheduledTasks object using Open or Create methods. A task object holds COM interfaces; call its Close method to release them.

For a list of all members of this type, see Task Members.

System.Object
Task

public class Task : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

Task Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task Members

Task overview

Public Instance Properties

AccountName | Gets the name of the account under which the task process will run.
ApplicationName | Gets/sets the application filename that task is to run. Get returns an absolute pathname. A name searched with the PATH environment variable can be assigned, and the path search is done when the task is saved.
Comment | Gets/sets the comment associated with the task. The comment appears in the Scheduled Tasks user interface.
Creator | Gets/sets the creator of the task. If no value is supplied, the system fills in the account name of the caller when the task is saved.
ExitCode | Gets the Win32 exit code from the last execution of the task. If the task failed to start on its last run, the reason is returned as an exception. Not updated while in an open task; the property does not change unless the task is closed and re-opened. Various exceptions for a task that couldn't be run.
Flags | Gets/sets the TaskFlags associated with the current task.
Hidden | Hidden tasks are stored in files with the hidden file attribute so they don't appear in the Explorer user interface. Because there is a special interface for Scheduled Tasks, they don't appear even if Explorer is set to show hidden files. Functionally equivalent to TaskFlags.Hidden.
IdleWaitDeadlineMinutes | Gets/sets the maximum number of minutes that Task Scheduler will wait for a required idle period to occur.
IdleWaitMinutes | Gets/sets how long the system must remain idle, even after the trigger would normally fire, before the task will run.
MaxRunTime | Gets/sets the maximum length of time the task is permitted to run. Setting MaxRunTime also affects the value of MaxRunTimeLimited. The longest MaxRunTime implemented is 0xFFFFFFFE milliseconds, or about 50 days. If you set a TimeSpan longer than that, the MaxRunTime will be unlimited.
MaxRunTimeLimited | If the maximum run time is limited, the task will be terminated after MaxRunTime expires. Setting the value to FALSE, i.e. unlimited, invalidates MaxRunTime. The Task Scheduler service will try to send a WM_CLOSE message when it needs to terminate a task. If the message can't be sent, or the task does not respond with three minutes, the task will be terminated using TerminateProcess.
MostRecentRunTime | Gets the most recent time the task began running. MinValue returned if the task has not run.
Name | Gets the name of the task. The name is also the filename (plus a .job extension) the Task Scheduler uses to store the task information. To change the name of a task, use Save to save it as a new name and then delete the old task.
NextRunTime | Gets the next time the task will run. Returns MinValue if the task is not scheduled to run.
Parameters | Gets/sets the command-line parameters for the task.
Priority | Gets/sets the priority for the task process. Note: ProcessPriorityClass defines two levels (AboveNormal and BelowNormal) that are not documented in the task scheduler interface and can't be use on Win 98 platforms.
Status | Gets the status of the task. Returns TaskStatus. Not updated while a task is open.
Tag | Gets/sets arbitrary data associated with the task. The tag can be used for any purpose by the client, and is not used by the Task Scheduler. Known as WorkItemData in the IWorkItem com interface.
Triggers | Gets the list of triggers associated with the task.
WorkingDirectory | Gets/sets the initial working directory for the task.

Public Instance Methods

Close | Release COM interfaces for this Task. After a Task is closed, accessing its members throws a null reference exception.
DisplayForEdit | For compatibility with earlier versions. New clients should use DisplayPropertySheet.
DisplayPropertySheet | Overloaded. Display the property pages of this task for user editing.
Dispose | A synonym for Close.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NextRunTimeAfter | Calculate the next time the task would be scheduled to run after a given arbitrary time. If the task will not run (perhaps disabled) then returns MinValue.
Run | Schedules the task for immediate execution. The system works from the saved version of the task, so call Save before running. If the task has never been saved, it throws an argument exception. Problems starting the task are reported by the ExitCode property, not by exceptions on Run.
Save | Overloaded. Saves changes that have been made to this Task.
SetAccountInformation | Sets the account under which the task will run. Supply the account name and password as parameters. For the localsystem account, pass an empty string for the account name and null for the password. See Remarks.
Terminate | Request that the task be terminated if it is currently running. The call returns immediately, although the task may continue briefly. For Windows programs, a WM_CLOSE message is sent first and the task is given three minutes to shut down voluntarily. Should it not, or if the task is not a Windows program, TerminateProcess is used.
ToString | Overridden. Outputs the name of the task, the application and parameters.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task Properties

The properties of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Instance Properties

AccountName | Gets the name of the account under which the task process will run.
ApplicationName | Gets/sets the application filename that task is to run. Get returns an absolute pathname. A name searched with the PATH environment variable can be assigned, and the path search is done when the task is saved.
Comment | Gets/sets the comment associated with the task. The comment appears in the Scheduled Tasks user interface.
Creator | Gets/sets the creator of the task. If no value is supplied, the system fills in the account name of the caller when the task is saved.
ExitCode | Gets the Win32 exit code from the last execution of the task. If the task failed to start on its last run, the reason is returned as an exception. Not updated while in an open task; the property does not change unless the task is closed and re-opened. Various exceptions for a task that couldn't be run.
Flags | Gets/sets the TaskFlags associated with the current task.
Hidden | Hidden tasks are stored in files with the hidden file attribute so they don't appear in the Explorer user interface. Because there is a special interface for Scheduled Tasks, they don't appear even if Explorer is set to show hidden files. Functionally equivalent to TaskFlags.Hidden.
IdleWaitDeadlineMinutes | Gets/sets the maximum number of minutes that Task Scheduler will wait for a required idle period to occur.
IdleWaitMinutes | Gets/sets how long the system must remain idle, even after the trigger would normally fire, before the task will run.
MaxRunTime | Gets/sets the maximum length of time the task is permitted to run. Setting MaxRunTime also affects the value of MaxRunTimeLimited. The longest MaxRunTime implemented is 0xFFFFFFFE milliseconds, or about 50 days. If you set a TimeSpan longer than that, the MaxRunTime will be unlimited.
MaxRunTimeLimited | If the maximum run time is limited, the task will be terminated after MaxRunTime expires. Setting the value to FALSE, i.e. unlimited, invalidates MaxRunTime. The Task Scheduler service will try to send a WM_CLOSE message when it needs to terminate a task. If the message can't be sent, or the task does not respond with three minutes, the task will be terminated using TerminateProcess.
MostRecentRunTime | Gets the most recent time the task began running. MinValue returned if the task has not run.
Name | Gets the name of the task. The name is also the filename (plus a .job extension) the Task Scheduler uses to store the task information. To change the name of a task, use Save to save it as a new name and then delete the old task.
NextRunTime | Gets the next time the task will run. Returns MinValue if the task is not scheduled to run.
Parameters | Gets/sets the command-line parameters for the task.
Priority | Gets/sets the priority for the task process. Note: ProcessPriorityClass defines two levels (AboveNormal and BelowNormal) that are not documented in the task scheduler interface and can't be use on Win 98 platforms.
Status | Gets the status of the task. Returns TaskStatus. Not updated while a task is open.
Tag | Gets/sets arbitrary data associated with the task. The tag can be used for any purpose by the client, and is not used by the Task Scheduler. Known as WorkItemData in the IWorkItem com interface.
Triggers | Gets the list of triggers associated with the task.
WorkingDirectory | Gets/sets the initial working directory for the task.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


AccountName Property

Aptify 5.0 Software Development Kit (SDK)

Task.AccountName Property

Gets the name of the account under which the task process will run.

public String AccountName {get;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


ApplicationName Property

Aptify 5.0 Software Development Kit (SDK)

Task.ApplicationName Property

Gets/sets the application filename that task is to run. Get returns an absolute pathname. A name searched with the PATH environment variable can be assigned, and the path search is done when the task is saved.

public String ApplicationName {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Comment Property

Aptify 5.0 Software Development Kit (SDK)

Task.Comment Property

Gets/sets the comment associated with the task. The comment appears in the Scheduled Tasks user interface.

public String Comment {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Creator Property

Aptify 5.0 Software Development Kit (SDK)

Task.Creator Property

Gets/sets the creator of the task. If no value is supplied, the system fills in the account name of the caller when the task is saved.

public String Creator {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


ExitCode Property

Aptify 5.0 Software Development Kit (SDK)

Task.ExitCode Property

Gets the Win32 exit code from the last execution of the task. If the task failed to start on its last run, the reason is returned as an exception. Not updated while in an open task; the property does not change unless the task is closed and re-opened. Various exceptions for a task that couldn't be run.

public Int32 ExitCode {get;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Flags Property

Aptify 5.0 Software Development Kit (SDK)

Task.Flags Property

Gets/sets the TaskFlags associated with the current task.

public TaskFlags Flags {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Hidden Property

Aptify 5.0 Software Development Kit (SDK)

Task.Hidden Property

Hidden tasks are stored in files with the hidden file attribute so they don't appear in the Explorer user interface. Because there is a special interface for Scheduled Tasks, they don't appear even if Explorer is set to show hidden files. Functionally equivalent to TaskFlags.Hidden.

public Boolean Hidden {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


IdleWaitDeadlineMinutes Property

Aptify 5.0 Software Development Kit (SDK)

Task.IdleWaitDeadlineMinutes Property

Gets/sets the maximum number of minutes that Task Scheduler will wait for a required idle period to occur.

public Int16 IdleWaitDeadlineMinutes {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


IdleWaitMinutes Property

Aptify 5.0 Software Development Kit (SDK)

Task.IdleWaitMinutes Property

Gets/sets how long the system must remain idle, even after the trigger would normally fire, before the task will run.

public Int16 IdleWaitMinutes {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MaxRunTime Property

Aptify 5.0 Software Development Kit (SDK)

Task.MaxRunTime Property

Gets/sets the maximum length of time the task is permitted to run. Setting MaxRunTime also affects the value of MaxRunTimeLimited.

The longest MaxRunTime implemented is 0xFFFFFFFE milliseconds, or about 50 days. If you set a TimeSpan longer than that, the MaxRunTime will be unlimited.

public TimeSpan MaxRunTime {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MaxRunTimeLimited Property

Aptify 5.0 Software Development Kit (SDK)

Task.MaxRunTimeLimited Property

If the maximum run time is limited, the task will be terminated after MaxRunTime expires. Setting the value to FALSE, i.e. unlimited, invalidates MaxRunTime.

The Task Scheduler service will try to send a WM_CLOSE message when it needs to terminate a task. If the message can't be sent, or the task does not respond with three minutes, the task will be terminated using TerminateProcess.

public Boolean MaxRunTimeLimited {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


MostRecentRunTime Property

Aptify 5.0 Software Development Kit (SDK)

Task.MostRecentRunTime Property

Gets the most recent time the task began running. MinValue returned if the task has not run.

public DateTime MostRecentRunTime {get;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

Task.Name Property

Gets the name of the task. The name is also the filename (plus a .job extension) the Task Scheduler uses to store the task information. To change the name of a task, use Save to save it as a new name and then delete the old task.

public String Name {get;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


NextRunTime Property

Aptify 5.0 Software Development Kit (SDK)

Task.NextRunTime Property

Gets the next time the task will run. Returns MinValue if the task is not scheduled to run.

public DateTime NextRunTime {get;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Parameters Property

Aptify 5.0 Software Development Kit (SDK)

Task.Parameters Property

Gets/sets the command-line parameters for the task.

public String Parameters {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Priority Property

Aptify 5.0 Software Development Kit (SDK)

Task.Priority Property

Gets/sets the priority for the task process. Note: ProcessPriorityClass defines two levels (AboveNormal and BelowNormal) that are not documented in the task scheduler interface and can't be use on Win 98 platforms.

public ProcessPriorityClass Priority {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

Task.Status Property

Gets the status of the task. Returns TaskStatus. Not updated while a task is open.

public TaskStatus Status {get;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Tag Property

Aptify 5.0 Software Development Kit (SDK)

Task.Tag Property

Gets/sets arbitrary data associated with the task. The tag can be used for any purpose by the client, and is not used by the Task Scheduler. Known as WorkItemData in the IWorkItem com interface.

public Object Tag {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Triggers Property

Aptify 5.0 Software Development Kit (SDK)

Task.Triggers Property

Gets the list of triggers associated with the task.

public TriggerList Triggers {get;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


WorkingDirectory Property

Aptify 5.0 Software Development Kit (SDK)

Task.WorkingDirectory Property

Gets/sets the initial working directory for the task.

public String WorkingDirectory {get; set;}

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task Methods

The methods of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Instance Methods

Close | Release COM interfaces for this Task. After a Task is closed, accessing its members throws a null reference exception.
DisplayForEdit | For compatibility with earlier versions. New clients should use DisplayPropertySheet.
DisplayPropertySheet | Overloaded. Display the property pages of this task for user editing.
Dispose | A synonym for Close.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NextRunTimeAfter | Calculate the next time the task would be scheduled to run after a given arbitrary time. If the task will not run (perhaps disabled) then returns MinValue.
Run | Schedules the task for immediate execution. The system works from the saved version of the task, so call Save before running. If the task has never been saved, it throws an argument exception. Problems starting the task are reported by the ExitCode property, not by exceptions on Run.
Save | Overloaded. Saves changes that have been made to this Task.
SetAccountInformation | Sets the account under which the task will run. Supply the account name and password as parameters. For the localsystem account, pass an empty string for the account name and null for the password. See Remarks.
Terminate | Request that the task be terminated if it is currently running. The call returns immediately, although the task may continue briefly. For Windows programs, a WM_CLOSE message is sent first and the task is given three minutes to shut down voluntarily. Should it not, or if the task is not a Windows program, TerminateProcess is used.
ToString | Overridden. Outputs the name of the task, the application and parameters.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task.Close Method

Release COM interfaces for this Task. After a Task is closed, accessing its members throws a null reference exception.

public void Close();

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task.DisplayForEdit Method

For compatibility with earlier versions. New clients should use DisplayPropertySheet.

public void DisplayForEdit();

Remarks

Display the property pages of this task for user editing. If the user clicks OK, the task's properties are updated and the task is also automatically saved.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


DisplayPropertySheet Method

Aptify 5.0 Software Development Kit (SDK)

Task.DisplayPropertySheet Method

Display the property pages of this task for user editing.

Overload List

Display all property pages.

public bool DisplayPropertySheet();

Display only the specified property pages.

public bool DisplayPropertySheet(Task.PropPages);

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task.DisplayPropertySheet Method ()

Display all property pages.

public bool DisplayPropertySheet();

Return Value

true if dialog box was dismissed with OK, otherwise false.

Remarks

The method does not return until the user has dismissed the dialog box. If the dialog box is dismissed with the OK button, returns true and updates properties in the task. The changes are not made permanent, however, until the task is saved. (Save() method.)

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | Task.DisplayPropertySheet Overload List


Task.DisplayPropertySheet Method (PropPages)

Display only the specified property pages.

public bool DisplayPropertySheet(
Task.PropPages pages
);

Parameters

pages
Controls which pages are presented

Return Value

true if dialog box was dismissed with OK, otherwise false.

Remarks

See the DisplayPropertySheet() overload.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | Task.DisplayPropertySheet Overload List


Task.Dispose Method

A synonym for Close.

public void Dispose();

Implements

IDisposable.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task.NextRunTimeAfter Method

Calculate the next time the task would be scheduled to run after a given arbitrary time. If the task will not run (perhaps disabled) then returns MinValue.

public DateTime NextRunTimeAfter(
DateTime after
);

Parameters

after
The time to calculate from.

Return Value

The next time the task would run.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task.Run Method

Schedules the task for immediate execution. The system works from the saved version of the task, so call Save before running. If the task has never been saved, it throws an argument exception. Problems starting the task are reported by the ExitCode property, not by exceptions on Run.

public void Run();

Remarks

The system never updates an open task, so you don't get current results for the Status or the ExitCode properties until you close and reopen the task.

Exceptions

Exception Type | Condition
ArgumentException |

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

Task.Save Method

Saves changes that have been made to this Task.

Overload List

Saves changes to the established task name.

public void Save();

Saves the Task with a new name. The task with the old name continues to exist in whatever state it was last saved. It is no longer open, because. the Task object is associated with the new name from now on. If there is already a task using the new name, it is overwritten.

public void Save(String);

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task.Save Method ()

Saves changes to the established task name.

public void Save();

Remarks

The account name is checked for validity when a Task is saved. The password is not checked, but the account name must be valid (or empty).

Exceptions

Exception Type | Condition
COMException | Unable to establish existence of the account specified.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | Task.Save Overload List


Task.Save Method (String)

Saves the Task with a new name. The task with the old name continues to exist in whatever state it was last saved. It is no longer open, because. the Task object is associated with the new name from now on. If there is already a task using the new name, it is overwritten.

public void Save(
String name
);

Parameters

name
The new name to be used for this task.

Remarks

See the Save() overload.

Exceptions

Exception Type | Condition
COMException | Unable to establish existence of the account specified.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | Task.Save Overload List


Task.SetAccountInformation Method

Sets the account under which the task will run. Supply the account name and password as parameters. For the localsystem account, pass an empty string for the account name and null for the password. See Remarks.

public void SetAccountInformation(
String accountName,
String password
);

Parameters

accountName
Full account name.
password
Password for the account.

Remarks

To have the task to run under the local system account, pass the empty string ("") as accountName and null as the password. The caller must be running in an administrator account or in the local system account.

You can also specify a null password if the task has the flag RunOnlyIfLoggedOn set. This allows you to schedule a task for an account for which you don't know the password, but the account must be logged on interactively at the time the task runs.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task.Terminate Method

Request that the task be terminated if it is currently running. The call returns immediately, although the task may continue briefly. For Windows programs, a WM_CLOSE message is sent first and the task is given three minutes to shut down voluntarily. Should it not, or if the task is not a Windows program, TerminateProcess is used.

public void Terminate();

Exceptions

Exception Type | Condition
COMException | The task is not running.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task.ToString Method

Overridden. Outputs the name of the task, the application and parameters.

public override string ToString();

Return Value

String representing task.

See Also

Task Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Task.PropPages Enumeration

Argument for DisplayForEdit to determine which property pages to display.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum Task.PropPages

Members

Member Name | Description | Value
Task | The task property page | 1
Schedule | The schedule property page | 2
Settings | The setting property page | 4

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TaskFlags Enumeration

Options for a task, used for the Flags property of a Task. Uses the "Flags" attribute, so these values are combined with |. Some flags are documented as Windows 95 only, but they have a user interface in Windows XP so that may not be true.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum TaskFlags

Members

Member Name | Description | Value
Enabled | Default Flag | 0
Interactive | The precise meaning of this flag is elusive. The MSDN documentation describes it only for use in converting jobs from the Windows NT "AT" service to the newer Task Scheduler. No other use for the flag is documented. | 1
DeleteWhenDone | The task will be deleted when there are no more scheduled run times. | 2
Disabled | The task is disabled. Used to temporarily prevent a task from being triggered normally. | 4
StartOnlyIfIdle | The task begins only if the computer is idle at the scheduled start time. The computer is not considered idle until the task's IdleWaitMinutes time elapses with no user input. | 16
KillOnIdleEnd | The task terminates if the computer makes an idle to non-idle transition while the task is running. For information regarding idle triggers, see OnIdleTrigger. | 32
DontStartIfOnBatteries | The task does not start if the computer is running on battery power. | 64
KillIfGoingOnBatteries | The task ends, and the associated application quits if the computer switches to battery power. | 128
RunOnlyIfDocked | The task runs only if the system is docked. (Not mentioned in current MSDN documentation; probably obsolete.) | 256
Hidden | The task item is hidden. This is implemented by setting the job file's hidden attribute. Testing revealed that clearing this flag doesn't clear the file attribute, so the library sets the file attribute directly. This flag is kept in sync with the task's Hidden property, so they function equivalently. | 512
RunIfConnectedToInternet | The task runs only if there is currently a valid Internet connection. Not currently implemented. (Check current MSDN documentation for updates.) | 1024
RestartOnIdleResume | The task starts again if the computer makes a non-idle to idle transition before all the task's task_triggers elapse. (Use this flag in conjunction with KillOnIdleEnd.) | 2048
SystemRequired | Wake the computer to run this task. Seems to be misnamed, but the name is taken from the low-level interface. | 4096
RunOnlyIfLoggedOn | The task runs only if the user specified in SetAccountInformation() is logged on interactively. This flag has no effect on tasks set to run in the local SYSTEM account. | 8192

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TaskStatus Enumeration

Status values returned for a task. Some values have been determined to occur although they do no appear in the Task Scheduler system documentation.

public enum TaskStatus

Members

Member Name | Description
Ready | The task is ready to run at its next scheduled time.
Running | The task is currently running.
NotScheduled | One or more of the properties that are needed to run this task on a schedule have not been set.
NeverRun | The task has not yet run.
Disabled | The task will not run at the scheduled times because it has been disabled.
NoMoreRuns | There are no more runs scheduled for this task.
Terminated | The last run of the task was terminated by the user.
NoTriggers | Either the task has no triggers or the existing triggers are disabled or not set.
NoTriggerTime | Event triggers don't have set run times.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Trigger Class

Trigger is a generalization of all the concrete trigger classes, and any actual Trigger object is one of those types. When included in the TriggerList of a Task, a Trigger determines when a scheduled task will be run.

For a list of all members of this type, see Trigger Members.

System.Object
Trigger
OnIdleTrigger
OnLogonTrigger
OnSystemStartTrigger
StartableTrigger

public class Trigger : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Create a concrete trigger for a specific start condition and then call TriggerList.Add to include it in a task's TriggerList.

A Trigger that is not yet in a Task's TriggerList is said to be unbound and it holds no resources (i.e. COM interfaces). Once it is added to a TriggerList, it is bound and holds a COM interface that is only released when the Trigger is removed from the list or the corresponding Task is closed.

A Trigger that is already bound cannot be added to a TriggerList. To copy a Trigger from one list to another, use Clone to create an unbound copy and then add the copy to the new list. To move a Trigger from one list to another, use Remove to extract the Trigger from the first list before adding it to the second.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

Trigger Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Trigger Members

Trigger overview

Public Instance Properties

BeginDate | Gets/sets the beginning year, month, and day for the trigger.
Disabled | Gets/sets whether trigger is disabled.
DurationMinutes | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.

Public Instance Methods

Clone | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SyncTrigger | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Trigger Properties

The properties of the Trigger class are listed below. For a complete list of Trigger class members, see the Trigger Members topic.

Public Instance Properties

BeginDate | Gets/sets the beginning year, month, and day for the trigger.
Disabled | Gets/sets whether trigger is disabled.
DurationMinutes | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


BeginDate Property

Aptify 5.0 Software Development Kit (SDK)

Trigger.BeginDate Property

Gets/sets the beginning year, month, and day for the trigger.

public DateTime BeginDate {get; set;}

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Disabled Property

Aptify 5.0 Software Development Kit (SDK)

Trigger.Disabled Property

Gets/sets whether trigger is disabled.

public Boolean Disabled {get; set;}

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


DurationMinutes Property

Aptify 5.0 Software Development Kit (SDK)

Trigger.DurationMinutes Property

Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.

public Int32 DurationMinutes {get; set;}

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Setting must be greater than or equal to the IntervalMinutes setting.

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

Trigger.EndDate Property

Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.

public DateTime EndDate {get; set;}

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


HasEndDate Property

Aptify 5.0 Software Development Kit (SDK)

Trigger.HasEndDate Property

Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.

public Boolean HasEndDate {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | Has EndDate becomes true only by setting the EndDate property.

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


IntervalMinutes Property

Aptify 5.0 Software Development Kit (SDK)

Trigger.IntervalMinutes Property

Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.

public Int32 IntervalMinutes {get; set;}

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Setting must be less than to the DurationMinutes setting.

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


KillAtDurationEnd Property

Aptify 5.0 Software Development Kit (SDK)

Trigger.KillAtDurationEnd Property

Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.

public Boolean KillAtDurationEnd {get; set;}

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Trigger Methods

The methods of the Trigger class are listed below. For a complete list of Trigger class members, see the Trigger Members topic.

Public Instance Methods

Clone | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SyncTrigger | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Trigger.Clone Method

Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.

public object Clone();

Return Value

Implements

ICloneable.

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Trigger.Equals Method

Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.

public override bool Equals(
Object obj
);

Parameters

obj
Value of trigger to compare.

Return Value

true if triggers are equivalent.

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Trigger.GetHashCode Method

Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.

public override int GetHashCode();

Return Value

Hash code value.

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Trigger.SyncTrigger Method

When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

protected void SyncTrigger();

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Trigger.ToString Method

Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

public override string ToString();

Return Value

String representation of the trigger.

See Also

Trigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList Class

TriggerList is a collection of Triggers. Every Task has a TriggerList that is created and destroyed automatically along with the Task. There are no public constructors.

For a list of all members of this type, see TriggerList Members.

System.Object
TriggerList

public class TriggerList : IList, ICollection, IEnumerable, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

A TriggerList can be empty, and indeed a newly created Task has an empty list. It's not clear how the system handles a task with no triggers, however.

TriggerList implements IList and behaves like other indexable collections with one limitation: You can't insert a Trigger at a position. Insert() throws NotImplementedException. This restriction is based on the underlying API.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

TriggerList Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList Members

TriggerList overview

Public Instance Properties

Count | Gets the number of Triggers in the collection.
IsFixedSize | Returns whether collection is a fixed size. Always returns false for TriggerLists.
IsReadOnly | Gets read-only state of collection. Always false for TriggerLists.
IsSynchronized | Returns synchronizable state. Always false since the Task Scheduler is not thread safe.
Item | Access the Trigger at a specified index. Assigning to a TriggerList element requires the value to unbound. The previous list element becomes unbound and lost, while the newly assigned Trigger becomes bound in its place.
SyncRoot | Gets the root object for synchronization. Always null since TriggerLists aren't synchronized.

Public Instance Methods

Add | Add the supplied Trigger to the collection. The Trigger to be added must be unbound, i.e. it must not be a current member of a TriggerList--this or any other.
Clear | Remove all triggers from collection.
Contains | Test to see if trigger is part of the collection.
CopyTo | Copies all the Triggers in the collection to an array, beginning at the given index. The Triggers assigned to the array are cloned from the originals, implying they are unbound copies. (Can't tell if cloning is the intended semantics for this ICollection method, but it seems a good choice for TriggerLists.)
Dispose | Unbinds and Disposes all the Triggers in the collection, releasing the com interfaces they hold. Destroys the internal private pointer to the ITask com interface, but does not specifically release the interface because it is also in the containing task.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Gets a TriggerList enumerator.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the index of the supplied Trigger.
Remove | Removes the trigger from the collection. If the trigger is not in the collection, nothing happens. (No exception.)
RemoveAt | Removes the trigger at a specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList Properties

The properties of the TriggerList class are listed below. For a complete list of TriggerList class members, see the TriggerList Members topic.

Public Instance Properties

Count | Gets the number of Triggers in the collection.
IsFixedSize | Returns whether collection is a fixed size. Always returns false for TriggerLists.
IsReadOnly | Gets read-only state of collection. Always false for TriggerLists.
IsSynchronized | Returns synchronizable state. Always false since the Task Scheduler is not thread safe.
Item | Access the Trigger at a specified index. Assigning to a TriggerList element requires the value to unbound. The previous list element becomes unbound and lost, while the newly assigned Trigger becomes bound in its place.
SyncRoot | Gets the root object for synchronization. Always null since TriggerLists aren't synchronized.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

TriggerList.Count Property

Gets the number of Triggers in the collection.

public Int32 Count {get;}

Implements

ICollection.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


IsFixedSize Property

Aptify 5.0 Software Development Kit (SDK)

TriggerList.IsFixedSize Property

Returns whether collection is a fixed size. Always returns false for TriggerLists.

public Boolean IsFixedSize {get;}

Implements

IList.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


IsReadOnly Property

Aptify 5.0 Software Development Kit (SDK)

TriggerList.IsReadOnly Property

Gets read-only state of collection. Always false for TriggerLists.

public Boolean IsReadOnly {get;}

Implements

IList.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


IsSynchronized Property

Aptify 5.0 Software Development Kit (SDK)

TriggerList.IsSynchronized Property

Returns synchronizable state. Always false since the Task Scheduler is not thread safe.

public Boolean IsSynchronized {get;}

Implements

ICollection.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

TriggerList.Item Property

Access the Trigger at a specified index. Assigning to a TriggerList element requires the value to unbound. The previous list element becomes unbound and lost, while the newly assigned Trigger becomes bound in its place.

public Trigger this[
Int32 index
] {get; set;}

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Collection index out of range.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


SyncRoot Property

Aptify 5.0 Software Development Kit (SDK)

TriggerList.SyncRoot Property

Gets the root object for synchronization. Always null since TriggerLists aren't synchronized.

public Object SyncRoot {get;}

Implements

ICollection.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList Methods

The methods of the TriggerList class are listed below. For a complete list of TriggerList class members, see the TriggerList Members topic.

Public Instance Methods

Add | Add the supplied Trigger to the collection. The Trigger to be added must be unbound, i.e. it must not be a current member of a TriggerList--this or any other.
Clear | Remove all triggers from collection.
Contains | Test to see if trigger is part of the collection.
CopyTo | Copies all the Triggers in the collection to an array, beginning at the given index. The Triggers assigned to the array are cloned from the originals, implying they are unbound copies. (Can't tell if cloning is the intended semantics for this ICollection method, but it seems a good choice for TriggerLists.)
Dispose | Unbinds and Disposes all the Triggers in the collection, releasing the com interfaces they hold. Destroys the internal private pointer to the ITask com interface, but does not specifically release the interface because it is also in the containing task.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Gets a TriggerList enumerator.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the index of the supplied Trigger.
Remove | Removes the trigger from the collection. If the trigger is not in the collection, nothing happens. (No exception.)
RemoveAt | Removes the trigger at a specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList.Add Method

Add the supplied Trigger to the collection. The Trigger to be added must be unbound, i.e. it must not be a current member of a TriggerList--this or any other.

public int Add(
Trigger trigger
);

Parameters

trigger
Trigger to add.

Return Value

Index of added trigger.

Exceptions

Exception Type | Condition
ArgumentException | Trigger being added is already bound.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList.Clear Method

Remove all triggers from collection.

public void Clear();

Implements

IList.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList.Contains Method

Test to see if trigger is part of the collection.

public bool Contains(
Trigger trigger
);

Parameters

trigger
Trigger to find.

Return Value

true if trigger found in collection.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList.CopyTo Method

Copies all the Triggers in the collection to an array, beginning at the given index. The Triggers assigned to the array are cloned from the originals, implying they are unbound copies. (Can't tell if cloning is the intended semantics for this ICollection method, but it seems a good choice for TriggerLists.)

public void CopyTo(
Array array,
Int32 index
);

Parameters

array
Array to copy triggers into.
index
Index at which to start copying.

Implements

ICollection.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList.Dispose Method

Unbinds and Disposes all the Triggers in the collection, releasing the com interfaces they hold. Destroys the internal private pointer to the ITask com interface, but does not specifically release the interface because it is also in the containing task.

public void Dispose();

Implements

IDisposable.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList.GetEnumerator Method

Gets a TriggerList enumerator.

public IEnumerator GetEnumerator();

Return Value

Enumerator for TriggerList.

Implements

IEnumerable.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList.IndexOf Method

Returns the index of the supplied Trigger.

public int IndexOf(
Trigger trigger
);

Parameters

trigger
Trigger to find.

Return Value

Zero based index in collection, -1 if not a member.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList.Remove Method

Removes the trigger from the collection. If the trigger is not in the collection, nothing happens. (No exception.)

public void Remove(
Trigger trigger
);

Parameters

trigger
Trigger to remove.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


TriggerList.RemoveAt Method

Removes the trigger at a specified index.

public void RemoveAt(
Int32 index
);

Parameters

index
Index of trigger to remove.

Implements

IList.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Index out of range.

See Also

TriggerList Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


WeeklyTrigger Class

Trigger that fires at a specified time, on specified days of the week, every so many weeks.

For a list of all members of this type, see WeeklyTrigger Members.

System.Object
Trigger
StartableTrigger
WeeklyTrigger

public class WeeklyTrigger : StartableTrigger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

WeeklyTrigger Members | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


WeeklyTrigger Members

WeeklyTrigger overview

Public Instance Constructors

WeeklyTrigger Overloaded. Initializes a new instance of the WeeklyTrigger class.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.
StartHour (inherited from StartableTrigger) | Gets/sets hour of the day that trigger will fire (24 hour clock).
StartMinute (inherited from StartableTrigger) | Gets/sets minute of the hour (specified in StartHour) that trigger will fire.
WeekDays | Gets/sets the days of the week on which the trigger fires.
WeeksInterval | Gets/sets number of weeks from one eligible week to the next.

Public Instance Methods

Clone (inherited from Trigger) | Clone returns an unbound copy of the Trigger object. It can be used on either a bound or unbound original.
Equals (inherited from Trigger) | Determines if two triggers are internally equal. Does not consider whether the Triggers are bound or not.
GetHashCode (inherited from Trigger) | Gets a hash code for the current trigger. A Trigger has the same hash code whether it is bound or not.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Trigger) | Gets a string, supplied by the WindowsTask Scheduler, of a bound Trigger. For an unbound trigger, returns "Unbound Trigger".

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetStartTime (inherited from StartableTrigger) | Sets the start time of the trigger.
SyncTrigger (inherited from Trigger) | When a bound Trigger is changed, the corresponding trigger in the system Task Scheduler is updated to stay in sync with the local structure.

See Also

WeeklyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


WeeklyTrigger Constructor

Creates a WeeklyTrigger that is eligible to fire only during certain weeks.

Overload List

Creates a WeeklyTrigger that is eligible to fire during any week.

public WeeklyTrigger(Int16,Int16,DaysOfTheWeek);

Creates a WeeklyTrigger that is eligible to fire only during certain weeks.

public WeeklyTrigger(Int16,Int16,DaysOfTheWeek,Int16);

See Also

WeeklyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


WeeklyTrigger Constructor (Int16, Int16, DaysOfTheWeek, Int16)

Creates a WeeklyTrigger that is eligible to fire only during certain weeks.

public WeeklyTrigger(
Int16 hour,
Int16 minutes,
DaysOfTheWeek daysOfTheWeek,
Int16 weeksInterval
);

Parameters

hour
Hour of day trigger will fire.
minutes
Minutes of hour (specified in "hour") trigger will fire.
daysOfTheWeek
Days of the week task will run.
weeksInterval
Number of weeks between task runs.

See Also

WeeklyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | WeeklyTrigger Constructor Overload List


WeeklyTrigger Constructor (Int16, Int16, DaysOfTheWeek)

Creates a WeeklyTrigger that is eligible to fire during any week.

public WeeklyTrigger(
Int16 hour,
Int16 minutes,
DaysOfTheWeek daysOfTheWeek
);

Parameters

hour
Hour of day trigger will fire.
minutes
Minutes of hour (specified in "hour") trigger will fire.
daysOfTheWeek
Days of the week task will run.

See Also

WeeklyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace | WeeklyTrigger Constructor Overload List


WeeklyTrigger Properties

The properties of the WeeklyTrigger class are listed below. For a complete list of WeeklyTrigger class members, see the WeeklyTrigger Members topic.

Public Instance Properties

BeginDate (inherited from Trigger) | Gets/sets the beginning year, month, and day for the trigger.
Disabled (inherited from Trigger) | Gets/sets whether trigger is disabled.
DurationMinutes (inherited from Trigger) | Gets/sets the number of minutes after the trigger fires that it remains active. Used in conjunction with IntervalMinutes to run a task repeatedly for a period of time. For example, if you want to start a task at 8:00 A.M. and repeatedly restart it until 5:00 P.M., there would be 540 minutes (9 hours) in the duration. Can also be used to terminate a task that is running when the DurationMinutes expire. Use KillAtDurationEnd to specify that task should be terminated at that time.
EndDate (inherited from Trigger) | Gets/sets the ending year, month, and day for the trigger. After a value has been set with EndDate, HasEndDate becomes true.
HasEndDate (inherited from Trigger) | Gets/sets indication that the task uses an EndDate. Returns true if a value has been set for the EndDate property. Set can only be used to turn indication off.
IntervalMinutes (inherited from Trigger) | Gets/sets the number of minutes between executions for a task that is to be run repeatedly. Repetition continues until the interval specified in DurationMinutes expires. IntervalMinutes are counted from the start of the previous execution.
KillAtDurationEnd (inherited from Trigger) | Gets/sets whether task will be killed (terminated) when DurationMinutes expires. See DurationMinutes.
StartHour (inherited from StartableTrigger) | Gets/sets hour of the day that trigger will fire (24 hour clock).
StartMinute (inherited from StartableTrigger) | Gets/sets minute of the hour (specified in StartHour) that trigger will fire.
WeekDays | Gets/sets the days of the week on which the trigger fires.
WeeksInterval | Gets/sets number of weeks from one eligible week to the next.

See Also

WeeklyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


WeekDays Property

Aptify 5.0 Software Development Kit (SDK)

WeeklyTrigger.WeekDays Property

Gets/sets the days of the week on which the trigger fires.

public DaysOfTheWeek WeekDays {get; set;}

See Also

WeeklyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


WeeksInterval Property

Aptify 5.0 Software Development Kit (SDK)

WeeklyTrigger.WeeksInterval Property

Gets/sets number of weeks from one eligible week to the next.

public Int16 WeeksInterval {get; set;}

See Also

WeeklyTrigger Class | Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


WhichWeek Enumeration

Values for week of month (first, second, ..., last)

public enum WhichWeek

Members

Member Name | Description
FirstWeek | First week of the month
SecondWeek | Second week of the month
ThirdWeek | Third week of the month
FourthWeek | Fourth week of the month
LastWeek | Last week of the month

Requirements

Namespace: Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Assembly: TaskScheduler (in TaskScheduler.dll)

See Also

Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler Namespace


Aptify.Framework.BusinessLogic.Security

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.Security Namespace

This namespace contains objects related to Aptify's Security Key service that can encrypt data on a field-by-field basis.

Namespace hierarchy

Classes

Class | Description
AptifyCryptograph |
AptifySecurityKey |
AptifySecurityKeyEntity |
AptifySecurityKeyException |
Constants |
SecurityKeyCache |
SecurityKeyData |

Delegates

Delegate | Description
AptifySecurityKeyEntity.BeginProcessingBlockEventHandler |
AptifySecurityKeyEntity.BeginUpdatingBlockEventHandler |
AptifySecurityKeyEntity.EndProcessingBlockEventHandler |
AptifySecurityKeyEntity.EndUpdatingBlockEventHandler |
AptifySecurityKeyEntity.ProcessingBlockEventHandler |


AptifyCryptograph Class

For a list of all members of this type, see AptifyCryptograph Members.

System.Object
AptifyCryptograph

public class AptifyCryptograph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

AptifyCryptograph Members | Aptify.Framework.BusinessLogic.Security Namespace


AptifyCryptograph Members

AptifyCryptograph overview

Public Instance Constructors

AptifyCryptograph Overloaded. Initializes a new instance of the AptifyCryptograph class.

Public Instance Methods

DecryptData |
EncryptData |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyCryptograph Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifyCryptograph Constructor

Initializes a new instance of the AptifyCryptograph class.

Overload List

Initializes a new instance of the AptifyCryptograph class.

public AptifyCryptograph();

public AptifyCryptograph(Boolean);

See Also

AptifyCryptograph Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifyCryptograph Constructor ()

Initializes a new instance of the AptifyCryptograph class.

public AptifyCryptograph();

See Also

AptifyCryptograph Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifyCryptograph Constructor Overload List


AptifyCryptograph Constructor (Boolean)

public AptifyCryptograph(
Boolean UseDES
);

See Also

AptifyCryptograph Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifyCryptograph Constructor Overload List


AptifyCryptograph Methods

The methods of the AptifyCryptograph class are listed below. For a complete list of AptifyCryptograph class members, see the AptifyCryptograph Members topic.

Public Instance Methods

DecryptData |
EncryptData |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyCryptograph Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifyCryptograph.DecryptData Method

public virtual string DecryptData(
String SecurityKey,
String EncryptedText
);

See Also

AptifyCryptograph Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifyCryptograph.EncryptData Method

public virtual string EncryptData(
String SecurityKey,
String ClearText
);

See Also

AptifyCryptograph Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKey Class

For a list of all members of this type, see AptifySecurityKey Members.

System.Object
AptifySecurityKey

public class AptifySecurityKey

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

AptifySecurityKey Members | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKey Members

AptifySecurityKey overview

Public Instance Constructors

AptifySecurityKey Constructor

Public Instance Methods

CanUserAccessKey | Overloaded.
DecryptData | Overloaded.
EncryptData | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSecurityKeyNameFromID |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetKeyValue | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKey Constructor

public AptifySecurityKey(
UserCredentials UserCredentials
);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKey Methods

The methods of the AptifySecurityKey class are listed below. For a complete list of AptifySecurityKey class members, see the AptifySecurityKey Members topic.

Public Instance Methods

CanUserAccessKey | Overloaded.
DecryptData | Overloaded.
EncryptData | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSecurityKeyNameFromID |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetKeyValue | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace


CanUserAccessKey Method

Aptify 5.0 Software Development Kit (SDK)

AptifySecurityKey.CanUserAccessKey Method

Overload List

public virtual bool CanUserAccessKey(Int64);

public virtual bool CanUserAccessKey(String);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKey.CanUserAccessKey Method (Int64)

public virtual bool CanUserAccessKey(
Int64 KeyID
);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKey.CanUserAccessKey Overload List


AptifySecurityKey.CanUserAccessKey Method (String)

public virtual bool CanUserAccessKey(
String KeyName
);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKey.CanUserAccessKey Overload List


DecryptData Method

Aptify 5.0 Software Development Kit (SDK)

AptifySecurityKey.DecryptData Method

Overload List

public virtual string DecryptData(Int64,String);

public virtual string DecryptData(String,String);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKey.DecryptData Method (Int64, String)

public virtual string DecryptData(
Int64 KeyID,
String ValueToDecrypt
);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKey.DecryptData Overload List


AptifySecurityKey.DecryptData Method (String, String)

public virtual string DecryptData(
String KeyName,
String ValueToDecrypt
);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKey.DecryptData Overload List


EncryptData Method

Aptify 5.0 Software Development Kit (SDK)

AptifySecurityKey.EncryptData Method

Overload List

public virtual string EncryptData(Int64,String);

public virtual string EncryptData(String,String);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKey.EncryptData Method (Int64, String)

public virtual string EncryptData(
Int64 KeyID,
String ValueToEncrypt
);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKey.EncryptData Overload List


AptifySecurityKey.EncryptData Method (String, String)

public virtual string EncryptData(
String KeyName,
String ValueToEncrypt
);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKey.EncryptData Overload List


GetKeyValue Method

Aptify 5.0 Software Development Kit (SDK)

AptifySecurityKey.GetKeyValue Method

Overload List

protected virtual string GetKeyValue(Int64);

protected virtual string GetKeyValue(String);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKey.GetKeyValue Method (Int64)

protected virtual string GetKeyValue(
Int64 KeyID
);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKey.GetKeyValue Overload List


AptifySecurityKey.GetKeyValue Method (String)

protected virtual string GetKeyValue(
String KeyName
);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKey.GetKeyValue Overload List


AptifySecurityKey.GetSecurityKeyNameFromID Method

public string GetSecurityKeyNameFromID(
Int64 ID
);

See Also

AptifySecurityKey Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity Class

For a list of all members of this type, see AptifySecurityKeyEntity Members.

System.Object
AptifySecurityKeyEntity

public class AptifySecurityKeyEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

AptifySecurityKeyEntity Members | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity Members

AptifySecurityKeyEntity overview

Public Instance Constructors

AptifySecurityKeyEntity Constructor

Public Instance Methods

AddFieldByKeyID |
AddFieldByKeyName |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteProcess |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveField |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

BeginProcessingBlock
BeginUpdatingBlock
EndProcessingBlock
EndUpdatingBlock
ProcessingBlock

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity Constructor

public AptifySecurityKeyEntity(
UserCredentials UserCredentials,
AptifyGenericEntityBase EntityGE
);

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity Methods

The methods of the AptifySecurityKeyEntity class are listed below. For a complete list of AptifySecurityKeyEntity class members, see the AptifySecurityKeyEntity Members topic.

Public Instance Methods

AddFieldByKeyID |
AddFieldByKeyName |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteProcess |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveField |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.AddFieldByKeyID Method

public bool AddFieldByKeyID(
String FieldName,
Int64 OldSecurityKeyId,
Int64 NewSecurityKeyId
);

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.AddFieldByKeyName Method

public bool AddFieldByKeyName(
String FieldName,
String OldSecurityKeyName,
String NewSecurityKeyName
);

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.ExecuteProcess Method

public bool ExecuteProcess(
String TransactionID
);

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.RemoveField Method

public bool RemoveField(
String FieldName
);

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity Events

The events of the AptifySecurityKeyEntity class are listed below. For a complete list of AptifySecurityKeyEntity class members, see the AptifySecurityKeyEntity Members topic.

Public Instance Events

BeginProcessingBlock
BeginUpdatingBlock
EndProcessingBlock
EndUpdatingBlock
ProcessingBlock

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.AptifySecurityKeyEntity.BeginProcessingBlockEventHandler Event

public event AptifySecurityKeyEntity.BeginProcessingBlockEventHandler BeginProcessingBlock;

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.AptifySecurityKeyEntity.BeginUpdatingBlockEventHandler Event

public event AptifySecurityKeyEntity.BeginUpdatingBlockEventHandler BeginUpdatingBlock;

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.AptifySecurityKeyEntity.EndProcessingBlockEventHandler Event

public event AptifySecurityKeyEntity.EndProcessingBlockEventHandler EndProcessingBlock;

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.AptifySecurityKeyEntity.EndUpdatingBlockEventHandler Event

public event AptifySecurityKeyEntity.EndUpdatingBlockEventHandler EndUpdatingBlock;

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.AptifySecurityKeyEntity.ProcessingBlockEventHandler Event

public event AptifySecurityKeyEntity.ProcessingBlockEventHandler ProcessingBlock;

See Also

AptifySecurityKeyEntity Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.BeginProcessingBlockEventHandler Delegate

public delegate void AptifySecurityKeyEntity.BeginProcessingBlockEventHandler(
Int32 CurrentPosition,
Int32 BlockSize,
Int32 TotalRecords
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.BeginUpdatingBlockEventHandler Delegate

public delegate void AptifySecurityKeyEntity.BeginUpdatingBlockEventHandler(
Int32 CurrentPosition,
Int32 BlockSize,
Int32 TotalRecords
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.EndProcessingBlockEventHandler Delegate

public delegate void AptifySecurityKeyEntity.EndProcessingBlockEventHandler(
Int32 CurrentPosition,
Int32 BlockSize,
Int32 TotalRecords
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.EndUpdatingBlockEventHandler Delegate

public delegate void AptifySecurityKeyEntity.EndUpdatingBlockEventHandler(
Int32 CurrentPosition,
Int32 BlockSize,
Int32 TotalRecords
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyEntity.ProcessingBlockEventHandler Delegate

public delegate void AptifySecurityKeyEntity.ProcessingBlockEventHandler(
Int32 CurrentPosition,
Int32 BlockSize,
Int32 TotalRecords
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyException Class

For a list of all members of this type, see AptifySecurityKeyException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifySecurityKeyException

public class AptifySecurityKeyException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

AptifySecurityKeyException Members | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyException Members

AptifySecurityKeyException overview

Public Instance Constructors

AptifySecurityKeyException Overloaded. Initializes a new instance of the AptifySecurityKeyException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifySecurityKeyException Overloaded. Initializes a new instance of the AptifySecurityKeyException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifySecurityKeyException Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyException Constructor

Overload List

public AptifySecurityKeyException(Int32,Int32,String);

public AptifySecurityKeyException(Int32,Int32,String,Exception);

protected AptifySecurityKeyException(SerializationInfo,StreamingContext);

public AptifySecurityKeyException(String);

public AptifySecurityKeyException(String,Exception);

See Also

AptifySecurityKeyException Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyException Constructor (String)

public AptifySecurityKeyException(
String Message
);

See Also

AptifySecurityKeyException Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKeyException Constructor Overload List


AptifySecurityKeyException Constructor (String, Exception)

public AptifySecurityKeyException(
String Message,
Exception inner
);

See Also

AptifySecurityKeyException Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKeyException Constructor Overload List


AptifySecurityKeyException Constructor (Int32, Int32, String)

public AptifySecurityKeyException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AptifySecurityKeyException Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKeyException Constructor Overload List


AptifySecurityKeyException Constructor (Int32, Int32, String, Exception)

public AptifySecurityKeyException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
Exception inner
);

See Also

AptifySecurityKeyException Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKeyException Constructor Overload List


AptifySecurityKeyException Constructor (SerializationInfo, StreamingContext)

protected AptifySecurityKeyException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifySecurityKeyException Class | Aptify.Framework.BusinessLogic.Security Namespace | AptifySecurityKeyException Constructor Overload List


AptifySecurityKeyException Methods

The methods of the AptifySecurityKeyException class are listed below. For a complete list of AptifySecurityKeyException class members, see the AptifySecurityKeyException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifySecurityKeyException Class | Aptify.Framework.BusinessLogic.Security Namespace


AptifySecurityKeyException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifySecurityKeyException Class | Aptify.Framework.BusinessLogic.Security Namespace


Constants Class

For a list of all members of this type, see Constants Members.

System.Object
Constants

public class Constants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

Constants Members | Aptify.Framework.BusinessLogic.Security Namespace


Constants Members

Constants overview

Public Static Fields

ARGUMENT_EMPTY_STRING
NO_SECURITY_KEY_VALUE

Public Static Methods

ArgumentEmptyStringMessage |
NoSecurityKeyValueMessage | Overloaded.

Public Instance Constructors

Constants Constructor Initializes a new instance of the Constants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.BusinessLogic.Security Namespace


Constants Constructor

Initializes a new instance of the Constants class.

public Constants();

See Also

Constants Class | Aptify.Framework.BusinessLogic.Security Namespace


Constants Fields

The fields of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Fields

ARGUMENT_EMPTY_STRING
NO_SECURITY_KEY_VALUE

See Also

Constants Class | Aptify.Framework.BusinessLogic.Security Namespace


Constants.ARGUMENT_EMPTY_STRING Field

public const ARGUMENT_EMPTY_STRING ARGUMENT_EMPTY_STRING = "ARGUMENT_EMPTY_STRING";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Security Namespace


Constants.NO_SECURITY_KEY_VALUE Field

public const NO_SECURITY_KEY_VALUE NO_SECURITY_KEY_VALUE = "NO_SECURITY_KEY_VALUE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Security Namespace


Constants Methods

The methods of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Methods

ArgumentEmptyStringMessage |
NoSecurityKeyValueMessage | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.BusinessLogic.Security Namespace


Constants.ArgumentEmptyStringMessage Method

public static string ArgumentEmptyStringMessage(
String Argument
);

See Also

Constants Class | Aptify.Framework.BusinessLogic.Security Namespace


NoSecurityKeyValueMessage Method

Aptify 5.0 Software Development Kit (SDK)

Constants.NoSecurityKeyValueMessage Method

Overload List

public static string NoSecurityKeyValueMessage(Int64);

public static string NoSecurityKeyValueMessage(String);

See Also

Constants Class | Aptify.Framework.BusinessLogic.Security Namespace


Constants.NoSecurityKeyValueMessage Method (Int64)

public static string NoSecurityKeyValueMessage(
Int64 KeyID
);

See Also

Constants Class | Aptify.Framework.BusinessLogic.Security Namespace | Constants.NoSecurityKeyValueMessage Overload List


Constants.NoSecurityKeyValueMessage Method (String)

public static string NoSecurityKeyValueMessage(
String KeyName
);

See Also

Constants Class | Aptify.Framework.BusinessLogic.Security Namespace | Constants.NoSecurityKeyValueMessage Overload List


SecurityKeyCache Class

For a list of all members of this type, see SecurityKeyCache Members.

System.Object
SecurityKeyCache

public class SecurityKeyCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

SecurityKeyCache Members | Aptify.Framework.BusinessLogic.Security Namespace


SecurityKeyCache Members

SecurityKeyCache overview

Public Static Methods

Instance

Public Instance Constructors

SecurityKeyCache Constructor

Public Instance Properties

SecurityKey | Overloaded.
SecurityKeys |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SecurityKeyCache Class | Aptify.Framework.BusinessLogic.Security Namespace


SecurityKeyCache Constructor

public SecurityKeyCache(
AptifyApplication Application
);

See Also

SecurityKeyCache Class | Aptify.Framework.BusinessLogic.Security Namespace


SecurityKeyCache Properties

The properties of the SecurityKeyCache class are listed below. For a complete list of SecurityKeyCache class members, see the SecurityKeyCache Members topic.

Public Instance Properties

SecurityKey | Overloaded.
SecurityKeys |

See Also

SecurityKeyCache Class | Aptify.Framework.BusinessLogic.Security Namespace


SecurityKeyData Property

Aptify 5.0 Software Development Kit (SDK)

SecurityKeyCache.SecurityKeyData Property

Overload List

public SecurityKeyData this[Int64] {get;}

public SecurityKeyData this[String] {get;}

See Also

SecurityKeyCache Class | Aptify.Framework.BusinessLogic.Security Namespace


SecurityKey Property (Int64)

Aptify 5.0 Software Development Kit (SDK)

SecurityKeyCache.SecurityKey Property (Int64)

public SecurityKeyData this[
Int64 ID
] {get;}

See Also

SecurityKeyCache Class | Aptify.Framework.BusinessLogic.Security Namespace | SecurityKeyCache.SecurityKeyData Overload List


SecurityKey Property (String)

Aptify 5.0 Software Development Kit (SDK)

SecurityKeyCache.SecurityKey Property (String)

public SecurityKeyData this[
String Name
] {get;}

See Also

SecurityKeyCache Class | Aptify.Framework.BusinessLogic.Security Namespace | SecurityKeyCache.SecurityKeyData Overload List


SecurityKeys Property

Aptify 5.0 Software Development Kit (SDK)

SecurityKeyCache.SecurityKeys Property

public Dictionary<TKey,TValue> this[
Boolean ForceRefresh
] {get;}

See Also

SecurityKeyCache Class | Aptify.Framework.BusinessLogic.Security Namespace


SecurityKeyCache Methods

The methods of the SecurityKeyCache class are listed below. For a complete list of SecurityKeyCache class members, see the SecurityKeyCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SecurityKeyCache Class | Aptify.Framework.BusinessLogic.Security Namespace


SecurityKeyCache.Instance Method

public static SecurityKeyCache Instance(
AptifyApplication Application
);

See Also

SecurityKeyCache Class | Aptify.Framework.BusinessLogic.Security Namespace


SecurityKeyData Class

For a list of all members of this type, see SecurityKeyData Members.

System.Object
SecurityKeyData

public class SecurityKeyData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Security

Assembly: AptifySecurityKey (in AptifySecurityKey.dll)

See Also

SecurityKeyData Members | Aptify.Framework.BusinessLogic.Security Namespace


SecurityKeyData Members

SecurityKeyData overview

Public Instance Constructors

SecurityKeyData Constructor

Public Instance Properties

ID
KeyValue
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SecurityKeyData Class | Aptify.Framework.BusinessLogic.Security Namespace


SecurityKeyData Constructor

public SecurityKeyData(
Int64 ID,
String Name,
String KeyValue
);

See Also

SecurityKeyData Class | Aptify.Framework.BusinessLogic.Security Namespace


SecurityKeyData Properties

The properties of the SecurityKeyData class are listed below. For a complete list of SecurityKeyData class members, see the SecurityKeyData Members topic.

Public Instance Properties

ID
KeyValue
Name

See Also

SecurityKeyData Class | Aptify.Framework.BusinessLogic.Security Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

SecurityKeyData.ID Property

public Int64 ID {get;}

See Also

SecurityKeyData Class | Aptify.Framework.BusinessLogic.Security Namespace


KeyValue Property

Aptify 5.0 Software Development Kit (SDK)

SecurityKeyData.KeyValue Property

public String KeyValue {get;}

See Also

SecurityKeyData Class | Aptify.Framework.BusinessLogic.Security Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

SecurityKeyData.Name Property

public String Name {get;}

See Also

SecurityKeyData Class | Aptify.Framework.BusinessLogic.Security Namespace


Aptify.Framework.BusinessLogic.Spelling

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.Spelling Namespace

This namespace defines Aptify's generic spelling check functionality.

Namespace hierarchy

Classes

Class | Description
MSWordSpell | This class provides an implementation of integrating MS Word Spell Check functionality into the Aptify framework as a sub-class of SpellCheckBase
SpellCheckBase | Aptify's implementation of the ISpellCheck interface that has some base class functionality but requires a sub-class to provide overrides for the actual spell check functionality.
SpellingError | This class provides information about an individual spelling error including the suggested spelling for the word provided by the spell checker.
SpellingSystem | Information about a spelling system
Utility | Spelling Utility Class provides access to spelling system meta-data and helps with creating the spelling system classes that implement ISpellCheck

Interfaces

Interface | Description
ISpellCheck | This interface is used by plug-ins to provide spelling checker functionality to the Aptify Framework. Any spelling checker can be plugged in by implementing this interface within a class and plugging in that class into the Aptify Framework.


ISpellCheck Interface

This interface is used by plug-ins to provide spelling checker functionality to the Aptify Framework. Any spelling checker can be plugged in by implementing this interface within a class and plugging in that class into the Aptify Framework.

For a list of all members of this type, see ISpellCheck Members.

public interface ISpellCheck

Types that implement ISpellCheck

Type | Description
MSWordSpell | This class provides an implementation of integrating MS Word Spell Check functionality into the Aptify framework as a sub-class of SpellCheckBase
SpellCheckBase | Aptify's implementation of the ISpellCheck interface that has some base class functionality but requires a sub-class to provide overrides for the actual spell check functionality.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Spelling

Assembly: AptifySpelling (in AptifySpelling.dll)

See Also

ISpellCheck Members | Aptify.Framework.BusinessLogic.Spelling Namespace


ISpellCheck Members

ISpellCheck overview

Public Instance Properties

SpellingErrors This property is only available after the CheckSpelling() method has been called and contains a list of the spelling errors that were found by the spell checker.

Public Instance Methods

CheckSpelling | This method will check the spelling of the text stream provided as the Text parameter and will return True if the spelling check executed succesfully and there are NO spelling errors. False is returned if there are one or more spelling errors or if there was a problem executing. After this method executes, the SpellingErrors property will be available to enumerate any spelling errors that may have been found by the spell checker.
CheckStatus | This method will check the internal status of the object to determine if it is ready to handle spell checking functions. This method is provided for those object implementations where the provider of spell-check functionality may time-out a connection and the status-check will allow the implementation of this interface to return a status of True if it is ready to check spelling, False otherwise.
Config | This method must be called before any other member of the interface is accessed.

See Also

ISpellCheck Interface | Aptify.Framework.BusinessLogic.Spelling Namespace


ISpellCheck Properties

The properties of the ISpellCheck interface are listed below. For a complete list of ISpellCheck interface members, see the ISpellCheck Members topic.

Public Instance Properties

SpellingErrors This property is only available after the CheckSpelling() method has been called and contains a list of the spelling errors that were found by the spell checker.

See Also

ISpellCheck Interface | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingErrors Property

Aptify 5.0 Software Development Kit (SDK)

ISpellCheck.SpellingErrors Property

This property is only available after the CheckSpelling() method has been called and contains a list of the spelling errors that were found by the spell checker.

List<T> SpellingErrors {get;}

Property Value

Remarks

See Also

ISpellCheck Interface | Aptify.Framework.BusinessLogic.Spelling Namespace


ISpellCheck Methods

The methods of the ISpellCheck interface are listed below. For a complete list of ISpellCheck interface members, see the ISpellCheck Members topic.

Public Instance Methods

CheckSpelling | This method will check the spelling of the text stream provided as the Text parameter and will return True if the spelling check executed succesfully and there are NO spelling errors. False is returned if there are one or more spelling errors or if there was a problem executing. After this method executes, the SpellingErrors property will be available to enumerate any spelling errors that may have been found by the spell checker.
CheckStatus | This method will check the internal status of the object to determine if it is ready to handle spell checking functions. This method is provided for those object implementations where the provider of spell-check functionality may time-out a connection and the status-check will allow the implementation of this interface to return a status of True if it is ready to check spelling, False otherwise.
Config | This method must be called before any other member of the interface is accessed.

See Also

ISpellCheck Interface | Aptify.Framework.BusinessLogic.Spelling Namespace


ISpellCheck.CheckSpelling Method

This method will check the spelling of the text stream provided as the Text parameter and will return True if the spelling check executed succesfully and there are NO spelling errors. False is returned if there are one or more spelling errors or if there was a problem executing. After this method executes, the SpellingErrors property will be available to enumerate any spelling errors that may have been found by the spell checker.

bool CheckSpelling(
ref String& Text,
Boolean AllowGUI,
ref Boolean& ResponseHandledInMethod
);

Parameters

Text
AllowGUI
ResponseHandledInMethod

Return Value

Remarks

See Also

ISpellCheck Interface | Aptify.Framework.BusinessLogic.Spelling Namespace


ISpellCheck.CheckStatus Method

This method will check the internal status of the object to determine if it is ready to handle spell checking functions. This method is provided for those object implementations where the provider of spell-check functionality may time-out a connection and the status-check will allow the implementation of this interface to return a status of True if it is ready to check spelling, False otherwise.

bool CheckStatus();

Return Value

Remarks

See Also

ISpellCheck Interface | Aptify.Framework.BusinessLogic.Spelling Namespace


ISpellCheck.Config Method

This method must be called before any other member of the interface is accessed.

void Config(
AptifyApplication Application
);

Parameters

Application

Remarks

See Also

ISpellCheck Interface | Aptify.Framework.BusinessLogic.Spelling Namespace


MSWordSpell Class

This class provides an implementation of integrating MS Word Spell Check functionality into the Aptify framework as a sub-class of SpellCheckBase

For a list of all members of this type, see MSWordSpell Members.

System.Object
SpellCheckBase
MSWordSpell

public class MSWordSpell : SpellCheckBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Spelling

Assembly: MSWordSpell (in MSWordSpell.dll)

See Also

MSWordSpell Members | Aptify.Framework.BusinessLogic.Spelling Namespace


MSWordSpell Members

MSWordSpell overview

Public Instance Constructors

MSWordSpell Constructor Initializes a new instance of the MSWordSpell class.

Public Instance Properties

Application (inherited from SpellCheckBase) | Returns an instance of the AptifyApplication object
Database (inherited from SpellCheckBase) | Returns the database name where the Aptify Framework entities are located
SpellingErrors (inherited from SpellCheckBase) |

Public Instance Methods

CheckSpelling |
CheckStatus |
Config (inherited from SpellCheckBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MSWordSpell Class | Aptify.Framework.BusinessLogic.Spelling Namespace


MSWordSpell Constructor

Initializes a new instance of the MSWordSpell class.

public MSWordSpell();

See Also

MSWordSpell Class | Aptify.Framework.BusinessLogic.Spelling Namespace


MSWordSpell Methods

The methods of the MSWordSpell class are listed below. For a complete list of MSWordSpell class members, see the MSWordSpell Members topic.

Public Instance Methods

CheckSpelling |
CheckStatus |
Config (inherited from SpellCheckBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MSWordSpell Class | Aptify.Framework.BusinessLogic.Spelling Namespace


MSWordSpell.CheckSpelling Method

public override bool CheckSpelling(
ref String& Text,
Boolean AllowGUI,
ref Boolean& ResponseHandledInMethod
);

Implements

ISpellCheck.

See Also

MSWordSpell Class | Aptify.Framework.BusinessLogic.Spelling Namespace


MSWordSpell.CheckStatus Method

public override bool CheckStatus();

Implements

ISpellCheck.

See Also

MSWordSpell Class | Aptify.Framework.BusinessLogic.Spelling Namespace


MSWordSpell.Finalize Method

protected override void Finalize();

See Also

MSWordSpell Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellCheckBase Class

Aptify's implementation of the ISpellCheck interface that has some base class functionality but requires a sub-class to provide overrides for the actual spell check functionality.

For a list of all members of this type, see SpellCheckBase Members.

System.Object
SpellCheckBase
MSWordSpell

public class SpellCheckBase : ISpellCheck

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Spelling

Assembly: AptifySpelling (in AptifySpelling.dll)

See Also

SpellCheckBase Members | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellCheckBase Members

SpellCheckBase overview

Public Instance Constructors

SpellCheckBase Constructor Initializes a new instance of the SpellCheckBase class.

Public Instance Properties

Application | Returns an instance of the AptifyApplication object
Database | Returns the database name where the Aptify Framework entities are located
SpellingErrors |

Public Instance Methods

CheckSpelling |
CheckStatus |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpellCheckBase Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellCheckBase Constructor

Initializes a new instance of the SpellCheckBase class.

public SpellCheckBase();

See Also

SpellCheckBase Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellCheckBase Properties

The properties of the SpellCheckBase class are listed below. For a complete list of SpellCheckBase class members, see the SpellCheckBase Members topic.

Public Instance Properties

Application | Returns an instance of the AptifyApplication object
Database | Returns the database name where the Aptify Framework entities are located
SpellingErrors |

See Also

SpellCheckBase Class | Aptify.Framework.BusinessLogic.Spelling Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

SpellCheckBase.Application Property

Returns an instance of the AptifyApplication object

public virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

SpellCheckBase Class | Aptify.Framework.BusinessLogic.Spelling Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

SpellCheckBase.Database Property

Returns the database name where the Aptify Framework entities are located

public virtual String Database {get;}

Property Value

Remarks

See Also

SpellCheckBase Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingErrors Property

Aptify 5.0 Software Development Kit (SDK)

SpellCheckBase.SpellingErrors Property

public List<T> SpellingErrors {get;}

Implements

ISpellCheck.

See Also

SpellCheckBase Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellCheckBase Methods

The methods of the SpellCheckBase class are listed below. For a complete list of SpellCheckBase class members, see the SpellCheckBase Members topic.

Public Instance Methods

CheckSpelling |
CheckStatus |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpellCheckBase Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellCheckBase.CheckSpelling Method

public abstract bool CheckSpelling(
ref String& Text,
Boolean AllowGUI,
ref Boolean& ResponseHandledInMethod
);

Implements

ISpellCheck.

See Also

SpellCheckBase Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellCheckBase.CheckStatus Method

public abstract bool CheckStatus();

Implements

ISpellCheck.

See Also

SpellCheckBase Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellCheckBase.Config Method

public void Config(
AptifyApplication Application
);

Implements

ISpellCheck.

See Also

SpellCheckBase Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingError Class

This class provides information about an individual spelling error including the suggested spelling for the word provided by the spell checker.

For a list of all members of this type, see SpellingError Members.

System.Object
SpellingError

public class SpellingError

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Spelling

Assembly: AptifySpelling (in AptifySpelling.dll)

See Also

SpellingError Members | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingError Members

SpellingError overview

Public Instance Constructors

SpellingError Overloaded. Initializes a new instance of the SpellingError class.

Public Instance Properties

EndPosition | End Position of the selection that caused the error
SpellingSuggestions |
StartPosition | Start Position of the selection that caused the error
Word |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpellingError Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingError Constructor

Initializes a new instance of the SpellingError class.

Overload List

Initializes a new instance of the SpellingError class.

public SpellingError();

public SpellingError(String);

See Also

SpellingError Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingError Constructor ()

Initializes a new instance of the SpellingError class.

public SpellingError();

See Also

SpellingError Class | Aptify.Framework.BusinessLogic.Spelling Namespace | SpellingError Constructor Overload List


SpellingError Constructor (String)

public SpellingError(
String Word
);

See Also

SpellingError Class | Aptify.Framework.BusinessLogic.Spelling Namespace | SpellingError Constructor Overload List


SpellingError Properties

The properties of the SpellingError class are listed below. For a complete list of SpellingError class members, see the SpellingError Members topic.

Public Instance Properties

EndPosition | End Position of the selection that caused the error
SpellingSuggestions |
StartPosition | Start Position of the selection that caused the error
Word |

See Also

SpellingError Class | Aptify.Framework.BusinessLogic.Spelling Namespace


EndPosition Property

Aptify 5.0 Software Development Kit (SDK)

SpellingError.EndPosition Property

End Position of the selection that caused the error

public virtual Int32 EndPosition {get; set;}

Property Value

Remarks

See Also

SpellingError Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSuggestions Property

Aptify 5.0 Software Development Kit (SDK)

SpellingError.SpellingSuggestions Property

public virtual List<T> SpellingSuggestions {get;}

See Also

SpellingError Class | Aptify.Framework.BusinessLogic.Spelling Namespace


StartPosition Property

Aptify 5.0 Software Development Kit (SDK)

SpellingError.StartPosition Property

Start Position of the selection that caused the error

public virtual Int32 StartPosition {get; set;}

Property Value

Remarks

See Also

SpellingError Class | Aptify.Framework.BusinessLogic.Spelling Namespace


Word Property

Aptify 5.0 Software Development Kit (SDK)

SpellingError.Word Property

public virtual String Word {get; set;}

See Also

SpellingError Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystem Class

Information about a spelling system

For a list of all members of this type, see SpellingSystem Members.

System.Object
SpellingSystem

public class SpellingSystem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Spelling

Assembly: AptifySpelling (in AptifySpelling.dll)

See Also

SpellingSystem Members | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystem Members

SpellingSystem overview

Public Instance Constructors

SpellingSystem Constructor Initializes a new instance of the SpellingSystem class.

Public Instance Fields

AssemblyName | Name of assembly containing the class specified in ClassName
ClassName | Class name
Description |
ID |
IsDefault | Is this the default spelling system
Name |
ObjectName | Aptify object repository location

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SpellingSystem Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystem Constructor

Initializes a new instance of the SpellingSystem class.

public SpellingSystem();

See Also

SpellingSystem Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystem Fields

The fields of the SpellingSystem class are listed below. For a complete list of SpellingSystem class members, see the SpellingSystem Members topic.

Public Instance Fields

AssemblyName | Name of assembly containing the class specified in ClassName
ClassName | Class name
Description |
ID |
IsDefault | Is this the default spelling system
Name |
ObjectName | Aptify object repository location

See Also

SpellingSystem Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystem.AssemblyName Field

Name of assembly containing the class specified in ClassName

public AssemblyName AssemblyName;

Remarks

See Also

SpellingSystem Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystem.ClassName Field

Class name

public ClassName ClassName;

Remarks

See Also

SpellingSystem Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystem.Description Field

public Description Description;

See Also

SpellingSystem Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystem.ID Field

public ID ID;

See Also

SpellingSystem Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystem.IsDefault Field

Is this the default spelling system

public IsDefault IsDefault;

Remarks

See Also

SpellingSystem Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystem.Name Field

public Name Name;

See Also

SpellingSystem Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystem.ObjectName Field

Aptify object repository location

public ObjectName ObjectName;

Remarks

See Also

SpellingSystem Class | Aptify.Framework.BusinessLogic.Spelling Namespace


Utility Class

Spelling Utility Class provides access to spelling system meta-data and helps with creating the spelling system classes that implement ISpellCheck

For a list of all members of this type, see Utility Members.

System.Object
Utility

public class Utility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Spelling

Assembly: AptifySpelling (in AptifySpelling.dll)

See Also

Utility Members | Aptify.Framework.BusinessLogic.Spelling Namespace


Utility Members

Utility overview

Public Static Properties

SpellingSystems Provides a list of all of the spelling systems available on the system

Public Static Methods

GetSpellChecker | Overloaded. This method returns the default spell checker component that is registered in the system through the Spelling Systems entity that has UseAsDefault BIT set to 1.
GetSpellCheckSystem | Overloaded. Returns the Spell Check System that is marked as IsDefault=1 in the database, or returns the first spell check system (by ID) if no system is marked as IsDefault=1

Public Instance Constructors

Utility Constructor Initializes a new instance of the Utility class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace


Utility Constructor

Initializes a new instance of the Utility class.

public Utility();

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace


Utility Properties

The properties of the Utility class are listed below. For a complete list of Utility class members, see the Utility Members topic.

Public Static Properties

SpellingSystems Provides a list of all of the spelling systems available on the system

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace


SpellingSystems Property

Aptify 5.0 Software Development Kit (SDK)

Utility.SpellingSystems Property

Provides a list of all of the spelling systems available on the system

public static List<T> this[
Boolean Refresh,
AptifyApplication Application,
DataAction DataAction
] {get;}

Parameters

Refresh
Application
DataAction

Property Value

Remarks

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace


Utility Methods

The methods of the Utility class are listed below. For a complete list of Utility class members, see the Utility Members topic.

Public Static Methods

GetSpellChecker | Overloaded. This method returns the default spell checker component that is registered in the system through the Spelling Systems entity that has UseAsDefault BIT set to 1.
GetSpellCheckSystem | Overloaded. Returns the Spell Check System that is marked as IsDefault=1 in the database, or returns the first spell check system (by ID) if no system is marked as IsDefault=1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace


GetSpellChecker Method

Aptify 5.0 Software Development Kit (SDK)

Utility.GetSpellChecker Method

This method returns the spell checker component that has an ID equal to the provided parameter.

Overload List

This method returns the spell checker component that has an ID equal to the provided parameter.

public static ISpellCheck GetSpellChecker(AptifyApplication,DataAction,SpellingSystem);

This method returns the default spell checker component that is registered in the system through the Spelling Systems entity that has UseAsDefault BIT set to 1.

public static ISpellCheck GetSpellChecker(AptifyApplication,DataAction,Boolean);

This method returns the spell checker component that has an ID equal to the provided parameter.

public static ISpellCheck GetSpellChecker(AptifyApplication,DataAction,Boolean,Int64);

This method returns the spell checker component that has a Name equal to the provided parameter.

public static ISpellCheck GetSpellChecker(AptifyApplication,DataAction,Boolean,String);

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace


Utility.GetSpellChecker Method (AptifyApplication, DataAction, SpellingSystem)

This method returns the spell checker component that has an ID equal to the provided parameter.

public static ISpellCheck GetSpellChecker(
AptifyApplication Application,
DataAction DataAction,
SpellingSystem SpellingSystem
);

Return Value

Remarks

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace | Utility.GetSpellChecker Overload List


Utility.GetSpellChecker Method (AptifyApplication, DataAction, Boolean)

This method returns the default spell checker component that is registered in the system through the Spelling Systems entity that has UseAsDefault BIT set to 1.

public static ISpellCheck GetSpellChecker(
AptifyApplication Application,
DataAction DataAction,
Boolean RefreshDatabase
);

Return Value

Remarks

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace | Utility.GetSpellChecker Overload List


Utility.GetSpellChecker Method (AptifyApplication, DataAction, Boolean, Int64)

This method returns the spell checker component that has an ID equal to the provided parameter.

public static ISpellCheck GetSpellChecker(
AptifyApplication Application,
DataAction DataAction,
Boolean RefreshDatabase,
Int64 SpellingSystemID
);

Return Value

Remarks

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace | Utility.GetSpellChecker Overload List


Utility.GetSpellChecker Method (AptifyApplication, DataAction, Boolean, String)

This method returns the spell checker component that has a Name equal to the provided parameter.

public static ISpellCheck GetSpellChecker(
AptifyApplication Application,
DataAction DataAction,
Boolean RefreshDatabase,
String SpellingSystemName
);

Return Value

Remarks

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace | Utility.GetSpellChecker Overload List


GetSpellCheckSystem Method

Aptify 5.0 Software Development Kit (SDK)

Utility.GetSpellCheckSystem Method

Returns the Spell Check System that is marked as IsDefault=1 in the database, or returns the first spell check system (by ID) if no system is marked as IsDefault=1

Overload List

Returns the Spell Check System that is marked as IsDefault=1 in the database, or returns the first spell check system (by ID) if no system is marked as IsDefault=1

public static SpellingSystem GetSpellCheckSystem(AptifyApplication,DataAction,Boolean);

public static SpellingSystem GetSpellCheckSystem(AptifyApplication,DataAction,Boolean,Int64);

public static SpellingSystem GetSpellCheckSystem(AptifyApplication,DataAction,Boolean,String);

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace


Utility.GetSpellCheckSystem Method (AptifyApplication, DataAction, Boolean)

Returns the Spell Check System that is marked as IsDefault=1 in the database, or returns the first spell check system (by ID) if no system is marked as IsDefault=1

public static SpellingSystem GetSpellCheckSystem(
AptifyApplication Application,
DataAction DataAction,
Boolean RefreshDatabase
);

Parameters

Application
DataAction
RefreshDatabase

Return Value

Remarks

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace | Utility.GetSpellCheckSystem Overload List


Utility.GetSpellCheckSystem Method (AptifyApplication, DataAction, Boolean, Int64)

public static SpellingSystem GetSpellCheckSystem(
AptifyApplication Application,
DataAction DataAction,
Boolean RefreshDatabase,
Int64 SpellingSystemID
);

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace | Utility.GetSpellCheckSystem Overload List


Utility.GetSpellCheckSystem Method (AptifyApplication, DataAction, Boolean, String)

public static SpellingSystem GetSpellCheckSystem(
AptifyApplication Application,
DataAction DataAction,
Boolean RefreshDatabase,
String SpellingSystemName
);

See Also

Utility Class | Aptify.Framework.BusinessLogic.Spelling Namespace | Utility.GetSpellCheckSystem Overload List


Aptify.Framework.BusinessLogic.Views

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.Views Namespace

This namespace defines additional functionality for the Views entity beyond what is provided by the Generic Entity.

Namespace hierarchy

Classes

Class | Description
AptifyViewsEntity | Aptify Views Entity GE Sub-Class that provides functionality specific to managing views including generating View SQL.
ViewsException |


AptifyViewsEntity Class

Aptify Views Entity GE Sub-Class that provides functionality specific to managing views including generating View SQL.

For a list of all members of this type, see AptifyViewsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AptifyViewsEntity

public class AptifyViewsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Views

Assembly: AptifyViewsEntity (in AptifyViewsEntity.dll)

See Also

AptifyViewsEntity Members | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity Members

AptifyViewsEntity overview

Public Instance Constructors

AptifyViewsEntity Constructor Initializes a new instance of the AptifyViewsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AvailableFields |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderGE |
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FieldCount |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FilterCount |
HierarchyCount |
IsCustomSQL |
IsDirty | If the View contains Custom SQL (IsCustomSQL = True), uses the AptifyGenericEntity class' IsDirty logic. If the View contains SQL generated by the Views Entity, the IsDirty function will exclude Dirty state of the ViewSQL SubType while determining whether or not the View is dirty. Aside from that exclusion, the same logic used by the AptifyGenericEntity class' IsDirty property is used. '''
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ScheduledViewApplicationServer |
ScheduledViewApplicationServerID |
ScheduledViewProcessFlowID |
ScheduledViewProcessFlowName |
ScheduledViewScheduledTaskCategory |
ScheduledViewScheduledTaskCategoryID |
ScheduledViewScheduledTaskService |
ScheduledViewScheduledTaskServiceID |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SortFieldCount |
SQL |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ViewEntityName |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenerateSortSQL | This method will return the ORDER BY Clause of the default view SQL statement
GenerateWhereSQL | Returns the Where clause used for this view, if the View is based on generated SQL. Aptify retains the right to change this method. This function should not be called. Please use WhereSQL.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDefaultViewSQL | This method will return the default view SQL that would be created for the standard view types that do not have their own custom SQL generation logic. This method will return the entire SQL statement for the view based on the standard view logic. If a specific sub-component of the SQL is required, instantiate the SQLStatement class with the return value of this method and then use the component SQL properties of the SQLStatement class to retrieve those specific elements.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
IsTime | Validates whether given value is valid Time or not.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LoadViewWithDefaults |
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
SetViewEntity |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateFromSQL | This method will return the FROM clause for the default view SQL
GenerateSelectSQL | This method will generate the Select SQL clause
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
LoadAvailableFields |
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetBaseView | If the BaseView has not been set or it is set to a Base View that is not defined on the Entity or the user is not permitted to access, set the Base View to the default Base View using SetDefaultBaseView.
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetDefaultBaseView | Set the BaseView and EntityBaseView values based on the following criteria: 1. User's personal default Base View from UserValues: [EntityName].DefaultViewingSystemBaseView 2. Default Base View for the User, set by the Administrator. 3. Default Base View for the User's Primary Group, set by the Administrator. 4. Default global Base View, set by the Administrator. 5. Entity's Base View.
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity Constructor

Initializes a new instance of the AptifyViewsEntity class.

public AptifyViewsEntity();

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity Properties

The properties of the AptifyViewsEntity class are listed below. For a complete list of AptifyViewsEntity class members, see the AptifyViewsEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AvailableFields |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderGE |
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FieldCount |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FilterCount |
HierarchyCount |
IsCustomSQL |
IsDirty | If the View contains Custom SQL (IsCustomSQL = True), uses the AptifyGenericEntity class' IsDirty logic. If the View contains SQL generated by the Views Entity, the IsDirty function will exclude Dirty state of the ViewSQL SubType while determining whether or not the View is dirty. Aside from that exclusion, the same logic used by the AptifyGenericEntity class' IsDirty property is used. '''
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ScheduledViewApplicationServer |
ScheduledViewApplicationServerID |
ScheduledViewProcessFlowID |
ScheduledViewProcessFlowName |
ScheduledViewScheduledTaskCategory |
ScheduledViewScheduledTaskCategoryID |
ScheduledViewScheduledTaskService |
ScheduledViewScheduledTaskServiceID |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SortFieldCount |
SQL |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ViewEntityName |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AvailableFields Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.AvailableFields Property

public ViewFields AvailableFields {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


ExtenderGE Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.ExtenderGE Property

public AptifyGenericEntityBase ExtenderGE {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


FieldCount Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.FieldCount Property

public Int32 FieldCount {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


FilterCount Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.FilterCount Property

public Int32 FilterCount {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


HierarchyCount Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.HierarchyCount Property

public Int32 HierarchyCount {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


IsCustomSQL Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.IsCustomSQL Property

public Boolean IsCustomSQL {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.IsDirty Property

If the View contains Custom SQL (IsCustomSQL = True), uses the AptifyGenericEntity class' IsDirty logic. If the View contains SQL generated by the Views Entity, the IsDirty function will exclude Dirty state of the ViewSQL SubType while determining whether or not the View is dirty. Aside from that exclusion, the same logic used by the AptifyGenericEntity class' IsDirty property is used. '''

public override Boolean IsDirty {get;}

Property Value

Remarks

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


ScheduledViewApplicationServer Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.ScheduledViewApplicationServer Property

public String ScheduledViewApplicationServer {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


ScheduledViewApplicationServerID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.ScheduledViewApplicationServerID Property

public Int64 ScheduledViewApplicationServerID {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


ScheduledViewProcessFlowID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.ScheduledViewProcessFlowID Property

public Int64 ScheduledViewProcessFlowID {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


ScheduledViewProcessFlowName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.ScheduledViewProcessFlowName Property

public String ScheduledViewProcessFlowName {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


ScheduledViewScheduledTaskCategory Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.ScheduledViewScheduledTaskCategory Property

public String ScheduledViewScheduledTaskCategory {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


ScheduledViewScheduledTaskCategoryID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.ScheduledViewScheduledTaskCategoryID Property

public Int64 ScheduledViewScheduledTaskCategoryID {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


ScheduledViewScheduledTaskService Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.ScheduledViewScheduledTaskService Property

public String ScheduledViewScheduledTaskService {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


ScheduledViewScheduledTaskServiceID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.ScheduledViewScheduledTaskServiceID Property

public Int64 ScheduledViewScheduledTaskServiceID {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


SortFieldCount Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.SortFieldCount Property

public Int32 SortFieldCount {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


SQL Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.SQL Property

public String SQL {get; set;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


ViewEntityName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.ViewEntityName Property

public String ViewEntityName {get;}

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity Methods

The methods of the AptifyViewsEntity class are listed below. For a complete list of AptifyViewsEntity class members, see the AptifyViewsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenerateSortSQL | This method will return the ORDER BY Clause of the default view SQL statement
GenerateWhereSQL | Returns the Where clause used for this view, if the View is based on generated SQL. Aptify retains the right to change this method. This function should not be called. Please use WhereSQL.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDefaultViewSQL | This method will return the default view SQL that would be created for the standard view types that do not have their own custom SQL generation logic. This method will return the entire SQL statement for the view based on the standard view logic. If a specific sub-component of the SQL is required, instantiate the SQLStatement class with the return value of this method and then use the component SQL properties of the SQLStatement class to retrieve those specific elements.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
IsTime | Validates whether given value is valid Time or not.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LoadViewWithDefaults |
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
SetViewEntity |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateFromSQL | This method will return the FROM clause for the default view SQL
GenerateSelectSQL | This method will generate the Select SQL clause
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
LoadAvailableFields |
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetBaseView | If the BaseView has not been set or it is set to a Base View that is not defined on the Entity or the user is not permitted to access, set the Base View to the default Base View using SetDefaultBaseView.
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetDefaultBaseView | Set the BaseView and EntityBaseView values based on the following criteria: 1. User's personal default Base View from UserValues: [EntityName].DefaultViewingSystemBaseView 2. Default Base View for the User, set by the Administrator. 3. Default Base View for the User's Primary Group, set by the Administrator. 4. Default global Base View, set by the Administrator. 5. Entity's Base View.
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace | AptifyViewsEntity.Config Overload List


Delete Method

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.Delete Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

public override bool Delete(String);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.Delete Method (String)

public override bool Delete(
String TransactionID
);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace | AptifyViewsEntity.Delete Overload List


AptifyViewsEntity.GenerateFromSQL Method

This method will return the FROM clause for the default view SQL

protected virtual string GenerateFromSQL(
String BaseDatabase,
String BaseView
);

Parameters

BaseDatabase
BaseView

Return Value

Remarks

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.GenerateSelectSQL Method

This method will generate the Select SQL clause

protected virtual string GenerateSelectSQL(
String BaseDatabase,
String BaseView
);

Return Value

Remarks

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.GenerateSortSQL Method

This method will return the ORDER BY Clause of the default view SQL statement

public virtual string GenerateSortSQL(
String BaseDatabase,
String BaseView
);

Parameters

BaseDatabase
BaseView

Return Value

Remarks

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.GenerateWhereSQL Method

Returns the Where clause used for this view, if the View is based on generated SQL. Aptify retains the right to change this method. This function should not be called. Please use WhereSQL.

public virtual string GenerateWhereSQL(
String sBaseDatabase,
String sBaseView
);

Return Value

Remarks

If the view is based on Custom SQL, then String.Empty will be returned. Aptify retains the right to change this method. This function should not be called. Please use WhereSQL.

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.GetDefaultViewSQL Method

This method will return the default view SQL that would be created for the standard view types that do not have their own custom SQL generation logic. This method will return the entire SQL statement for the view based on the standard view logic. If a specific sub-component of the SQL is required, instantiate the SQLStatement class with the return value of this method and then use the component SQL properties of the SQLStatement class to retrieve those specific elements.

public virtual string GetDefaultViewSQL();

Return Value

Remarks

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.IsTime Method

Validates whether given value is valid Time or not.

public bool IsTime(
String argInputString
);

Parameters

argInputString

Return Value

Remarks

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


Load Method

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.Load Method

Overload List

Inherited from AptifyGenericEntity.

public override void Load(DataRow);

Inherited from AptifyGenericEntity.

public override void Load(IDataReader);

public override void Load(Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Load(String);

Inherited from AptifyGenericEntity.

public override void Load(String,Boolean);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.Load Method (Int64)

public override void Load(
Int64 ID
);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace | AptifyViewsEntity.Load Overload List


AptifyViewsEntity.LoadAvailableFields Method

protected virtual void LoadAvailableFields();

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.LoadViewWithDefaults Method

public void LoadViewWithDefaults();

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace | AptifyViewsEntity.Save Overload List


AptifyViewsEntity.SetBaseView Method

If the BaseView has not been set or it is set to a Base View that is not defined on the Entity or the user is not permitted to access, set the Base View to the default Base View using SetDefaultBaseView.

protected virtual void SetBaseView();

Remarks

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.SetDefaultBaseView Method

Set the BaseView and EntityBaseView values based on the following criteria: 1. User's personal default Base View from UserValues: [EntityName].DefaultViewingSystemBaseView 2. Default Base View for the User, set by the Administrator. 3. Default Base View for the User's Primary Group, set by the Administrator. 4. Default global Base View, set by the Administrator. 5. Entity's Base View.

protected virtual void SetDefaultBaseView();

Remarks

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.SetViewEntity Method

public bool SetViewEntity(
Int64 EntityID
);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AptifyViewsEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace


AptifyViewsEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

AptifyViewsEntity Class | Aptify.Framework.BusinessLogic.Views Namespace | AptifyViewsEntity.Validate Overload List


ViewsException Class

For a list of all members of this type, see ViewsException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
ViewsException

public class ViewsException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Views

Assembly: AptifyViewsEntity (in AptifyViewsEntity.dll)

See Also

ViewsException Members | Aptify.Framework.BusinessLogic.Views Namespace


ViewsException Members

ViewsException overview

Public Instance Constructors

ViewsException Overloaded. Initializes a new instance of the ViewsException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ViewsException Class | Aptify.Framework.BusinessLogic.Views Namespace


ViewsException Constructor

Initializes a new instance of the ViewsException class.

Overload List

Initializes a new instance of the ViewsException class.

public ViewsException();

public ViewsException(String);

public ViewsException(String,Exception);

See Also

ViewsException Class | Aptify.Framework.BusinessLogic.Views Namespace


ViewsException Constructor ()

Initializes a new instance of the ViewsException class.

public ViewsException();

See Also

ViewsException Class | Aptify.Framework.BusinessLogic.Views Namespace | ViewsException Constructor Overload List


ViewsException Constructor (String)

public ViewsException(
String Message
);

See Also

ViewsException Class | Aptify.Framework.BusinessLogic.Views Namespace | ViewsException Constructor Overload List


ViewsException Constructor (String, Exception)

public ViewsException(
String Message,
Exception InnerException
);

See Also

ViewsException Class | Aptify.Framework.BusinessLogic.Views Namespace | ViewsException Constructor Overload List


Aptify.Framework.DataPacker

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.DataPacker Namespace

This namespace contains the objects related to Aptify's Data Packer and Unpacker wizards that are used to copy records from a source server and add them to a target server.

Namespace hierarchy

Classes

Class | Description
DataPacker | Aptify Data Packer Class - used to pack meta-data from an entity to an XML based directory/file structure that is portable across computing environments.
DataPackerConstants |
DataPackerException |
DataPackerWizardForm | Provides the user interface for the standard Aptify Entity Data Packer Wizard.
DataUnPacker | Aptify DataUnPacker Class - used to unpack meta-data from previously packed meta-data and load it into the appropriate entities.
DataUnpackerWizardForm | Provides the user interface for the standard Aptify Entity Data Unacker Wizard.
MapRecord | Holds the data for an individual Data record that has been unpacked.
MapRecords | Provides a way to keep track of data that have been unpacked.
Wizard |
WizardPanel |


DataPacker Class

Aptify Data Packer Class - used to pack meta-data from an entity to an XML based directory/file structure that is portable across computing environments.

For a list of all members of this type, see DataPacker Members.

System.Object
DataPacker

public class DataPacker

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DataPacker

Assembly: AptifyDataPacker (in AptifyDataPacker.dll)

See Also

DataPacker Members | Aptify.Framework.DataPacker Namespace


DataPacker Members

DataPacker overview

Public Instance Constructors

DataPacker Constructor Initializes a new instance of the DataPacker class.

Public Instance Properties

Application
DataAction
Database
ObjectRepository

Public Instance Methods

Config | Call this method before any other member of a class instance is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Pack | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Pack | Overloaded. This function will pack the specified entity record based on the EntityName and RecordID parameters.
PackReverseLinkedRecords | This member will examine the PackingEntityRelations entity attribute for the EntityName parameter. For each entity in the list(comma delimited) specified by the PackingEntityRelations entity attribute, a query will be executed to identify all reverse linked records where a linked field refers back to the record being packed. The method will then use the functionality in the Pack() method to pack each single record that refers back to RecordID.

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace


DataPacker Constructor

Initializes a new instance of the DataPacker class.

public DataPacker();

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace


DataPacker Properties

The properties of the DataPacker class are listed below. For a complete list of DataPacker class members, see the DataPacker Members topic.

Public Instance Properties

Application
DataAction
Database
ObjectRepository

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

DataPacker.Application Property

public virtual AptifyApplication Application {get;}

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

DataPacker.DataAction Property

public virtual IAptifyDataAction DataAction {get;}

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

DataPacker.Database Property

public virtual String Database {get;}

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace


ObjectRepository Property

Aptify 5.0 Software Development Kit (SDK)

DataPacker.ObjectRepository Property

public virtual AptifyObjectRepository ObjectRepository {get;}

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace


DataPacker Methods

The methods of the DataPacker class are listed below. For a complete list of DataPacker class members, see the DataPacker Members topic.

Public Instance Methods

Config | Call this method before any other member of a class instance is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Pack | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Pack | Overloaded. This function will pack the specified entity record based on the EntityName and RecordID parameters.
PackReverseLinkedRecords | This member will examine the PackingEntityRelations entity attribute for the EntityName parameter. For each entity in the list(comma delimited) specified by the PackingEntityRelations entity attribute, a query will be executed to identify all reverse linked records where a linked field refers back to the record being packed. The method will then use the functionality in the Pack() method to pack each single record that refers back to RecordID.

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace


DataPacker.Config Method

Call this method before any other member of a class instance is accessed.

public void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Remarks

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace


Pack Method

Aptify 5.0 Software Development Kit (SDK)

DataPacker.Pack Method

Overload List

public virtual void Pack(String,ArrayList,String);

public virtual void Pack(String,ArrayList,String,Boolean);

public virtual void Pack(String,Int64,String);

public virtual void Pack(String,Int64,String,Boolean);

This function will pack the specified entity record based on the EntityName and RecordID parameters.

protected virtual void Pack(String,Int64,String,Boolean,Boolean);

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace


DataPacker.Pack Method (String, ArrayList, String)

public virtual void Pack(
String EntityName,
ArrayList Records,
String ParentDirectory
);

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace | DataPacker.Pack Overload List


DataPacker.Pack Method (String, ArrayList, String, Boolean)

public virtual void Pack(
String EntityName,
ArrayList Records,
String ParentDirectory,
Boolean PackRepositoryObjects
);

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace | DataPacker.Pack Overload List


DataPacker.Pack Method (String, Int64, String)

public virtual void Pack(
String EntityName,
Int64 RecordID,
String ParentDirectory
);

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace | DataPacker.Pack Overload List


DataPacker.Pack Method (String, Int64, String, Boolean)

public virtual void Pack(
String EntityName,
Int64 RecordID,
String ParentDirectory,
Boolean PackRepositoryObjects
);

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace | DataPacker.Pack Overload List


DataPacker.Pack Method (String, Int64, String, Boolean, Boolean)

This function will pack the specified entity record based on the EntityName and RecordID parameters.

protected virtual void Pack(
String EntityName,
Int64 RecordID,
String ParentDirectory,
Boolean TopLevelEntity,
Boolean PackRepositoryObjects
);

Parameters

EntityName
RecordID
ParentDirectory
TopLevelEntity
PackRepositoryObjects

Remarks

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace | DataPacker.Pack Overload List


DataPacker.PackReverseLinkedRecords Method

This member will examine the PackingEntityRelations entity attribute for the EntityName parameter. For each entity in the list(comma delimited) specified by the PackingEntityRelations entity attribute, a query will be executed to identify all reverse linked records where a linked field refers back to the record being packed. The method will then use the functionality in the Pack() method to pack each single record that refers back to RecordID.

protected virtual bool PackReverseLinkedRecords(
String EntityName,
Int64 RecordID,
String ParentDirectory,
Boolean PackRepositoryObjects
);

Parameters

EntityName
RecordID
ParentDirectory
PackRepositoryObjects

Return Value

Remarks

See Also

DataPacker Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants Class

For a list of all members of this type, see DataPackerConstants Members.

System.Object
DataPackerConstants

public class DataPackerConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataPacker

Assembly: AptifyDataPacker (in AptifyDataPacker.dll)

See Also

DataPackerConstants Members | Aptify.Framework.DataPacker Namespace


DataPackerConstants Members

DataPackerConstants overview

Public Static Fields

BASE_DATA_PACKER_EXCEPTION
ENTITY_DOES_NOT_SUPPORT_PACKING
ENTITY_MAP_FILE
ENTITY_MAP_FILE_CGI
FILE_EXTENSION
FILE_EXTENSION_CGI
INVALID_DATA_TYPE_RECORDS
OBJECTS_DIR
OBJECTS_DIR_CGI
OBJECTS_FILE
OBJECTS_FILE_CGI
TEXT_LINK_MAP_FILE
TEXT_LINK_MAP_FILE_CGI
UNPACK_STEPS_FILE
UNPACK_STEPS_FILE_CGI

Public Static Methods

GetString Overloaded.

Public Instance Constructors

DataPackerConstants Constructor Initializes a new instance of the DataPackerConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants Constructor

Initializes a new instance of the DataPackerConstants class.

public DataPackerConstants();

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants Fields

The fields of the DataPackerConstants class are listed below. For a complete list of DataPackerConstants class members, see the DataPackerConstants Members topic.

Public Static Fields

BASE_DATA_PACKER_EXCEPTION
ENTITY_DOES_NOT_SUPPORT_PACKING
ENTITY_MAP_FILE
ENTITY_MAP_FILE_CGI
FILE_EXTENSION
FILE_EXTENSION_CGI
INVALID_DATA_TYPE_RECORDS
OBJECTS_DIR
OBJECTS_DIR_CGI
OBJECTS_FILE
OBJECTS_FILE_CGI
TEXT_LINK_MAP_FILE
TEXT_LINK_MAP_FILE_CGI
UNPACK_STEPS_FILE
UNPACK_STEPS_FILE_CGI

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.BASE_DATA_PACKER_EXCEPTION Field

public const BASE_DATA_PACKER_EXCEPTION BASE_DATA_PACKER_EXCEPTION = "BASE_DATA_PACKER_EXCEPTION";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.ENTITY_DOES_NOT_SUPPORT_PACKING Field

public const ENTITY_DOES_NOT_SUPPORT_PACKING ENTITY_DOES_NOT_SUPPORT_PACKING = "ENTITY_DOES_NOT_SUPPORT_PACKING";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.ENTITY_MAP_FILE Field

public const ENTITY_MAP_FILE ENTITY_MAP_FILE = "_aptify_entitymap.txt";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.ENTITY_MAP_FILE_CGI Field

public const ENTITY_MAP_FILE_CGI ENTITY_MAP_FILE_CGI = "_cgi_entitymap.txt";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.FILE_EXTENSION Field

public const FILE_EXTENSION FILE_EXTENSION = ".apt";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.FILE_EXTENSION_CGI Field

public const FILE_EXTENSION_CGI FILE_EXTENSION_CGI = ".cgi";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.INVALID_DATA_TYPE_RECORDS Field

public const INVALID_DATA_TYPE_RECORDS INVALID_DATA_TYPE_RECORDS = "INVALID_DATA_TYPE_RECORDS";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.OBJECTS_DIR Field

public const OBJECTS_DIR OBJECTS_DIR = "_aptify_objects";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.OBJECTS_DIR_CGI Field

public const OBJECTS_DIR_CGI OBJECTS_DIR_CGI = "_cgi_objects";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.OBJECTS_FILE Field

public const OBJECTS_FILE OBJECTS_FILE = "_aptify_objects.txt";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.OBJECTS_FILE_CGI Field

public const OBJECTS_FILE_CGI OBJECTS_FILE_CGI = "_cgi_objects.txt";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.TEXT_LINK_MAP_FILE Field

public const TEXT_LINK_MAP_FILE TEXT_LINK_MAP_FILE = "_aptify_textlinkmap.txt";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.TEXT_LINK_MAP_FILE_CGI Field

public const TEXT_LINK_MAP_FILE_CGI TEXT_LINK_MAP_FILE_CGI = "_cgi_textlinkmap.txt";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.UNPACK_STEPS_FILE Field

public const UNPACK_STEPS_FILE UNPACK_STEPS_FILE = "_aptify_unpack_steps.txt";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.UNPACK_STEPS_FILE_CGI Field

public const UNPACK_STEPS_FILE_CGI UNPACK_STEPS_FILE_CGI = "_cgi_unpack_steps.txt";

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants Methods

The methods of the DataPackerConstants class are listed below. For a complete list of DataPackerConstants class members, see the DataPackerConstants Members topic.

Public Static Methods

GetString Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


GetString Method

Aptify 5.0 Software Development Kit (SDK)

DataPackerConstants.GetString Method

Overload List

public static string GetString(String);

public static string GetString(String,params String[]);

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace


DataPackerConstants.GetString Method (String)

public static string GetString(
String Text
);

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace | DataPackerConstants.GetString Overload List


DataPackerConstants.GetString Method (String, String[])

public static string GetString(
String Text,
params String[] FormatParameters
);

See Also

DataPackerConstants Class | Aptify.Framework.DataPacker Namespace | DataPackerConstants.GetString Overload List


DataPackerException Class

For a list of all members of this type, see DataPackerException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
DataPackerException

public class DataPackerException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataPacker

Assembly: AptifyDataPacker (in AptifyDataPacker.dll)

See Also

DataPackerException Members | Aptify.Framework.DataPacker Namespace


DataPackerException Members

DataPackerException overview

Public Instance Constructors

DataPackerException Overloaded. Initializes a new instance of the DataPackerException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
EntityData |
EntityID |
EntityName |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace


DataPackerException Constructor

Overload List

public DataPackerException(ref SerializationInfo&,ref StreamingContext&);

public DataPackerException(ref String&);

public DataPackerException(ref String&,ref Exception&);

public DataPackerException(ref String&,ref String&,ref Int64&,ref String&);

public DataPackerException(ref String&,ref String&,ref Int64&,ref String&,ref Exception&);

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace


DataPackerException Constructor (String&)

public DataPackerException(
ref String& Message
);

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace | DataPackerException Constructor Overload List


DataPackerException Constructor (String&, Exception&)

public DataPackerException(
ref String& Message,
ref Exception& InnerException
);

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace | DataPackerException Constructor Overload List


DataPackerException Constructor (String&, String&, Int64&, String&)

public DataPackerException(
ref String& Message,
ref String& EntityName,
ref Int64& EntityID,
ref String& EntityData
);

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace | DataPackerException Constructor Overload List


DataPackerException Constructor (String&, String&, Int64&, String&, Exception&)

public DataPackerException(
ref String& Message,
ref String& EntityName,
ref Int64& EntityID,
ref String& EntityData,
ref Exception& InnerException
);

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace | DataPackerException Constructor Overload List


DataPackerException Constructor (SerializationInfo&, StreamingContext&)

public DataPackerException(
ref SerializationInfo& Info,
ref StreamingContext& Context
);

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace | DataPackerException Constructor Overload List


DataPackerException Properties

The properties of the DataPackerException class are listed below. For a complete list of DataPackerException class members, see the DataPackerException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
EntityData |
EntityID |
EntityName |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace


EntityData Property

Aptify 5.0 Software Development Kit (SDK)

DataPackerException.EntityData Property

public String EntityData {get; set;}

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

DataPackerException.EntityID Property

public Int64 EntityID {get; set;}

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

DataPackerException.EntityName Property

public String EntityName {get; set;}

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

DataPackerException.Message Property

public override String Message {get;}

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace


DataPackerException Methods

The methods of the DataPackerException class are listed below. For a complete list of DataPackerException class members, see the DataPackerException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace


DataPackerException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

DataPackerException Class | Aptify.Framework.DataPacker Namespace


DataPackerWizardForm Class

Provides the user interface for the standard Aptify Entity Data Packer Wizard.

For a list of all members of this type, see DataPackerWizardForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
DataPackerWizardForm

public class DataPackerWizardForm : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DataPacker

Assembly: AptifyDataPacker (in AptifyDataPacker.dll)

See Also

DataPackerWizardForm Members | Aptify.Framework.DataPacker Namespace


DataPackerWizardForm Members

DataPackerWizardForm overview

Public Instance Constructors

DataPackerWizardForm Constructor Initializes a new instance of the DataPackerWizardForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataPackerWizardForm Constructor

Initializes a new instance of the DataPackerWizardForm class.

public DataPackerWizardForm();

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataPackerWizardForm Methods

The methods of the DataPackerWizardForm class are listed below. For a complete list of DataPackerWizardForm class members, see the DataPackerWizardForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataPackerWizardForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

DataPackerWizardForm.Config Method

Overload List

public void Config(AptifyApplication);

public void Config(AptifyApplication,Int64);

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataPackerWizardForm.Config Method (AptifyApplication)

public void Config(
AptifyApplication ApplicationObject
);

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataPackerWizardForm.Config Overload List


DataPackerWizardForm.Config Method (AptifyApplication, Int64)

public void Config(
AptifyApplication ApplicationObject,
Int64 InitiallySelectedEntityID
);

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataPackerWizardForm.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DataPackerWizardForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataPackerWizardForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataPackerWizardForm.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

DataPackerWizardForm.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

Configures and Displays the Data Packer Wizard.

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataPackerWizardForm.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataPackerWizardForm.DoAction Overload List


DataPackerWizardForm.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataPackerWizardForm.DoAction Overload List


DataPackerWizardForm.DoAction Method (AptifyApplication, Int64, Int64, Object[])

Configures and Displays the Data Packer Wizard.

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Parameters

ApplicationObject
EntityID
ViewID
SelectedItems

Implements

IAptifyAction.

Remarks

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataPackerWizardForm.DoAction Overload List


DataPackerWizardForm.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

DataPackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataPackerWizardForm.DoAction Overload List


DataUnPacker Class

Aptify DataUnPacker Class - used to unpack meta-data from previously packed meta-data and load it into the appropriate entities.

For a list of all members of this type, see DataUnPacker Members.

System.Object
DataUnPacker

public class DataUnPacker

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DataPacker

Assembly: AptifyDataPacker (in AptifyDataPacker.dll)

See Also

DataUnPacker Members | Aptify.Framework.DataPacker Namespace


DataUnPacker Members

DataUnPacker overview

Public Static Fields

RECORDMAP_LOG_FILE

Public Instance Constructors

DataUnPacker Constructor Initializes a new instance of the DataUnPacker class.

Public Instance Properties

Status Returns the current status of the Data Unpack.

Public Instance Methods

Config | Call this method before any other member of this class in order to configure the instance for use.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unpack | Overloaded. This overload unpacks the specified directory using default settings, which results in existing records being upgraded and object repository objects being unpacked. Call the other overloads if the default functionality for record upgrading or loading repository objects needs to be adjusted.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace


DataUnPacker Constructor

Initializes a new instance of the DataUnPacker class.

public DataUnPacker();

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace


DataUnPacker Fields

The fields of the DataUnPacker class are listed below. For a complete list of DataUnPacker class members, see the DataUnPacker Members topic.

Public Static Fields

RECORDMAP_LOG_FILE

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace


DataUnPacker.RECORDMAP_LOG_FILE Field

public const RECORDMAP_LOG_FILE RECORDMAP_LOG_FILE = "RecordMapLog.APT";

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace


DataUnPacker Properties

The properties of the DataUnPacker class are listed below. For a complete list of DataUnPacker class members, see the DataUnPacker Members topic.

Public Instance Properties

Status Returns the current status of the Data Unpack.

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

DataUnPacker.Status Property

Returns the current status of the Data Unpack.

public Status Status {get;}

Property Value

Remarks

Only the Message property is used.

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace


DataUnPacker Methods

The methods of the DataUnPacker class are listed below. For a complete list of DataUnPacker class members, see the DataUnPacker Members topic.

Public Instance Methods

Config | Call this method before any other member of this class in order to configure the instance for use.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unpack | Overloaded. This overload unpacks the specified directory using default settings, which results in existing records being upgraded and object repository objects being unpacked. Call the other overloads if the default functionality for record upgrading or loading repository objects needs to be adjusted.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace


DataUnPacker.Config Method

Call this method before any other member of this class in order to configure the instance for use.

public void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Remarks

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace


Unpack Method

Aptify 5.0 Software Development Kit (SDK)

DataUnPacker.Unpack Method

This overload unpacks the specified directory using default settings, which results in existing records being upgraded and object repository objects being unpacked. Call the other overloads if the default functionality for record upgrading or loading repository objects needs to be adjusted.

Overload List

This overload unpacks the specified directory using default settings, which results in existing records being upgraded and object repository objects being unpacked. Call the other overloads if the default functionality for record upgrading or loading repository objects needs to be adjusted.

public virtual void Unpack(String);

This overload unpacks the specified directory using default settings for repository object unpacking, which results in object repository objects being unpacked. Call the other overload if the default functionality for loading repository objects needs to be adjusted..

public virtual void Unpack(String,Boolean);

public virtual void Unpack(String,Boolean,Boolean);

This overload unpacks the specified directory using specified settings settings for repository object unpacking and record upgrading.

public virtual void Unpack(String,Boolean,Boolean,Boolean);

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace


DataUnPacker.Unpack Method (String)

This overload unpacks the specified directory using default settings, which results in existing records being upgraded and object repository objects being unpacked. Call the other overloads if the default functionality for record upgrading or loading repository objects needs to be adjusted.

public virtual void Unpack(
String DirectoryName
);

Parameters

DirectoryName

Remarks

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace | DataUnPacker.Unpack Overload List


DataUnPacker.Unpack Method (String, Boolean)

This overload unpacks the specified directory using default settings for repository object unpacking, which results in object repository objects being unpacked. Call the other overload if the default functionality for loading repository objects needs to be adjusted..

public virtual void Unpack(
String DirectoryName,
Boolean UpgradeExistingRecords
);

Parameters

DirectoryName
UpgradeExistingRecords
If set to True, existing records in the database being unpacked to will be updated from the packed meta-data if they match the "PackingUniqueKeyList" fields from the entity definition.

Remarks

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace | DataUnPacker.Unpack Overload List


DataUnPacker.Unpack Method (String, Boolean, Boolean)

public virtual void Unpack(
String DirectoryName,
Boolean UpgradeExistingRecords,
Boolean UnpackRepositoryObjects
);

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace | DataUnPacker.Unpack Overload List


DataUnPacker.Unpack Method (String, Boolean, Boolean, Boolean)

This overload unpacks the specified directory using specified settings settings for repository object unpacking and record upgrading.

public virtual void Unpack(
String DirectoryName,
Boolean UpgradeExistingRecords,
Boolean UnpackRepositoryObjects,
Boolean SpecialUpgradeBehavior
);

Parameters

DirectoryName
UpgradeExistingRecords
If set to True, existing records in the database being unpacked to will be updated from the packed meta-data if they match the "PackingUniqueKeyList" fields from the entity definition.
UnpackRepositoryObjects
If set to True, object repository objects in the target server will be added/updated from the pack files. If set to False, object repository objects are ignored.
SpecialUpgradeBehavior
If set to True, the Unpack operations is set to the mode used by the Aptify Upgrade Tools to migrate meta-data from the source server to the destination server. This mode includes support for the 3.x unpack format.

Remarks

See Also

DataUnPacker Class | Aptify.Framework.DataPacker Namespace | DataUnPacker.Unpack Overload List


DataUnpackerWizardForm Class

Provides the user interface for the standard Aptify Entity Data Unacker Wizard.

For a list of all members of this type, see DataUnpackerWizardForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
DataUnpackerWizardForm

public class DataUnpackerWizardForm : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DataPacker

Assembly: AptifyDataPacker (in AptifyDataPacker.dll)

See Also

DataUnpackerWizardForm Members | Aptify.Framework.DataPacker Namespace


DataUnpackerWizardForm Members

DataUnpackerWizardForm overview

Public Instance Constructors

DataUnpackerWizardForm Constructor Initializes a new instance of the DataUnpackerWizardForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileName |
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataUnpackerWizardForm Constructor

Initializes a new instance of the DataUnpackerWizardForm class.

public DataUnpackerWizardForm();

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataUnpackerWizardForm Methods

The methods of the DataUnpackerWizardForm class are listed below. For a complete list of DataUnpackerWizardForm class members, see the DataUnpackerWizardForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FileName |
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataUnpackerWizardForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataUnpackerWizardForm.Config Method

public void Config(
AptifyApplication ApplicationObject
);

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DataUnpackerWizardForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataUnpackerWizardForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataUnpackerWizardForm.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

DataUnpackerWizardForm.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

''' Configures and Displays the Data Unpacker Wizard.

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace


DataUnpackerWizardForm.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataUnpackerWizardForm.DoAction Overload List


DataUnpackerWizardForm.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataUnpackerWizardForm.DoAction Overload List


DataUnpackerWizardForm.DoAction Method (AptifyApplication, Int64, Int64, Object[])

''' Configures and Displays the Data Unpacker Wizard.

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Parameters

ApplicationObject
EntityID
ViewID
SelectedItems

Implements

IAptifyAction.

Remarks

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataUnpackerWizardForm.DoAction Overload List


DataUnpackerWizardForm.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace | DataUnpackerWizardForm.DoAction Overload List


DataUnpackerWizardForm.FileName Method

public string FileName(
String sFullName
);

See Also

DataUnpackerWizardForm Class | Aptify.Framework.DataPacker Namespace


MapRecord Class

Holds the data for an individual Data record that has been unpacked.

For a list of all members of this type, see MapRecord Members.

System.Object
MapRecord

public class MapRecord

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DataPacker

Assembly: AptifyDataPacker (in AptifyDataPacker.dll)

See Also

MapRecord Members | Aptify.Framework.DataPacker Namespace


MapRecord Members

MapRecord overview

Public Instance Constructors

MapRecord Constructor Initializes a new instance of the MapRecord class.

Public Instance Fields

Complete
DestinationID
EntityName
InProgress
SourceID
TextName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapRecord Class | Aptify.Framework.DataPacker Namespace


MapRecord Constructor

Initializes a new instance of the MapRecord class.

public MapRecord();

See Also

MapRecord Class | Aptify.Framework.DataPacker Namespace


MapRecord Fields

The fields of the MapRecord class are listed below. For a complete list of MapRecord class members, see the MapRecord Members topic.

Public Instance Fields

Complete
DestinationID
EntityName
InProgress
SourceID
TextName

See Also

MapRecord Class | Aptify.Framework.DataPacker Namespace


MapRecord.Complete Field

public Complete Complete;

See Also

MapRecord Class | Aptify.Framework.DataPacker Namespace


MapRecord.DestinationID Field

public DestinationID DestinationID;

See Also

MapRecord Class | Aptify.Framework.DataPacker Namespace


MapRecord.EntityName Field

public EntityName EntityName;

See Also

MapRecord Class | Aptify.Framework.DataPacker Namespace


MapRecord.InProgress Field

public InProgress InProgress;

See Also

MapRecord Class | Aptify.Framework.DataPacker Namespace


MapRecord.SourceID Field

public SourceID SourceID;

See Also

MapRecord Class | Aptify.Framework.DataPacker Namespace


MapRecord.TextName Field

public TextName TextName;

See Also

MapRecord Class | Aptify.Framework.DataPacker Namespace


MapRecords Class

Provides a way to keep track of data that have been unpacked.

For a list of all members of this type, see MapRecords Members.

System.Object
NameObjectCollectionBase
MapRecords

public class MapRecords : NameObjectCollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DataPacker

Assembly: AptifyDataPacker (in AptifyDataPacker.dll)

See Also

MapRecords Members | Aptify.Framework.DataPacker Namespace


MapRecords Members

MapRecords overview

Public Instance Constructors

MapRecords Constructor Initializes a new instance of the MapRecords class.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from NameObjectCollectionBase) | Returns an enumerator that iterates through the NameObjectCollectionBase.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetTextLinkSourceID | Function which locates the source record ID for a column which links based on a text field, not ID.
GetType (inherited from Object) | Gets the Type of the current instance.
Item | Overloaded.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapRecords Class | Aptify.Framework.DataPacker Namespace


MapRecords Constructor

Initializes a new instance of the MapRecords class.

public MapRecords();

See Also

MapRecords Class | Aptify.Framework.DataPacker Namespace


MapRecords Methods

The methods of the MapRecords class are listed below. For a complete list of MapRecords class members, see the MapRecords Members topic.

Public Instance Methods

Add | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from NameObjectCollectionBase) | Returns an enumerator that iterates through the NameObjectCollectionBase.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetTextLinkSourceID | Function which locates the source record ID for a column which links based on a text field, not ID.
GetType (inherited from Object) | Gets the Type of the current instance.
Item | Overloaded.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapRecords Class | Aptify.Framework.DataPacker Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

MapRecords.Add Method

Overload List

public MapRecord Add(String,Int64,String);

public MapRecord Add(ref String&,ref Int64&,ref Int64&);

See Also

MapRecords Class | Aptify.Framework.DataPacker Namespace


MapRecords.Add Method (String, Int64, String)

public MapRecord Add(
String EntityName,
Int64 SourceID,
String TextLink
);

See Also

MapRecords Class | Aptify.Framework.DataPacker Namespace | MapRecords.Add Overload List


MapRecords.Add Method (String&, Int64&, Int64&)

public MapRecord Add(
ref String& EntityName,
ref Int64& SourceID,
ref Int64& DestinationID
);

See Also

MapRecords Class | Aptify.Framework.DataPacker Namespace | MapRecords.Add Overload List


MapRecords.GetTextLinkSourceID Method

Function which locates the source record ID for a column which links based on a text field, not ID.

public long GetTextLinkSourceID(
String EntityName,
String TextLink
);

Parameters

EntityName
The name of the Entity to query.
TextLink
The value of the link.

Return Value

Remarks

See Also

MapRecords Class | Aptify.Framework.DataPacker Namespace


Item Method

Aptify 5.0 Software Development Kit (SDK)

MapRecords.Item Method

Overload List

public MapRecord Item(ref Int32&);

public MapRecord Item(ref String&);

public MapRecord Item(ref String&,ref Int64&);

See Also

MapRecords Class | Aptify.Framework.DataPacker Namespace


MapRecords.Item Method (Int32&)

public MapRecord Item(
ref Int32& Index
);

See Also

MapRecords Class | Aptify.Framework.DataPacker Namespace | MapRecords.Item Overload List


MapRecords.Item Method (String&)

public MapRecord Item(
ref String& Name
);

See Also

MapRecords Class | Aptify.Framework.DataPacker Namespace | MapRecords.Item Overload List


MapRecords.Item Method (String&, Int64&)

public MapRecord Item(
ref String& EntityName,
ref Int64& SourceID
);

See Also

MapRecords Class | Aptify.Framework.DataPacker Namespace | MapRecords.Item Overload List


Wizard Class

For a list of all members of this type, see Wizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Wizard

public class Wizard : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataPacker

Assembly: AptifyDataPacker (in AptifyDataPacker.dll)

See Also

Wizard Members | Aptify.Framework.DataPacker Namespace


Wizard Members

Wizard overview

Public Instance Constructors

Wizard Constructor Initializes a new instance of the Wizard class.

Public Instance Properties

AcceptButton |
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
ButtonTop |
CancelButton |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
CurrentPanel |
CurrentStep |
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EnableBack |
EnableCancel |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableFinish |
EnableHelp |
EnableNext |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowBack |
ShowBottomLine |
ShowCancel |
ShowFinish |
ShowHelp |
ShowNext |
ShowTopLine |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Steps |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddPanel | Overloaded.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformBack |
PerformCancel |
PerformFinish |
PerformHelp |
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PerformNext |
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveAllPanels |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
Canceling |
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
Finishing |
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
Help |
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MovedBack |
MovedNext |
MovingBack |
MovingNext |
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout |
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard Constructor

Initializes a new instance of the Wizard class.

public Wizard();

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard Properties

The properties of the Wizard class are listed below. For a complete list of Wizard class members, see the Wizard Members topic.

Public Instance Properties

AcceptButton |
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
ButtonTop |
CancelButton |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
CurrentPanel |
CurrentStep |
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EnableBack |
EnableCancel |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EnableFinish |
EnableHelp |
EnableNext |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowBack |
ShowBottomLine |
ShowCancel |
ShowFinish |
ShowHelp |
ShowNext |
ShowTopLine |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Steps |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


AcceptButton Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.AcceptButton Property

public IButtonControl AcceptButton {get;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


ButtonTop Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.ButtonTop Property

public Int32 ButtonTop {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


CancelButton Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.CancelButton Property

public IButtonControl CancelButton {get;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


CurrentPanel Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.CurrentPanel Property

public Panel CurrentPanel {get;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


CurrentStep Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.CurrentStep Property

public Int32 CurrentStep {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


EnableBack Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.EnableBack Property

public Boolean EnableBack {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


EnableCancel Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.EnableCancel Property

public Boolean EnableCancel {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


EnableFinish Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.EnableFinish Property

public Boolean EnableFinish {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


EnableHelp Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.EnableHelp Property

public Boolean EnableHelp {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


EnableNext Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.EnableNext Property

public Boolean EnableNext {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


ShowBack Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.ShowBack Property

public Boolean ShowBack {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


ShowBottomLine Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.ShowBottomLine Property

public Boolean ShowBottomLine {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


ShowCancel Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.ShowCancel Property

public Boolean ShowCancel {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


ShowFinish Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.ShowFinish Property

public Boolean ShowFinish {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


ShowHelp Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.ShowHelp Property

public Boolean ShowHelp {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


ShowNext Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.ShowNext Property

public Boolean ShowNext {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


ShowTopLine Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.ShowTopLine Property

public Boolean ShowTopLine {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Steps Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.Steps Property

public Int32 Steps {get;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

Wizard.UserCredentials Property

public UserCredentials UserCredentials {get; set;}

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard Methods

The methods of the Wizard class are listed below. For a complete list of Wizard class members, see the Wizard Members topic.

Public Instance Methods

AddPanel | Overloaded.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformBack |
PerformCancel |
PerformFinish |
PerformHelp |
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PerformNext |
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveAllPanels |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout |
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


AddPanel Method

Aptify 5.0 Software Development Kit (SDK)

Wizard.AddPanel Method

Overload List

public void AddPanel(WizardPanel);

public void AddPanel(WizardPanel,Boolean);

public void AddPanel(Panel);

public void AddPanel(Panel,Boolean);

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.AddPanel Method (WizardPanel)

public void AddPanel(
WizardPanel NewPanel
);

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace | Wizard.AddPanel Overload List


Wizard.AddPanel Method (WizardPanel, Boolean)

public void AddPanel(
WizardPanel NewPanel,
Boolean SizeToFirstPanel
);

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace | Wizard.AddPanel Overload List


Wizard.AddPanel Method (Panel)

public void AddPanel(
Panel NewPanel
);

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace | Wizard.AddPanel Overload List


Wizard.AddPanel Method (Panel, Boolean)

public void AddPanel(
Panel NewPanel,
Boolean SizeToFirstPanel
);

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace | Wizard.AddPanel Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

Wizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace | Wizard.Dispose Overload List


Wizard.DoLocalization Method

public void DoLocalization(
UserCredentials UserCredentials
);

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.InitLayout Method

protected override void InitLayout();

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.PerformBack Method

public void PerformBack();

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.PerformCancel Method

public void PerformCancel();

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.PerformFinish Method

public void PerformFinish();

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.PerformHelp Method

public void PerformHelp();

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.PerformNext Method

public void PerformNext();

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.RemoveAllPanels Method

public void RemoveAllPanels();

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard Events

The events of the Wizard class are listed below. For a complete list of Wizard class members, see the Wizard Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
Canceling |
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
Finishing |
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
Help |
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MovedBack |
MovedNext |
MovingBack |
MovingNext |
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.CancelEventHandler Event

public event CancelEventHandler Canceling;

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.CancelEventHandler Event

public event CancelEventHandler Finishing;

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.HelpEventHandler Event

public event HelpEventHandler Help;

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.EventHandler Event

public event EventHandler MovedBack;

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.EventHandler Event

public event EventHandler MovedNext;

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.CancelEventHandler Event

public event CancelEventHandler MovingBack;

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


Wizard.CancelEventHandler Event

public event CancelEventHandler MovingNext;

See Also

Wizard Class | Aptify.Framework.DataPacker Namespace


WizardPanel Class

For a list of all members of this type, see WizardPanel Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
Panel
WizardPanel

public class WizardPanel : Panel

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataPacker

Assembly: AptifyDataPacker (in AptifyDataPacker.dll)

See Also

WizardPanel Members | Aptify.Framework.DataPacker Namespace


WizardPanel Members

WizardPanel overview

Public Instance Constructors

WizardPanel Constructor Initializes a new instance of the WizardPanel class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Panel) |
AutoSizeMode (inherited from Panel) | Indicates the automatic sizing behavior of the control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) | This member is not meaningful for this control.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) | Returns a string representation for this control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AutoSizeChanged (inherited from Panel) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) | This member is not meaningful for this control.
KeyPress (inherited from Panel) | This member is not meaningful for this control.
KeyUp (inherited from Panel) | This member is not meaningful for this control.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MovingBack |
MovingNext |
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
ShowingFromBack |
ShowingFromNext |
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) | This member is not meaningful for this control.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Panel) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Panel) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ScrollableControl) | Adjusts the scroll bars on the container based on the current control positions and the control currently selected.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Panel) | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ScrollableControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
OnMovingBack |
OnMovingNext |
OnShowingFromBack |
OnShowingFromNext |
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


WizardPanel Constructor

Initializes a new instance of the WizardPanel class.

public WizardPanel();

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


WizardPanel Methods

The methods of the WizardPanel class are listed below. For a complete list of WizardPanel class members, see the WizardPanel Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) | Returns a string representation for this control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ScrollableControl) | Adjusts the scroll bars on the container based on the current control positions and the control currently selected.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Panel) | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ScrollableControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
OnMovingBack |
OnMovingNext |
OnShowingFromBack |
OnShowingFromNext |
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


WizardPanel.OnMovingBack Method

protected internal void OnMovingBack(
Object Sender,
CancelEventArgs e
);

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


WizardPanel.OnMovingNext Method

protected internal void OnMovingNext(
Object Sender,
CancelEventArgs e
);

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


WizardPanel.OnShowingFromBack Method

protected internal void OnShowingFromBack(
Object Sender,
EventArgs e
);

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


WizardPanel.OnShowingFromNext Method

protected internal void OnShowingFromNext(
Object Sender,
EventArgs e
);

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


WizardPanel Events

The events of the WizardPanel class are listed below. For a complete list of WizardPanel class members, see the WizardPanel Members topic.

Public Instance Events

AutoSizeChanged (inherited from Panel) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) | This member is not meaningful for this control.
KeyPress (inherited from Panel) | This member is not meaningful for this control.
KeyUp (inherited from Panel) | This member is not meaningful for this control.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
MovingBack |
MovingNext |
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
ShowingFromBack |
ShowingFromNext |
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) | This member is not meaningful for this control.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


WizardPanel.CancelEventHandler Event

public event CancelEventHandler MovingBack;

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


WizardPanel.CancelEventHandler Event

public event CancelEventHandler MovingNext;

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


WizardPanel.EventHandler Event

public event EventHandler ShowingFromBack;

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


WizardPanel.EventHandler Event

public event EventHandler ShowingFromNext;

See Also

WizardPanel Class | Aptify.Framework.DataPacker Namespace


Aptify.Framework.DataServices

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.DataServices Namespace

This namespace contains the interface definition (IAptifyDataServices) and generic implementation, AptifyGenericDataServices, for the Data Services Layer. The classes defined in AptifyGenericDataServices, which implement and use objects defined in IAptifyDataServices, are the objects that will be used by developers to access the Data Services Layer functionality. DataAction and UserCredentials are the two classes/objects that developers will typically use. The ELV uses AsyncRetrieveData to perform asynchronous data access. Note that the code within the AptifyGenericDataServices assembly does not access or modify information in the database directly. Instead, it delegates to a database-specific implementation, in this case, the AptifySQLDataServices assembly, which is in the Aptify.Framework.DataServices.SQLDataServices namespace. Developers should not reference AptifySQLDataServices; all work should be done through references to objects in the Aptify.Framework.DataServices namespace.

Namespace hierarchy

Classes

Class | Description
AptifyDataAsyncOperationInProgressException |
AptifyDataException |
AptifyDataInvalidObjectException | Thrown when the Database throws a SQL Server Exception for Invalid Object in a SQL statement.
AptifyDataLoginException | Either username or password/trusted connection is not valid.
AptifyDataNoPermissionException | Thrown when the Database throws a SQL Server Exception for lack of permissions on a database object.
AptifyDataNoServerException | Instance of the data base server was not found.
AptifyDataNoTransactionException | The system attempted to commit or roll back a transaction, but no transaction exists.
AptifyDataTimeoutException | Query has timed out.
AptifyDataUniqueKeyConstraintViolation |
AsyncRetrieveData |
CheckConstraintViolation |
Constants |
CredentialParameters |
DataAction | The DataAction class in AptifyGenericDataServices is the main Data Services Layer class that is used for all synchronous data access for applications developed with Aptify Technology Platform. The DataAction component also manages connections and data caching intrinsically. This class is not bound to a specific database engine. Hence, the Generic nomenclature. Through configuration information, the generic Data Services Layer binds to a specific database engine. The default implementation is for Microsoft SQL Server which is contained in the assembly, AptifySQLDataServices.
DataServicesConstants |
UISettings |
UserCredentials | This class contains a set of data points related to user login credentials that are used by other framework and application objects to authenticate a user.

Interfaces

Interface | Description
IAptifyAsyncRetrieveData |
IAptifyDataAction | Implementations of this interface will be responsible for all database access, including transaction management.

Delegates

Delegate | Description
IAptifyAsyncRetrieveData.DataReaderDelegate |

Enumerations

Enumeration | Description
AptifyColorScheme |
IAptifyDataAction.CacheWorkingSet |
IAptifyDataAction.DSLCacheSetting |


AptifyColorScheme Enumeration

public enum AptifyColorScheme

Members

Member Name | Description
DefaultScheme |
UseMSOfficeSetting |
Blue |
Silver |
Black |

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

Aptify.Framework.DataServices Namespace


AptifyDataAsyncOperationInProgressException Class

For a list of all members of this type, see AptifyDataAsyncOperationInProgressException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyDataException
AptifyDataAsyncOperationInProgressException

public class AptifyDataAsyncOperationInProgressException : AptifyDataException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

AptifyDataAsyncOperationInProgressException Members | Aptify.Framework.DataServices Namespace


AptifyDataAsyncOperationInProgressException Members

AptifyDataAsyncOperationInProgressException overview

Public Instance Constructors

AptifyDataAsyncOperationInProgressException Overloaded. Initializes a new instance of the AptifyDataAsyncOperationInProgressException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString (inherited from AptifyDataException) |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters (inherited from AptifyDataException) |
ParameterString (inherited from AptifyDataException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL (inherited from AptifyDataException) |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyDataException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyDataAsyncOperationInProgressException Overloaded. Initializes a new instance of the AptifyDataAsyncOperationInProgressException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataAsyncOperationInProgressException Class | Aptify.Framework.DataServices Namespace


AptifyDataAsyncOperationInProgressException Constructor

Initializes a new instance of the AptifyDataAsyncOperationInProgressException class.

Overload List

Initializes a new instance of the AptifyDataAsyncOperationInProgressException class.

public AptifyDataAsyncOperationInProgressException();

public AptifyDataAsyncOperationInProgressException(Int32,Int32);

public AptifyDataAsyncOperationInProgressException(Int32,Int32,String);

public AptifyDataAsyncOperationInProgressException(Int32,Int32,String,Exception);

public AptifyDataAsyncOperationInProgressException(Int32,Int32,String,String);

public AptifyDataAsyncOperationInProgressException(Int32,Int32,String,String,Exception);

protected AptifyDataAsyncOperationInProgressException(SerializationInfo,StreamingContext);

public AptifyDataAsyncOperationInProgressException(String);

public AptifyDataAsyncOperationInProgressException(String,String);

See Also

AptifyDataAsyncOperationInProgressException Class | Aptify.Framework.DataServices Namespace


AptifyDataAsyncOperationInProgressException Constructor ()

Initializes a new instance of the AptifyDataAsyncOperationInProgressException class.

public AptifyDataAsyncOperationInProgressException();

See Also

AptifyDataAsyncOperationInProgressException Class | Aptify.Framework.DataServices Namespace | AptifyDataAsyncOperationInProgressException Constructor Overload List


AptifyDataAsyncOperationInProgressException Constructor (String)

public AptifyDataAsyncOperationInProgressException(
String SQL
);

See Also

AptifyDataAsyncOperationInProgressException Class | Aptify.Framework.DataServices Namespace | AptifyDataAsyncOperationInProgressException Constructor Overload List


AptifyDataAsyncOperationInProgressException Constructor (String, String)

public AptifyDataAsyncOperationInProgressException(
String SQL,
String ConnectionString
);

See Also

AptifyDataAsyncOperationInProgressException Class | Aptify.Framework.DataServices Namespace | AptifyDataAsyncOperationInProgressException Constructor Overload List


AptifyDataAsyncOperationInProgressException Constructor (Int32, Int32)

public AptifyDataAsyncOperationInProgressException(
Int32 ErrorNumber,
Int32 Severity
);

See Also

AptifyDataAsyncOperationInProgressException Class | Aptify.Framework.DataServices Namespace | AptifyDataAsyncOperationInProgressException Constructor Overload List


AptifyDataAsyncOperationInProgressException Constructor (Int32, Int32, String)

public AptifyDataAsyncOperationInProgressException(
Int32 ErrorNumber,
Int32 Severity,
String SQL
);

See Also

AptifyDataAsyncOperationInProgressException Class | Aptify.Framework.DataServices Namespace | AptifyDataAsyncOperationInProgressException Constructor Overload List


AptifyDataAsyncOperationInProgressException Constructor (Int32, Int32, String, String)

public AptifyDataAsyncOperationInProgressException(
Int32 ErrorNumber,
Int32 Severity,
String SQL,
String ConnectionString
);

See Also

AptifyDataAsyncOperationInProgressException Class | Aptify.Framework.DataServices Namespace | AptifyDataAsyncOperationInProgressException Constructor Overload List


AptifyDataAsyncOperationInProgressException Constructor (Int32, Int32, String, Exception)

public AptifyDataAsyncOperationInProgressException(
Int32 ErrorNumber,
Int32 Severity,
String SQL,
Exception inner
);

See Also

AptifyDataAsyncOperationInProgressException Class | Aptify.Framework.DataServices Namespace | AptifyDataAsyncOperationInProgressException Constructor Overload List


AptifyDataAsyncOperationInProgressException Constructor (Int32, Int32, String, String, Exception)

public AptifyDataAsyncOperationInProgressException(
Int32 ErrorNumber,
Int32 Severity,
String SQL,
String ConnectionString,
Exception inner
);

See Also

AptifyDataAsyncOperationInProgressException Class | Aptify.Framework.DataServices Namespace | AptifyDataAsyncOperationInProgressException Constructor Overload List


AptifyDataAsyncOperationInProgressException Constructor (SerializationInfo, StreamingContext)

protected AptifyDataAsyncOperationInProgressException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyDataAsyncOperationInProgressException Class | Aptify.Framework.DataServices Namespace | AptifyDataAsyncOperationInProgressException Constructor Overload List


AptifyDataException Class

For a list of all members of this type, see AptifyDataException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyDataException
Derived types

public class AptifyDataException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

AptifyDataException Members | Aptify.Framework.DataServices Namespace


AptifyDataException Members

AptifyDataException overview

Public Instance Constructors

AptifyDataException Overloaded. Initializes a new instance of the AptifyDataException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters |
ParameterString |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyDataException Overloaded. Initializes a new instance of the AptifyDataException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace


AptifyDataException Constructor

Overload List

public AptifyDataException(Int32,Int32,String);

public AptifyDataException(Int32,Int32,String,String);

public AptifyDataException(Int32,Int32,String,String,IDataParameter[]);

public AptifyDataException(Int32,Int32,String,String,IDataParameter[],Exception);

public AptifyDataException(Int32,Int32,String,String,IDataParameter[],String);

public AptifyDataException(Int32,Int32,String,String,IDataParameter[],String,Exception);

public AptifyDataException(Int32,Int32,String,String,Exception);

public AptifyDataException(Int32,Int32,String,String,String);

public AptifyDataException(Int32,Int32,String,String,String,Exception);

protected AptifyDataException(SerializationInfo,StreamingContext);

public AptifyDataException(String);

public AptifyDataException(String,String);

public AptifyDataException(String,String,IDataParameter[]);

public AptifyDataException(String,String,IDataParameter[],String);

public AptifyDataException(String,String,String);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace


AptifyDataException Constructor (String)

public AptifyDataException(
String Message
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (String, String)

public AptifyDataException(
String Message,
String SQL
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (String, String, IDataParameter[])

public AptifyDataException(
String Message,
String SQL,
IDataParameter[] Parameters
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (String, String, String)

public AptifyDataException(
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (String, String, IDataParameter[], String)

public AptifyDataException(
String Message,
String SQL,
IDataParameter[] Parameters,
String ConnectionString
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (Int32, Int32, String)

public AptifyDataException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (Int32, Int32, String, String)

public AptifyDataException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (Int32, Int32, String, String, IDataParameter[])

public AptifyDataException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
IDataParameter[] Parameters
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (Int32, Int32, String, String, String)

public AptifyDataException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (Int32, Int32, String, String, IDataParameter[], String)

public AptifyDataException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
IDataParameter[] Parameters,
String ConnectionString
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (Int32, Int32, String, String, Exception)

public AptifyDataException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
Exception inner
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (Int32, Int32, String, String, IDataParameter[], Exception)

public AptifyDataException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
IDataParameter[] Parameters,
Exception inner
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (Int32, Int32, String, String, String, Exception)

public AptifyDataException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString,
Exception inner
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (Int32, Int32, String, String, IDataParameter[], String, Exception)

public AptifyDataException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
IDataParameter[] Parameters,
String ConnectionString,
Exception inner
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Constructor (SerializationInfo, StreamingContext)

protected AptifyDataException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace | AptifyDataException Constructor Overload List


AptifyDataException Properties

The properties of the AptifyDataException class are listed below. For a complete list of AptifyDataException class members, see the AptifyDataException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters |
ParameterString |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace


ConnectionString Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataException.ConnectionString Property

public String ConnectionString {get;}

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace


Parameters Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataException.Parameters Property

public IDataParameter[] Parameters {get;}

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace


ParameterString Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataException.ParameterString Property

public String ParameterString {get;}

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace


SQL Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataException.SQL Property

public String SQL {get;}

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace


AptifyDataException Methods

The methods of the AptifyDataException class are listed below. For a complete list of AptifyDataException class members, see the AptifyDataException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace


AptifyDataException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyDataException Class | Aptify.Framework.DataServices Namespace


AptifyDataInvalidObjectException Class

Thrown when the Database throws a SQL Server Exception for Invalid Object in a SQL statement.

For a list of all members of this type, see AptifyDataInvalidObjectException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyDataException
AptifyDataInvalidObjectException

public class AptifyDataInvalidObjectException : AptifyDataException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Occurs for any object that is not found in the database (e.g., tables, stored procedures, views, function, etc.).

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

AptifyDataInvalidObjectException Members | Aptify.Framework.DataServices Namespace


AptifyDataInvalidObjectException Members

AptifyDataInvalidObjectException overview

Public Instance Constructors

AptifyDataInvalidObjectException Overloaded. Initializes a new instance of the AptifyDataInvalidObjectException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString (inherited from AptifyDataException) |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters (inherited from AptifyDataException) |
ParameterString (inherited from AptifyDataException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL (inherited from AptifyDataException) |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyDataException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyDataInvalidObjectException Overloaded. Initializes a new instance of the AptifyDataInvalidObjectException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataInvalidObjectException Class | Aptify.Framework.DataServices Namespace


AptifyDataInvalidObjectException Constructor

Overload List

public AptifyDataInvalidObjectException(Int32,Int32,String);

public AptifyDataInvalidObjectException(Int32,Int32,String,String);

public AptifyDataInvalidObjectException(Int32,Int32,String,String,Exception);

public AptifyDataInvalidObjectException(Int32,Int32,String,String,String);

public AptifyDataInvalidObjectException(Int32,Int32,String,String,String,Exception);

protected AptifyDataInvalidObjectException(SerializationInfo,StreamingContext);

public AptifyDataInvalidObjectException(String);

public AptifyDataInvalidObjectException(String,String);

public AptifyDataInvalidObjectException(String,String,String);

See Also

AptifyDataInvalidObjectException Class | Aptify.Framework.DataServices Namespace


AptifyDataInvalidObjectException Constructor (String)

public AptifyDataInvalidObjectException(
String Message
);

See Also

AptifyDataInvalidObjectException Class | Aptify.Framework.DataServices Namespace | AptifyDataInvalidObjectException Constructor Overload List


AptifyDataInvalidObjectException Constructor (String, String)

public AptifyDataInvalidObjectException(
String Message,
String SQL
);

See Also

AptifyDataInvalidObjectException Class | Aptify.Framework.DataServices Namespace | AptifyDataInvalidObjectException Constructor Overload List


AptifyDataInvalidObjectException Constructor (String, String, String)

public AptifyDataInvalidObjectException(
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataInvalidObjectException Class | Aptify.Framework.DataServices Namespace | AptifyDataInvalidObjectException Constructor Overload List


AptifyDataInvalidObjectException Constructor (Int32, Int32, String)

public AptifyDataInvalidObjectException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AptifyDataInvalidObjectException Class | Aptify.Framework.DataServices Namespace | AptifyDataInvalidObjectException Constructor Overload List


AptifyDataInvalidObjectException Constructor (Int32, Int32, String, String)

public AptifyDataInvalidObjectException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL
);

See Also

AptifyDataInvalidObjectException Class | Aptify.Framework.DataServices Namespace | AptifyDataInvalidObjectException Constructor Overload List


AptifyDataInvalidObjectException Constructor (Int32, Int32, String, String, String)

public AptifyDataInvalidObjectException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataInvalidObjectException Class | Aptify.Framework.DataServices Namespace | AptifyDataInvalidObjectException Constructor Overload List


AptifyDataInvalidObjectException Constructor (Int32, Int32, String, String, Exception)

public AptifyDataInvalidObjectException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
Exception inner
);

See Also

AptifyDataInvalidObjectException Class | Aptify.Framework.DataServices Namespace | AptifyDataInvalidObjectException Constructor Overload List


AptifyDataInvalidObjectException Constructor (Int32, Int32, String, String, String, Exception)

public AptifyDataInvalidObjectException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString,
Exception inner
);

See Also

AptifyDataInvalidObjectException Class | Aptify.Framework.DataServices Namespace | AptifyDataInvalidObjectException Constructor Overload List


AptifyDataInvalidObjectException Constructor (SerializationInfo, StreamingContext)

protected AptifyDataInvalidObjectException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyDataInvalidObjectException Class | Aptify.Framework.DataServices Namespace | AptifyDataInvalidObjectException Constructor Overload List


AptifyDataLoginException Class

Either username or password/trusted connection is not valid.

For a list of all members of this type, see AptifyDataLoginException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyDataException
AptifyDataLoginException

public class AptifyDataLoginException : AptifyDataException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Thrown when the Server exists but the user doesn't have permission to login or the wrong credentials (User Name and/or Password) were supplied.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

AptifyDataLoginException Members | Aptify.Framework.DataServices Namespace


AptifyDataLoginException Members

AptifyDataLoginException overview

Public Instance Constructors

AptifyDataLoginException Overloaded. Initializes a new instance of the AptifyDataLoginException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString (inherited from AptifyDataException) |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters (inherited from AptifyDataException) |
ParameterString (inherited from AptifyDataException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL (inherited from AptifyDataException) |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyDataException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyDataLoginException Overloaded. Initializes a new instance of the AptifyDataLoginException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataLoginException Class | Aptify.Framework.DataServices Namespace


AptifyDataLoginException Constructor

Overload List

public AptifyDataLoginException(Int32,Int32,String);

public AptifyDataLoginException(Int32,Int32,String,String);

public AptifyDataLoginException(Int32,Int32,String,String,Exception);

public AptifyDataLoginException(Int32,Int32,String,String,String);

public AptifyDataLoginException(Int32,Int32,String,String,String,Exception);

protected AptifyDataLoginException(SerializationInfo,StreamingContext);

public AptifyDataLoginException(String);

public AptifyDataLoginException(String,String);

public AptifyDataLoginException(String,String,String);

See Also

AptifyDataLoginException Class | Aptify.Framework.DataServices Namespace


AptifyDataLoginException Constructor (String)

public AptifyDataLoginException(
String Message
);

See Also

AptifyDataLoginException Class | Aptify.Framework.DataServices Namespace | AptifyDataLoginException Constructor Overload List


AptifyDataLoginException Constructor (String, String)

public AptifyDataLoginException(
String Message,
String SQL
);

See Also

AptifyDataLoginException Class | Aptify.Framework.DataServices Namespace | AptifyDataLoginException Constructor Overload List


AptifyDataLoginException Constructor (String, String, String)

public AptifyDataLoginException(
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataLoginException Class | Aptify.Framework.DataServices Namespace | AptifyDataLoginException Constructor Overload List


AptifyDataLoginException Constructor (Int32, Int32, String)

public AptifyDataLoginException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AptifyDataLoginException Class | Aptify.Framework.DataServices Namespace | AptifyDataLoginException Constructor Overload List


AptifyDataLoginException Constructor (Int32, Int32, String, String)

public AptifyDataLoginException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL
);

See Also

AptifyDataLoginException Class | Aptify.Framework.DataServices Namespace | AptifyDataLoginException Constructor Overload List


AptifyDataLoginException Constructor (Int32, Int32, String, String, String)

public AptifyDataLoginException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataLoginException Class | Aptify.Framework.DataServices Namespace | AptifyDataLoginException Constructor Overload List


AptifyDataLoginException Constructor (Int32, Int32, String, String, Exception)

public AptifyDataLoginException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
Exception inner
);

See Also

AptifyDataLoginException Class | Aptify.Framework.DataServices Namespace | AptifyDataLoginException Constructor Overload List


AptifyDataLoginException Constructor (Int32, Int32, String, String, String, Exception)

public AptifyDataLoginException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString,
Exception inner
);

See Also

AptifyDataLoginException Class | Aptify.Framework.DataServices Namespace | AptifyDataLoginException Constructor Overload List


AptifyDataLoginException Constructor (SerializationInfo, StreamingContext)

protected AptifyDataLoginException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyDataLoginException Class | Aptify.Framework.DataServices Namespace | AptifyDataLoginException Constructor Overload List


AptifyDataNoPermissionException Class

Thrown when the Database throws a SQL Server Exception for lack of permissions on a database object.

For a list of all members of this type, see AptifyDataNoPermissionException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyDataException
AptifyDataNoPermissionException

public class AptifyDataNoPermissionException : AptifyDataException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

User does not have permission at the database level to perform this operation.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

AptifyDataNoPermissionException Members | Aptify.Framework.DataServices Namespace


AptifyDataNoPermissionException Members

AptifyDataNoPermissionException overview

Public Instance Constructors

AptifyDataNoPermissionException Overloaded. Initializes a new instance of the AptifyDataNoPermissionException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString (inherited from AptifyDataException) |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters (inherited from AptifyDataException) |
ParameterString (inherited from AptifyDataException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL (inherited from AptifyDataException) |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyDataException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyDataNoPermissionException Overloaded. Initializes a new instance of the AptifyDataNoPermissionException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataNoPermissionException Class | Aptify.Framework.DataServices Namespace


AptifyDataNoPermissionException Constructor

Overload List

public AptifyDataNoPermissionException(Int32,Int32,String);

public AptifyDataNoPermissionException(Int32,Int32,String,String);

public AptifyDataNoPermissionException(Int32,Int32,String,String,Exception);

public AptifyDataNoPermissionException(Int32,Int32,String,String,String);

public AptifyDataNoPermissionException(Int32,Int32,String,String,String,Exception);

protected AptifyDataNoPermissionException(SerializationInfo,StreamingContext);

public AptifyDataNoPermissionException(String);

public AptifyDataNoPermissionException(String,String);

public AptifyDataNoPermissionException(String,String,String);

See Also

AptifyDataNoPermissionException Class | Aptify.Framework.DataServices Namespace


AptifyDataNoPermissionException Constructor (String)

public AptifyDataNoPermissionException(
String Message
);

See Also

AptifyDataNoPermissionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoPermissionException Constructor Overload List


AptifyDataNoPermissionException Constructor (String, String)

public AptifyDataNoPermissionException(
String Message,
String SQL
);

See Also

AptifyDataNoPermissionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoPermissionException Constructor Overload List


AptifyDataNoPermissionException Constructor (String, String, String)

public AptifyDataNoPermissionException(
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataNoPermissionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoPermissionException Constructor Overload List


AptifyDataNoPermissionException Constructor (Int32, Int32, String)

public AptifyDataNoPermissionException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AptifyDataNoPermissionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoPermissionException Constructor Overload List


AptifyDataNoPermissionException Constructor (Int32, Int32, String, String)

public AptifyDataNoPermissionException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL
);

See Also

AptifyDataNoPermissionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoPermissionException Constructor Overload List


AptifyDataNoPermissionException Constructor (Int32, Int32, String, String, String)

public AptifyDataNoPermissionException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataNoPermissionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoPermissionException Constructor Overload List


AptifyDataNoPermissionException Constructor (Int32, Int32, String, String, Exception)

public AptifyDataNoPermissionException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
Exception inner
);

See Also

AptifyDataNoPermissionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoPermissionException Constructor Overload List


AptifyDataNoPermissionException Constructor (Int32, Int32, String, String, String, Exception)

public AptifyDataNoPermissionException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString,
Exception inner
);

See Also

AptifyDataNoPermissionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoPermissionException Constructor Overload List


AptifyDataNoPermissionException Constructor (SerializationInfo, StreamingContext)

protected AptifyDataNoPermissionException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyDataNoPermissionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoPermissionException Constructor Overload List


AptifyDataNoServerException Class

Instance of the data base server was not found.

For a list of all members of this type, see AptifyDataNoServerException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyDataException
AptifyDataNoServerException

public class AptifyDataNoServerException : AptifyDataException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Thrown when the Database Server doesn't exist or access is denied

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

AptifyDataNoServerException Members | Aptify.Framework.DataServices Namespace


AptifyDataNoServerException Members

AptifyDataNoServerException overview

Public Instance Constructors

AptifyDataNoServerException Overloaded. Initializes a new instance of the AptifyDataNoServerException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString (inherited from AptifyDataException) |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters (inherited from AptifyDataException) |
ParameterString (inherited from AptifyDataException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL (inherited from AptifyDataException) |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyDataException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyDataNoServerException Overloaded. Initializes a new instance of the AptifyDataNoServerException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataNoServerException Class | Aptify.Framework.DataServices Namespace


AptifyDataNoServerException Constructor

Overload List

public AptifyDataNoServerException(Int32,Int32,String);

public AptifyDataNoServerException(Int32,Int32,String,String);

public AptifyDataNoServerException(Int32,Int32,String,String,Exception);

public AptifyDataNoServerException(Int32,Int32,String,String,String);

public AptifyDataNoServerException(Int32,Int32,String,String,String,Exception);

protected AptifyDataNoServerException(SerializationInfo,StreamingContext);

public AptifyDataNoServerException(String);

public AptifyDataNoServerException(String,String);

public AptifyDataNoServerException(String,String,String);

See Also

AptifyDataNoServerException Class | Aptify.Framework.DataServices Namespace


AptifyDataNoServerException Constructor (String)

public AptifyDataNoServerException(
String Message
);

See Also

AptifyDataNoServerException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoServerException Constructor Overload List


AptifyDataNoServerException Constructor (String, String)

public AptifyDataNoServerException(
String Message,
String SQL
);

See Also

AptifyDataNoServerException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoServerException Constructor Overload List


AptifyDataNoServerException Constructor (String, String, String)

public AptifyDataNoServerException(
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataNoServerException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoServerException Constructor Overload List


AptifyDataNoServerException Constructor (Int32, Int32, String)

public AptifyDataNoServerException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AptifyDataNoServerException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoServerException Constructor Overload List


AptifyDataNoServerException Constructor (Int32, Int32, String, String)

public AptifyDataNoServerException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL
);

See Also

AptifyDataNoServerException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoServerException Constructor Overload List


AptifyDataNoServerException Constructor (Int32, Int32, String, String, String)

public AptifyDataNoServerException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataNoServerException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoServerException Constructor Overload List


AptifyDataNoServerException Constructor (Int32, Int32, String, String, Exception)

public AptifyDataNoServerException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
Exception inner
);

See Also

AptifyDataNoServerException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoServerException Constructor Overload List


AptifyDataNoServerException Constructor (Int32, Int32, String, String, String, Exception)

public AptifyDataNoServerException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString,
Exception inner
);

See Also

AptifyDataNoServerException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoServerException Constructor Overload List


AptifyDataNoServerException Constructor (SerializationInfo, StreamingContext)

protected AptifyDataNoServerException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyDataNoServerException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoServerException Constructor Overload List


AptifyDataNoTransactionException Class

The system attempted to commit or roll back a transaction, but no transaction exists.

For a list of all members of this type, see AptifyDataNoTransactionException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyDataException
AptifyDataNoTransactionException

public class AptifyDataNoTransactionException : AptifyDataException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

AptifyDataNoTransactionException Members | Aptify.Framework.DataServices Namespace


AptifyDataNoTransactionException Members

AptifyDataNoTransactionException overview

Public Instance Constructors

AptifyDataNoTransactionException Overloaded. Initializes a new instance of the AptifyDataNoTransactionException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString (inherited from AptifyDataException) |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters (inherited from AptifyDataException) |
ParameterString (inherited from AptifyDataException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL (inherited from AptifyDataException) |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
TransactionID |
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyDataNoTransactionException Overloaded. Initializes a new instance of the AptifyDataNoTransactionException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataNoTransactionException Class | Aptify.Framework.DataServices Namespace


AptifyDataNoTransactionException Constructor

Overload List

protected AptifyDataNoTransactionException(SerializationInfo,StreamingContext);

public AptifyDataNoTransactionException(String,String);

public AptifyDataNoTransactionException(String,String,String);

See Also

AptifyDataNoTransactionException Class | Aptify.Framework.DataServices Namespace


AptifyDataNoTransactionException Constructor (String, String)

public AptifyDataNoTransactionException(
String Message,
String TransactionID
);

See Also

AptifyDataNoTransactionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoTransactionException Constructor Overload List


AptifyDataNoTransactionException Constructor (String, String, String)

public AptifyDataNoTransactionException(
String Message,
String TransactionID,
String ConnectionString
);

See Also

AptifyDataNoTransactionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoTransactionException Constructor Overload List


AptifyDataNoTransactionException Constructor (SerializationInfo, StreamingContext)

protected AptifyDataNoTransactionException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyDataNoTransactionException Class | Aptify.Framework.DataServices Namespace | AptifyDataNoTransactionException Constructor Overload List


AptifyDataNoTransactionException Properties

The properties of the AptifyDataNoTransactionException class are listed below. For a complete list of AptifyDataNoTransactionException class members, see the AptifyDataNoTransactionException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString (inherited from AptifyDataException) |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters (inherited from AptifyDataException) |
ParameterString (inherited from AptifyDataException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL (inherited from AptifyDataException) |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
TransactionID |
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AptifyDataNoTransactionException Class | Aptify.Framework.DataServices Namespace


TransactionID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataNoTransactionException.TransactionID Property

public String TransactionID {get;}

See Also

AptifyDataNoTransactionException Class | Aptify.Framework.DataServices Namespace


AptifyDataNoTransactionException Methods

The methods of the AptifyDataNoTransactionException class are listed below. For a complete list of AptifyDataNoTransactionException class members, see the AptifyDataNoTransactionException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataNoTransactionException Class | Aptify.Framework.DataServices Namespace


AptifyDataNoTransactionException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyDataNoTransactionException Class | Aptify.Framework.DataServices Namespace


AptifyDataTimeoutException Class

Query has timed out.

For a list of all members of this type, see AptifyDataTimeoutException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyDataException
AptifyDataTimeoutException

public class AptifyDataTimeoutException : AptifyDataException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This exception inherits from AptifyDataException. Many methods need to use this exception as:

  • The outer exception from a database call.
  • The root cause of an exception as an inner exception.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

AptifyDataTimeoutException Members | Aptify.Framework.DataServices Namespace


AptifyDataTimeoutException Members

AptifyDataTimeoutException overview

Public Instance Constructors

AptifyDataTimeoutException Overloaded. Initializes a new instance of the AptifyDataTimeoutException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString (inherited from AptifyDataException) |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters (inherited from AptifyDataException) |
ParameterString (inherited from AptifyDataException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL (inherited from AptifyDataException) |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyDataException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyDataTimeoutException Overloaded. Initializes a new instance of the AptifyDataTimeoutException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataTimeoutException Class | Aptify.Framework.DataServices Namespace


AptifyDataTimeoutException Constructor

Overload List

public AptifyDataTimeoutException(Int32,Int32,String);

public AptifyDataTimeoutException(Int32,Int32,String,String);

public AptifyDataTimeoutException(Int32,Int32,String,String,Exception);

public AptifyDataTimeoutException(Int32,Int32,String,String,String);

public AptifyDataTimeoutException(Int32,Int32,String,String,String,Exception);

protected AptifyDataTimeoutException(SerializationInfo,StreamingContext);

public AptifyDataTimeoutException(String);

public AptifyDataTimeoutException(String,String);

public AptifyDataTimeoutException(String,String,String);

See Also

AptifyDataTimeoutException Class | Aptify.Framework.DataServices Namespace


AptifyDataTimeoutException Constructor (String)

public AptifyDataTimeoutException(
String Message
);

See Also

AptifyDataTimeoutException Class | Aptify.Framework.DataServices Namespace | AptifyDataTimeoutException Constructor Overload List


AptifyDataTimeoutException Constructor (String, String)

public AptifyDataTimeoutException(
String Message,
String SQL
);

See Also

AptifyDataTimeoutException Class | Aptify.Framework.DataServices Namespace | AptifyDataTimeoutException Constructor Overload List


AptifyDataTimeoutException Constructor (String, String, String)

public AptifyDataTimeoutException(
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataTimeoutException Class | Aptify.Framework.DataServices Namespace | AptifyDataTimeoutException Constructor Overload List


AptifyDataTimeoutException Constructor (Int32, Int32, String)

public AptifyDataTimeoutException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AptifyDataTimeoutException Class | Aptify.Framework.DataServices Namespace | AptifyDataTimeoutException Constructor Overload List


AptifyDataTimeoutException Constructor (Int32, Int32, String, String)

public AptifyDataTimeoutException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL
);

See Also

AptifyDataTimeoutException Class | Aptify.Framework.DataServices Namespace | AptifyDataTimeoutException Constructor Overload List


AptifyDataTimeoutException Constructor (Int32, Int32, String, String, String)

public AptifyDataTimeoutException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataTimeoutException Class | Aptify.Framework.DataServices Namespace | AptifyDataTimeoutException Constructor Overload List


AptifyDataTimeoutException Constructor (Int32, Int32, String, String, Exception)

public AptifyDataTimeoutException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
Exception inner
);

See Also

AptifyDataTimeoutException Class | Aptify.Framework.DataServices Namespace | AptifyDataTimeoutException Constructor Overload List


AptifyDataTimeoutException Constructor (Int32, Int32, String, String, String, Exception)

public AptifyDataTimeoutException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString,
Exception inner
);

See Also

AptifyDataTimeoutException Class | Aptify.Framework.DataServices Namespace | AptifyDataTimeoutException Constructor Overload List


AptifyDataTimeoutException Constructor (SerializationInfo, StreamingContext)

protected AptifyDataTimeoutException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyDataTimeoutException Class | Aptify.Framework.DataServices Namespace | AptifyDataTimeoutException Constructor Overload List


AptifyDataUniqueKeyConstraintViolation Class

For a list of all members of this type, see AptifyDataUniqueKeyConstraintViolation Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyDataException
AptifyDataUniqueKeyConstraintViolation

public class AptifyDataUniqueKeyConstraintViolation : AptifyDataException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

AptifyDataUniqueKeyConstraintViolation Members | Aptify.Framework.DataServices Namespace


AptifyDataUniqueKeyConstraintViolation Members

AptifyDataUniqueKeyConstraintViolation overview

Public Instance Constructors

AptifyDataUniqueKeyConstraintViolation Overloaded. Initializes a new instance of the AptifyDataUniqueKeyConstraintViolation class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString (inherited from AptifyDataException) |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters (inherited from AptifyDataException) |
ParameterString (inherited from AptifyDataException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL (inherited from AptifyDataException) |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyDataException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyDataUniqueKeyConstraintViolation Overloaded. Initializes a new instance of the AptifyDataUniqueKeyConstraintViolation class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataUniqueKeyConstraintViolation Class | Aptify.Framework.DataServices Namespace


AptifyDataUniqueKeyConstraintViolation Constructor

Overload List

public AptifyDataUniqueKeyConstraintViolation(Int32,Int32,String);

public AptifyDataUniqueKeyConstraintViolation(Int32,Int32,String,String);

public AptifyDataUniqueKeyConstraintViolation(Int32,Int32,String,String,Exception);

public AptifyDataUniqueKeyConstraintViolation(Int32,Int32,String,String,String);

public AptifyDataUniqueKeyConstraintViolation(Int32,Int32,String,String,String,Exception);

protected AptifyDataUniqueKeyConstraintViolation(SerializationInfo,StreamingContext);

public AptifyDataUniqueKeyConstraintViolation(String);

public AptifyDataUniqueKeyConstraintViolation(String,String);

public AptifyDataUniqueKeyConstraintViolation(String,String,String);

See Also

AptifyDataUniqueKeyConstraintViolation Class | Aptify.Framework.DataServices Namespace


AptifyDataUniqueKeyConstraintViolation Constructor (String)

public AptifyDataUniqueKeyConstraintViolation(
String Message
);

See Also

AptifyDataUniqueKeyConstraintViolation Class | Aptify.Framework.DataServices Namespace | AptifyDataUniqueKeyConstraintViolation Constructor Overload List


AptifyDataUniqueKeyConstraintViolation Constructor (String, String)

public AptifyDataUniqueKeyConstraintViolation(
String Message,
String SQL
);

See Also

AptifyDataUniqueKeyConstraintViolation Class | Aptify.Framework.DataServices Namespace | AptifyDataUniqueKeyConstraintViolation Constructor Overload List


AptifyDataUniqueKeyConstraintViolation Constructor (String, String, String)

public AptifyDataUniqueKeyConstraintViolation(
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataUniqueKeyConstraintViolation Class | Aptify.Framework.DataServices Namespace | AptifyDataUniqueKeyConstraintViolation Constructor Overload List


AptifyDataUniqueKeyConstraintViolation Constructor (Int32, Int32, String)

public AptifyDataUniqueKeyConstraintViolation(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AptifyDataUniqueKeyConstraintViolation Class | Aptify.Framework.DataServices Namespace | AptifyDataUniqueKeyConstraintViolation Constructor Overload List


AptifyDataUniqueKeyConstraintViolation Constructor (Int32, Int32, String, String)

public AptifyDataUniqueKeyConstraintViolation(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL
);

See Also

AptifyDataUniqueKeyConstraintViolation Class | Aptify.Framework.DataServices Namespace | AptifyDataUniqueKeyConstraintViolation Constructor Overload List


AptifyDataUniqueKeyConstraintViolation Constructor (Int32, Int32, String, String, String)

public AptifyDataUniqueKeyConstraintViolation(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString
);

See Also

AptifyDataUniqueKeyConstraintViolation Class | Aptify.Framework.DataServices Namespace | AptifyDataUniqueKeyConstraintViolation Constructor Overload List


AptifyDataUniqueKeyConstraintViolation Constructor (Int32, Int32, String, String, Exception)

public AptifyDataUniqueKeyConstraintViolation(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
Exception inner
);

See Also

AptifyDataUniqueKeyConstraintViolation Class | Aptify.Framework.DataServices Namespace | AptifyDataUniqueKeyConstraintViolation Constructor Overload List


AptifyDataUniqueKeyConstraintViolation Constructor (Int32, Int32, String, String, String, Exception)

public AptifyDataUniqueKeyConstraintViolation(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString,
Exception inner
);

See Also

AptifyDataUniqueKeyConstraintViolation Class | Aptify.Framework.DataServices Namespace | AptifyDataUniqueKeyConstraintViolation Constructor Overload List


AptifyDataUniqueKeyConstraintViolation Constructor (SerializationInfo, StreamingContext)

protected AptifyDataUniqueKeyConstraintViolation(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyDataUniqueKeyConstraintViolation Class | Aptify.Framework.DataServices Namespace | AptifyDataUniqueKeyConstraintViolation Constructor Overload List


AsyncRetrieveData Class

For a list of all members of this type, see AsyncRetrieveData Members.

System.Object
AsyncRetrieveData

public class AsyncRetrieveData : IAptifyAsyncRetrieveData, ISupportsAttributes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: AptifyGenericDataServices (in AptifyGenericDataServices.dll)

See Also

AsyncRetrieveData Members | Aptify.Framework.DataServices Namespace


AsyncRetrieveData Members

AsyncRetrieveData overview

Public Instance Constructors

AsyncRetrieveData Overloaded. Initializes a new instance of the AsyncRetrieveData class.

Public Instance Properties

ConnectionString
DataReader
InProcess
LastError
StillExecuting
UserCredentials

Public Instance Methods

BeginGetDataReader | Overloaded.
CancelGetDataReader |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttribute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


AsyncRetrieveData Constructor

Initializes a new instance of the AsyncRetrieveData class.

Overload List

Initializes a new instance of the AsyncRetrieveData class.

public AsyncRetrieveData();

public AsyncRetrieveData(UserCredentials);

public AsyncRetrieveData(UserCredentials,String);

public AsyncRetrieveData(UserCredentials,String,Boolean);

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


AsyncRetrieveData Constructor ()

Initializes a new instance of the AsyncRetrieveData class.

public AsyncRetrieveData();

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace | AsyncRetrieveData Constructor Overload List


AsyncRetrieveData Constructor (UserCredentials)

public AsyncRetrieveData(
UserCredentials UserCredentials
);

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace | AsyncRetrieveData Constructor Overload List


AsyncRetrieveData Constructor (UserCredentials, String)

public AsyncRetrieveData(
UserCredentials UserCredentials,
String ConnectionString
);

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace | AsyncRetrieveData Constructor Overload List


AsyncRetrieveData Constructor (UserCredentials, String, Boolean)

public AsyncRetrieveData(
UserCredentials UserCredentials,
String ConnectionString,
Boolean SetAsDefault
);

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace | AsyncRetrieveData Constructor Overload List


AsyncRetrieveData Properties

The properties of the AsyncRetrieveData class are listed below. For a complete list of AsyncRetrieveData class members, see the AsyncRetrieveData Members topic.

Public Instance Properties

ConnectionString
DataReader
InProcess
LastError
StillExecuting
UserCredentials

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


ConnectionString Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.ConnectionString Property

public String ConnectionString {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


DataReader Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.DataReader Property

public IDataReader DataReader {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


InProcess Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.InProcess Property

public Boolean InProcess {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


LastError Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.LastError Property

public String LastError {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


StillExecuting Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.StillExecuting Property

public Boolean StillExecuting {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.UserCredentials Property

public UserCredentials UserCredentials {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


AsyncRetrieveData Methods

The methods of the AsyncRetrieveData class are listed below. For a complete list of AsyncRetrieveData class members, see the AsyncRetrieveData Members topic.

Public Instance Methods

BeginGetDataReader | Overloaded.
CancelGetDataReader |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttribute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


BeginGetDataReader Method

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.BeginGetDataReader Method

Overload List

public void BeginGetDataReader(String);

public void BeginGetDataReader(String,CommandBehavior);

public void BeginGetDataReader(String,CommandBehavior,IAptifyAsyncRetrieveData.DataReaderDelegate);

public void BeginGetDataReader(String,CommandBehavior,Int32);

public void BeginGetDataReader(String,CommandBehavior,Int32,IAptifyAsyncRetrieveData.DataReaderDelegate);

public void BeginGetDataReader(String,Int32);

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


AsyncRetrieveData.BeginGetDataReader Method (String)

public void BeginGetDataReader(
String SQL
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior)

public void BeginGetDataReader(
String SQL,
CommandBehavior CommandBehavior
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior, DataReaderDelegate)

public void BeginGetDataReader(
String SQL,
CommandBehavior CommandBehavior,
IAptifyAsyncRetrieveData.DataReaderDelegate drDelegate
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior, Int32)

public void BeginGetDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior, Int32, DataReaderDelegate)

public void BeginGetDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout,
IAptifyAsyncRetrieveData.DataReaderDelegate drDelegate
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.BeginGetDataReader Method (String, Int32)

public void BeginGetDataReader(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.CancelGetDataReader Method

public void CancelGetDataReader();

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


AsyncRetrieveData.GetAttribute Method

public Attribute GetAttribute(
String Name
);

Implements

ISupportsAttributes.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


AsyncRetrieveData.Initialize Method

public void Initialize(
UserCredentials UserCredentials,
String ConnectionString,
Boolean SetAsDefault
);

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices Namespace


CheckConstraintViolation Class

For a list of all members of this type, see CheckConstraintViolation Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyDataException
CheckConstraintViolation

public class CheckConstraintViolation : AptifyDataException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

CheckConstraintViolation Members | Aptify.Framework.DataServices Namespace


CheckConstraintViolation Members

CheckConstraintViolation overview

Public Instance Constructors

CheckConstraintViolation Overloaded. Initializes a new instance of the CheckConstraintViolation class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ConnectionString (inherited from AptifyDataException) |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Parameters (inherited from AptifyDataException) |
ParameterString (inherited from AptifyDataException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL (inherited from AptifyDataException) |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyDataException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckConstraintViolation Class | Aptify.Framework.DataServices Namespace


CheckConstraintViolation Constructor

Overload List

public CheckConstraintViolation(Int32,Int32,String,String,String,Exception);

public CheckConstraintViolation(String);

See Also

CheckConstraintViolation Class | Aptify.Framework.DataServices Namespace


CheckConstraintViolation Constructor (String)

public CheckConstraintViolation(
String Message
);

See Also

CheckConstraintViolation Class | Aptify.Framework.DataServices Namespace | CheckConstraintViolation Constructor Overload List


CheckConstraintViolation Constructor (Int32, Int32, String, String, String, Exception)

public CheckConstraintViolation(
Int32 ErrorNumber,
Int32 Severity,
String Message,
String SQL,
String ConnectionString,
Exception inner
);

See Also

CheckConstraintViolation Class | Aptify.Framework.DataServices Namespace | CheckConstraintViolation Constructor Overload List


Constants Class

For a list of all members of this type, see Constants Members.

System.Object
Constants

public class Constants : ISupportsAttributes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: AptifyGenericDataServices (in AptifyGenericDataServices.dll)

See Also

Constants Members | Aptify.Framework.DataServices Namespace


Constants Members

Constants overview

Public Static Fields

ASYNC_RETRIEVE_ASSEMBLY
ASYNC_RETRIEVE_TYPE
DATA_ACTION_ASSEMBLY
DATA_ACTION_TYPE
INFO_NOT_PROVIDED_FOR_ASYNC_RETRIEVE_DATA_INITIALIZATION
INFO_NOT_PROVIDED_FOR_DATA_ACTION_INITIALIZATION
QUERY_TIME_OUT

Public Static Properties

QueryTimeOut

Public Instance Constructors

Constants Constructor Initializes a new instance of the Constants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttribute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants Constructor

Initializes a new instance of the Constants class.

public Constants();

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants Fields

The fields of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Fields

ASYNC_RETRIEVE_ASSEMBLY
ASYNC_RETRIEVE_TYPE
DATA_ACTION_ASSEMBLY
DATA_ACTION_TYPE
INFO_NOT_PROVIDED_FOR_ASYNC_RETRIEVE_DATA_INITIALIZATION
INFO_NOT_PROVIDED_FOR_DATA_ACTION_INITIALIZATION
QUERY_TIME_OUT

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants.ASYNC_RETRIEVE_ASSEMBLY Field

public const ASYNC_RETRIEVE_ASSEMBLY ASYNC_RETRIEVE_ASSEMBLY = "AsyncRetrieveAssembly";

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants.ASYNC_RETRIEVE_TYPE Field

public const ASYNC_RETRIEVE_TYPE ASYNC_RETRIEVE_TYPE = "AsyncRetrieveType";

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants.DATA_ACTION_ASSEMBLY Field

public const DATA_ACTION_ASSEMBLY DATA_ACTION_ASSEMBLY = "DataActionAssembly";

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants.DATA_ACTION_TYPE Field

public const DATA_ACTION_TYPE DATA_ACTION_TYPE = "DataActionType";

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants.INFO_NOT_PROVIDED_FOR_ASYNC_RETRIEVE_DATA_INITIALIZATION Field

public const INFO_NOT_PROVIDED_FOR_ASYNC_RETRIEVE_DATA_INITIALIZATION INFO_NOT_PROVIDED_FOR_ASYNC_RETRIEVE_DATA_INITIALIZATION = "INFO_NOT_PROVIDED_FOR_ASYNC_RETRIEVE_DATA_INITIALIZATION";

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants.INFO_NOT_PROVIDED_FOR_DATA_ACTION_INITIALIZATION Field

public const INFO_NOT_PROVIDED_FOR_DATA_ACTION_INITIALIZATION INFO_NOT_PROVIDED_FOR_DATA_ACTION_INITIALIZATION = "INFO_NOT_PROVIDED_FOR_DATA_ACTION_INITIALIZATION";

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants.QUERY_TIME_OUT Field

public const QUERY_TIME_OUT QUERY_TIME_OUT = "QueryTimeOut";

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants Properties

The properties of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Properties

QueryTimeOut

See Also

Constants Class | Aptify.Framework.DataServices Namespace


QueryTimeOut Property

Aptify 5.0 Software Development Kit (SDK)

Constants.QueryTimeOut Property

public static Int32 QueryTimeOut {get;}

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants Methods

The methods of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttribute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.DataServices Namespace


Constants.GetAttribute Method

public Attribute GetAttribute(
String Name
);

Implements

ISupportsAttributes.

See Also

Constants Class | Aptify.Framework.DataServices Namespace


CredentialParameters Class

For a list of all members of this type, see CredentialParameters Members.

System.Object
Hashtable
CredentialParameters

public class CredentialParameters : Hashtable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

CredentialParameters Members | Aptify.Framework.DataServices Namespace


CredentialParameters Members

CredentialParameters overview

Public Instance Constructors

CredentialParameters Overloaded. Initializes a new instance of the CredentialParameters class.

Public Instance Properties

Count (inherited from Hashtable) | Gets the number of key/value pairs contained in the Hashtable.
IsFixedSize (inherited from Hashtable) | Gets a value indicating whether the Hashtable has a fixed size.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread safe).
Item | Overloaded.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

Public Instance Methods

Add | Overloaded.
Add (inherited from Hashtable) | Overloaded. Adds an element with the specified key and value into the Hashtable.
Clear (inherited from Hashtable) | Removes all elements from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines whether the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable elements to a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from Hashtable) | Returns an IDictionaryEnumerator that iterates through the Hashtable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the element with the specified key from the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

comparer (inherited from Hashtable) | Obsolete. Gets or sets the IComparer to use for the Hashtable.
EqualityComparer (inherited from Hashtable) | Gets the IEqualityComparer to use for the Hashtable.
hcp (inherited from Hashtable) | Obsolete. Gets or sets the object that can dispense hash codes.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CredentialParameters Class | Aptify.Framework.DataServices Namespace


CredentialParameters Constructor

Initializes a new instance of the CredentialParameters class.

Overload List

Initializes a new instance of the CredentialParameters class.

public CredentialParameters();

public CredentialParameters(SerializationInfo,StreamingContext);

See Also

CredentialParameters Class | Aptify.Framework.DataServices Namespace


CredentialParameters Constructor ()

Initializes a new instance of the CredentialParameters class.

public CredentialParameters();

See Also

CredentialParameters Class | Aptify.Framework.DataServices Namespace | CredentialParameters Constructor Overload List


CredentialParameters Constructor (SerializationInfo, StreamingContext)

public CredentialParameters(
SerializationInfo info,
StreamingContext context
);

See Also

CredentialParameters Class | Aptify.Framework.DataServices Namespace | CredentialParameters Constructor Overload List


CredentialParameters Properties

The properties of the CredentialParameters class are listed below. For a complete list of CredentialParameters class members, see the CredentialParameters Members topic.

Public Instance Properties

Count (inherited from Hashtable) | Gets the number of key/value pairs contained in the Hashtable.
IsFixedSize (inherited from Hashtable) | Gets a value indicating whether the Hashtable has a fixed size.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread safe).
Item | Overloaded.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

Protected Instance Properties

comparer (inherited from Hashtable) | Obsolete. Gets or sets the IComparer to use for the Hashtable.
EqualityComparer (inherited from Hashtable) | Gets the IEqualityComparer to use for the Hashtable.
hcp (inherited from Hashtable) | Obsolete. Gets or sets the object that can dispense hash codes.

See Also

CredentialParameters Class | Aptify.Framework.DataServices Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

CredentialParameters.Item Property

public String this[
String Key
] {get;}

See Also

CredentialParameters Class | Aptify.Framework.DataServices Namespace


CredentialParameters Methods

The methods of the CredentialParameters class are listed below. For a complete list of CredentialParameters class members, see the CredentialParameters Members topic.

Public Instance Methods

Add | Overloaded.
Add (inherited from Hashtable) | Overloaded. Adds an element with the specified key and value into the Hashtable.
Clear (inherited from Hashtable) | Removes all elements from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines whether the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable elements to a one-dimensional Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from Hashtable) | Returns an IDictionaryEnumerator that iterates through the Hashtable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from Hashtable) | Removes the element with the specified key from the Hashtable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CredentialParameters Class | Aptify.Framework.DataServices Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

CredentialParameters.Add Method

Overload List

Inherited from Hashtable.

public virtual void Add(Object,Object);

public void Add(String,String);

See Also

CredentialParameters Class | Aptify.Framework.DataServices Namespace


CredentialParameters.Add Method (String, String)

public void Add(
String Key,
String Value
);

See Also

CredentialParameters Class | Aptify.Framework.DataServices Namespace | CredentialParameters.Add Overload List


CredentialParameters.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

CredentialParameters Class | Aptify.Framework.DataServices Namespace


DataAction Class

The DataAction class in AptifyGenericDataServices is the main Data Services Layer class that is used for all synchronous data access for applications developed with Aptify Technology Platform. The DataAction component also manages connections and data caching intrinsically. This class is not bound to a specific database engine. Hence, the Generic nomenclature. Through configuration information, the generic Data Services Layer binds to a specific database engine. The default implementation is for Microsoft SQL Server which is contained in the assembly, AptifySQLDataServices.

For a list of all members of this type, see DataAction Members.

System.Object
DataAction

public class DataAction : IAptifyDataAction, ISupportsAttributes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Developers of Aptify applications reference and use the DataAction class in AptifyGenericDataServices for all database access. No direct references should be made to the database-specific implementations of the Aptify Data Services Layer.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: AptifyGenericDataServices (in AptifyGenericDataServices.dll)

See Also

DataAction Members | Aptify.Framework.DataServices Namespace


DataAction Members

DataAction overview

Public Instance Constructors

DataAction Overloaded. Initializes a new instance of the DataAction class.

Public Instance Properties

TranCount | Overloaded. This returns the number of uncommitted segments for the default transaction.
UserCredentials | This is the evidence that is used to detemine what user has control of a specific DataAction. It keeps track user specific information.

Public Instance Methods

BeginTransaction | Overloaded.
ClearDataCache | The DataAction caches DataSets, DataTables, and Scalars based on the SQL used to retrieve them. This member allows you to selectively clear the cache.
CommitTransaction | Overloaded. This commits the last segment that was started for the transaction that is associated with the UserCredential's DefaultTransaction ID.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteDataReader | Overloaded.
ExecuteDataReaderParametrized | Overloaded. This will open a data reader so a developer can quickly read through a forward only block of data.
ExecuteNonQuery | Overloaded. Executes a Transact-SQL statement against the connection and returns the number of rows affected.
ExecuteNonQueryParametrized | Overloaded.
ExecuteScalar | Overloaded.
ExecuteScalarParametrized | Overloaded.
GetAttribute | This will return any Aptify Attributes that are associated with the specific class. This call makes an underlying call to the Attribute Manager.
GetDataParameter | Overloaded. Returns an Instance of an IDataParameter.
GetDataSet | Overloaded. This allows a developer to return a DataSet. A DataSet represents an in-memory cache of data.
GetDataSetParametrized | Overloaded.
GetDataTable | Overloaded.
GetDataTableParametrized | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXMLReader | Overloaded. Returns an XML reader that streams from the database.
Initialize |
InTransaction | Overloaded. This returns true if the default transaction is active. It returns false if the default transaction is not active.
RollbackTransaction | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction Constructor

Creates a new instance of a DataAction class without providing a UserCredentials object. A valid UserCredentials object is required by the DataAction object. If one is not provided, the object will attempt to obtain the default UserCredentials object. The default UserCredentials object is set with the first UserCredentials object provided when a DataAction object is instantiated. Therefore, this constructor will only succeed if a default UserCredentials object exists. That means some other instance of the DataAction class was created with a valid UserCredentials object before this constructor is called.

Overload List

Creates a new instance of a DataAction class without providing a UserCredentials object. A valid UserCredentials object is required by the DataAction object. If one is not provided, the object will attempt to obtain the default UserCredentials object. The default UserCredentials object is set with the first UserCredentials object provided when a DataAction object is instantiated. Therefore, this constructor will only succeed if a default UserCredentials object exists. That means some other instance of the DataAction class was created with a valid UserCredentials object before this constructor is called.

public DataAction();

public DataAction(UserCredentials);

public DataAction(UserCredentials,String);

public DataAction(UserCredentials,String,Boolean);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction Constructor ()

Creates a new instance of a DataAction class without providing a UserCredentials object. A valid UserCredentials object is required by the DataAction object. If one is not provided, the object will attempt to obtain the default UserCredentials object. The default UserCredentials object is set with the first UserCredentials object provided when a DataAction object is instantiated. Therefore, this constructor will only succeed if a default UserCredentials object exists. That means some other instance of the DataAction class was created with a valid UserCredentials object before this constructor is called.

public DataAction();

Remarks

Aptify recommends explicitly passing a valid UserCredentials object when instantiating the DataAction class.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction Constructor Overload List


DataAction Constructor (UserCredentials)

public DataAction(
UserCredentials UserCredentials
);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction Constructor Overload List


DataAction Constructor (UserCredentials, String)

public DataAction(
UserCredentials UserCredentials,
String ConnectionString
);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction Constructor Overload List


DataAction Constructor (UserCredentials, String, Boolean)

public DataAction(
UserCredentials UserCredentials,
String ConnectionString,
Boolean SetAsDefault
);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction Constructor Overload List


DataAction Properties

The properties of the DataAction class are listed below. For a complete list of DataAction class members, see the DataAction Members topic.

Public Instance Properties

TranCount | Overloaded. This returns the number of uncommitted segments for the default transaction.
UserCredentials | This is the evidence that is used to detemine what user has control of a specific DataAction. It keeps track user specific information.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


Int32 Property

Aptify 5.0 Software Development Kit (SDK)

DataAction.Int32 Property

This returns the number of uncommitted segments for the default transaction.

Overload List

This returns the number of uncommitted segments for the default transaction.

public Int32 TranCount {get;}

This returns the number of uncomitted segments for the specified transaction.

public Int32 this[String] {get;}

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


TranCount Property

Aptify 5.0 Software Development Kit (SDK)

DataAction.TranCount Property

This returns the number of uncommitted segments for the default transaction.

public Int32 TranCount {get;}

Property Value

Return the current Transaction Count for the default transaction.

Implements

IAptifyDataAction.

Remarks

TranCount is 0 if the transaction is not in process. TranCount is incremented by 1 for each call to BeginTransaction. TranCount is decremented by 1 for each call to CommitTransaction. TranCount is reset to 0 when RollbackTransaction is called.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.Int32 Overload List


TranCount Property (String)

Aptify 5.0 Software Development Kit (SDK)

DataAction.TranCount Property (String)

This returns the number of uncomitted segments for the specified transaction.

public Int32 this[
String TransactionID
] {get;}

Parameters

TransactionID

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.Int32 Overload List


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

DataAction.UserCredentials Property

This is the evidence that is used to detemine what user has control of a specific DataAction. It keeps track user specific information.

public UserCredentials UserCredentials {get;}

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction Methods

The methods of the DataAction class are listed below. For a complete list of DataAction class members, see the DataAction Members topic.

Public Instance Methods

BeginTransaction | Overloaded.
ClearDataCache | The DataAction caches DataSets, DataTables, and Scalars based on the SQL used to retrieve them. This member allows you to selectively clear the cache.
CommitTransaction | Overloaded. This commits the last segment that was started for the transaction that is associated with the UserCredential's DefaultTransaction ID.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteDataReader | Overloaded.
ExecuteDataReaderParametrized | Overloaded. This will open a data reader so a developer can quickly read through a forward only block of data.
ExecuteNonQuery | Overloaded. Executes a Transact-SQL statement against the connection and returns the number of rows affected.
ExecuteNonQueryParametrized | Overloaded.
ExecuteScalar | Overloaded.
ExecuteScalarParametrized | Overloaded.
GetAttribute | This will return any Aptify Attributes that are associated with the specific class. This call makes an underlying call to the Attribute Manager.
GetDataParameter | Overloaded. Returns an Instance of an IDataParameter.
GetDataSet | Overloaded. This allows a developer to return a DataSet. A DataSet represents an in-memory cache of data.
GetDataSetParametrized | Overloaded.
GetDataTable | Overloaded.
GetDataTableParametrized | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXMLReader | Overloaded. Returns an XML reader that streams from the database.
Initialize |
InTransaction | Overloaded. This returns true if the default transaction is active. It returns false if the default transaction is not active.
RollbackTransaction | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


BeginTransaction Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.BeginTransaction Method

Overload List

public string BeginTransaction();

public string BeginTransaction(Boolean);

public string BeginTransaction(IsolationLevel);

public string BeginTransaction(IsolationLevel,Boolean);

This will begin a transaction and return a transaction Id that can be used to associate things with this transaction at a later time.

public string BeginTransaction(IsolationLevel,Boolean,String);

public string BeginTransaction(String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.BeginTransaction Method ()

public string BeginTransaction();

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.BeginTransaction Method (Boolean)

public string BeginTransaction(
Boolean NewTransaction
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.BeginTransaction Method (IsolationLevel)

public string BeginTransaction(
IsolationLevel IsolationLevel
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.BeginTransaction Method (IsolationLevel, Boolean)

public string BeginTransaction(
IsolationLevel IsolationLevel,
Boolean NewTransaction
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.BeginTransaction Method (IsolationLevel, Boolean, String)

This will begin a transaction and return a transaction Id that can be used to associate things with this transaction at a later time.

public string BeginTransaction(
IsolationLevel IsolationLevel,
Boolean NewTransaction,
String TransactionID
);

Parameters

IsolationLevel
NewTransaction
TransactionID

Return Value

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.BeginTransaction Method (String)

public string BeginTransaction(
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.ClearDataCache Method

The DataAction caches DataSets, DataTables, and Scalars based on the SQL used to retrieve them. This member allows you to selectively clear the cache.

public void ClearDataCache(
IAptifyDataAction.CacheWorkingSet WorkingSet
);

Parameters

WorkingSet

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


CommitTransaction Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.CommitTransaction Method

This commits the last segment that was started for the transaction that is associated with the UserCredential's DefaultTransaction ID.

Overload List

This commits the last segment that was started for the transaction that is associated with the UserCredential's DefaultTransaction ID.

public void CommitTransaction();

This commits the last segment that was started for the transaction with the specified id.

public void CommitTransaction(String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.CommitTransaction Method ()

This commits the last segment that was started for the transaction that is associated with the UserCredential's DefaultTransaction ID.

public void CommitTransaction();

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.CommitTransaction Overload List


DataAction.CommitTransaction Method (String)

This commits the last segment that was started for the transaction with the specified id.

public void CommitTransaction(
String TransactionID
);

Parameters

TransactionID

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.CommitTransaction Overload List


ExecuteDataReader Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteDataReader Method

Overload List

public IDataReader ExecuteDataReader(String);

public IDataReader ExecuteDataReader(String,CommandBehavior);

public IDataReader ExecuteDataReader(String,CommandBehavior,Int32);

This will open a data reader so a developer can quickly read through a forward only block of data.

public IDataReader ExecuteDataReader(String,CommandBehavior,Int32,String);

public IDataReader ExecuteDataReader(String,CommandBehavior,String);

public IDataReader ExecuteDataReader(String,Int32);

public IDataReader ExecuteDataReader(String,Int32,String);

public IDataReader ExecuteDataReader(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.ExecuteDataReader Method (String)

public IDataReader ExecuteDataReader(
String SQL
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, CommandBehavior)

public IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, CommandBehavior, Int32)

public IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, CommandBehavior, Int32, String)

This will open a data reader so a developer can quickly read through a forward only block of data.

public IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout,
String TransactionID
);

Parameters

SQL
CommandBehavior
QueryTimeout
TransactionID

Return Value

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, CommandBehavior, String)

public IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, Int32)

public IDataReader ExecuteDataReader(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, Int32, String)

public IDataReader ExecuteDataReader(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, String)

public IDataReader ExecuteDataReader(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReader Overload List


ExecuteDataReaderParametrized Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteDataReaderParametrized Method

This will open a data reader so a developer can quickly read through a forward only block of data.

Overload List

This will open a data reader so a developer can quickly read through a forward only block of data.

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[]);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior,Int32);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior,Int32,String);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior,String);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],Int32);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],Int32,String);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[])

This will open a data reader so a developer can quickly read through a forward only block of data.

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

Parameters

SQL
CommandType
Parameters

Return Value

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior, Int32)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior, Int32, String)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior, String)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], Int32)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], Int32, String)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], String)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


ExecuteNonQuery Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteNonQuery Method

Executes a Transact-SQL statement against the connection and returns the number of rows affected.

Overload List

Executes a Transact-SQL statement against the connection and returns the number of rows affected.

public int ExecuteNonQuery(String);

public int ExecuteNonQuery(String,Int32);

public int ExecuteNonQuery(String,Int32,String);

public int ExecuteNonQuery(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.ExecuteNonQuery Method (String)

Executes a Transact-SQL statement against the connection and returns the number of rows affected.

public int ExecuteNonQuery(
String SQL
);

Parameters

SQL

Return Value

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteNonQuery Overload List


DataAction.ExecuteNonQuery Method (String, Int32)

public int ExecuteNonQuery(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteNonQuery Overload List


DataAction.ExecuteNonQuery Method (String, Int32, String)

public int ExecuteNonQuery(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteNonQuery Overload List


DataAction.ExecuteNonQuery Method (String, String)

public int ExecuteNonQuery(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteNonQuery Overload List


ExecuteNonQueryParametrized Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteNonQueryParametrized Method

Executes a Transact-SQL statement against the connection and returns the number of rows affected.

Overload List

Executes a Transact-SQL statement against the connection and returns the number of rows affected.

public int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[]);

public int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[],Int32);

public int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[],Int32,String);

public int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[],String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[])

Executes a Transact-SQL statement against the connection and returns the number of rows affected.

public int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

Parameters

SQL
CommandType
Parameters

Return Value

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteNonQueryParametrized Overload List


DataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[], Int32)

public int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteNonQueryParametrized Overload List


DataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[], Int32, String)

public int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteNonQueryParametrized Overload List


DataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[], String)

public int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteNonQueryParametrized Overload List


ExecuteScalar Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteScalar Method

Overload List

public object ExecuteScalar(String);

public object ExecuteScalar(String,IAptifyDataAction.DSLCacheSetting);

public object ExecuteScalar(String,IAptifyDataAction.DSLCacheSetting,String);

public object ExecuteScalar(String,Int32);

public object ExecuteScalar(String,Int32,IAptifyDataAction.DSLCacheSetting);

This will execute an SQL statement and return the resulting value from the statement.

public object ExecuteScalar(String,Int32,IAptifyDataAction.DSLCacheSetting,String);

public object ExecuteScalar(String,Int32,String);

public object ExecuteScalar(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.ExecuteScalar Method (String)

public object ExecuteScalar(
String SQL
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, DSLCacheSetting)

public object ExecuteScalar(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, DSLCacheSetting, String)

public object ExecuteScalar(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, Int32)

public object ExecuteScalar(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, Int32, DSLCacheSetting)

public object ExecuteScalar(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, Int32, DSLCacheSetting, String)

This will execute an SQL statement and return the resulting value from the statement.

public object ExecuteScalar(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Parameters

SQL
QueryTimeout
CacheSetting
TransactionID

Return Value

Implements

IAptifyDataAction.

Remarks

It will return the first column of the first row in the result set. The rest of the result set will be discarded. If nothing was returned from the SQL statement then Null, Nothing in VB, will be returned as the result.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, Int32, String)

public object ExecuteScalar(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, String)

public object ExecuteScalar(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalar Overload List


ExecuteScalarParametrized Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteScalarParametrized Method

Overload List

public object ExecuteScalarParametrized(String,CommandType,IDataParameter[]);

public object ExecuteScalarParametrized(String,CommandType,IDataParameter[],Int32);

This will execute an SQL statement and return the resulting value from the statement.

public object ExecuteScalarParametrized(String,CommandType,IDataParameter[],Int32,String);

public object ExecuteScalarParametrized(String,CommandType,IDataParameter[],String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[])

public object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalarParametrized Overload List


DataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[], Int32)

public object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalarParametrized Overload List


DataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[], Int32, String)

This will execute an SQL statement and return the resulting value from the statement.

public object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

Parameters

SQL
CommandType
Parameters
QueryTimeout
TransactionID

Return Value

Implements

IAptifyDataAction.

Remarks

It will return the first column of the first row in the result set. The rest of the result set will be discarded. If nothing was returned from the SQL statement then Null, Nothing in VB, will be returned as the result.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalarParametrized Overload List


DataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[], String)

public object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.ExecuteScalarParametrized Overload List


DataAction.GetAttribute Method

This will return any Aptify Attributes that are associated with the specific class. This call makes an underlying call to the Attribute Manager.

public Attribute GetAttribute(
String Name
);

Parameters

Name

Return Value

Implements

ISupportsAttributes.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


GetDataParameter Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetDataParameter Method

Returns an Instance of an IDataParameter.

Overload List

Returns an Instance of an IDataParameter.

public IDataParameter GetDataParameter();

public IDataParameter GetDataParameter(String);

public IDataParameter GetDataParameter(String,SqlDbType);

public IDataParameter GetDataParameter(String,SqlDbType,Int32,Object);

public IDataParameter GetDataParameter(String,SqlDbType,Object);

public IDataParameter GetDataParameter(String,Object);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.GetDataParameter Method ()

Returns an Instance of an IDataParameter.

public IDataParameter GetDataParameter();

Return Value

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataParameter Overload List


DataAction.GetDataParameter Method (String)

public IDataParameter GetDataParameter(
String Name
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataParameter Overload List


DataAction.GetDataParameter Method (String, SqlDbType)

public IDataParameter GetDataParameter(
String Name,
SqlDbType DataType
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataParameter Overload List


DataAction.GetDataParameter Method (String, SqlDbType, Int32, Object)

public IDataParameter GetDataParameter(
String Name,
SqlDbType DataType,
Int32 Size,
Object Value
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataParameter Overload List


DataAction.GetDataParameter Method (String, SqlDbType, Object)

public IDataParameter GetDataParameter(
String Name,
SqlDbType DataType,
Object Value
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataParameter Overload List


DataAction.GetDataParameter Method (String, Object)

public IDataParameter GetDataParameter(
String Name,
Object Value
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataParameter Overload List


GetDataSet Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetDataSet Method

This allows a developer to return a DataSet. A DataSet represents an in-memory cache of data.

Overload List

This allows a developer to return a DataSet. A DataSet represents an in-memory cache of data.

public DataSet GetDataSet(String);

public DataSet GetDataSet(String,IAptifyDataAction.DSLCacheSetting);

public DataSet GetDataSet(String,IAptifyDataAction.DSLCacheSetting,String);

public DataSet GetDataSet(String,CommandType,IDataParameter[],String);

public DataSet GetDataSet(String,Int32);

public DataSet GetDataSet(String,Int32,IAptifyDataAction.DSLCacheSetting);

public DataSet GetDataSet(String,Int32,IAptifyDataAction.DSLCacheSetting,String);

public DataSet GetDataSet(String,Int32,String);

public DataSet GetDataSet(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.GetDataSet Method (String)

This allows a developer to return a DataSet. A DataSet represents an in-memory cache of data.

public DataSet GetDataSet(
String SQL
);

Parameters

SQL

Return Value

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, DSLCacheSetting)

public DataSet GetDataSet(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, DSLCacheSetting, String)

public DataSet GetDataSet(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, CommandType, IDataParameter[], String)

public DataSet GetDataSet(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, Int32)

public DataSet GetDataSet(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, Int32, DSLCacheSetting)

public DataSet GetDataSet(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, Int32, DSLCacheSetting, String)

public DataSet GetDataSet(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, Int32, String)

public DataSet GetDataSet(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, String)

public DataSet GetDataSet(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSet Overload List


GetDataSetParametrized Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetDataSetParametrized Method

Overload List

public DataSet GetDataSetParametrized(String,CommandType,IDataParameter[]);

public DataSet GetDataSetParametrized(String,CommandType,IDataParameter[],Int32);

public DataSet GetDataSetParametrized(String,CommandType,IDataParameter[],Int32,String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.GetDataSetParametrized Method (String, CommandType, IDataParameter[])

public DataSet GetDataSetParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSetParametrized Overload List


DataAction.GetDataSetParametrized Method (String, CommandType, IDataParameter[], Int32)

public DataSet GetDataSetParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSetParametrized Overload List


DataAction.GetDataSetParametrized Method (String, CommandType, IDataParameter[], Int32, String)

public DataSet GetDataSetParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataSetParametrized Overload List


GetDataTable Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetDataTable Method

Overload List

public DataTable GetDataTable(String);

public DataTable GetDataTable(String,IAptifyDataAction.DSLCacheSetting);

public DataTable GetDataTable(String,IAptifyDataAction.DSLCacheSetting,String);

public DataTable GetDataTable(String,Int32);

public DataTable GetDataTable(String,Int32,IAptifyDataAction.DSLCacheSetting);

This allows a developer to return a DataTable. A DataTable represents one table of in-memory data.

public DataTable GetDataTable(String,Int32,IAptifyDataAction.DSLCacheSetting,String);

public DataTable GetDataTable(String,Int32,String);

public DataTable GetDataTable(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.GetDataTable Method (String)

public DataTable GetDataTable(
String SQL
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, DSLCacheSetting)

public DataTable GetDataTable(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, DSLCacheSetting, String)

public DataTable GetDataTable(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, Int32)

public DataTable GetDataTable(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, Int32, DSLCacheSetting)

public DataTable GetDataTable(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, Int32, DSLCacheSetting, String)

This allows a developer to return a DataTable. A DataTable represents one table of in-memory data.

public DataTable GetDataTable(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Parameters

SQL
QueryTimeout
CacheSetting
TransactionID

Return Value

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, Int32, String)

public DataTable GetDataTable(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, String)

public DataTable GetDataTable(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTable Overload List


GetDataTableParametrized Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetDataTableParametrized Method

Overload List

public DataTable GetDataTableParametrized(String,CommandType,IDataParameter[]);

public DataTable GetDataTableParametrized(String,CommandType,IDataParameter[],Int32);

This allows a developer to return a DataTable. A DataTable represents one table of in-memory data.

public DataTable GetDataTableParametrized(String,CommandType,IDataParameter[],Int32,String);

public DataTable GetDataTableParametrized(String,CommandType,IDataParameter[],String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[])

public DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTableParametrized Overload List


DataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[], Int32)

public DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTableParametrized Overload List


DataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[], Int32, String)

This allows a developer to return a DataTable. A DataTable represents one table of in-memory data.

public DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

Parameters

SQL
CommandType
Parameters
QueryTimeout
TransactionID

Return Value

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTableParametrized Overload List


DataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[], String)

public DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetDataTableParametrized Overload List


GetXMLReader Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetXMLReader Method

Returns an XML reader that streams from the database.

Overload List

Returns an XML reader that streams from the database.

public XmlReader GetXMLReader(String);

public XmlReader GetXMLReader(String,Int32);

public XmlReader GetXMLReader(String,Int32,String);

public XmlReader GetXMLReader(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.GetXMLReader Method (String)

Returns an XML reader that streams from the database.

public XmlReader GetXMLReader(
String SQL
);

Parameters

SQL

Return Value

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetXMLReader Overload List


DataAction.GetXMLReader Method (String, Int32)

public XmlReader GetXMLReader(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetXMLReader Overload List


DataAction.GetXMLReader Method (String, Int32, String)

public XmlReader GetXMLReader(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetXMLReader Overload List


DataAction.GetXMLReader Method (String, String)

public XmlReader GetXMLReader(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.GetXMLReader Overload List


DataAction.Initialize Method

public void Initialize(
UserCredentials UserCredentials,
String ConnectionString,
Boolean SetAsDefault
);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


InTransaction Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.InTransaction Method

This returns true if the default transaction is active. It returns false if the default transaction is not active.

Overload List

This returns true if the default transaction is active. It returns false if the default transaction is not active.

public bool InTransaction();

public bool InTransaction(String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.InTransaction Method ()

This returns true if the default transaction is active. It returns false if the default transaction is not active.

public bool InTransaction();

Return Value

This returns true of the default transaction is active. It returns false if the default transaction is not active.

Implements

IAptifyDataAction.

Example

You should put a watch on the oUserCredential and observe the DefaultTransactionID
You should put a watch on the oDataAction and observe the TranCount

You should also place breakpoints on lines of interest to you
you can then see immediate values by higlighting the method and hitting Shift-F9

Dim oUserCredential As Aptify.Framework.DataServices.UserCredentials
Dim oDataAction As Aptify.Framework.DataServices.IAptifyDataAction

oUserCredential = New Aptify.Framework.DataServices.UserCredentials(".", "Aptify", "Aptify", True, Nothing, Nothing, Nothing, Nothing, True)
oDataAction = New Aptify.Framework.DataServices.DataAction(oUserCredential)

oDataAction.InTransaction()

Dim sTranID1 As String = oDataAction.BeginTransaction(True)
Dim sTranID2 As String = oDataAction.BeginTransaction(True)

oDataAction.CommitTransaction(sTranID1)

sTranID1 = oDataAction.BeginTransaction()
sTranID1 = oDataAction.BeginTransaction(sTranID1)
sTranID1 = oDataAction.BeginTransaction(sTranID1)

oDataAction.InTransaction()
oDataAction.InTransaction(sTranID1)
oDataAction.InTransaction(sTranID2)

oDataAction.CommitTransaction(sTranID1)
oDataAction.CommitTransaction()
oDataAction.CommitTransaction(sTranID1)

oDataAction.InTransaction()
oDataAction.InTransaction(sTranID1)
oDataAction.InTransaction(sTranID2)

oDataAction.UserCredentials.DefaultTransactionID = sTranID2
oDataAction.InTransaction()
oDataAction.UserCredentials.DefaultTransactionID = ""

oDataAction.InTransaction()
oDataAction.InTransaction(sTranID1)
oDataAction.InTransaction(sTranID2)

oDataAction.CommitTransaction(sTranID2)

oDataAction.InTransaction()
oDataAction.InTransaction(sTranID1)
oDataAction.InTransaction(sTranID2)

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.InTransaction Overload List


DataAction.InTransaction Method (String)

public bool InTransaction(
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.InTransaction Overload List


RollbackTransaction Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.RollbackTransaction Method

Overload List

public void RollbackTransaction();

RollbackTransaction will rollback all transactions for the specified transaction, including nested segments for the specified transaction.

public void RollbackTransaction(String);

See Also

DataAction Class | Aptify.Framework.DataServices Namespace


DataAction.RollbackTransaction Method ()

public void RollbackTransaction();

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.RollbackTransaction Overload List


DataAction.RollbackTransaction Method (String)

RollbackTransaction will rollback all transactions for the specified transaction, including nested segments for the specified transaction.

public void RollbackTransaction(
String TransactionID
);

Parameters

TransactionID

Implements

IAptifyDataAction.

Remarks

See Also

DataAction Class | Aptify.Framework.DataServices Namespace | DataAction.RollbackTransaction Overload List


DataServicesConstants Class

For a list of all members of this type, see DataServicesConstants Members.

System.Object
DataServicesConstants

public class DataServicesConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

DataServicesConstants Members | Aptify.Framework.DataServices Namespace


DataServicesConstants Members

DataServicesConstants overview

Public Static Properties

AsyncOperationInProgress

Public Instance Constructors

DataServicesConstants Constructor Initializes a new instance of the DataServicesConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataServicesConstants Class | Aptify.Framework.DataServices Namespace


DataServicesConstants Constructor

Initializes a new instance of the DataServicesConstants class.

public DataServicesConstants();

See Also

DataServicesConstants Class | Aptify.Framework.DataServices Namespace


DataServicesConstants Properties

The properties of the DataServicesConstants class are listed below. For a complete list of DataServicesConstants class members, see the DataServicesConstants Members topic.

Public Static Properties

AsyncOperationInProgress

See Also

DataServicesConstants Class | Aptify.Framework.DataServices Namespace


AsyncOperationInProgress Property

Aptify 5.0 Software Development Kit (SDK)

DataServicesConstants.AsyncOperationInProgress Property

public static String AsyncOperationInProgress {get;}

See Also

DataServicesConstants Class | Aptify.Framework.DataServices Namespace


IAptifyAsyncRetrieveData Interface

For a list of all members of this type, see IAptifyAsyncRetrieveData Members.

public interface IAptifyAsyncRetrieveData

Types that implement IAptifyAsyncRetrieveData

Type | Description
AsyncRetrieveData |
AsyncRetrieveData |

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

IAptifyAsyncRetrieveData Members | Aptify.Framework.DataServices Namespace


IAptifyAsyncRetrieveData Members

IAptifyAsyncRetrieveData overview

Public Instance Properties

ConnectionString
DataReader
InProcess
LastError
StillExecuting
UserCredentials

Public Instance Methods

BeginGetDataReader | Overloaded.
CancelGetDataReader |

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace


IAptifyAsyncRetrieveData Properties

The properties of the IAptifyAsyncRetrieveData interface are listed below. For a complete list of IAptifyAsyncRetrieveData interface members, see the IAptifyAsyncRetrieveData Members topic.

Public Instance Properties

ConnectionString
DataReader
InProcess
LastError
StillExecuting
UserCredentials

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace


ConnectionString Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyAsyncRetrieveData.ConnectionString Property

String ConnectionString {get;}

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace


DataReader Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyAsyncRetrieveData.DataReader Property

IDataReader DataReader {get;}

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace


InProcess Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyAsyncRetrieveData.InProcess Property

Boolean InProcess {get;}

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace


LastError Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyAsyncRetrieveData.LastError Property

String LastError {get;}

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace


StillExecuting Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyAsyncRetrieveData.StillExecuting Property

Boolean StillExecuting {get;}

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyAsyncRetrieveData.UserCredentials Property

UserCredentials UserCredentials {get;}

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace


IAptifyAsyncRetrieveData Methods

The methods of the IAptifyAsyncRetrieveData interface are listed below. For a complete list of IAptifyAsyncRetrieveData interface members, see the IAptifyAsyncRetrieveData Members topic.

Public Instance Methods

BeginGetDataReader | Overloaded.
CancelGetDataReader |

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace


BeginGetDataReader Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyAsyncRetrieveData.BeginGetDataReader Method

Overload List

void BeginGetDataReader(String);

void BeginGetDataReader(String,CommandBehavior);

void BeginGetDataReader(String,CommandBehavior,IAptifyAsyncRetrieveData.DataReaderDelegate);

void BeginGetDataReader(String,CommandBehavior,Int32);

void BeginGetDataReader(String,CommandBehavior,Int32,IAptifyAsyncRetrieveData.DataReaderDelegate);

void BeginGetDataReader(String,Int32);

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace


IAptifyAsyncRetrieveData.BeginGetDataReader Method (String)

void BeginGetDataReader(
String SQL
);

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace | IAptifyAsyncRetrieveData.BeginGetDataReader Overload List


IAptifyAsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior)

void BeginGetDataReader(
String SQL,
CommandBehavior CommandBehavior
);

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace | IAptifyAsyncRetrieveData.BeginGetDataReader Overload List


IAptifyAsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior, DataReaderDelegate)

void BeginGetDataReader(
String sSQL,
CommandBehavior CommandBehavior,
IAptifyAsyncRetrieveData.DataReaderDelegate drDelegate
);

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace | IAptifyAsyncRetrieveData.BeginGetDataReader Overload List


IAptifyAsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior, Int32)

void BeginGetDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout
);

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace | IAptifyAsyncRetrieveData.BeginGetDataReader Overload List


IAptifyAsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior, Int32, DataReaderDelegate)

void BeginGetDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout,
IAptifyAsyncRetrieveData.DataReaderDelegate drDelegate
);

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace | IAptifyAsyncRetrieveData.BeginGetDataReader Overload List


IAptifyAsyncRetrieveData.BeginGetDataReader Method (String, Int32)

void BeginGetDataReader(
String SQL,
Int32 QueryTimeout
);

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace | IAptifyAsyncRetrieveData.BeginGetDataReader Overload List


IAptifyAsyncRetrieveData.CancelGetDataReader Method

void CancelGetDataReader();

See Also

IAptifyAsyncRetrieveData Interface | Aptify.Framework.DataServices Namespace


IAptifyAsyncRetrieveData.DataReaderDelegate Delegate

public delegate void IAptifyAsyncRetrieveData.DataReaderDelegate(
Int32 OperationID,
IDataReader DataReader,
String ErrorString
);

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

Aptify.Framework.DataServices Namespace


IAptifyDataAction Interface

Implementations of this interface will be responsible for all database access, including transaction management.

For a list of all members of this type, see IAptifyDataAction Members.

public interface IAptifyDataAction

Types that implement IAptifyDataAction

Type | Description
DataAction | The DataAction class in AptifyGenericDataServices is the main Data Services Layer class that is used for all synchronous data access for applications developed with Aptify Technology Platform. The DataAction component also manages connections and data caching intrinsically. This class is not bound to a specific database engine. Hence, the Generic nomenclature. Through configuration information, the generic Data Services Layer binds to a specific database engine. The default implementation is for Microsoft SQL Server which is contained in the assembly, AptifySQLDataServices.
DataAction |

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

IAptifyDataAction Members | Aptify.Framework.DataServices Namespace


IAptifyDataAction Members

IAptifyDataAction overview

Public Instance Properties

TranCount | Overloaded.
UserCredentials |

Public Instance Methods

BeginTransaction | Overloaded.
ClearDataCache |
CommitTransaction | Overloaded.
ExecuteDataReader | Overloaded.
ExecuteDataReaderParametrized | Overloaded.
ExecuteNonQuery | Overloaded.
ExecuteNonQueryParametrized | Overloaded.
ExecuteScalar | Overloaded.
ExecuteScalarParametrized | Overloaded.
GetDataParameter | Overloaded.
GetDataSet | Overloaded.
GetDataSetParametrized | Overloaded.
GetDataTable | Overloaded.
GetDataTableParametrized | Overloaded.
GetXMLReader | Overloaded.
InTransaction | Overloaded.
RollbackTransaction | Overloaded.

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction Properties

The properties of the IAptifyDataAction interface are listed below. For a complete list of IAptifyDataAction interface members, see the IAptifyDataAction Members topic.

Public Instance Properties

TranCount | Overloaded.
UserCredentials |

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


Int32 Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.Int32 Property

Overload List

Int32 TranCount {get;}

Int32 this[String] {get;}

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


TranCount Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.TranCount Property

Int32 TranCount {get;}

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.Int32 Overload List


TranCount Property (String)

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.TranCount Property (String)

Int32 this[
String TransactionID
] {get;}

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.Int32 Overload List


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.UserCredentials Property

UserCredentials UserCredentials {get;}

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction Methods

The methods of the IAptifyDataAction interface are listed below. For a complete list of IAptifyDataAction interface members, see the IAptifyDataAction Members topic.

Public Instance Methods

BeginTransaction | Overloaded.
ClearDataCache |
CommitTransaction | Overloaded.
ExecuteDataReader | Overloaded.
ExecuteDataReaderParametrized | Overloaded.
ExecuteNonQuery | Overloaded.
ExecuteNonQueryParametrized | Overloaded.
ExecuteScalar | Overloaded.
ExecuteScalarParametrized | Overloaded.
GetDataParameter | Overloaded.
GetDataSet | Overloaded.
GetDataSetParametrized | Overloaded.
GetDataTable | Overloaded.
GetDataTableParametrized | Overloaded.
GetXMLReader | Overloaded.
InTransaction | Overloaded.
RollbackTransaction | Overloaded.

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


BeginTransaction Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.BeginTransaction Method

Overload List

string BeginTransaction();

string BeginTransaction(Boolean);

string BeginTransaction(IsolationLevel);

string BeginTransaction(IsolationLevel,Boolean);

string BeginTransaction(IsolationLevel,Boolean,String);

string BeginTransaction(String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.BeginTransaction Method ()

string BeginTransaction();

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.BeginTransaction Overload List


IAptifyDataAction.BeginTransaction Method (Boolean)

string BeginTransaction(
Boolean NewTransaction
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.BeginTransaction Overload List


IAptifyDataAction.BeginTransaction Method (IsolationLevel)

string BeginTransaction(
IsolationLevel IsolationLevel
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.BeginTransaction Overload List


IAptifyDataAction.BeginTransaction Method (IsolationLevel, Boolean)

string BeginTransaction(
IsolationLevel IsolationLevel,
Boolean NewTransaction
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.BeginTransaction Overload List


IAptifyDataAction.BeginTransaction Method (IsolationLevel, Boolean, String)

string BeginTransaction(
IsolationLevel IsolationLevel,
Boolean NewTransaction,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.BeginTransaction Overload List


IAptifyDataAction.BeginTransaction Method (String)

string BeginTransaction(
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.BeginTransaction Overload List


IAptifyDataAction.ClearDataCache Method

void ClearDataCache(
IAptifyDataAction.CacheWorkingSet WorkingSet
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


CommitTransaction Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.CommitTransaction Method

Overload List

void CommitTransaction();

void CommitTransaction(String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.CommitTransaction Method ()

void CommitTransaction();

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.CommitTransaction Overload List


IAptifyDataAction.CommitTransaction Method (String)

void CommitTransaction(
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.CommitTransaction Overload List


ExecuteDataReader Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.ExecuteDataReader Method

Overload List

IDataReader ExecuteDataReader(String);

IDataReader ExecuteDataReader(String,CommandBehavior);

IDataReader ExecuteDataReader(String,CommandBehavior,Int32);

IDataReader ExecuteDataReader(String,CommandBehavior,Int32,String);

IDataReader ExecuteDataReader(String,CommandBehavior,String);

IDataReader ExecuteDataReader(String,Int32);

IDataReader ExecuteDataReader(String,Int32,String);

IDataReader ExecuteDataReader(String,String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.ExecuteDataReader Method (String)

IDataReader ExecuteDataReader(
String SQL
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReader Overload List


IAptifyDataAction.ExecuteDataReader Method (String, CommandBehavior)

IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReader Overload List


IAptifyDataAction.ExecuteDataReader Method (String, CommandBehavior, Int32)

IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReader Overload List


IAptifyDataAction.ExecuteDataReader Method (String, CommandBehavior, Int32, String)

IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReader Overload List


IAptifyDataAction.ExecuteDataReader Method (String, CommandBehavior, String)

IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReader Overload List


IAptifyDataAction.ExecuteDataReader Method (String, Int32)

IDataReader ExecuteDataReader(
String SQL,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReader Overload List


IAptifyDataAction.ExecuteDataReader Method (String, Int32, String)

IDataReader ExecuteDataReader(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReader Overload List


IAptifyDataAction.ExecuteDataReader Method (String, String)

IDataReader ExecuteDataReader(
String SQL,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReader Overload List


ExecuteDataReaderParametrized Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.ExecuteDataReaderParametrized Method

Overload List

IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[]);

IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior);

IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior,Int32);

IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior,Int32,String);

IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior,String);

IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],Int32);

IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],Int32,String);

IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[])

IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReaderParametrized Overload List


IAptifyDataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior)

IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReaderParametrized Overload List


IAptifyDataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior, Int32)

IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReaderParametrized Overload List


IAptifyDataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior, Int32, String)

IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReaderParametrized Overload List


IAptifyDataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior, String)

IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReaderParametrized Overload List


IAptifyDataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], Int32)

IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReaderParametrized Overload List


IAptifyDataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], Int32, String)

IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReaderParametrized Overload List


IAptifyDataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], String)

IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteDataReaderParametrized Overload List


ExecuteNonQuery Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.ExecuteNonQuery Method

Overload List

int ExecuteNonQuery(String);

int ExecuteNonQuery(String,Int32);

int ExecuteNonQuery(String,Int32,String);

int ExecuteNonQuery(String,String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.ExecuteNonQuery Method (String)

int ExecuteNonQuery(
String SQL
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteNonQuery Overload List


IAptifyDataAction.ExecuteNonQuery Method (String, Int32)

int ExecuteNonQuery(
String SQL,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteNonQuery Overload List


IAptifyDataAction.ExecuteNonQuery Method (String, Int32, String)

int ExecuteNonQuery(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteNonQuery Overload List


IAptifyDataAction.ExecuteNonQuery Method (String, String)

int ExecuteNonQuery(
String SQL,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteNonQuery Overload List


ExecuteNonQueryParametrized Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.ExecuteNonQueryParametrized Method

Overload List

int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[]);

int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[],Int32);

int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[],Int32,String);

int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[],String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[])

int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteNonQueryParametrized Overload List


IAptifyDataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[], Int32)

int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteNonQueryParametrized Overload List


IAptifyDataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[], Int32, String)

int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteNonQueryParametrized Overload List


IAptifyDataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[], String)

int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteNonQueryParametrized Overload List


ExecuteScalar Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.ExecuteScalar Method

Overload List

object ExecuteScalar(String);

object ExecuteScalar(String,IAptifyDataAction.DSLCacheSetting);

object ExecuteScalar(String,IAptifyDataAction.DSLCacheSetting,String);

object ExecuteScalar(String,Int32);

object ExecuteScalar(String,Int32,IAptifyDataAction.DSLCacheSetting);

object ExecuteScalar(String,Int32,IAptifyDataAction.DSLCacheSetting,String);

object ExecuteScalar(String,Int32,String);

object ExecuteScalar(String,String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.ExecuteScalar Method (String)

object ExecuteScalar(
String SQL
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalar Overload List


IAptifyDataAction.ExecuteScalar Method (String, DSLCacheSetting)

object ExecuteScalar(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalar Overload List


IAptifyDataAction.ExecuteScalar Method (String, DSLCacheSetting, String)

object ExecuteScalar(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalar Overload List


IAptifyDataAction.ExecuteScalar Method (String, Int32)

object ExecuteScalar(
String SQL,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalar Overload List


IAptifyDataAction.ExecuteScalar Method (String, Int32, DSLCacheSetting)

object ExecuteScalar(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalar Overload List


IAptifyDataAction.ExecuteScalar Method (String, Int32, DSLCacheSetting, String)

object ExecuteScalar(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalar Overload List


IAptifyDataAction.ExecuteScalar Method (String, Int32, String)

object ExecuteScalar(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalar Overload List


IAptifyDataAction.ExecuteScalar Method (String, String)

object ExecuteScalar(
String SQL,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalar Overload List


ExecuteScalarParametrized Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.ExecuteScalarParametrized Method

Overload List

object ExecuteScalarParametrized(String,CommandType,IDataParameter[]);

object ExecuteScalarParametrized(String,CommandType,IDataParameter[],Int32);

object ExecuteScalarParametrized(String,CommandType,IDataParameter[],Int32,String);

object ExecuteScalarParametrized(String,CommandType,IDataParameter[],String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[])

object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalarParametrized Overload List


IAptifyDataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[], Int32)

object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalarParametrized Overload List


IAptifyDataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[], Int32, String)

object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalarParametrized Overload List


IAptifyDataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[], String)

object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.ExecuteScalarParametrized Overload List


GetDataParameter Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.GetDataParameter Method

Overload List

IDataParameter GetDataParameter();

IDataParameter GetDataParameter(String);

IDataParameter GetDataParameter(String,SqlDbType);

IDataParameter GetDataParameter(String,SqlDbType,Int32,Object);

IDataParameter GetDataParameter(String,SqlDbType,Object);

IDataParameter GetDataParameter(String,Object);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.GetDataParameter Method ()

IDataParameter GetDataParameter();

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataParameter Overload List


IAptifyDataAction.GetDataParameter Method (String)

IDataParameter GetDataParameter(
String Name
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataParameter Overload List


IAptifyDataAction.GetDataParameter Method (String, SqlDbType)

IDataParameter GetDataParameter(
String Name,
SqlDbType DataType
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataParameter Overload List


IAptifyDataAction.GetDataParameter Method (String, SqlDbType, Int32, Object)

IDataParameter GetDataParameter(
String Name,
SqlDbType DataType,
Int32 Size,
Object Value
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataParameter Overload List


IAptifyDataAction.GetDataParameter Method (String, SqlDbType, Object)

IDataParameter GetDataParameter(
String Name,
SqlDbType DataType,
Object Value
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataParameter Overload List


IAptifyDataAction.GetDataParameter Method (String, Object)

IDataParameter GetDataParameter(
String Name,
Object Value
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataParameter Overload List


GetDataSet Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.GetDataSet Method

Overload List

DataSet GetDataSet(String);

DataSet GetDataSet(String,IAptifyDataAction.DSLCacheSetting);

DataSet GetDataSet(String,IAptifyDataAction.DSLCacheSetting,String);

DataSet GetDataSet(String,Int32);

DataSet GetDataSet(String,Int32,IAptifyDataAction.DSLCacheSetting);

DataSet GetDataSet(String,Int32,IAptifyDataAction.DSLCacheSetting,String);

DataSet GetDataSet(String,Int32,String);

DataSet GetDataSet(String,String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.GetDataSet Method (String)

DataSet GetDataSet(
String SQL
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSet Overload List


IAptifyDataAction.GetDataSet Method (String, DSLCacheSetting)

DataSet GetDataSet(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSet Overload List


IAptifyDataAction.GetDataSet Method (String, DSLCacheSetting, String)

DataSet GetDataSet(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSet Overload List


IAptifyDataAction.GetDataSet Method (String, Int32)

DataSet GetDataSet(
String SQL,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSet Overload List


IAptifyDataAction.GetDataSet Method (String, Int32, DSLCacheSetting)

DataSet GetDataSet(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSet Overload List


IAptifyDataAction.GetDataSet Method (String, Int32, DSLCacheSetting, String)

DataSet GetDataSet(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSet Overload List


IAptifyDataAction.GetDataSet Method (String, Int32, String)

DataSet GetDataSet(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSet Overload List


IAptifyDataAction.GetDataSet Method (String, String)

DataSet GetDataSet(
String SQL,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSet Overload List


GetDataSetParametrized Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.GetDataSetParametrized Method

Overload List

DataSet GetDataSetParametrized(String,CommandType,IDataParameter[]);

DataSet GetDataSetParametrized(String,CommandType,IDataParameter[],Int32);

DataSet GetDataSetParametrized(String,CommandType,IDataParameter[],Int32,String);

DataSet GetDataSetParametrized(String,CommandType,IDataParameter[],String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.GetDataSetParametrized Method (String, CommandType, IDataParameter[])

DataSet GetDataSetParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSetParametrized Overload List


IAptifyDataAction.GetDataSetParametrized Method (String, CommandType, IDataParameter[], Int32)

DataSet GetDataSetParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSetParametrized Overload List


IAptifyDataAction.GetDataSetParametrized Method (String, CommandType, IDataParameter[], Int32, String)

DataSet GetDataSetParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSetParametrized Overload List


IAptifyDataAction.GetDataSetParametrized Method (String, CommandType, IDataParameter[], String)

DataSet GetDataSetParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataSetParametrized Overload List


GetDataTable Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.GetDataTable Method

Overload List

DataTable GetDataTable(String);

DataTable GetDataTable(String,IAptifyDataAction.DSLCacheSetting);

DataTable GetDataTable(String,IAptifyDataAction.DSLCacheSetting,String);

DataTable GetDataTable(String,Int32);

DataTable GetDataTable(String,Int32,IAptifyDataAction.DSLCacheSetting);

DataTable GetDataTable(String,Int32,IAptifyDataAction.DSLCacheSetting,String);

DataTable GetDataTable(String,Int32,String);

DataTable GetDataTable(String,String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.GetDataTable Method (String)

DataTable GetDataTable(
String SQL
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTable Overload List


IAptifyDataAction.GetDataTable Method (String, DSLCacheSetting)

DataTable GetDataTable(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTable Overload List


IAptifyDataAction.GetDataTable Method (String, DSLCacheSetting, String)

DataTable GetDataTable(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTable Overload List


IAptifyDataAction.GetDataTable Method (String, Int32)

DataTable GetDataTable(
String SQL,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTable Overload List


IAptifyDataAction.GetDataTable Method (String, Int32, DSLCacheSetting)

DataTable GetDataTable(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTable Overload List


IAptifyDataAction.GetDataTable Method (String, Int32, DSLCacheSetting, String)

DataTable GetDataTable(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTable Overload List


IAptifyDataAction.GetDataTable Method (String, Int32, String)

DataTable GetDataTable(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTable Overload List


IAptifyDataAction.GetDataTable Method (String, String)

DataTable GetDataTable(
String SQL,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTable Overload List


GetDataTableParametrized Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.GetDataTableParametrized Method

Overload List

DataTable GetDataTableParametrized(String,CommandType,IDataParameter[]);

DataTable GetDataTableParametrized(String,CommandType,IDataParameter[],Int32);

DataTable GetDataTableParametrized(String,CommandType,IDataParameter[],Int32,String);

DataTable GetDataTableParametrized(String,CommandType,IDataParameter[],String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[])

DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTableParametrized Overload List


IAptifyDataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[], Int32)

DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTableParametrized Overload List


IAptifyDataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[], Int32, String)

DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTableParametrized Overload List


IAptifyDataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[], String)

DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetDataTableParametrized Overload List


GetXMLReader Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.GetXMLReader Method

Overload List

XmlReader GetXMLReader(String);

XmlReader GetXMLReader(String,Int32);

XmlReader GetXMLReader(String,Int32,String);

XmlReader GetXMLReader(String,String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.GetXMLReader Method (String)

XmlReader GetXMLReader(
String SQL
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetXMLReader Overload List


IAptifyDataAction.GetXMLReader Method (String, Int32)

XmlReader GetXMLReader(
String SQL,
Int32 QueryTimeout
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetXMLReader Overload List


IAptifyDataAction.GetXMLReader Method (String, Int32, String)

XmlReader GetXMLReader(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetXMLReader Overload List


IAptifyDataAction.GetXMLReader Method (String, String)

XmlReader GetXMLReader(
String SQL,
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.GetXMLReader Overload List


InTransaction Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.InTransaction Method

Overload List

bool InTransaction();

bool InTransaction(String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.InTransaction Method ()

bool InTransaction();

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.InTransaction Overload List


IAptifyDataAction.InTransaction Method (String)

bool InTransaction(
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.InTransaction Overload List


RollbackTransaction Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyDataAction.RollbackTransaction Method

Overload List

void RollbackTransaction();

void RollbackTransaction(String);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace


IAptifyDataAction.RollbackTransaction Method ()

void RollbackTransaction();

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.RollbackTransaction Overload List


IAptifyDataAction.RollbackTransaction Method (String)

void RollbackTransaction(
String TransactionID
);

See Also

IAptifyDataAction Interface | Aptify.Framework.DataServices Namespace | IAptifyDataAction.RollbackTransaction Overload List


IAptifyDataAction.CacheWorkingSet Enumeration

public enum IAptifyDataAction.CacheWorkingSet

Members

Member Name | Description
All |
Tables |
Sets |
Scalars |

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

Aptify.Framework.DataServices Namespace


IAptifyDataAction.DSLCacheSetting Enumeration

public enum IAptifyDataAction.DSLCacheSetting

Members

Member Name | Description
UseCache |
RefreshCache |
BypassCache |

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

Aptify.Framework.DataServices Namespace


UISettings Class

For a list of all members of this type, see UISettings Members.

System.Object
UISettings

public class UISettings : ISerializable, ISupportsAttributes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

UISettings Members | Aptify.Framework.DataServices Namespace


UISettings Members

UISettings overview

Public Instance Constructors

UISettings Constructor This special constructor is used for deserialization of the object

Public Instance Properties

ColorScheme | Color Scheme used by Aptify User Interface components to control appearance. Examples include the Main Form's Ribbon Toolbar and the Entity List View component.
EnhancedUI | When True, the Form Template User Interface will be drawn with gradient fills and the Form Components will have transparent backgrounds. Transparency increases the redraw time. If the redraw with EnhancedUI is too expensive, it can be turned off. When EnhancedUI is set to False, the Form Template and control backgrounds will be a solid color.
MSOfficeColorScheme | Returns the User's current Color Scheme for MS Office. One of three possible values: Blue (default), Silver or Black.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttribute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Support for ISerializable interface for serialization of object data
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UISettings Class | Aptify.Framework.DataServices Namespace


UISettings Constructor

This special constructor is used for deserialization of the object

public UISettings(
SerializationInfo info,
StreamingContext context
);

Parameters

info
context

See Also

UISettings Class | Aptify.Framework.DataServices Namespace


UISettings Properties

The properties of the UISettings class are listed below. For a complete list of UISettings class members, see the UISettings Members topic.

Public Instance Properties

ColorScheme | Color Scheme used by Aptify User Interface components to control appearance. Examples include the Main Form's Ribbon Toolbar and the Entity List View component.
EnhancedUI | When True, the Form Template User Interface will be drawn with gradient fills and the Form Components will have transparent backgrounds. Transparency increases the redraw time. If the redraw with EnhancedUI is too expensive, it can be turned off. When EnhancedUI is set to False, the Form Template and control backgrounds will be a solid color.
MSOfficeColorScheme | Returns the User's current Color Scheme for MS Office. One of three possible values: Blue (default), Silver or Black.

See Also

UISettings Class | Aptify.Framework.DataServices Namespace


ColorScheme Property

Aptify 5.0 Software Development Kit (SDK)

UISettings.ColorScheme Property

Color Scheme used by Aptify User Interface components to control appearance. Examples include the Main Form's Ribbon Toolbar and the Entity List View component.

public virtual AptifyColorScheme ColorScheme {get; set;}

Property Value

Remarks

See Also

UISettings Class | Aptify.Framework.DataServices Namespace


EnhancedUI Property

Aptify 5.0 Software Development Kit (SDK)

UISettings.EnhancedUI Property

When True, the Form Template User Interface will be drawn with gradient fills and the Form Components will have transparent backgrounds. Transparency increases the redraw time. If the redraw with EnhancedUI is too expensive, it can be turned off. When EnhancedUI is set to False, the Form Template and control backgrounds will be a solid color.

public Boolean EnhancedUI {get;}

Property Value

Remarks

See Also

UISettings Class | Aptify.Framework.DataServices Namespace


MSOfficeColorScheme Property

Aptify 5.0 Software Development Kit (SDK)

UISettings.MSOfficeColorScheme Property

Returns the User's current Color Scheme for MS Office. One of three possible values: Blue (default), Silver or Black.

public AptifyColorScheme MSOfficeColorScheme {get;}

Property Value

Remarks

See Also

UISettings Class | Aptify.Framework.DataServices Namespace


UISettings Methods

The methods of the UISettings class are listed below. For a complete list of UISettings class members, see the UISettings Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttribute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Support for ISerializable interface for serialization of object data
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UISettings Class | Aptify.Framework.DataServices Namespace


UISettings.GetAttribute Method

public Attribute GetAttribute(
String Name
);

Implements

ISupportsAttributes.

See Also

UISettings Class | Aptify.Framework.DataServices Namespace


UISettings.GetObjectData Method

Support for ISerializable interface for serialization of object data

public void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Parameters

info
context

Implements

ISerializable.

Remarks

See Also

UISettings Class | Aptify.Framework.DataServices Namespace


UserCredentials Class

This class contains a set of data points related to user login credentials that are used by other framework and application objects to authenticate a user.

For a list of all members of this type, see UserCredentials Members.

System.Object
UserCredentials

public class UserCredentials : ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DataServices

Assembly: IAptifyDataServices (in IAptifyDataServices.dll)

See Also

UserCredentials Members | Aptify.Framework.DataServices Namespace


UserCredentials Members

UserCredentials overview

Public Instance Constructors

UserCredentials Overloaded. Initializes a new instance of the UserCredentials class.

Public Instance Properties

AllowGUI |
Application |
AptifyUserID |
ConnectionString |
CultureID |
DefaultTransactionID |
EntitiesDatabase |
Parameters |
Password |
Server |
SQLLogin |
SysAdminUser |
Trusted |
UI |
UserEntityRelations | Stores the IDs of related Entity records for the current Aptify User, defined by AptifyUserID. Typically, this will contain the Employees Record ID for the current user. During the Login process, this dictionary is populated with information from the UserEntityRelations sub-type.
UsersDatabase |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Support for ISerializable interface for serialization of object data
GetType (inherited from Object) | Gets the Type of the current instance.
GetUserRelatedRecordID | Given an Entity Name, return the Record ID for that Entity which is linked to the current User. If no related Entity information is found, a value of -1 will be returned. The source information come from the UserEntityRelations property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


UserCredentials Constructor

Overload List

This special constructor is used for deserialization of the object

public UserCredentials(SerializationInfo,StreamingContext);

public UserCredentials(String,String,String,Boolean,Int64,String,String,CredentialParameters,Boolean,Int64,Boolean);

public UserCredentials(String,String,String,String,Boolean,Int64,String,String,CredentialParameters,Boolean,Int64,Boolean);

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


UserCredentials Constructor (String, String, String, Boolean, Int64, String, String, CredentialParameters, Boolean, Int64, Boolean)

public UserCredentials(
String Server,
String UsersDatabase,
String EntitiesDatabase,
Boolean Trusted,
Int64 AptifyUserID,
String SQLLogin,
String Password,
CredentialParameters Parameters,
Boolean AllowGUI,
Int64 CultureID,
Boolean SysAdminUser
);

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace | UserCredentials Constructor Overload List


UserCredentials Constructor (String, String, String, String, Boolean, Int64, String, String, CredentialParameters, Boolean, Int64, Boolean)

public UserCredentials(
String Application,
String Server,
String UsersDatabase,
String EntitiesDatabase,
Boolean Trusted,
Int64 AptifyUserID,
String SQLLogin,
String Password,
CredentialParameters Parameters,
Boolean AllowGUI,
Int64 CultureID,
Boolean SysAdminUser
);

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace | UserCredentials Constructor Overload List


UserCredentials Constructor (SerializationInfo, StreamingContext)

This special constructor is used for deserialization of the object

public UserCredentials(
SerializationInfo info,
StreamingContext context
);

Parameters

info
context

Remarks

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace | UserCredentials Constructor Overload List


UserCredentials Properties

The properties of the UserCredentials class are listed below. For a complete list of UserCredentials class members, see the UserCredentials Members topic.

Public Instance Properties

AllowGUI |
Application |
AptifyUserID |
ConnectionString |
CultureID |
DefaultTransactionID |
EntitiesDatabase |
Parameters |
Password |
Server |
SQLLogin |
SysAdminUser |
Trusted |
UI |
UserEntityRelations | Stores the IDs of related Entity records for the current Aptify User, defined by AptifyUserID. Typically, this will contain the Employees Record ID for the current user. During the Login process, this dictionary is populated with information from the UserEntityRelations sub-type.
UsersDatabase |

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


AllowGUI Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.AllowGUI Property

public Boolean AllowGUI {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.Application Property

public String Application {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


AptifyUserID Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.AptifyUserID Property

public Int64 AptifyUserID {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


ConnectionString Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.ConnectionString Property

public String ConnectionString {get; set;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


CultureID Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.CultureID Property

public Int64 CultureID {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


DefaultTransactionID Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.DefaultTransactionID Property

public String DefaultTransactionID {get; set;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


EntitiesDatabase Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.EntitiesDatabase Property

public String EntitiesDatabase {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


Parameters Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.Parameters Property

public CredentialParameters Parameters {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


Password Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.Password Property

public String Password {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


Server Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.Server Property

public String Server {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


SQLLogin Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.SQLLogin Property

public String SQLLogin {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


SysAdminUser Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.SysAdminUser Property

public Boolean SysAdminUser {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


Trusted Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.Trusted Property

public Boolean Trusted {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


UI Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.UI Property

public UISettings UI {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


UserEntityRelations Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.UserEntityRelations Property

Stores the IDs of related Entity records for the current Aptify User, defined by AptifyUserID. Typically, this will contain the Employees Record ID for the current user. During the Login process, this dictionary is populated with information from the UserEntityRelations sub-type.

public Dictionary<TKey,TValue> UserEntityRelations {get;}

Property Value

Remarks

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


UsersDatabase Property

Aptify 5.0 Software Development Kit (SDK)

UserCredentials.UsersDatabase Property

public String UsersDatabase {get;}

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


UserCredentials Methods

The methods of the UserCredentials class are listed below. For a complete list of UserCredentials class members, see the UserCredentials Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Support for ISerializable interface for serialization of object data
GetType (inherited from Object) | Gets the Type of the current instance.
GetUserRelatedRecordID | Given an Entity Name, return the Record ID for that Entity which is linked to the current User. If no related Entity information is found, a value of -1 will be returned. The source information come from the UserEntityRelations property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


UserCredentials.GetObjectData Method

Support for ISerializable interface for serialization of object data

public void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Parameters

info
context

Implements

ISerializable.

Remarks

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


UserCredentials.GetUserRelatedRecordID Method

Given an Entity Name, return the Record ID for that Entity which is linked to the current User. If no related Entity information is found, a value of -1 will be returned. The source information come from the UserEntityRelations property.

public long GetUserRelatedRecordID(
String EntityName
);

Parameters

EntityName
The name of the related Entity for which the Related Record ID will be returned.

Return Value

Remarks

See Also

UserCredentials Class | Aptify.Framework.DataServices Namespace


Aptify.Framework.DataServices.SQLDataServices

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.DataServices.SQLDataServices Namespace

This namespace contains the SQL Server-specific implementation of Aptify.Framework.DataServices. Note that developers should not reference AptifySQLDataServices; all work should be done through references to objects in the Aptify.Framework.DataServices namespace. See Aptify.Framework.DataServices for additional details.

Namespace hierarchy

Classes

Class | Description
AsyncRetrieveData |
Constants |
DataAction |


AsyncRetrieveData Class

For a list of all members of this type, see AsyncRetrieveData Members.

System.Object
AsyncRetrieveData

public class AsyncRetrieveData : IAptifyAsyncRetrieveData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataServices.SQLDataServices

Assembly: AptifySQLDataServices (in AptifySQLDataServices.dll)

See Also

AsyncRetrieveData Members | Aptify.Framework.DataServices.SQLDataServices Namespace


AsyncRetrieveData Members

AsyncRetrieveData overview

Public Instance Constructors

AsyncRetrieveData Overloaded. Initializes a new instance of the AsyncRetrieveData class.

Public Instance Properties

ConnectionString
DataReader
InProcess
LastError
StillExecuting
UserCredentials

Public Instance Methods

BeginGetDataReader | Overloaded.
CancelGetDataReader |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


AsyncRetrieveData Constructor

Overload List

public AsyncRetrieveData(UserCredentials);

public AsyncRetrieveData(UserCredentials,String);

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


AsyncRetrieveData Constructor (UserCredentials)

public AsyncRetrieveData(
UserCredentials UserCredentials
);

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace | AsyncRetrieveData Constructor Overload List


AsyncRetrieveData Constructor (UserCredentials, String)

public AsyncRetrieveData(
UserCredentials UserCredentials,
String ConnectionString
);

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace | AsyncRetrieveData Constructor Overload List


AsyncRetrieveData Properties

The properties of the AsyncRetrieveData class are listed below. For a complete list of AsyncRetrieveData class members, see the AsyncRetrieveData Members topic.

Public Instance Properties

ConnectionString
DataReader
InProcess
LastError
StillExecuting
UserCredentials

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


ConnectionString Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.ConnectionString Property

public String ConnectionString {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataReader Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.DataReader Property

public IDataReader DataReader {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


InProcess Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.InProcess Property

public Boolean InProcess {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


LastError Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.LastError Property

public String LastError {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


StillExecuting Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.StillExecuting Property

public Boolean StillExecuting {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.UserCredentials Property

public UserCredentials UserCredentials {get;}

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


AsyncRetrieveData Methods

The methods of the AsyncRetrieveData class are listed below. For a complete list of AsyncRetrieveData class members, see the AsyncRetrieveData Members topic.

Public Instance Methods

BeginGetDataReader | Overloaded.
CancelGetDataReader |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


BeginGetDataReader Method

Aptify 5.0 Software Development Kit (SDK)

AsyncRetrieveData.BeginGetDataReader Method

Overload List

public void BeginGetDataReader(String);

public void BeginGetDataReader(String,CommandBehavior);

public void BeginGetDataReader(String,CommandBehavior,IAptifyAsyncRetrieveData.DataReaderDelegate);

public void BeginGetDataReader(String,CommandBehavior,Int32);

public void BeginGetDataReader(String,CommandBehavior,Int32,IAptifyAsyncRetrieveData.DataReaderDelegate);

public void BeginGetDataReader(String,Int32);

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


AsyncRetrieveData.BeginGetDataReader Method (String)

public void BeginGetDataReader(
String SQL
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior)

public void BeginGetDataReader(
String SQL,
CommandBehavior CommandBehavior
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior, DataReaderDelegate)

public void BeginGetDataReader(
String SQL,
CommandBehavior CommandBehavior,
IAptifyAsyncRetrieveData.DataReaderDelegate drDelegate
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior, Int32)

public void BeginGetDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.BeginGetDataReader Method (String, CommandBehavior, Int32, DataReaderDelegate)

public void BeginGetDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout,
IAptifyAsyncRetrieveData.DataReaderDelegate drDelegate
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.BeginGetDataReader Method (String, Int32)

public void BeginGetDataReader(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace | AsyncRetrieveData.BeginGetDataReader Overload List


AsyncRetrieveData.CancelGetDataReader Method

public void CancelGetDataReader();

Implements

IAptifyAsyncRetrieveData.

See Also

AsyncRetrieveData Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants Class

For a list of all members of this type, see Constants Members.

System.Object
Constants

public class Constants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataServices.SQLDataServices

Assembly: AptifySQLDataServices (in AptifySQLDataServices.dll)

See Also

Constants Members | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants Members

Constants overview

Public Static Fields

ARGUMENT_OUT_OF_RANGE
BEGIN_GET_DATA_READER_EXCEPTION_MESSAGE
CANCEL_GET_DATA_READER_EXCEPTION
CANCEL_GET_DATA_READER_FAILED
CANNOT_CREATE_SQLDATA_OBJECT
CANNOT_GET_DATA_READER
DATA_READER_CANNOT_EXECUTE
DATA_READER_STILL_EXECUTING
DATAREADER_OPERATION_EXCEPTION
DATASET_OPERATION_EXCEPTION
DATATABLE_OPERATION_EXCEPTION
ISOLATION_LEVEL_MISMATCH
NO_MATCHING_OPEN_TRANSACTION
NON_QUERY_OPERATION_EXCEPTION
OPERATION_CANCELED_BY_USER
SCALAR_OPERATION_EXCEPTION
SQL_TIMEOUT_MESSAGE
TRANSACTION_NOT_ACTIVE
TRANSACTION_NOT_FOUND
UNABLE_TO_BEGIN
UNABLE_TO_COMMIT
UNABLE_TO_ROLLBACK
XMLREADER_OPERATION_EXCEPTION

Public Static Methods

GetBeginDataReaderException |
GetCannotCreateSQLDataObjectMessage |
GetIsolationMismatchMessage |
GetReaderException |
GetResourceString |
GetSQLTimedOutException | Overloaded.
GetTransactionNotActiveMessage |
GetTransactionNotFoundMessage |
NoMatchingOpenTransactionMessage |

Public Instance Constructors

Constants Constructor Initializes a new instance of the Constants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants Constructor

Initializes a new instance of the Constants class.

public Constants();

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants Fields

The fields of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Fields

ARGUMENT_OUT_OF_RANGE
BEGIN_GET_DATA_READER_EXCEPTION_MESSAGE
CANCEL_GET_DATA_READER_EXCEPTION
CANCEL_GET_DATA_READER_FAILED
CANNOT_CREATE_SQLDATA_OBJECT
CANNOT_GET_DATA_READER
DATA_READER_CANNOT_EXECUTE
DATA_READER_STILL_EXECUTING
DATAREADER_OPERATION_EXCEPTION
DATASET_OPERATION_EXCEPTION
DATATABLE_OPERATION_EXCEPTION
ISOLATION_LEVEL_MISMATCH
NO_MATCHING_OPEN_TRANSACTION
NON_QUERY_OPERATION_EXCEPTION
OPERATION_CANCELED_BY_USER
SCALAR_OPERATION_EXCEPTION
SQL_TIMEOUT_MESSAGE
TRANSACTION_NOT_ACTIVE
TRANSACTION_NOT_FOUND
UNABLE_TO_BEGIN
UNABLE_TO_COMMIT
UNABLE_TO_ROLLBACK
XMLREADER_OPERATION_EXCEPTION

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.ARGUMENT_OUT_OF_RANGE Field

public const ARGUMENT_OUT_OF_RANGE ARGUMENT_OUT_OF_RANGE = "ARGUMENT_OUT_OF_RANGE";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.BEGIN_GET_DATA_READER_EXCEPTION_MESSAGE Field

public const BEGIN_GET_DATA_READER_EXCEPTION_MESSAGE BEGIN_GET_DATA_READER_EXCEPTION_MESSAGE = "BEGIN_GET_DATA_READER_EXCEPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.CANCEL_GET_DATA_READER_EXCEPTION Field

public const CANCEL_GET_DATA_READER_EXCEPTION CANCEL_GET_DATA_READER_EXCEPTION = "CANCEL_GET_DATA_READER_EXCEPTION";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.CANCEL_GET_DATA_READER_FAILED Field

public const CANCEL_GET_DATA_READER_FAILED CANCEL_GET_DATA_READER_FAILED = "CANCELED_GET_DATA_READER";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.CANNOT_CREATE_SQLDATA_OBJECT Field

public const CANNOT_CREATE_SQLDATA_OBJECT CANNOT_CREATE_SQLDATA_OBJECT = "CANNOT_CREATE_SQLDATA_OBJECT";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.CANNOT_GET_DATA_READER Field

public const CANNOT_GET_DATA_READER CANNOT_GET_DATA_READER = "CANNOT_GET_DATA_READER";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.DATA_READER_CANNOT_EXECUTE Field

public const DATA_READER_CANNOT_EXECUTE DATA_READER_CANNOT_EXECUTE = "DATA_READER_CANNOT_EXECUTE";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.DATA_READER_STILL_EXECUTING Field

public const DATA_READER_STILL_EXECUTING DATA_READER_STILL_EXECUTING = "DATA_READER_STILL_EXECUTING";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.DATAREADER_OPERATION_EXCEPTION Field

public const DATAREADER_OPERATION_EXCEPTION DATAREADER_OPERATION_EXCEPTION = "DATAREADER_OPERATION_EXCEPTION";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.DATASET_OPERATION_EXCEPTION Field

public const DATASET_OPERATION_EXCEPTION DATASET_OPERATION_EXCEPTION = "DATASET_OPERATION_EXCEPTION";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.DATATABLE_OPERATION_EXCEPTION Field

public const DATATABLE_OPERATION_EXCEPTION DATATABLE_OPERATION_EXCEPTION = "DATATABLE_OPERATION_EXCEPTION";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.ISOLATION_LEVEL_MISMATCH Field

public const ISOLATION_LEVEL_MISMATCH ISOLATION_LEVEL_MISMATCH = "ISOLATION_LEVEL_MISMATCH";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.NO_MATCHING_OPEN_TRANSACTION Field

public const NO_MATCHING_OPEN_TRANSACTION NO_MATCHING_OPEN_TRANSACTION = "NO_MATCHING_OPEN_TRANSACTION";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.NON_QUERY_OPERATION_EXCEPTION Field

public const NON_QUERY_OPERATION_EXCEPTION NON_QUERY_OPERATION_EXCEPTION = "NON_QUERY_OPERATION_EXCEPTION";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.OPERATION_CANCELED_BY_USER Field

public const OPERATION_CANCELED_BY_USER OPERATION_CANCELED_BY_USER = "OPERATION_CANCELED_BY_USER";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.SCALAR_OPERATION_EXCEPTION Field

public const SCALAR_OPERATION_EXCEPTION SCALAR_OPERATION_EXCEPTION = "SCALAR_OPERATION_EXCEPTION";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.SQL_TIMEOUT_MESSAGE Field

public const SQL_TIMEOUT_MESSAGE SQL_TIMEOUT_MESSAGE = "SQL_TIMEOUT_MESSAGE";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.TRANSACTION_NOT_ACTIVE Field

public const TRANSACTION_NOT_ACTIVE TRANSACTION_NOT_ACTIVE = "TRANSACTION_NOT_ACTIVE";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.TRANSACTION_NOT_FOUND Field

public const TRANSACTION_NOT_FOUND TRANSACTION_NOT_FOUND = "TRANSACTION_NOT_FOUND";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.UNABLE_TO_BEGIN Field

public const UNABLE_TO_BEGIN UNABLE_TO_BEGIN = "UNABLE_TO_BEGIN";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.UNABLE_TO_COMMIT Field

public const UNABLE_TO_COMMIT UNABLE_TO_COMMIT = "UNABLE_TO_COMMIT";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.UNABLE_TO_ROLLBACK Field

public const UNABLE_TO_ROLLBACK UNABLE_TO_ROLLBACK = "UNABLE_TO_ROLLBACK";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.XMLREADER_OPERATION_EXCEPTION Field

public const XMLREADER_OPERATION_EXCEPTION XMLREADER_OPERATION_EXCEPTION = "XMLREADER_OPERATION_EXCEPTION";

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants Methods

The methods of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Methods

GetBeginDataReaderException |
GetCannotCreateSQLDataObjectMessage |
GetIsolationMismatchMessage |
GetReaderException |
GetResourceString |
GetSQLTimedOutException | Overloaded.
GetTransactionNotActiveMessage |
GetTransactionNotFoundMessage |
NoMatchingOpenTransactionMessage |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.GetBeginDataReaderException Method

public static ApplicationException GetBeginDataReaderException(
Exception Ex
);

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.GetCannotCreateSQLDataObjectMessage Method

public static string GetCannotCreateSQLDataObjectMessage();

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.GetIsolationMismatchMessage Method

public static string GetIsolationMismatchMessage(
String Current,
String Expected
);

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.GetReaderException Method

public static ApplicationException GetReaderException(
String SQL,
Exception InnerException
);

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.GetResourceString Method

public static string GetResourceString(
String ResourceKey
);

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


GetSQLTimedOutException Method

Aptify 5.0 Software Development Kit (SDK)

Constants.GetSQLTimedOutException Method

Overload List

public static AptifyDataTimeoutException GetSQLTimedOutException(SqlException,String,String);

public static AptifyDataTimeoutException GetSQLTimedOutException(String);

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.GetSQLTimedOutException Method (SqlException, String, String)

public static AptifyDataTimeoutException GetSQLTimedOutException(
SqlException ex,
String SQL,
String ConnectionString
);

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace | Constants.GetSQLTimedOutException Overload List


Constants.GetSQLTimedOutException Method (String)

public static AptifyDataTimeoutException GetSQLTimedOutException(
String SQL
);

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace | Constants.GetSQLTimedOutException Overload List


Constants.GetTransactionNotActiveMessage Method

public static string GetTransactionNotActiveMessage(
String TransactionID
);

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.GetTransactionNotFoundMessage Method

public static string GetTransactionNotFoundMessage(
String TransactionID
);

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Constants.NoMatchingOpenTransactionMessage Method

public static string NoMatchingOpenTransactionMessage(
String Operation,
String TransactionID
);

See Also

Constants Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction Class

For a list of all members of this type, see DataAction Members.

System.Object
DataAction

public class DataAction : IAptifyDataAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DataServices.SQLDataServices

Assembly: AptifySQLDataServices (in AptifySQLDataServices.dll)

See Also

DataAction Members | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction Members

DataAction overview

Public Instance Constructors

DataAction Overloaded. Initializes a new instance of the DataAction class.

Public Instance Properties

TranCount | Overloaded.
UserCredentials |

Public Instance Methods

BeginTransaction | Overloaded.
ClearDataCache |
CommitTransaction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteDataReader | Overloaded.
ExecuteDataReaderParametrized | Overloaded.
ExecuteNonQuery | Overloaded.
ExecuteNonQueryParametrized | Overloaded.
ExecuteScalar | Overloaded.
ExecuteScalarParametrized | Overloaded.
GetDataParameter | Overloaded.
GetDataSet | Overloaded.
GetDataSetParametrized | Overloaded.
GetDataTable | Overloaded.
GetDataTableParametrized | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXMLReader | Overloaded.
InnerExecuteNonQuery |
InnerExecuteScalar |
InTransaction | Overloaded.
RollbackTransaction | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction Constructor

Overload List

public DataAction(UserCredentials);

public DataAction(UserCredentials,String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction Constructor (UserCredentials)

public DataAction(
UserCredentials UserCredentials
);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction Constructor Overload List


DataAction Constructor (UserCredentials, String)

public DataAction(
UserCredentials UserCredentials,
String ConnectionString
);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction Constructor Overload List


DataAction Properties

The properties of the DataAction class are listed below. For a complete list of DataAction class members, see the DataAction Members topic.

Public Instance Properties

TranCount | Overloaded.
UserCredentials |

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


Int32 Property

Aptify 5.0 Software Development Kit (SDK)

DataAction.Int32 Property

Overload List

public Int32 TranCount {get;}

public Int32 this[String] {get;}

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


TranCount Property

Aptify 5.0 Software Development Kit (SDK)

DataAction.TranCount Property

public Int32 TranCount {get;}

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.Int32 Overload List


TranCount Property (String)

Aptify 5.0 Software Development Kit (SDK)

DataAction.TranCount Property (String)

public Int32 this[
String TransactionID
] {get;}

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.Int32 Overload List


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

DataAction.UserCredentials Property

public UserCredentials UserCredentials {get;}

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction Methods

The methods of the DataAction class are listed below. For a complete list of DataAction class members, see the DataAction Members topic.

Public Instance Methods

BeginTransaction | Overloaded.
ClearDataCache |
CommitTransaction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteDataReader | Overloaded.
ExecuteDataReaderParametrized | Overloaded.
ExecuteNonQuery | Overloaded.
ExecuteNonQueryParametrized | Overloaded.
ExecuteScalar | Overloaded.
ExecuteScalarParametrized | Overloaded.
GetDataParameter | Overloaded.
GetDataSet | Overloaded.
GetDataSetParametrized | Overloaded.
GetDataTable | Overloaded.
GetDataTableParametrized | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXMLReader | Overloaded.
InnerExecuteNonQuery |
InnerExecuteScalar |
InTransaction | Overloaded.
RollbackTransaction | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


BeginTransaction Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.BeginTransaction Method

Overload List

public string BeginTransaction();

public string BeginTransaction(Boolean);

public string BeginTransaction(IsolationLevel);

public string BeginTransaction(IsolationLevel,Boolean);

public string BeginTransaction(IsolationLevel,Boolean,String);

public string BeginTransaction(String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.BeginTransaction Method ()

public string BeginTransaction();

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.BeginTransaction Method (Boolean)

public string BeginTransaction(
Boolean NewTransaction
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.BeginTransaction Method (IsolationLevel)

public string BeginTransaction(
IsolationLevel IsolationLevel
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.BeginTransaction Method (IsolationLevel, Boolean)

public string BeginTransaction(
IsolationLevel IsolationLevel,
Boolean NewTransaction
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.BeginTransaction Method (IsolationLevel, Boolean, String)

public string BeginTransaction(
IsolationLevel IsolationLevel,
Boolean NewTransaction,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.BeginTransaction Method (String)

public string BeginTransaction(
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.BeginTransaction Overload List


DataAction.ClearDataCache Method

public void ClearDataCache(
IAptifyDataAction.CacheWorkingSet WorkingSet
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


CommitTransaction Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.CommitTransaction Method

Overload List

public void CommitTransaction();

public void CommitTransaction(String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.CommitTransaction Method ()

public void CommitTransaction();

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.CommitTransaction Overload List


DataAction.CommitTransaction Method (String)

public void CommitTransaction(
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.CommitTransaction Overload List


ExecuteDataReader Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteDataReader Method

Overload List

public IDataReader ExecuteDataReader(String);

public IDataReader ExecuteDataReader(String,CommandBehavior);

public IDataReader ExecuteDataReader(String,CommandBehavior,Int32);

public IDataReader ExecuteDataReader(String,CommandBehavior,Int32,String);

public IDataReader ExecuteDataReader(String,CommandBehavior,String);

public IDataReader ExecuteDataReader(String,Int32);

public IDataReader ExecuteDataReader(String,Int32,String);

public IDataReader ExecuteDataReader(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.ExecuteDataReader Method (String)

public IDataReader ExecuteDataReader(
String SQL
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, CommandBehavior)

public IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, CommandBehavior, Int32)

public IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, CommandBehavior, Int32, String)

public IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, CommandBehavior, String)

public IDataReader ExecuteDataReader(
String SQL,
CommandBehavior CommandBehavior,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, Int32)

public IDataReader ExecuteDataReader(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, Int32, String)

public IDataReader ExecuteDataReader(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReader Overload List


DataAction.ExecuteDataReader Method (String, String)

public IDataReader ExecuteDataReader(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReader Overload List


ExecuteDataReaderParametrized Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteDataReaderParametrized Method

Overload List

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[]);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior,Int32);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior,Int32,String);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],CommandBehavior,String);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],Int32);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],Int32,String);

public IDataReader ExecuteDataReaderParametrized(String,CommandType,IDataParameter[],String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[])

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior, Int32)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior, Int32, String)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], CommandBehavior, String)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
CommandBehavior CommandBehavior,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], Int32)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], Int32, String)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


DataAction.ExecuteDataReaderParametrized Method (String, CommandType, IDataParameter[], String)

public IDataReader ExecuteDataReaderParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteDataReaderParametrized Overload List


ExecuteNonQuery Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteNonQuery Method

Overload List

public int ExecuteNonQuery(String);

public int ExecuteNonQuery(String,Int32);

public int ExecuteNonQuery(String,Int32,String);

public int ExecuteNonQuery(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.ExecuteNonQuery Method (String)

public int ExecuteNonQuery(
String SQL
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteNonQuery Overload List


DataAction.ExecuteNonQuery Method (String, Int32)

public int ExecuteNonQuery(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteNonQuery Overload List


DataAction.ExecuteNonQuery Method (String, Int32, String)

public int ExecuteNonQuery(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteNonQuery Overload List


DataAction.ExecuteNonQuery Method (String, String)

public int ExecuteNonQuery(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteNonQuery Overload List


ExecuteNonQueryParametrized Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteNonQueryParametrized Method

Overload List

public int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[]);

public int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[],Int32);

public int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[],Int32,String);

public int ExecuteNonQueryParametrized(String,CommandType,IDataParameter[],String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[])

public int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteNonQueryParametrized Overload List


DataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[], Int32)

public int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteNonQueryParametrized Overload List


DataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[], Int32, String)

public int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteNonQueryParametrized Overload List


DataAction.ExecuteNonQueryParametrized Method (String, CommandType, IDataParameter[], String)

public int ExecuteNonQueryParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteNonQueryParametrized Overload List


ExecuteScalar Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteScalar Method

Overload List

public object ExecuteScalar(String);

public object ExecuteScalar(String,IAptifyDataAction.DSLCacheSetting);

public object ExecuteScalar(String,IAptifyDataAction.DSLCacheSetting,String);

public object ExecuteScalar(String,Int32);

public object ExecuteScalar(String,Int32,IAptifyDataAction.DSLCacheSetting);

public object ExecuteScalar(String,Int32,IAptifyDataAction.DSLCacheSetting,String);

public object ExecuteScalar(String,Int32,String);

public object ExecuteScalar(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.ExecuteScalar Method (String)

public object ExecuteScalar(
String SQL
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, DSLCacheSetting)

public object ExecuteScalar(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, DSLCacheSetting, String)

public object ExecuteScalar(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, Int32)

public object ExecuteScalar(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, Int32, DSLCacheSetting)

public object ExecuteScalar(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, Int32, DSLCacheSetting, String)

public object ExecuteScalar(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, Int32, String)

public object ExecuteScalar(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalar Overload List


DataAction.ExecuteScalar Method (String, String)

public object ExecuteScalar(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalar Overload List


ExecuteScalarParametrized Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.ExecuteScalarParametrized Method

Overload List

public object ExecuteScalarParametrized(String,CommandType,IDataParameter[]);

public object ExecuteScalarParametrized(String,CommandType,IDataParameter[],Int32);

public object ExecuteScalarParametrized(String,CommandType,IDataParameter[],Int32,String);

public object ExecuteScalarParametrized(String,CommandType,IDataParameter[],String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[])

public object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalarParametrized Overload List


DataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[], Int32)

public object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalarParametrized Overload List


DataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[], Int32, String)

public object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalarParametrized Overload List


DataAction.ExecuteScalarParametrized Method (String, CommandType, IDataParameter[], String)

public object ExecuteScalarParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.ExecuteScalarParametrized Overload List


GetDataParameter Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetDataParameter Method

Overload List

public IDataParameter GetDataParameter();

public IDataParameter GetDataParameter(String);

public IDataParameter GetDataParameter(String,SqlDbType);

public IDataParameter GetDataParameter(String,SqlDbType,Int32,Object);

public IDataParameter GetDataParameter(String,SqlDbType,Object);

public IDataParameter GetDataParameter(String,Object);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.GetDataParameter Method ()

public IDataParameter GetDataParameter();

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataParameter Overload List


DataAction.GetDataParameter Method (String)

public IDataParameter GetDataParameter(
String Name
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataParameter Overload List


DataAction.GetDataParameter Method (String, SqlDbType)

public IDataParameter GetDataParameter(
String Name,
SqlDbType DataType
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataParameter Overload List


DataAction.GetDataParameter Method (String, SqlDbType, Int32, Object)

public IDataParameter GetDataParameter(
String Name,
SqlDbType DataType,
Int32 Size,
Object Value
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataParameter Overload List


DataAction.GetDataParameter Method (String, SqlDbType, Object)

public IDataParameter GetDataParameter(
String Name,
SqlDbType DataType,
Object Value
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataParameter Overload List


DataAction.GetDataParameter Method (String, Object)

public IDataParameter GetDataParameter(
String Name,
Object Value
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataParameter Overload List


GetDataSet Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetDataSet Method

Overload List

public DataSet GetDataSet(String);

public DataSet GetDataSet(String,IAptifyDataAction.DSLCacheSetting);

public DataSet GetDataSet(String,IAptifyDataAction.DSLCacheSetting,String);

public DataSet GetDataSet(String,Int32);

public DataSet GetDataSet(String,Int32,IAptifyDataAction.DSLCacheSetting);

public DataSet GetDataSet(String,Int32,IAptifyDataAction.DSLCacheSetting,String);

public DataSet GetDataSet(String,Int32,String);

public DataSet GetDataSet(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.GetDataSet Method (String)

public DataSet GetDataSet(
String SQL
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, DSLCacheSetting)

public DataSet GetDataSet(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, DSLCacheSetting, String)

public DataSet GetDataSet(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, Int32)

public DataSet GetDataSet(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, Int32, DSLCacheSetting)

public DataSet GetDataSet(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, Int32, DSLCacheSetting, String)

public DataSet GetDataSet(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, Int32, String)

public DataSet GetDataSet(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSet Overload List


DataAction.GetDataSet Method (String, String)

public DataSet GetDataSet(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSet Overload List


GetDataSetParametrized Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetDataSetParametrized Method

Overload List

public DataSet GetDataSetParametrized(String,CommandType,IDataParameter[]);

public DataSet GetDataSetParametrized(String,CommandType,IDataParameter[],Int32);

public DataSet GetDataSetParametrized(String,CommandType,IDataParameter[],Int32,String);

public DataSet GetDataSetParametrized(String,CommandType,IDataParameter[],String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.GetDataSetParametrized Method (String, CommandType, IDataParameter[])

public DataSet GetDataSetParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSetParametrized Overload List


DataAction.GetDataSetParametrized Method (String, CommandType, IDataParameter[], Int32)

public DataSet GetDataSetParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSetParametrized Overload List


DataAction.GetDataSetParametrized Method (String, CommandType, IDataParameter[], Int32, String)

public DataSet GetDataSetParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSetParametrized Overload List


DataAction.GetDataSetParametrized Method (String, CommandType, IDataParameter[], String)

public DataSet GetDataSetParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataSetParametrized Overload List


GetDataTable Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetDataTable Method

Overload List

public DataTable GetDataTable(String);

public DataTable GetDataTable(String,IAptifyDataAction.DSLCacheSetting);

public DataTable GetDataTable(String,IAptifyDataAction.DSLCacheSetting,String);

public DataTable GetDataTable(String,Int32);

public DataTable GetDataTable(String,Int32,IAptifyDataAction.DSLCacheSetting);

public DataTable GetDataTable(String,Int32,IAptifyDataAction.DSLCacheSetting,String);

public DataTable GetDataTable(String,Int32,String);

public DataTable GetDataTable(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.GetDataTable Method (String)

public DataTable GetDataTable(
String SQL
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, DSLCacheSetting)

public DataTable GetDataTable(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, DSLCacheSetting, String)

public DataTable GetDataTable(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, Int32)

public DataTable GetDataTable(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, Int32, DSLCacheSetting)

public DataTable GetDataTable(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, Int32, DSLCacheSetting, String)

public DataTable GetDataTable(
String SQL,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, Int32, String)

public DataTable GetDataTable(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTable Overload List


DataAction.GetDataTable Method (String, String)

public DataTable GetDataTable(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTable Overload List


GetDataTableParametrized Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetDataTableParametrized Method

Overload List

public DataTable GetDataTableParametrized(String,CommandType,IDataParameter[]);

public DataTable GetDataTableParametrized(String,CommandType,IDataParameter[],Int32);

public DataTable GetDataTableParametrized(String,CommandType,IDataParameter[],Int32,String);

public DataTable GetDataTableParametrized(String,CommandType,IDataParameter[],String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[])

public DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTableParametrized Overload List


DataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[], Int32)

public DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTableParametrized Overload List


DataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[], Int32, String)

public DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTableParametrized Overload List


DataAction.GetDataTableParametrized Method (String, CommandType, IDataParameter[], String)

public DataTable GetDataTableParametrized(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetDataTableParametrized Overload List


GetXMLReader Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.GetXMLReader Method

Overload List

public XmlReader GetXMLReader(String);

public XmlReader GetXMLReader(String,Int32);

public XmlReader GetXMLReader(String,Int32,String);

public XmlReader GetXMLReader(String,String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.GetXMLReader Method (String)

public XmlReader GetXMLReader(
String SQL
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetXMLReader Overload List


DataAction.GetXMLReader Method (String, Int32)

public XmlReader GetXMLReader(
String SQL,
Int32 QueryTimeout
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetXMLReader Overload List


DataAction.GetXMLReader Method (String, Int32, String)

public XmlReader GetXMLReader(
String SQL,
Int32 QueryTimeout,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetXMLReader Overload List


DataAction.GetXMLReader Method (String, String)

public XmlReader GetXMLReader(
String SQL,
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.GetXMLReader Overload List


DataAction.InnerExecuteNonQuery Method

public int InnerExecuteNonQuery(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
String TransactionID
);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.InnerExecuteScalar Method

public object InnerExecuteScalar(
String SQL,
CommandType CommandType,
IDataParameter[] Parameters,
Int32 QueryTimeout,
IAptifyDataAction.DSLCacheSetting CacheSetting,
String TransactionID
);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


InTransaction Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.InTransaction Method

Overload List

public bool InTransaction();

public bool InTransaction(String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.InTransaction Method ()

public bool InTransaction();

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.InTransaction Overload List


DataAction.InTransaction Method (String)

public bool InTransaction(
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.InTransaction Overload List


RollbackTransaction Method

Aptify 5.0 Software Development Kit (SDK)

DataAction.RollbackTransaction Method

Overload List

public void RollbackTransaction();

public void RollbackTransaction(String);

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace


DataAction.RollbackTransaction Method ()

public void RollbackTransaction();

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.RollbackTransaction Overload List


DataAction.RollbackTransaction Method (String)

public void RollbackTransaction(
String TransactionID
);

Implements

IAptifyDataAction.

See Also

DataAction Class | Aptify.Framework.DataServices.SQLDataServices Namespace | DataAction.RollbackTransaction Overload List


Aptify.Framework.DigitalDashboard

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.DigitalDashboard Namespace

This namespace contains the objects related to Aptify's Digital Dashboard functionality, including the dashboard designer forms, dashboard areas, and dashboard parts.

Namespace hierarchy

Classes

Class | Description
AptifyDashboardArea | This class provides a container for dashboard components.
AptifyDashLayout | This control is used as a host control to display Aptify Dashboards.
AreaConstants |
CannotBeOpenedInANewWindow |
ControlWithBorderDesigner | This designer can be used for a control that has a (BorderStyle as BorderStyle) property and can contain child controls.
DashboardAreaConfigurationForm | This is an implementation of IDashboardConfigurationForm and it is used to configure dashboard areas.
DashboardAreaException | Items implementing IDashboardArea should throw this exception if they experience an error.
DashboardAreaMetadata | This class represents an instance of meta-data for a specific Dashboard Area
DashboardComponentException | Items implementing IDashboardComponent should throw this exception if they experience an error.
DashboardComponentWrapperException | Items implementing IDashboardComponent should throw this exception if they experience an error.
DashboardException | This is the base class that all exceptions in this namespace inherit from.
DashboardLayoutException | Items implementing IDashboardContainer should throw this exception if they experience an error.
DashboardManager | The Dashboard Manager is responsible for creating, destroying, and caching AptifyDashLayout instances.
DashboardMetadata | This class represents an instance of meta-data for a specific Dashboard
DashboardMetadataBase | This is the base class used for all Dashbaord Meta-Data classes and provides some of the generic functionality that is used for these classes. This class is abstract and requries a sub-class to operate.
DashboardMetadataCache | This class handles the process of accessing the Dashboard Meta-Data via its Shared Instance() method which returns a class instance that is shared amongst all of the various classes that need Dashboard Meta-Data within a process. To look-up a meta-data record for a Dashboard, simply access the DashboaMetaDataCache Instance shared property and call the Dashboards property. This class also provides caching for meta-data for Dashboard Areas and Dashboardrd Parts. To access Area or Part meta-data use the Instance() property and then use the DashboartAreas or DashboardParts property.
DashboardOptionsForm | Exposes a GUI that can be used to allow users to configure Dashboard options.
DashboardPartConfigurationForm | This is an implementation of IDashboardConfigurationForm and it is used to configure dashboard parts.
DashboardPartInputMap | This class represents Input Map items within a Dashboard Part
DashboardPartMetadata | This class represents an instance of meta-data for a specific Dashboard Part
DashCtrlWrapper | This class provides a container for user defined parts.
DropPanel | Provides the target used to drop Views onto.
FadePanel | Provieds the fade in effect when dragging and dropping views onto a dashboard.
InterfaceConstants | This class holds all of the constants used for localizing strings for the IAptifyDashboard assembly.
LayoutConstants |
SelectAreaForm |
VerticalLabel |
WrapperConstants |

Interfaces

Interface | Description
IDashboardArea | This is the interface implemented by a class that functions as a Dashboard Area. A Dashboard Area acts as a container for Dashboard Components.
IDashboardComponent | The interface implemented by a class that functions as a Dashboard Component.
IDashboardConfigurationForm | This interface is implemented by forms that are used to configure Areas and Parts by Aptify.
IDashboardContainer | This is the interface implemented by a class that functions as a Dashboard Area Container.
IDashboardPropPage | This interface implemented by a user control that will act as a property page for a dashboard entity. IDashboardPropPage provides an interface for components that will act as property pages for dashboard entities.

Enumerations

Enumeration | Description
AnchorType |
ApplicationScope |
ButtonBarStyle |
ComponentOrientation |
ComponentState |
DashAreaStyle |
DashboardAreaMetadata.DashboardAreaAnchorType |
DashboardAreaMetadata.DashboardAreaStyle |
DashboardBorderStyle |
DashboardMetadata.DashboardApplicationScope |
DashboardMetadata.DashboardUsageScope |
DashboardMode |
DashboardPartInputMap.InputMapSourceType |
DashboardPartMetadata.DashboardPartState |
DashboardPartResizeMode |
DashboardResizeMode |
ResizeType |


AnchorType Enumeration

public enum AnchorType

Members

Member Name | Description
AnchorFixed |
AnchorProportional |
AnchorLinked |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


ApplicationScope Enumeration

public enum ApplicationScope

Members

Member Name | Description
Global |
Application |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea Class

This class provides a container for dashboard components.

For a list of all members of this type, see AptifyDashboardArea Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
Panel
AptifyDashboardArea

public class AptifyDashboardArea : Panel, IDashboardArea

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The dashboard area is the object that will be used in Digital Dashboards to host components.

Example

DashArea.Mode = Me.Mode
DashArea.Config(m_oApplication, m_lAreaID, DashLayout)

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: AptifyDashboardArea (in AptifyDashboardArea.dll)

See Also

AptifyDashboardArea Members | Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea Members

AptifyDashboardArea overview

Public Instance Constructors

AptifyDashboardArea Constructor Initializes a new instance of the AptifyDashboardArea class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Panel) |
AutoSizeMode (inherited from Panel) | Indicates the automatic sizing behavior of the control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) | This member is not meaningful for this control.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | This is the class member that will be called to initialize the area's context.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainer |
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPart |
GetPartCount |
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadArea |
NotifyPartChanged |
NotifyPartClosed |
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) | Returns a string representation for this control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AutoSizeChanged (inherited from Panel) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) | This member is not meaningful for this control.
KeyPress (inherited from Panel) | This member is not meaningful for this control.
KeyUp (inherited from Panel) | This member is not meaningful for this control.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) | This member is not meaningful for this control.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Panel) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Panel) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ScrollableControl) | Adjusts the scroll bars on the container based on the current control positions and the control currently selected.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Panel) | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ScrollableControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea Constructor

Initializes a new instance of the AptifyDashboardArea class.

public AptifyDashboardArea();

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea Properties

The properties of the AptifyDashboardArea class are listed below. For a complete list of AptifyDashboardArea class members, see the AptifyDashboardArea Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Panel) |
AutoSizeMode (inherited from Panel) | Indicates the automatic sizing behavior of the control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) | This member is not meaningful for this control.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Panel) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Panel) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDashboardArea.ID Property

public Int64 ID {get;}

Implements

IDashboardArea.

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDashboardArea.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardArea.

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea Methods

The methods of the AptifyDashboardArea class are listed below. For a complete list of AptifyDashboardArea class members, see the AptifyDashboardArea Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | This is the class member that will be called to initialize the area's context.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainer |
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPart |
GetPartCount |
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadArea |
NotifyPartChanged |
NotifyPartClosed |
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) | Returns a string representation for this control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ScrollableControl) | Adjusts the scroll bars on the container based on the current control positions and the control currently selected.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Panel) | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ScrollableControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea.Config Method

This is the class member that will be called to initialize the area's context.

public void Config(
AptifyApplication ApplicationObject,
Int64 AreaID,
IDashboardContainer Container
);

Parameters

ApplicationObject
An instantiated class that is used to retrieve general system information.
AreaID
The ID of the Dashboard Area Record that should be configured.
Container
This will contain an instantiated reference to the Dashboard container that will host this Area.

Implements

IDashboardArea.

Remarks

If there is a problem in this method that cannot be handled then it should be wrapped in a DashboardAreaException and re-thrown.

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDashboardArea.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace | AptifyDashboardArea.Dispose Overload List


AptifyDashboardArea.GetContainer Method

public IDashboardContainer GetContainer();

Implements

IDashboardArea.

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea.GetPart Method

public IDashboardComponent GetPart(
Int32 Index
);

Implements

IDashboardArea.

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea.GetPartCount Method

public int GetPartCount();

Implements

IDashboardArea.

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea.LoadArea Method

public void LoadArea();

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea.NotifyPartChanged Method

public void NotifyPartChanged(
IDashboardComponent Part
);

Implements

IDashboardArea.

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashboardArea.NotifyPartClosed Method

public void NotifyPartClosed(
IDashboardComponent Part
);

Implements

IDashboardArea.

See Also

AptifyDashboardArea Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout Class

This control is used as a host control to display Aptify Dashboards.

For a list of all members of this type, see AptifyDashLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
AptifyDashLayout

public class AptifyDashLayout : UserControl, IDashboardContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

In order to properly use this control, it should be placed on a parent control and then call Config.

Example

'this will config the dashboard to display the dashboard with ID=1
'It will then bring it to the front and make sure it is visible
DashboardLayout.Config(m_Application, 1)
DashboardLayout.BringToFront()
DashboardLayout.Visible = True

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: AptifyDashboardLayout (in AptifyDashboardLayout.dll)

See Also

AptifyDashLayout Members | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout Members

AptifyDashLayout overview

Public Static Fields

AREA_HEIGHT_SPACE
AREA_WIDTH_SPACE

Public Instance Constructors

AptifyDashLayout Constructor Initializes a new instance of the AptifyDashLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AreaCount |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowToolbar |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
TitleBarTextColor |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UsageScope |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Overloaded. Configures the Dashboard Layout for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyAreaChanged |
NotifyAreaClosed |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout Constructor

Initializes a new instance of the AptifyDashLayout class.

public AptifyDashLayout();

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout Fields

The fields of the AptifyDashLayout class are listed below. For a complete list of AptifyDashLayout class members, see the AptifyDashLayout Members topic.

Public Static Fields

AREA_HEIGHT_SPACE
AREA_WIDTH_SPACE

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout.AREA_HEIGHT_SPACE Field

public const AREA_HEIGHT_SPACE AREA_HEIGHT_SPACE = 4;

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout.AREA_WIDTH_SPACE Field

public const AREA_WIDTH_SPACE AREA_WIDTH_SPACE = 4;

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout Properties

The properties of the AptifyDashLayout class are listed below. For a complete list of AptifyDashLayout class members, see the AptifyDashLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AreaCount |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowToolbar |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
TitleBarTextColor |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UsageScope |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AreaCount Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDashLayout.AreaCount Property

public Int32 AreaCount {get;}

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDashLayout.ID Property

public Int64 ID {get;}

Implements

IDashboardContainer.

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDashLayout.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardContainer.

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


ShowToolbar Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDashLayout.ShowToolbar Property

public Boolean ShowToolbar {get; set;}

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


TitleBarTextColor Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDashLayout.TitleBarTextColor Property

public Color TitleBarTextColor {get;}

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


UsageScope Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDashLayout.UsageScope Property

public String UsageScope {get;}

Implements

IDashboardContainer.

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout Methods

The methods of the AptifyDashLayout class are listed below. For a complete list of AptifyDashLayout class members, see the AptifyDashLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Overloaded. Configures the Dashboard Layout for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyAreaChanged |
NotifyAreaClosed |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout.ApplySkin Method

protected virtual void ApplySkin();

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDashLayout.Config Method

Configures the Dashboard Layout for use.

Overload List

Configures the Dashboard Layout for use.

public void Config(AptifyApplication,Int64);

Configures the Dashboard Layout for use.

public void Config(AptifyApplication,Int64,ApplicationScope,Int64);

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout.Config Method (AptifyApplication, Int64)

Configures the Dashboard Layout for use.

public void Config(
AptifyApplication ApplicationObject,
Int64 DashboardID
);

Parameters

ApplicationObject
A configured AptifyApplication instance.
DashboardID
An ID of a Dashboard Entity Record.

Implements

IDashboardContainer.

Remarks

This member calls through to Config.

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace | AptifyDashLayout.Config Overload List


AptifyDashLayout.Config Method (AptifyApplication, Int64, ApplicationScope, Int64)

Configures the Dashboard Layout for use.

public void Config(
AptifyApplication ApplicationObject,
Int64 DashboardID,
ApplicationScope ApplicationScope,
Int64 ApplicationID
);

Parameters

ApplicationObject
A configured AptifyApplication instance.
DashboardID
An ID of a Dashboard Entity Record.
ApplicationScope
The Scope for which this dashboard should be available.
ApplicationID
The Id of the Application that this dashboard is being configured for.

Implements

IDashboardContainer.

Remarks

This method should be called before all other methods.

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace | AptifyDashLayout.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDashLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace | AptifyDashLayout.Dispose Overload List


AptifyDashLayout.NotifyAreaChanged Method

public void NotifyAreaChanged(
IDashboardArea Area
);

Implements

IDashboardContainer.

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AptifyDashLayout.NotifyAreaClosed Method

public void NotifyAreaClosed(
IDashboardArea Area
);

Implements

IDashboardContainer.

See Also

AptifyDashLayout Class | Aptify.Framework.DigitalDashboard Namespace


AreaConstants Class

For a list of all members of this type, see AreaConstants Members.

System.Object
AreaConstants

public class AreaConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: AptifyDashboardArea (in AptifyDashboardArea.dll)

See Also

AreaConstants Members | Aptify.Framework.DigitalDashboard Namespace


AreaConstants Members

AreaConstants overview

Public Static Fields

REMOVE_PART_MESSAGE

Public Static Methods

GetString Overloaded.

Public Instance Constructors

AreaConstants Constructor Initializes a new instance of the AreaConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AreaConstants Class | Aptify.Framework.DigitalDashboard Namespace


AreaConstants Constructor

Initializes a new instance of the AreaConstants class.

public AreaConstants();

See Also

AreaConstants Class | Aptify.Framework.DigitalDashboard Namespace


AreaConstants Fields

The fields of the AreaConstants class are listed below. For a complete list of AreaConstants class members, see the AreaConstants Members topic.

Public Static Fields

REMOVE_PART_MESSAGE

See Also

AreaConstants Class | Aptify.Framework.DigitalDashboard Namespace


AreaConstants.REMOVE_PART_MESSAGE Field

public const REMOVE_PART_MESSAGE REMOVE_PART_MESSAGE = "REMOVE_PART_MESSAGE";

See Also

AreaConstants Class | Aptify.Framework.DigitalDashboard Namespace


AreaConstants Methods

The methods of the AreaConstants class are listed below. For a complete list of AreaConstants class members, see the AreaConstants Members topic.

Public Static Methods

GetString Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AreaConstants Class | Aptify.Framework.DigitalDashboard Namespace


GetString Method

Aptify 5.0 Software Development Kit (SDK)

AreaConstants.GetString Method

Overload List

public static string GetString(String);

public static string GetString(String,params String[]);

See Also

AreaConstants Class | Aptify.Framework.DigitalDashboard Namespace


AreaConstants.GetString Method (String)

public static string GetString(
String Text
);

See Also

AreaConstants Class | Aptify.Framework.DigitalDashboard Namespace | AreaConstants.GetString Overload List


AreaConstants.GetString Method (String, String[])

public static string GetString(
String Text,
params String[] FormatParameters
);

See Also

AreaConstants Class | Aptify.Framework.DigitalDashboard Namespace | AreaConstants.GetString Overload List


ButtonBarStyle Enumeration

public enum ButtonBarStyle

Members

Member Name | Description
LeftRight |
TopBottom |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


CannotBeOpenedInANewWindow Class

For a list of all members of this type, see CannotBeOpenedInANewWindow Members.

System.Object
Attribute
CannotBeOpenedInANewWindow

public class CannotBeOpenedInANewWindow : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

CannotBeOpenedInANewWindow Members | Aptify.Framework.DigitalDashboard Namespace


CannotBeOpenedInANewWindow Members

CannotBeOpenedInANewWindow overview

Public Instance Constructors

CannotBeOpenedInANewWindow Constructor Initializes a new instance of the CannotBeOpenedInANewWindow class.

Public Instance Properties

TypeId (inherited from Attribute) When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CannotBeOpenedInANewWindow Class | Aptify.Framework.DigitalDashboard Namespace


CannotBeOpenedInANewWindow Constructor

Initializes a new instance of the CannotBeOpenedInANewWindow class.

public CannotBeOpenedInANewWindow();

See Also

CannotBeOpenedInANewWindow Class | Aptify.Framework.DigitalDashboard Namespace


ComponentOrientation Enumeration

public enum ComponentOrientation

Members

Member Name | Description
Horizontal |
Vertical |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


ComponentState Enumeration

public enum ComponentState

Members

Member Name | Description
NotSet |
Minimized |
Normal |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


ControlWithBorderDesigner Class

This designer can be used for a control that has a (BorderStyle as BorderStyle) property and can contain child controls.

For a list of all members of this type, see ControlWithBorderDesigner Members.

System.Object
ComponentDesigner
ControlDesigner
ParentControlDesigner
ScrollableControlDesigner
ControlWithBorderDesigner

public class ControlWithBorderDesigner : ScrollableControlDesigner

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If a control specifies this as its designer and it does not have the proper BorderStyle property, then no border will be used in design time. If a control uses this as its designer and extra lines appear when the designed control is re-drawn, then you should set its Style to ControlStyles.

    Protected Overrides Sub InitLayout()
       MyBase.InitLayout()
       Me.SetStyle(System.Windows.Forms.ControlStyles.ResizeRedraw, True)
    End Sub

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

ControlWithBorderDesigner Members | Aptify.Framework.DigitalDashboard Namespace | Control Styles


ControlWithBorderDesigner Members

ControlWithBorderDesigner overview

Public Instance Constructors

ControlWithBorderDesigner Constructor Initializes a new instance of the ControlWithBorderDesigner class.

Public Instance Properties

AccessibilityObject (inherited from ControlDesigner) | Gets the AccessibleObject assigned to the control.
ActionLists (inherited from ComponentDesigner) | Gets the design-time action lists supported by the component associated with the designer.
AssociatedComponents (inherited from ControlDesigner) | Gets the collection of components associated with the component managed by the designer.
AutoResizeHandles (inherited from ControlDesigner) | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property.
Component (inherited from ComponentDesigner) | Gets the component this designer is designing.
Control (inherited from ControlDesigner) | Gets the control that the designer is designing.
ParticipatesWithSnapLines (inherited from ControlDesigner) | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation.
SelectionRules (inherited from ControlDesigner) | Gets the selection rules that indicate the movement capabilities of a component.
SnapLines (inherited from ParentControlDesigner) | Gets a list of SnapLine objects representing significant alignment points for this control.
Verbs (inherited from ComponentDesigner) | Gets the design-time verbs supported by the component that is associated with the designer.

Public Instance Methods

CanBeParentedTo (inherited from ControlDesigner) | Indicates if this designer's control can be parented by the control of the specified designer.
CanParent (inherited from ParentControlDesigner) | Overloaded. Indicates whether the control managed by the specified designer can be a child of the control managed by this designer.
Dispose (inherited from ComponentDesigner) | Overloaded. Releases all resources used by the ComponentDesigner.
DoDefaultAction (inherited from ComponentDesigner) | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetGlyphs (inherited from ParentControlDesigner) | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from ParentControlDesigner) | Initializes the designer with the specified component.
InitializeExistingComponent (inherited from ControlDesigner) | Re-initializes an existing component.
InitializeNewComponent (inherited from ParentControlDesigner) |
InitializeNonDefault (inherited from ComponentDesigner) | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults.
InternalControlDesigner (inherited from ControlDesigner) | Returns the internal control designer with the specified index in the ControlDesigner.
NumberOfInternalControlDesigners (inherited from ControlDesigner) | Returns the number of internal control designers in the ControlDesigner.
OnSetComponentDefaults (inherited from ControlDesigner) | Obsolete. Called when the designer is intialized.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

accessibilityObj (inherited from ControlDesigner) Specifies the accessibility object for the designer.

Protected Instance Properties

AllowControlLasso (inherited from ParentControlDesigner) | Gets a value indicating whether selected controls will be re-parented.
AllowGenericDragBox (inherited from ParentControlDesigner) | Gets a value indicating whether a generic drag box should be drawn when dragging a toolbox item over the designer's surface.
BehaviorService (inherited from ControlDesigner) | Gets the BehaviorService from the design environment.
DefaultControlLocation (inherited from ParentControlDesigner) | Gets the default location for a control added to the designer.
DrawGrid (inherited from ParentControlDesigner) | Gets or sets a value indicating whether a grid should be drawn on the control for this designer.
EnableDragRect (inherited from ParentControlDesigner) | Gets a value indicating whether drag rectangles are drawn by the designer.
GridSize (inherited from ParentControlDesigner) | Gets or sets the size of each square of the grid that is drawn when the designer is in grid draw mode.
InheritanceAttribute (inherited from ControlDesigner) | Gets the InheritanceAttribute of the designer.
Inherited (inherited from ComponentDesigner) | Gets a value indicating whether this component is inherited.
MouseDragTool (inherited from ParentControlDesigner) | Gets a value indicating whether the designer has a valid tool during a drag operation.
ParentComponent (inherited from ControlDesigner) | Gets the parent component for the ControlDesigner.
ShadowProperties (inherited from ComponentDesigner) | Gets a collection of property values that override user settings.

Protected Instance Methods

AddPaddingSnapLines (inherited from ParentControlDesigner) | Adds padding snaplines.
BaseWndProc (inherited from ControlDesigner) | Processes Windows messages.
CreateTool (inherited from ParentControlDesigner) | Overloaded. Creates a component or control from the specified tool and adds it to the current design document.
CreateToolCore (inherited from ParentControlDesigner) | Provides core functionality for all the CreateTool methods.
DefWndProc (inherited from ControlDesigner) | Provides default processing for Windows messages.
DisplayError (inherited from ControlDesigner) | Displays information about the specified exception to the user.
Dispose (inherited from ParentControlDesigner) | Overloaded. Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources.
EnableDesignMode (inherited from ControlDesigner) | Enables design time functionality for a child control.
EnableDragDrop (inherited from ControlDesigner) | Enables or disables drag-and-drop support for the control being designed.
Finalize (inherited from ComponentDesigner) | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection.
GetControl (inherited from ParentControlDesigner) | Gets the control from the designer of the specified component.
GetControlGlyph (inherited from ParentControlDesigner) |
GetHitTest (inherited from ScrollableControlDesigner) | Indicates whether a mouse click at the specified point should be handled by the control.
GetParentForComponent (inherited from ParentControlDesigner) | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it.
GetService (inherited from ComponentDesigner) | Attempts to retrieve the specified type of service from the design mode site of the designer's component.
GetUpdatedRect (inherited from ParentControlDesigner) | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled.
HookChildControls (inherited from ControlDesigner) | Routes messages from the child controls of the specified control to the designer.
InvokeGetInheritanceAttribute (inherited from ComponentDesigner) | Gets the InheritanceAttribute of the specified ComponentDesigner.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnContextMenu (inherited from ControlDesigner) | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed.
OnCreateHandle (inherited from ControlDesigner) | Provides an opportunity to perform additional processing immediately after the control handle has been created.
OnDragComplete (inherited from ParentControlDesigner) | Called in order to clean up a drag-and-drop operation.
OnDragDrop (inherited from ParentControlDesigner) | Called when a drag-and-drop object is dropped onto the control designer view.
OnDragEnter (inherited from ParentControlDesigner) | Called when a drag-and-drop operation enters the control designer view.
OnDragLeave (inherited from ParentControlDesigner) | Called when a drag-and-drop operation leaves the control designer view.
OnDragOver (inherited from ParentControlDesigner) | Called when a drag-and-drop object is dragged over the control designer view.
OnGiveFeedback (inherited from ControlDesigner) | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress.
OnMouseDragBegin (inherited from ParentControlDesigner) | Called in response to the left mouse button being pressed and held while over the component.
OnMouseDragEnd (inherited from ParentControlDesigner) | Called at the end of a drag-and-drop operation to complete or cancel the operation.
OnMouseDragMove (inherited from ParentControlDesigner) | Called for each movement of the mouse during a drag-and-drop operation.
OnMouseEnter (inherited from ControlDesigner) | Receives a call when the mouse first enters the control.
OnMouseHover (inherited from ControlDesigner) | Receives a call after the mouse hovers over the control.
OnMouseLeave (inherited from ControlDesigner) | Receives a call when the mouse first enters the control.
OnPaintAdornments | Determines if a border needs to be drawn around the control at design time.
OnSetCursor (inherited from ParentControlDesigner) | Provides an opportunity to change the current mouse cursor.
PostFilterAttributes (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor.
PostFilterEvents (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor.
PostFilterProperties (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor.
PreFilterAttributes (inherited from ComponentDesigner) | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor.
PreFilterEvents (inherited from ComponentDesigner) | Allows a designer to add to the set of events that it exposes through a TypeDescriptor.
PreFilterProperties (inherited from ParentControlDesigner) | Adjusts the set of properties the component will expose through a TypeDescriptor.
RaiseComponentChanged (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component has been changed.
RaiseComponentChanging (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component is about to be changed.
UnhookChildControls (inherited from ControlDesigner) | Routes messages for the children of the specified control to each control rather than to a parent designer.
WndProc (inherited from ScrollableControlDesigner) | Processes Windows messages and passes WM_HSCROLL and WM_VSCROLL messages to the control at design time.

Protected Internal Instance Properties

AllowSetChildIndexOnDrop (inherited from ParentControlDesigner) Gets a value indicating whether the z-order of dragged controls should be maintained when dropped on a ParentControlDesigner.

See Also

ControlWithBorderDesigner Class | Aptify.Framework.DigitalDashboard Namespace | Control Styles


ControlWithBorderDesigner Constructor

Initializes a new instance of the ControlWithBorderDesigner class.

public ControlWithBorderDesigner();

See Also

ControlWithBorderDesigner Class | Aptify.Framework.DigitalDashboard Namespace


ControlWithBorderDesigner Methods

The methods of the ControlWithBorderDesigner class are listed below. For a complete list of ControlWithBorderDesigner class members, see the ControlWithBorderDesigner Members topic.

Public Instance Methods

CanBeParentedTo (inherited from ControlDesigner) | Indicates if this designer's control can be parented by the control of the specified designer.
CanParent (inherited from ParentControlDesigner) | Overloaded. Indicates whether the control managed by the specified designer can be a child of the control managed by this designer.
Dispose (inherited from ComponentDesigner) | Overloaded. Releases all resources used by the ComponentDesigner.
DoDefaultAction (inherited from ComponentDesigner) | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetGlyphs (inherited from ParentControlDesigner) | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from ParentControlDesigner) | Initializes the designer with the specified component.
InitializeExistingComponent (inherited from ControlDesigner) | Re-initializes an existing component.
InitializeNewComponent (inherited from ParentControlDesigner) |
InitializeNonDefault (inherited from ComponentDesigner) | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults.
InternalControlDesigner (inherited from ControlDesigner) | Returns the internal control designer with the specified index in the ControlDesigner.
NumberOfInternalControlDesigners (inherited from ControlDesigner) | Returns the number of internal control designers in the ControlDesigner.
OnSetComponentDefaults (inherited from ControlDesigner) | Obsolete. Called when the designer is intialized.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddPaddingSnapLines (inherited from ParentControlDesigner) | Adds padding snaplines.
BaseWndProc (inherited from ControlDesigner) | Processes Windows messages.
CreateTool (inherited from ParentControlDesigner) | Overloaded. Creates a component or control from the specified tool and adds it to the current design document.
CreateToolCore (inherited from ParentControlDesigner) | Provides core functionality for all the CreateTool methods.
DefWndProc (inherited from ControlDesigner) | Provides default processing for Windows messages.
DisplayError (inherited from ControlDesigner) | Displays information about the specified exception to the user.
Dispose (inherited from ParentControlDesigner) | Overloaded. Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources.
EnableDesignMode (inherited from ControlDesigner) | Enables design time functionality for a child control.
EnableDragDrop (inherited from ControlDesigner) | Enables or disables drag-and-drop support for the control being designed.
Finalize (inherited from ComponentDesigner) | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection.
GetControl (inherited from ParentControlDesigner) | Gets the control from the designer of the specified component.
GetControlGlyph (inherited from ParentControlDesigner) |
GetHitTest (inherited from ScrollableControlDesigner) | Indicates whether a mouse click at the specified point should be handled by the control.
GetParentForComponent (inherited from ParentControlDesigner) | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it.
GetService (inherited from ComponentDesigner) | Attempts to retrieve the specified type of service from the design mode site of the designer's component.
GetUpdatedRect (inherited from ParentControlDesigner) | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled.
HookChildControls (inherited from ControlDesigner) | Routes messages from the child controls of the specified control to the designer.
InvokeGetInheritanceAttribute (inherited from ComponentDesigner) | Gets the InheritanceAttribute of the specified ComponentDesigner.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnContextMenu (inherited from ControlDesigner) | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed.
OnCreateHandle (inherited from ControlDesigner) | Provides an opportunity to perform additional processing immediately after the control handle has been created.
OnDragComplete (inherited from ParentControlDesigner) | Called in order to clean up a drag-and-drop operation.
OnDragDrop (inherited from ParentControlDesigner) | Called when a drag-and-drop object is dropped onto the control designer view.
OnDragEnter (inherited from ParentControlDesigner) | Called when a drag-and-drop operation enters the control designer view.
OnDragLeave (inherited from ParentControlDesigner) | Called when a drag-and-drop operation leaves the control designer view.
OnDragOver (inherited from ParentControlDesigner) | Called when a drag-and-drop object is dragged over the control designer view.
OnGiveFeedback (inherited from ControlDesigner) | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress.
OnMouseDragBegin (inherited from ParentControlDesigner) | Called in response to the left mouse button being pressed and held while over the component.
OnMouseDragEnd (inherited from ParentControlDesigner) | Called at the end of a drag-and-drop operation to complete or cancel the operation.
OnMouseDragMove (inherited from ParentControlDesigner) | Called for each movement of the mouse during a drag-and-drop operation.
OnMouseEnter (inherited from ControlDesigner) | Receives a call when the mouse first enters the control.
OnMouseHover (inherited from ControlDesigner) | Receives a call after the mouse hovers over the control.
OnMouseLeave (inherited from ControlDesigner) | Receives a call when the mouse first enters the control.
OnPaintAdornments | Determines if a border needs to be drawn around the control at design time.
OnSetCursor (inherited from ParentControlDesigner) | Provides an opportunity to change the current mouse cursor.
PostFilterAttributes (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor.
PostFilterEvents (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor.
PostFilterProperties (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor.
PreFilterAttributes (inherited from ComponentDesigner) | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor.
PreFilterEvents (inherited from ComponentDesigner) | Allows a designer to add to the set of events that it exposes through a TypeDescriptor.
PreFilterProperties (inherited from ParentControlDesigner) | Adjusts the set of properties the component will expose through a TypeDescriptor.
RaiseComponentChanged (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component has been changed.
RaiseComponentChanging (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component is about to be changed.
UnhookChildControls (inherited from ControlDesigner) | Routes messages for the children of the specified control to each control rather than to a parent designer.
WndProc (inherited from ScrollableControlDesigner) | Processes Windows messages and passes WM_HSCROLL and WM_VSCROLL messages to the control at design time.

See Also

ControlWithBorderDesigner Class | Aptify.Framework.DigitalDashboard Namespace | Control Styles


ControlWithBorderDesigner.OnPaintAdornments Method

Determines if a border needs to be drawn around the control at design time.

protected override void OnPaintAdornments(
PaintEventArgs pe
);

Parameters

pe
An instantiated PaintEventArgs that will be passed in from the system.

Exceptions

Exception Type | Condition
InvalidCastException | Throw when the designer is assigned to a control that does not have a BorderStyle property.

See Also

ControlWithBorderDesigner Class | Aptify.Framework.DigitalDashboard Namespace


DashAreaStyle Enumeration

public enum DashAreaStyle

Members

Member Name | Description
TopBottom |
BottomTop |
LeftRight |
RightLeft |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


DashboardAreaConfigurationForm Class

This is an implementation of IDashboardConfigurationForm and it is used to configure dashboard areas.

For a list of all members of this type, see DashboardAreaConfigurationForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
DashboardAreaConfigurationForm

public class DashboardAreaConfigurationForm : Form, IDashboardConfigurationForm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

    Dim oArea As IDashboardConfigurationForm
    oArea = DirectCast(AppDomain.CurrentDomain.CreateInstanceAndUnwrap("IAptifyDashboard", "Aptify.Framework.DigitalDashboard.DashboardAreaConfigurationForm"), IDashboardConfigurationForm)

    'configure a new area for this dashboard
    oArea.Config(-1, m_lDashboardID, m_oApplication)
    'display the new configuration form

    If oArea.ShowDialog = DialogResult.OK Then
        'need to reload the Dashboard
    End If
    oArea.Dispose()

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

DashboardAreaConfigurationForm Members | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaConfigurationForm Members

DashboardAreaConfigurationForm overview

Public Instance Constructors

DashboardAreaConfigurationForm Constructor Initializes a new instance of the DashboardAreaConfigurationForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaConfigurationForm Constructor

Initializes a new instance of the DashboardAreaConfigurationForm class.

public DashboardAreaConfigurationForm();

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaConfigurationForm Properties

The properties of the DashboardAreaConfigurationForm class are listed below. For a complete list of DashboardAreaConfigurationForm class members, see the DashboardAreaConfigurationForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaConfigurationForm.ID Property

public Int64 ID {get;}

Implements

IDashboardConfigurationForm.

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaConfigurationForm Methods

The methods of the DashboardAreaConfigurationForm class are listed below. For a complete list of DashboardAreaConfigurationForm class members, see the DashboardAreaConfigurationForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaConfigurationForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaConfigurationForm.Config Method

public void Config(
Int64 ID,
Int64 ContainerID,
AptifyApplication ApplicationObject
);

Implements

IDashboardConfigurationForm.

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaConfigurationForm.Dispose Method

Overload List

new public void Dispose();

new protected void Dispose(Boolean);

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaConfigurationForm.Dispose Method ()

new public void Dispose();

Implements

IDashboardConfigurationForm.

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace | DashboardAreaConfigurationForm.Dispose Overload List


DashboardAreaConfigurationForm.Dispose Method (Boolean)

new protected void Dispose(
Boolean disposing
);

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace | DashboardAreaConfigurationForm.Dispose Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaConfigurationForm.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaConfigurationForm.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IDashboardConfigurationForm.

See Also

DashboardAreaConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace | DashboardAreaConfigurationForm.ShowDialog Overload List


DashboardAreaException Class

Items implementing IDashboardArea should throw this exception if they experience an error.

For a list of all members of this type, see DashboardAreaException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
DashboardException
DashboardAreaException

public class DashboardAreaException : DashboardException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

DashboardAreaException Members | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaException Members

DashboardAreaException overview

Public Instance Constructors

DashboardAreaException Overloaded. Initializes a new instance of the DashboardAreaException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
ID (inherited from DashboardException) |
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from DashboardException) |
Properties (inherited from DashboardException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DashboardException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardAreaException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaException Constructor

Overload List

public DashboardAreaException(String,Int64);

public DashboardAreaException(String,Int64,Exception);

See Also

DashboardAreaException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaException Constructor (String, Int64, Exception)

public DashboardAreaException(
String Message,
Int64 ID,
Exception Inner
);

See Also

DashboardAreaException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardAreaException Constructor Overload List


DashboardAreaException Constructor (String, Int64)

public DashboardAreaException(
String Message,
Int64 ID
);

See Also

DashboardAreaException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardAreaException Constructor Overload List


DashboardAreaMetadata Class

This class represents an instance of meta-data for a specific Dashboard Area

For a list of all members of this type, see DashboardAreaMetadata Members.

System.Object
DashboardMetadataBase
DashboardAreaMetadata

public class DashboardAreaMetadata : DashboardMetadataBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

DashboardAreaMetadata Members | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaMetadata Members

DashboardAreaMetadata overview

Public Instance Constructors

DashboardAreaMetadata Overloaded. Initializes a new instance of the DashboardAreaMetadata class.

Public Instance Properties

Application (inherited from DashboardMetadataBase)
BackColor
Dashboard
DashboardAreaUserValueID
DashboardID
Data (inherited from DashboardMetadataBase)
DataAction (inherited from DashboardMetadataBase)
Description
Height
HeightProportion
ID
Item (inherited from DashboardMetadataBase)
LeftAnchor
LeftAnchorAreaID
LeftPos
Name
Parts
Position
ResizeHeight
ResizeWidth
ShowBorder
Style
TopAnchor
TopAnchorAreaID
TopPos
Width
WidthProportion

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPartRow |
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Overloaded. Refresh the Dashboard Area meta-data in the database
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Database (inherited from DashboardMetadataBase)
DataRow (inherited from DashboardMetadataBase)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadParts |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaMetadata Constructor

Overload List

public DashboardAreaMetadata(AptifyApplication,DataAction,Int64);

public DashboardAreaMetadata(AptifyApplication,DataAction,Int64,DataRow);

public DashboardAreaMetadata(AptifyApplication,DataAction,Int64,DataRow,DataTable);

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaMetadata Constructor (AptifyApplication, DataAction, Int64)

public DashboardAreaMetadata(
AptifyApplication Application,
DataAction DataAction,
Int64 DashboardAreaID
);

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace | DashboardAreaMetadata Constructor Overload List


DashboardAreaMetadata Constructor (AptifyApplication, DataAction, Int64, DataRow)

public DashboardAreaMetadata(
AptifyApplication Application,
DataAction DataAction,
Int64 DashboardAreaID,
DataRow DataRow
);

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace | DashboardAreaMetadata Constructor Overload List


DashboardAreaMetadata Constructor (AptifyApplication, DataAction, Int64, DataRow, DataTable)

public DashboardAreaMetadata(
AptifyApplication Application,
DataAction DataAction,
Int64 DashboardAreaID,
DataRow DataRow,
DataTable PartsDataTable
);

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace | DashboardAreaMetadata Constructor Overload List


DashboardAreaMetadata Properties

The properties of the DashboardAreaMetadata class are listed below. For a complete list of DashboardAreaMetadata class members, see the DashboardAreaMetadata Members topic.

Public Instance Properties

Application (inherited from DashboardMetadataBase)
BackColor
Dashboard
DashboardAreaUserValueID
DashboardID
Data (inherited from DashboardMetadataBase)
DataAction (inherited from DashboardMetadataBase)
Description
Height
HeightProportion
ID
Item (inherited from DashboardMetadataBase)
LeftAnchor
LeftAnchorAreaID
LeftPos
Name
Parts
Position
ResizeHeight
ResizeWidth
ShowBorder
Style
TopAnchor
TopAnchorAreaID
TopPos
Width
WidthProportion

Protected Instance Properties

Database (inherited from DashboardMetadataBase)
DataRow (inherited from DashboardMetadataBase)

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


BackColor Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.BackColor Property

public virtual Color BackColor {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Dashboard Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.Dashboard Property

public virtual DashboardMetadata Dashboard {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaUserValueID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.DashboardAreaUserValueID Property

public virtual Int64 DashboardAreaUserValueID {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.DashboardID Property

public virtual Int64 DashboardID {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.Description Property

public virtual String Description {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Height Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.Height Property

public virtual Int32 Height {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


HeightProportion Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.HeightProportion Property

public virtual Single HeightProportion {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.ID Property

public virtual Int64 ID {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


LeftAnchor Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.LeftAnchor Property

public virtual DashboardAreaMetadata.DashboardAreaAnchorType LeftAnchor {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


LeftAnchorAreaID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.LeftAnchorAreaID Property

public virtual Int64 LeftAnchorAreaID {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


LeftPos Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.LeftPos Property

public virtual Int32 LeftPos {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.Name Property

public virtual String Name {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Parts Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.Parts Property

public virtual List<T> Parts {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Position Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.Position Property

public virtual Int32 Position {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ResizeHeight Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.ResizeHeight Property

public virtual DashboardResizeMode ResizeHeight {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ResizeWidth Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.ResizeWidth Property

public virtual DashboardResizeMode ResizeWidth {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ShowBorder Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.ShowBorder Property

public virtual Boolean ShowBorder {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Style Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.Style Property

public virtual DashboardAreaMetadata.DashboardAreaStyle Style {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


TopAnchor Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.TopAnchor Property

public virtual DashboardAreaMetadata.DashboardAreaAnchorType TopAnchor {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


TopAnchorAreaID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.TopAnchorAreaID Property

public virtual Int64 TopAnchorAreaID {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


TopPos Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.TopPos Property

public virtual Int32 TopPos {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Width Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.Width Property

public virtual Int32 Width {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


WidthProportion Property

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.WidthProportion Property

public virtual Single WidthProportion {get;}

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaMetadata Methods

The methods of the DashboardAreaMetadata class are listed below. For a complete list of DashboardAreaMetadata class members, see the DashboardAreaMetadata Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPartRow |
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Overloaded. Refresh the Dashboard Area meta-data in the database
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadParts |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaMetadata.GetPartRow Method

public virtual DataRow GetPartRow(
Int64 PartID
);

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaMetadata.LoadParts Method

protected virtual void LoadParts(
Boolean Refresh
);

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Refresh Method

Aptify 5.0 Software Development Kit (SDK)

DashboardAreaMetadata.Refresh Method

Refresh the Dashboard Area meta-data in the database

Overload List

Refresh the Dashboard Area meta-data in the database

public override void Refresh(Boolean);

Refresh the Dashboard Area meta-data from a specified data-row

public void Refresh(DataRow);

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaMetadata.Refresh Method (Boolean)

Refresh the Dashboard Area meta-data in the database

public override void Refresh(
Boolean RefreshDataCache
);

Remarks

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace | DashboardAreaMetadata.Refresh Overload List


DashboardAreaMetadata.Refresh Method (DataRow)

Refresh the Dashboard Area meta-data from a specified data-row

public void Refresh(
DataRow DataRow
);

Parameters

DataRow

Remarks

See Also

DashboardAreaMetadata Class | Aptify.Framework.DigitalDashboard Namespace | DashboardAreaMetadata.Refresh Overload List


DashboardAreaMetadata.DashboardAreaAnchorType Enumeration

public enum DashboardAreaMetadata.DashboardAreaAnchorType

Members

Member Name | Description
Fixed |
Linked |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


DashboardAreaMetadata.DashboardAreaStyle Enumeration

public enum DashboardAreaMetadata.DashboardAreaStyle

Members

Member Name | Description
TopBottom |
LeftRight |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


DashboardBorderStyle Enumeration

public enum DashboardBorderStyle

Members

Member Name | Description
None |
Fixed3D |
FixedSingle |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


DashboardComponentException Class

Items implementing IDashboardComponent should throw this exception if they experience an error.

For a list of all members of this type, see DashboardComponentException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
DashboardException
DashboardComponentException

public class DashboardComponentException : DashboardException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

DashboardComponentException Members | Aptify.Framework.DigitalDashboard Namespace


DashboardComponentException Members

DashboardComponentException overview

Public Instance Constructors

DashboardComponentException Overloaded. Initializes a new instance of the DashboardComponentException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
ID (inherited from DashboardException) |
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from DashboardException) |
Properties (inherited from DashboardException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DashboardException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardComponentException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardComponentException Constructor

Overload List

public DashboardComponentException(String,Int64,AptifyProperties);

public DashboardComponentException(String,Int64,Exception,AptifyProperties);

See Also

DashboardComponentException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardComponentException Constructor (String, Int64, Exception, AptifyProperties)

public DashboardComponentException(
String Message,
Int64 ID,
Exception Inner,
AptifyProperties Properties
);

See Also

DashboardComponentException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardComponentException Constructor Overload List


DashboardComponentException Constructor (String, Int64, AptifyProperties)

public DashboardComponentException(
String Message,
Int64 ID,
AptifyProperties Properties
);

See Also

DashboardComponentException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardComponentException Constructor Overload List


DashboardComponentWrapperException Class

Items implementing IDashboardComponent should throw this exception if they experience an error.

For a list of all members of this type, see DashboardComponentWrapperException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
DashboardException
DashboardComponentWrapperException

public class DashboardComponentWrapperException : DashboardException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

DashboardComponentWrapperException Members | Aptify.Framework.DigitalDashboard Namespace


DashboardComponentWrapperException Members

DashboardComponentWrapperException overview

Public Instance Constructors

DashboardComponentWrapperException Overloaded. Initializes a new instance of the DashboardComponentWrapperException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
ID (inherited from DashboardException) |
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from DashboardException) |
Properties (inherited from DashboardException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DashboardException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardComponentWrapperException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardComponentWrapperException Constructor

Overload List

public DashboardComponentWrapperException(String,Int64,AptifyProperties);

public DashboardComponentWrapperException(String,Int64,Exception,AptifyProperties);

See Also

DashboardComponentWrapperException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardComponentWrapperException Constructor (String, Int64, Exception, AptifyProperties)

public DashboardComponentWrapperException(
String Message,
Int64 ID,
Exception Inner,
AptifyProperties Properties
);

See Also

DashboardComponentWrapperException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardComponentWrapperException Constructor Overload List


DashboardComponentWrapperException Constructor (String, Int64, AptifyProperties)

public DashboardComponentWrapperException(
String Message,
Int64 ID,
AptifyProperties Properties
);

See Also

DashboardComponentWrapperException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardComponentWrapperException Constructor Overload List


DashboardException Class

This is the base class that all exceptions in this namespace inherit from.

For a list of all members of this type, see DashboardException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
DashboardException
DashboardAreaException
DashboardComponentException
DashboardComponentWrapperException
DashboardLayoutException

public class DashboardException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Example

Throw new DashboardException("Exception Message",m_lDashID,InnerEx,m_oProps)

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

DashboardException Members | Aptify.Framework.DigitalDashboard Namespace


DashboardException Members

DashboardException overview

Public Instance Constructors

DashboardException Overloaded. Initializes a new instance of the DashboardException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
ID |
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Properties |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardException Constructor

Initializes a new instance of the DashboardException class.

Overload List

Initializes a new instance of the DashboardException class.

public DashboardException();

public DashboardException(Int32);

public DashboardException(Int32,Int32);

public DashboardException(Int32,String,Int32);

public DashboardException(Int32,String,Int32,Exception);

public DashboardException(SerializationInfo,StreamingContext);

public DashboardException(String);

public DashboardException(String,Exception);

public DashboardException(String,Int64,AptifyProperties);

public DashboardException(String,Int64,Exception,AptifyProperties);

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardException Constructor ()

Initializes a new instance of the DashboardException class.

public DashboardException();

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardException Constructor Overload List


DashboardException Constructor (Int32, Int32)

public DashboardException(
Int32 ErrorNumber,
Int32 Severity
);

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardException Constructor Overload List


DashboardException Constructor (String)

public DashboardException(
String Message
);

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardException Constructor Overload List


DashboardException Constructor (String, Exception)

public DashboardException(
String Message,
Exception Inner
);

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardException Constructor Overload List


DashboardException Constructor (Int32)

public DashboardException(
Int32 ErrorNumber
);

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardException Constructor Overload List


DashboardException Constructor (Int32, String, Int32)

public DashboardException(
Int32 ErrorNumber,
String Message,
Int32 Severity
);

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardException Constructor Overload List


DashboardException Constructor (Int32, String, Int32, Exception)

public DashboardException(
Int32 ErrorNumber,
String Message,
Int32 Severity,
Exception Inner
);

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardException Constructor Overload List


DashboardException Constructor (SerializationInfo, StreamingContext)

public DashboardException(
SerializationInfo Info,
StreamingContext context
);

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardException Constructor Overload List


DashboardException Constructor (String, Int64, Exception, AptifyProperties)

public DashboardException(
String Message,
Int64 ID,
Exception Inner,
AptifyProperties Properties
);

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardException Constructor Overload List


DashboardException Constructor (String, Int64, AptifyProperties)

public DashboardException(
String Message,
Int64 ID,
AptifyProperties Properties
);

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardException Constructor Overload List


DashboardException Properties

The properties of the DashboardException class are listed below. For a complete list of DashboardException class members, see the DashboardException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
ID |
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Properties |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardException.ID Property

public Int64 ID {get; set;}

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

DashboardException.Message Property

public override String Message {get;}

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

DashboardException.Properties Property

public String Properties {get; set;}

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardException Methods

The methods of the DashboardException class are listed below. For a complete list of DashboardException class members, see the DashboardException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext context
);

Implements

ISerializable.

See Also

DashboardException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardLayoutException Class

Items implementing IDashboardContainer should throw this exception if they experience an error.

For a list of all members of this type, see DashboardLayoutException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
DashboardException
DashboardLayoutException

public class DashboardLayoutException : DashboardException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

DashboardLayoutException Members | Aptify.Framework.DigitalDashboard Namespace


DashboardLayoutException Members

DashboardLayoutException overview

Public Instance Constructors

DashboardLayoutException Overloaded. Initializes a new instance of the DashboardLayoutException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
ID (inherited from DashboardException) |
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from DashboardException) |
Properties (inherited from DashboardException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DashboardException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardLayoutException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardLayoutException Constructor

Overload List

public DashboardLayoutException(String,Int64,AptifyProperties);

public DashboardLayoutException(String,Int64,Exception,AptifyProperties);

See Also

DashboardLayoutException Class | Aptify.Framework.DigitalDashboard Namespace


DashboardLayoutException Constructor (String, Int64, Exception, AptifyProperties)

public DashboardLayoutException(
String Message,
Int64 ID,
Exception Inner,
AptifyProperties Properties
);

See Also

DashboardLayoutException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardLayoutException Constructor Overload List


DashboardLayoutException Constructor (String, Int64, AptifyProperties)

public DashboardLayoutException(
String Message,
Int64 ID,
AptifyProperties Properties
);

See Also

DashboardLayoutException Class | Aptify.Framework.DigitalDashboard Namespace | DashboardLayoutException Constructor Overload List


DashboardManager Class

The Dashboard Manager is responsible for creating, destroying, and caching AptifyDashLayout instances.

For a list of all members of this type, see DashboardManager Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
DashboardManager

public class DashboardManager : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class supports an Attribute named LiveFor. The LiveFor attribute tells the Dashboard Manager when it should refresh the cache. The value is in minutes. 0 means never refresh the cache. -1 means always refresh the cache.

Example

Public Class TestForm
    Inherits System.windows.forms.Form

    Private WithEvents m_oDashboardManager As Aptify.Framework.DigitalDashboard.DashboardManager

    Public Sub New()
        MyBase.new()
        Me.m_oDashboardManager = New Aptify.Framework.DigitalDashboard.DashboardManager '''
        Me.Controls.Add(Me.m_oDashboardManager)
    End Sub

    Protected Overrides Sub OnLoad(ByVal e As System.EventArgs)
        MyBase.OnLoad(e)

        Me.m_oDashboardManager.Dock = System.Windows.Forms.DockStyle.Fill
        Me.m_oDashboardManager.Config(New Aptify.Framework.Application.AptifyApplication, -1)
        Me.m_oDashboardManager.BringToFront()
    End Sub
End Class

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

DashboardManager Members | Aptify.Framework.DigitalDashboard Namespace


DashboardManager Members

DashboardManager overview

Public Instance Constructors

DashboardManager Constructor Initializes a new instance of the DashboardManager class.

Public Instance Fields

LiveFor The number of minutes that a cached Dashboard will live for.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Overloaded. This is the class member that will be called to initialize the container context.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DashboardManager Class | Aptify.Framework.DigitalDashboard Namespace


DashboardManager Constructor

Initializes a new instance of the DashboardManager class.

public DashboardManager();

See Also

DashboardManager Class | Aptify.Framework.DigitalDashboard Namespace


DashboardManager Fields

The fields of the DashboardManager class are listed below. For a complete list of DashboardManager class members, see the DashboardManager Members topic.

Public Instance Fields

LiveFor The number of minutes that a cached Dashboard will live for.

See Also

DashboardManager Class | Aptify.Framework.DigitalDashboard Namespace


DashboardManager.LiveFor Field

The number of minutes that a cached Dashboard will live for.

public readonly LiveFor LiveFor;

Remarks

The Manager will not proactively refresh the cache. It will only refresh if a config is called and a cached dashboard has been alive longer than the LiveFor value. If LiveFor is -1, then caching will not be used. If LiveFor is 0, then we will never refresh.

See Also

DashboardManager Class | Aptify.Framework.DigitalDashboard Namespace


DashboardManager Methods

The methods of the DashboardManager class are listed below. For a complete list of DashboardManager class members, see the DashboardManager Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Overloaded. This is the class member that will be called to initialize the container context.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DashboardManager Class | Aptify.Framework.DigitalDashboard Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

DashboardManager.Config Method

This is the class member that will be called to initialize the container context.

Overload List

This is the class member that will be called to initialize the container context.

public virtual void Config(AptifyApplication,Int64);

This is the class member that will be called to initialize the container context.

public virtual void Config(AptifyApplication,Int64,ApplicationScope,Int64);

This is the class member that will be called to initialize the container context.

public virtual void Config(AptifyApplication,Int64,ApplicationScope,Int64,Boolean);

See Also

DashboardManager Class | Aptify.Framework.DigitalDashboard Namespace


DashboardManager.Config Method (AptifyApplication, Int64)

This is the class member that will be called to initialize the container context.

public virtual void Config(
AptifyApplication ApplicationObject,
Int64 DashboardID
);

Parameters

ApplicationObject
An instantiated class that is used to retrieve general system information.
DashboardID
The ID of the Dashboard record to configure.

Remarks

If there is a problem in this method that cannot be handled then it is wrapped in a DashboardContainerException and re-thrown.

See Also

DashboardManager Class | Aptify.Framework.DigitalDashboard Namespace | DashboardManager.Config Overload List


DashboardManager.Config Method (AptifyApplication, Int64, ApplicationScope, Int64)

This is the class member that will be called to initialize the container context.

public virtual void Config(
AptifyApplication ApplicationObject,
Int64 DashboardID,
ApplicationScope ApplicationScope,
Int64 ApplicationID
);

Parameters

ApplicationObject
An instantiated class that is used to retrieve general system information.
DashboardID
The ID of the Dashboard record to configure.
ApplicationScope
This is the scope at which the dashboard is running under.
ApplicationID
This is the ID of the application that the dashboard is specific to.

Remarks

If there is a problem in this method that cannot be handled then it is wrapped in a DashboardContainerException and re-thrown.

See Also

DashboardManager Class | Aptify.Framework.DigitalDashboard Namespace | DashboardManager.Config Overload List


DashboardManager.Config Method (AptifyApplication, Int64, ApplicationScope, Int64, Boolean)

This is the class member that will be called to initialize the container context.

public virtual void Config(
AptifyApplication ApplicationObject,
Int64 DashboardID,
ApplicationScope ApplicationScope,
Int64 ApplicationID,
Boolean ForceRefresh
);

Parameters

ApplicationObject
An instantiated class that is used to retrieve general system information.
DashboardID
The ID of the Dashboard record to configure.
ApplicationScope
This is the scope at which the dashboard is running under.
ApplicationID
This is the ID of the application that the dashboard is specific to.
ForceRefresh
This is tells the DashboardManager to force the Dashboard to refresh if this is true. It is false by default

Remarks

If there is a problem in this method that cannot be handled then it is wrapped in a DashboardContainerException and re-thrown.

See Also

DashboardManager Class | Aptify.Framework.DigitalDashboard Namespace | DashboardManager.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DashboardManager.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

DashboardManager Class | Aptify.Framework.DigitalDashboard Namespace


DashboardManager.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

DashboardManager Class | Aptify.Framework.DigitalDashboard Namespace | DashboardManager.Dispose Overload List


DashboardMetadata Class

This class represents an instance of meta-data for a specific Dashboard

For a list of all members of this type, see DashboardMetadata Members.

System.Object
DashboardMetadataBase
DashboardMetadata

public class DashboardMetadata : DashboardMetadataBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

DashboardMetadata Members | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadata Members

DashboardMetadata overview

Public Instance Constructors

DashboardMetadata Constructor

Public Instance Properties

Application (inherited from DashboardMetadataBase) |
ApplicationID |
ApplicationName |
ApplicationScope |
Areas | Collection of Dashboard Areas within the current Dashboard
BackColor |
BaseDashboard |
BaseDashboardID |
BorderStyle |
Comments |
DashboardID |
Data (inherited from DashboardMetadataBase) |
DataAction (inherited from DashboardMetadataBase) |
Description |
DisplayCultureString |
DisplayCultureStringID |
GroupID |
GroupName |
Item (inherited from DashboardMetadataBase) |
Name |
PartTable |
Rank |
ShowAreaBorders |
TitleBarTextColor |
UsageScope |
UserID |
UserName |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAreaRow |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Refresh the Form Template meta-data in the database
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Database (inherited from DashboardMetadataBase)
DataRow (inherited from DashboardMetadataBase)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadata Constructor

public DashboardMetadata(
AptifyApplication Application,
DataAction DataAction,
Int64 DashboardID
);

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadata Properties

The properties of the DashboardMetadata class are listed below. For a complete list of DashboardMetadata class members, see the DashboardMetadata Members topic.

Public Instance Properties

Application (inherited from DashboardMetadataBase) |
ApplicationID |
ApplicationName |
ApplicationScope |
Areas | Collection of Dashboard Areas within the current Dashboard
BackColor |
BaseDashboard |
BaseDashboardID |
BorderStyle |
Comments |
DashboardID |
Data (inherited from DashboardMetadataBase) |
DataAction (inherited from DashboardMetadataBase) |
Description |
DisplayCultureString |
DisplayCultureStringID |
GroupID |
GroupName |
Item (inherited from DashboardMetadataBase) |
Name |
PartTable |
Rank |
ShowAreaBorders |
TitleBarTextColor |
UsageScope |
UserID |
UserName |

Protected Instance Properties

Database (inherited from DashboardMetadataBase)
DataRow (inherited from DashboardMetadataBase)

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ApplicationID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.ApplicationID Property

public virtual Int64 ApplicationID {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ApplicationName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.ApplicationName Property

public virtual String ApplicationName {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ApplicationScope Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.ApplicationScope Property

public virtual DashboardMetadata.DashboardApplicationScope ApplicationScope {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Areas Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.Areas Property

Collection of Dashboard Areas within the current Dashboard

public virtual List<T> Areas {get;}

Property Value

Remarks

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


BackColor Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.BackColor Property

public virtual Color BackColor {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


BaseDashboard Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.BaseDashboard Property

public virtual String BaseDashboard {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


BaseDashboardID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.BaseDashboardID Property

public virtual Int64 BaseDashboardID {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


BorderStyle Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.BorderStyle Property

public virtual DashboardBorderStyle BorderStyle {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.Comments Property

public virtual String Comments {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.DashboardID Property

public virtual Int64 DashboardID {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.Description Property

public virtual String Description {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DisplayCultureString Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.DisplayCultureString Property

public virtual String DisplayCultureString {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DisplayCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.DisplayCultureStringID Property

public virtual Int64 DisplayCultureStringID {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


GroupID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.GroupID Property

public virtual Int64 GroupID {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


GroupName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.GroupName Property

public virtual String GroupName {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.Name Property

public virtual String Name {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


PartTable Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.PartTable Property

public virtual DataTable PartTable {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Rank Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.Rank Property

public virtual Int32 Rank {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ShowAreaBorders Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.ShowAreaBorders Property

public virtual Boolean ShowAreaBorders {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


TitleBarTextColor Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.TitleBarTextColor Property

public virtual Color TitleBarTextColor {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


UsageScope Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.UsageScope Property

public virtual DashboardMetadata.DashboardUsageScope UsageScope {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


UserID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.UserID Property

public virtual Int64 UserID {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


UserName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadata.UserName Property

public virtual String UserName {get;}

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadata Methods

The methods of the DashboardMetadata class are listed below. For a complete list of DashboardMetadata class members, see the DashboardMetadata Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAreaRow |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Refresh the Form Template meta-data in the database
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadata.GetAreaRow Method

public virtual DataRow GetAreaRow(
Int64 AreaID
);

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadata.Refresh Method

Refresh the Form Template meta-data in the database

public override void Refresh(
Boolean RefreshDataCache
);

Remarks

See Also

DashboardMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadata.DashboardApplicationScope Enumeration

public enum DashboardMetadata.DashboardApplicationScope

Members

Member Name | Description
GlobalScope |
ApplicationScope |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


DashboardMetadata.DashboardUsageScope Enumeration

public enum DashboardMetadata.DashboardUsageScope

Members

Member Name | Description
GlobalScope |
GroupScope |
UserScope |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataBase Class

This is the base class used for all Dashbaord Meta-Data classes and provides some of the generic functionality that is used for these classes. This class is abstract and requries a sub-class to operate.

For a list of all members of this type, see DashboardMetadataBase Members.

System.Object
DashboardMetadataBase
DashboardAreaMetadata
DashboardMetadata
DashboardPartMetadata

public class DashboardMetadataBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

DashboardMetadataBase Members | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataBase Members

DashboardMetadataBase overview

Public Instance Constructors

DashboardMetadataBase Constructor

Public Instance Properties

Application
Data
DataAction
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Database
DataRow

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardMetadataBase Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataBase Constructor

public DashboardMetadataBase(
AptifyApplication Application,
DataAction DataAction
);

See Also

DashboardMetadataBase Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataBase Properties

The properties of the DashboardMetadataBase class are listed below. For a complete list of DashboardMetadataBase class members, see the DashboardMetadataBase Members topic.

Public Instance Properties

Application
Data
DataAction
Item

Protected Instance Properties

Database
DataRow

See Also

DashboardMetadataBase Class | Aptify.Framework.DigitalDashboard Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadataBase.Application Property

public virtual AptifyApplication Application {get;}

See Also

DashboardMetadataBase Class | Aptify.Framework.DigitalDashboard Namespace


Data Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadataBase.Data Property

public virtual DataRow Data {get;}

See Also

DashboardMetadataBase Class | Aptify.Framework.DigitalDashboard Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadataBase.DataAction Property

public virtual DataAction DataAction {get;}

See Also

DashboardMetadataBase Class | Aptify.Framework.DigitalDashboard Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadataBase.Database Property

protected virtual String Database {get;}

See Also

DashboardMetadataBase Class | Aptify.Framework.DigitalDashboard Namespace


DataRow Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadataBase.DataRow Property

protected virtual DataRow DataRow {get; set;}

See Also

DashboardMetadataBase Class | Aptify.Framework.DigitalDashboard Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadataBase.Item Property

public virtual Object this[
String FieldName
] {get;}

See Also

DashboardMetadataBase Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataBase Methods

The methods of the DashboardMetadataBase class are listed below. For a complete list of DashboardMetadataBase class members, see the DashboardMetadataBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardMetadataBase Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataBase.Refresh Method

public abstract void Refresh(
Boolean RefreshDataCache
);

See Also

DashboardMetadataBase Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache Class

This class handles the process of accessing the Dashboard Meta-Data via its Shared Instance() method which returns a class instance that is shared amongst all of the various classes that need Dashboard Meta-Data within a process. To look-up a meta-data record for a Dashboard, simply access the DashboaMetaDataCache Instance shared property and call the Dashboards property. This class also provides caching for meta-data for Dashboard Areas and Dashboardrd Parts. To access Area or Part meta-data use the Instance() property and then use the DashboartAreas or DashboardParts property.

For a list of all members of this type, see DashboardMetadataCache Members.

System.Object
DashboardMetadataCache

public class DashboardMetadataCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

DashboardMetadataCache Members | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache Members

DashboardMetadataCache overview

Public Static Methods

Instance

Public Instance Constructors

DashboardMetadataCache Constructor

Public Instance Properties

DashboardAreas | This method will either return a Dashboard Area meta-data object from the cache if one exists, or it will load a new meta-data part if required.
DashboardParts | This method will either return a Dashboard Part meta-data object from the cache if one exists, or it will load a new meta-data part if required.
Dashboards | This method will either return a Dashboard meta-data object from the cache if one exists, or it will load a new meta-data part if required.

Public Instance Methods

ClearDashboard |
ClearDashboardArea |
ClearDashboardAreas |
ClearDashboardPart |
ClearDashboardParts |
ClearDashboards |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache Constructor

public DashboardMetadataCache(
AptifyApplication Application
);

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache Properties

The properties of the DashboardMetadataCache class are listed below. For a complete list of DashboardMetadataCache class members, see the DashboardMetadataCache Members topic.

Public Instance Properties

DashboardAreas | This method will either return a Dashboard Area meta-data object from the cache if one exists, or it will load a new meta-data part if required.
DashboardParts | This method will either return a Dashboard Part meta-data object from the cache if one exists, or it will load a new meta-data part if required.
Dashboards | This method will either return a Dashboard meta-data object from the cache if one exists, or it will load a new meta-data part if required.

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreas Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadataCache.DashboardAreas Property

This method will either return a Dashboard Area meta-data object from the cache if one exists, or it will load a new meta-data part if required.

public virtual DashboardAreaMetadata this[
Int64 DashboardAreaID,
DataRow AreaRow,
DataTable PartsTable,
Boolean ForceRefresh
] {get;}

Parameters

DashboardAreaID
AreaRow
PartsTable
ForceRefresh
If this parameter is set to True, the refresh occurs at the database level regardless of if the object was previosly in cache

Property Value

Remarks

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardParts Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadataCache.DashboardParts Property

This method will either return a Dashboard Part meta-data object from the cache if one exists, or it will load a new meta-data part if required.

public virtual DashboardPartMetadata this[
Int64 DashboardPartID,
DataRow DashboardPartDataRow,
Boolean ForceRefresh
] {get;}

Parameters

DashboardPartID
DashboardPartDataRow
ForceRefresh
If this parameter is set to True, the refresh occurs at the database level regardless of if the object was previosly in cache

Property Value

Remarks

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


Dashboards Property

Aptify 5.0 Software Development Kit (SDK)

DashboardMetadataCache.Dashboards Property

This method will either return a Dashboard meta-data object from the cache if one exists, or it will load a new meta-data part if required.

public virtual DashboardMetadata this[
Int64 DashboardID,
Boolean ForceRefresh
] {get;}

Parameters

DashboardID
ForceRefresh

Property Value

Remarks

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache Methods

The methods of the DashboardMetadataCache class are listed below. For a complete list of DashboardMetadataCache class members, see the DashboardMetadataCache Members topic.

Public Static Methods

Instance

Public Instance Methods

ClearDashboard |
ClearDashboardArea |
ClearDashboardAreas |
ClearDashboardPart |
ClearDashboardParts |
ClearDashboards |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache.ClearDashboard Method

public virtual void ClearDashboard(
Int64 DashboardID
);

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache.ClearDashboardArea Method

public virtual void ClearDashboardArea(
Int64 DashboardAreaID
);

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache.ClearDashboardAreas Method

public virtual void ClearDashboardAreas();

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache.ClearDashboardPart Method

public virtual void ClearDashboardPart(
Int64 DashboardPartID
);

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache.ClearDashboardParts Method

public virtual void ClearDashboardParts();

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache.ClearDashboards Method

public virtual void ClearDashboards();

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMetadataCache.Instance Method

public static DashboardMetadataCache Instance(
AptifyApplication Application
);

See Also

DashboardMetadataCache Class | Aptify.Framework.DigitalDashboard Namespace


DashboardMode Enumeration

public enum DashboardMode

Members

Member Name | Description
NotSet |
DashbordRunTime |
DashboardDesignTime |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


DashboardOptionsForm Class

Exposes a GUI that can be used to allow users to configure Dashboard options.

For a list of all members of this type, see DashboardOptionsForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
DashboardOptionsForm

public class DashboardOptionsForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: AptifyDashboardLayout (in AptifyDashboardLayout.dll)

See Also

DashboardOptionsForm Members | Aptify.Framework.DigitalDashboard Namespace


DashboardOptionsForm Members

DashboardOptionsForm overview

Public Instance Constructors

DashboardOptionsForm Constructor Initializes a new instance of the DashboardOptionsForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DashboardID | Returns the Id for the currently loaded Dashboard.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Configures the Options Form to display the options for a specific Dashboard.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DashboardOptionsForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardOptionsForm Constructor

Initializes a new instance of the DashboardOptionsForm class.

public DashboardOptionsForm();

See Also

DashboardOptionsForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardOptionsForm Properties

The properties of the DashboardOptionsForm class are listed below. For a complete list of DashboardOptionsForm class members, see the DashboardOptionsForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DashboardID | Returns the Id for the currently loaded Dashboard.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

DashboardOptionsForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardOptionsForm.DashboardID Property

Returns the Id for the currently loaded Dashboard.

public Int64 DashboardID {get;}

Property Value

Returns the Id for the currently loaded Dashboard. Returns a -1 if the Dashboard is new and has not been saved.

Remarks

See Also

DashboardOptionsForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardOptionsForm Methods

The methods of the DashboardOptionsForm class are listed below. For a complete list of DashboardOptionsForm class members, see the DashboardOptionsForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Configures the Options Form to display the options for a specific Dashboard.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DashboardOptionsForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardOptionsForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

DashboardOptionsForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardOptionsForm.Config Method

Configures the Options Form to display the options for a specific Dashboard.

public void Config(
Int64 DashboardID,
AptifyApplication ApplicationObject,
ApplicationScope Scope,
Int64 ApplicationID,
String UsageScope,
Int64 UserID,
Int64 GroupID
);

Parameters

DashboardID
The ID of the Dashboard to load.
ApplicationObject
A configured AptifyApplication
Scope
The scope determines if the Dashboard can be loaded by the current user.
ApplicationID
The Id of the Application that the Dashboard belongs to.
UsageScope
Determines if this Dashboard should be used for as a Global Dashboard or as a User Dashboard.
UserID
The specific ID of a User record.
GroupID
The specific ID of a Group record.

See Also

DashboardOptionsForm Class | Aptify.Framework.DigitalDashboard Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DashboardOptionsForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

DashboardOptionsForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardOptionsForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

DashboardOptionsForm Class | Aptify.Framework.DigitalDashboard Namespace | DashboardOptionsForm.Dispose Overload List


DashboardPartConfigurationForm Class

This is an implementation of IDashboardConfigurationForm and it is used to configure dashboard parts.

For a list of all members of this type, see DashboardPartConfigurationForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
DashboardPartConfigurationForm

public class DashboardPartConfigurationForm : Form, IDashboardConfigurationForm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Example

Dim oPart As IDashboardConfigurationForm
oPart = DirectCast(AppDomain.CurrentDomain.CreateInstanceAndUnwrap("IAptifyDashboard", "Aptify.Framework.DigitalDashboard.DashboardPartConfigurationForm"), IDashboardConfigurationForm)

'configure a new part for this area
oPart.Config(-1, m_lAreaID, m_oApplication)

'display the new configuration form
If oPart.ShowDialog = DialogResult.OK Then
    'need to reload the dashboardarea
End If
oPart.Dispose()

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

DashboardPartConfigurationForm Members | Aptify.Framework.DigitalDashboard Namespace


DashboardPartConfigurationForm Members

DashboardPartConfigurationForm overview

Public Instance Constructors

DashboardPartConfigurationForm Constructor Initializes a new instance of the DashboardPartConfigurationForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartConfigurationForm Constructor

Initializes a new instance of the DashboardPartConfigurationForm class.

public DashboardPartConfigurationForm();

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartConfigurationForm Properties

The properties of the DashboardPartConfigurationForm class are listed below. For a complete list of DashboardPartConfigurationForm class members, see the DashboardPartConfigurationForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartConfigurationForm.ID Property

public Int64 ID {get;}

Implements

IDashboardConfigurationForm.

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartConfigurationForm Methods

The methods of the DashboardPartConfigurationForm class are listed below. For a complete list of DashboardPartConfigurationForm class members, see the DashboardPartConfigurationForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartConfigurationForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartConfigurationForm.Config Method

public void Config(
Int64 ID,
Int64 ContainerID,
AptifyApplication ApplicationObject
);

Implements

IDashboardConfigurationForm.

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DashboardPartConfigurationForm.Dispose Method

Overload List

new public void Dispose();

new protected void Dispose(Boolean);

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartConfigurationForm.Dispose Method ()

new public void Dispose();

Implements

IDashboardConfigurationForm.

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace | DashboardPartConfigurationForm.Dispose Overload List


DashboardPartConfigurationForm.Dispose Method (Boolean)

new protected void Dispose(
Boolean disposing
);

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace | DashboardPartConfigurationForm.Dispose Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

DashboardPartConfigurationForm.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartConfigurationForm.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IDashboardConfigurationForm.

See Also

DashboardPartConfigurationForm Class | Aptify.Framework.DigitalDashboard Namespace | DashboardPartConfigurationForm.ShowDialog Overload List


DashboardPartInputMap Class

This class represents Input Map items within a Dashboard Part

For a list of all members of this type, see DashboardPartInputMap Members.

System.Object
DashboardPartInputMap

public class DashboardPartInputMap

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

DashboardPartInputMap Members | Aptify.Framework.DigitalDashboard Namespace


DashboardPartInputMap Members

DashboardPartInputMap overview

Public Instance Constructors

DashboardPartInputMap Constructor

Public Instance Properties

Comments
DashboardPartID
ID
InputProperty
Sequence
Source
SourceType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_dr

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartInputMap Constructor

public DashboardPartInputMap(
DataRow InputMapDataRow
);

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartInputMap Fields

The fields of the DashboardPartInputMap class are listed below. For a complete list of DashboardPartInputMap class members, see the DashboardPartInputMap Members topic.

Protected Instance Fields

m_dr

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartInputMap.m_dr Field

protected m_dr m_dr;

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartInputMap Properties

The properties of the DashboardPartInputMap class are listed below. For a complete list of DashboardPartInputMap class members, see the DashboardPartInputMap Members topic.

Public Instance Properties

Comments
DashboardPartID
ID
InputProperty
Sequence
Source
SourceType

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartInputMap.Comments Property

public virtual String Comments {get;}

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartInputMap.DashboardPartID Property

public virtual Int64 DashboardPartID {get;}

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartInputMap.ID Property

public virtual Int64 ID {get;}

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


InputProperty Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartInputMap.InputProperty Property

public virtual String InputProperty {get;}

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartInputMap.Sequence Property

public virtual Int64 Sequence {get;}

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


Source Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartInputMap.Source Property

public virtual String Source {get;}

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


SourceType Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartInputMap.SourceType Property

public virtual DashboardPartInputMap.InputMapSourceType SourceType {get;}

See Also

DashboardPartInputMap Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartInputMap.InputMapSourceType Enumeration

public enum DashboardPartInputMap.InputMapSourceType

Members

Member Name | Description
StaticValue |
SQLStatement |
Formula |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


DashboardPartMetadata Class

This class represents an instance of meta-data for a specific Dashboard Part

For a list of all members of this type, see DashboardPartMetadata Members.

System.Object
DashboardMetadataBase
DashboardPartMetadata

public class DashboardPartMetadata : DashboardMetadataBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

DashboardPartMetadata Members | Aptify.Framework.DigitalDashboard Namespace


DashboardPartMetadata Members

DashboardPartMetadata overview

Public Instance Constructors

DashboardPartMetadata Overloaded. Initializes a new instance of the DashboardPartMetadata class.

Public Instance Properties

Application (inherited from DashboardMetadataBase)
AssemblyName
BasePart
BasePartID
ClassName
Comments
DashboardArea
DashboardAreaID
DashboardAreaName
DashboardComponent
DashboardComponentID
DashboardPartUserValueID
Data (inherited from DashboardMetadataBase)
DataAction (inherited from DashboardMetadataBase)
Description
DisplayCultureStringID
DisplayCultureStringName
FormComponent
FormComponentID
ID
InputMap
Item (inherited from DashboardMetadataBase)
License
Name
ObjectName
Position
Proportion
PropPageAssemblyName
PropPageClassName
PropPageLicense
PropPageObjectName
ResizeMode
ShowMinButton
ShowRemoveButton
ShowTitleBar
State
TitleBarBackColor
TitleBarTextColor
WebAssemblyName
WebClass
WebLicense
WebObject

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Overloaded. Refresh the Dashboard Part meta-data in the database
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Database (inherited from DashboardMetadataBase)
DataRow (inherited from DashboardMetadataBase)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadInputMap |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartMetadata Constructor

Overload List

public DashboardPartMetadata(AptifyApplication,DataAction,Int64);

public DashboardPartMetadata(AptifyApplication,DataAction,Int64,DataRow);

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartMetadata Constructor (AptifyApplication, DataAction, Int64)

public DashboardPartMetadata(
AptifyApplication Application,
DataAction DataAction,
Int64 DashboardPartID
);

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace | DashboardPartMetadata Constructor Overload List


DashboardPartMetadata Constructor (AptifyApplication, DataAction, Int64, DataRow)

public DashboardPartMetadata(
AptifyApplication Application,
DataAction DataAction,
Int64 DashboardPartID,
DataRow DataRow
);

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace | DashboardPartMetadata Constructor Overload List


DashboardPartMetadata Properties

The properties of the DashboardPartMetadata class are listed below. For a complete list of DashboardPartMetadata class members, see the DashboardPartMetadata Members topic.

Public Instance Properties

Application (inherited from DashboardMetadataBase)
AssemblyName
BasePart
BasePartID
ClassName
Comments
DashboardArea
DashboardAreaID
DashboardAreaName
DashboardComponent
DashboardComponentID
DashboardPartUserValueID
Data (inherited from DashboardMetadataBase)
DataAction (inherited from DashboardMetadataBase)
Description
DisplayCultureStringID
DisplayCultureStringName
FormComponent
FormComponentID
ID
InputMap
Item (inherited from DashboardMetadataBase)
License
Name
ObjectName
Position
Proportion
PropPageAssemblyName
PropPageClassName
PropPageLicense
PropPageObjectName
ResizeMode
ShowMinButton
ShowRemoveButton
ShowTitleBar
State
TitleBarBackColor
TitleBarTextColor
WebAssemblyName
WebClass
WebLicense
WebObject

Protected Instance Properties

Database (inherited from DashboardMetadataBase)
DataRow (inherited from DashboardMetadataBase)

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


AssemblyName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.AssemblyName Property

public virtual String AssemblyName {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


BasePart Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.BasePart Property

public virtual String BasePart {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


BasePartID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.BasePartID Property

public virtual Int64 BasePartID {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ClassName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.ClassName Property

public virtual String ClassName {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.Comments Property

public virtual String Comments {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardArea Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.DashboardArea Property

public virtual DashboardAreaMetadata DashboardArea {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.DashboardAreaID Property

public virtual Int64 DashboardAreaID {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardAreaName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.DashboardAreaName Property

public virtual String DashboardAreaName {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardComponent Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.DashboardComponent Property

public virtual String DashboardComponent {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardComponentID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.DashboardComponentID Property

public virtual Int64 DashboardComponentID {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartUserValueID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.DashboardPartUserValueID Property

public virtual Int64 DashboardPartUserValueID {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.Description Property

public virtual String Description {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DisplayCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.DisplayCultureStringID Property

public virtual Int64 DisplayCultureStringID {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DisplayCultureStringName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.DisplayCultureStringName Property

public virtual String DisplayCultureStringName {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


FormComponent Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.FormComponent Property

public virtual String FormComponent {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


FormComponentID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.FormComponentID Property

public virtual Int64 FormComponentID {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.ID Property

public virtual Int64 ID {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


InputMap Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.InputMap Property

public virtual List<T> InputMap {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


License Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.License Property

public virtual String License {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.Name Property

public virtual String Name {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ObjectName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.ObjectName Property

public virtual String ObjectName {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Position Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.Position Property

public virtual Int32 Position {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Proportion Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.Proportion Property

public virtual Single Proportion {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


PropPageAssemblyName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.PropPageAssemblyName Property

public virtual String PropPageAssemblyName {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


PropPageClassName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.PropPageClassName Property

public virtual String PropPageClassName {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


PropPageLicense Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.PropPageLicense Property

public virtual String PropPageLicense {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


PropPageObjectName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.PropPageObjectName Property

public virtual String PropPageObjectName {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ResizeMode Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.ResizeMode Property

public virtual DashboardResizeMode ResizeMode {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ShowMinButton Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.ShowMinButton Property

public virtual Boolean ShowMinButton {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ShowRemoveButton Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.ShowRemoveButton Property

public virtual Boolean ShowRemoveButton {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


ShowTitleBar Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.ShowTitleBar Property

public virtual Boolean ShowTitleBar {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.State Property

public virtual DashboardPartMetadata.DashboardPartState State {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


TitleBarBackColor Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.TitleBarBackColor Property

public virtual Color TitleBarBackColor {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


TitleBarTextColor Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.TitleBarTextColor Property

public virtual Color TitleBarTextColor {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


WebAssemblyName Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.WebAssemblyName Property

public virtual String WebAssemblyName {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


WebClass Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.WebClass Property

public virtual String WebClass {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


WebLicense Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.WebLicense Property

public virtual String WebLicense {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


WebObject Property

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.WebObject Property

public virtual String WebObject {get;}

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartMetadata Methods

The methods of the DashboardPartMetadata class are listed below. For a complete list of DashboardPartMetadata class members, see the DashboardPartMetadata Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Overloaded. Refresh the Dashboard Part meta-data in the database
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadInputMap |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartMetadata.LoadInputMap Method

protected virtual void LoadInputMap(
Boolean Refresh
);

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


Refresh Method

Aptify 5.0 Software Development Kit (SDK)

DashboardPartMetadata.Refresh Method

Refresh the Dashboard Part meta-data in the database

Overload List

Refresh the Dashboard Part meta-data in the database

public override void Refresh(Boolean);

Refresh the Dashboard Part meta-data from a specified data-row

public void Refresh(DataRow);

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace


DashboardPartMetadata.Refresh Method (Boolean)

Refresh the Dashboard Part meta-data in the database

public override void Refresh(
Boolean RefreshDataCache
);

Remarks

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace | DashboardPartMetadata.Refresh Overload List


DashboardPartMetadata.Refresh Method (DataRow)

Refresh the Dashboard Part meta-data from a specified data-row

public void Refresh(
DataRow DataRow
);

Parameters

DataRow

Remarks

See Also

DashboardPartMetadata Class | Aptify.Framework.DigitalDashboard Namespace | DashboardPartMetadata.Refresh Overload List


DashboardPartMetadata.DashboardPartState Enumeration

public enum DashboardPartMetadata.DashboardPartState

Members

Member Name | Description
Normal |
Minimized |
Maximized |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


DashboardPartResizeMode Enumeration

public enum DashboardPartResizeMode

Members

Member Name | Description
Fixed |
Proportional |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


DashboardResizeMode Enumeration

public enum DashboardResizeMode

Members

Member Name | Description
None |
Proportional |
Fill |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: DashboardMetadata (in DashboardMetadata.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


DashCtrlWrapper Class

This class provides a container for user defined parts.

For a list of all members of this type, see DashCtrlWrapper Members.

System.Object
MarshalByRefObject
Component
Control
UltraControlBase
UltraGroupBox
DashCtrlWrapper

public class DashCtrlWrapper : UltraGroupBox, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The dashboard area is the object that will be used in digital dashboards to host components.

Example

DashWrapper.Mode = Me.Mode
DashWrapper.Config(m_oApplication, m_lAreaID, DashLayout)
DashWrapper.State=Normal
DashWrapper.Mode=DashboardRuntime

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: AptifyDashCtrlWrapper (in AptifyDashCtrlWrapper.dll)

See Also

DashCtrlWrapper Members | Aptify.Framework.DigitalDashboard Namespace


DashCtrlWrapper Members

DashCtrlWrapper overview

Public Static Methods

LoadPartProperties This method is shared and will add the properties to the property collection for a given DashboardComponent

Public Instance Constructors

DashCtrlWrapper Constructor Initializes a new instance of the DashCtrlWrapper class.

Public Instance Properties

About (inherited from Infragistics.Win.Misc.UltraGroupBox) |
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AlphaBlendEnabled (inherited from Infragistics.Win.UltraControlBase) | Obsolete.
AlphaBlendMode (inherited from Infragistics.Win.UltraControlBase) |
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Appearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoSize (inherited from Control) | This property is not relevant for this class.
BackColor (inherited from Infragistics.Win.Misc.UltraGroupBox) |
BackColorInternal (inherited from Infragistics.Win.Misc.UltraGroupBox) |
BackgroundImage (inherited from Infragistics.Win.Misc.UltraGroupBox) |
BackgroundImageLayout (inherited from Infragistics.Win.UltraControlBase) |
BaseCursor (inherited from Infragistics.Win.UltraControlBase) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Infragistics.Win.Misc.UltraGroupBox) |
BorderStyleResolved (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionAlignment (inherited from Infragistics.Win.Misc.UltraGroupBox) |
CaptionAlignmentResolved (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
ComponentRole (inherited from Infragistics.Win.UltraControlBase) |
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContentAreaAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ContentPadding (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CreationFilter (inherited from Infragistics.Win.UltraControlBase) |
Cursor (inherited from Infragistics.Win.UltraControlBase) |
CursorFilter (inherited from Infragistics.Win.UltraControlBase) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DrawFilter (inherited from Infragistics.Win.UltraControlBase) |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatMode (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HasContentAreaAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HasHeaderAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HeaderAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HeaderBorderStyle (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HeaderBorderStyleResolved (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HeaderPosition (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HeaderPositionResolved (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Height (inherited from Control) | Gets or sets the height of the control.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsUpdating (inherited from Infragistics.Win.UltraControlBase) |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Infragistics.Win.UltraControlBase) |
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
StyleLibraryName (inherited from Infragistics.Win.UltraControlBase) |
StyleSetName (inherited from Infragistics.Win.UltraControlBase) |
SupportThemes (inherited from Infragistics.Win.Misc.UltraGroupBox) |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text |
TextRenderingMode (inherited from Infragistics.Win.UltraControlBase) |
ToolBarVisible |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UIElement (inherited from Infragistics.Win.Misc.UltraGroupBox) |
UseAppStyling (inherited from Infragistics.Win.UltraControlBase) |
UseFlatMode (inherited from Infragistics.Win.Misc.UltraGroupBox) |
UseFlatModeResolved (inherited from Infragistics.Win.UltraControlBase) |
UseMnemonic (inherited from Infragistics.Win.Misc.UltraGroupBox) |
UseOsThemes (inherited from Infragistics.Win.Misc.UltraGroupBox) |
UseOsThemesResolved (inherited from Infragistics.Win.UltraControlBase) |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalTextOrientation (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ViewStyle (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ViewStyleResolved (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WrapText (inherited from Infragistics.Win.Misc.UltraGroupBox) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from Infragistics.Win.UltraControlBase) |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
EndUpdate (inherited from Infragistics.Win.UltraControlBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredControlSize (inherited from Infragistics.Win.Misc.UltraGroupBox) |
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Infragistics.Win.UltraControlBase) | Overloaded.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Infragistics.Win.UltraControlBase) |
ResetAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetContentAreaAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ResetContentPadding (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetHeaderAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetInnerObject |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Infragistics.Win.UltraControlBase) |

Public Instance Events

AutoSizeChanged (inherited from Control) | This event is not relevant for this class.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseEnterElement (inherited from Infragistics.Win.UltraControlBase) |
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseLeaveElement (inherited from Infragistics.Win.UltraControlBase) |
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
PropertyChanged (inherited from Infragistics.Win.UltraControlBase) |
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
ControlUIElement (inherited from Infragistics.Win.Misc.UltraGroupBox) |
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Infragistics.Win.Misc.UltraGroupBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Infragistics.Win.UltraControlBase) |
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubObjectPropChangeHandler (inherited from Infragistics.Win.Misc.UltraGroupBox) |
SupportsEditorWithMask (inherited from Infragistics.Win.UltraControlBase) |
SupportsFormattedLinkEditor (inherited from Infragistics.Win.UltraControlBase) |
SuppressExpansionEvents (inherited from Infragistics.Win.Misc.UltraGroupBox) |

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
CreateAccessibilityInstance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
CreateComponentRole (inherited from Infragistics.Win.Misc.UltraGroupBox) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DrawControl (inherited from Infragistics.Win.UltraControlBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetSelectionManager (inherited from Infragistics.Win.UltraControlBase) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyDesignEnvironmentOfChange (inherited from Infragistics.Win.UltraControlBase) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
NotifyPropChange (inherited from Infragistics.Win.UltraControlBase) | Overloaded.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Infragistics.Win.UltraControlBase) |
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBeginInit (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Infragistics.Win.UltraControlBase) |
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Infragistics.Win.UltraControlBase) |
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Infragistics.Win.UltraControlBase) |
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnEndInit (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Infragistics.Win.UltraControlBase) |
OnHandleCreated (inherited from Infragistics.Win.UltraControlBase) |
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Infragistics.Win.UltraControlBase) |
OnKeyPress (inherited from Infragistics.Win.UltraControlBase) |
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoadConfigInnerObject | This method is reponsible for loading and configuring the inner object within the dashboard component wrapper.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Infragistics.Win.UltraControlBase) |
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Infragistics.Win.UltraControlBase) |
OnMouseEnter (inherited from Infragistics.Win.UltraControlBase) |
OnMouseEnterElement (inherited from Infragistics.Win.UltraControlBase) |
OnMouseHover (inherited from Infragistics.Win.UltraControlBase) |
OnMouseLeave (inherited from Infragistics.Win.UltraControlBase) |
OnMouseLeaveElement (inherited from Infragistics.Win.UltraControlBase) |
OnMouseMove (inherited from Infragistics.Win.UltraControlBase) |
OnMouseUp (inherited from Infragistics.Win.UltraControlBase) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnOffice2007ColorSchemeChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnPaddingChanged (inherited from Control) | Raises the PaddingChanged event.
OnPaint (inherited from Infragistics.Win.UltraControlBase) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Infragistics.Win.UltraControlBase) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnPropertyChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Infragistics.Win.UltraControlBase) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSubObjectPropChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnThemeChanged (inherited from Infragistics.Win.UltraControlBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Infragistics.Win.UltraControlBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Infragistics.Win.Misc.UltraGroupBox) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshControlSize (inherited from Infragistics.Win.Misc.UltraGroupBox) |
RefreshPanel (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
ScaleCore (inherited from Control) |
ScrollControl (inherited from Infragistics.Win.UltraControlBase) |
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ShouldSerializeContentAreaAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ShouldSerializeContentPadding (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ShouldSerializeHeaderAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Properties

DesignerChangeNotificationsDisabled (inherited from Infragistics.Win.UltraControlBase) |
HasExpansionIndicator (inherited from Infragistics.Win.Misc.UltraGroupBox) |
RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
FocusInternal (inherited from Infragistics.Win.UltraControlBase) |
ForwardMouseMove (inherited from Infragistics.Win.UltraControlBase) |
IsPointDesignTimeActive (inherited from Infragistics.Win.UltraControlBase) |
OnAppStyleChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
SetFocusToNextControl (inherited from Infragistics.Win.UltraControlBase) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


DashCtrlWrapper Constructor

Initializes a new instance of the DashCtrlWrapper class.

public DashCtrlWrapper();

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


DashCtrlWrapper Properties

The properties of the DashCtrlWrapper class are listed below. For a complete list of DashCtrlWrapper class members, see the DashCtrlWrapper Members topic.

Public Instance Properties

About (inherited from Infragistics.Win.Misc.UltraGroupBox) |
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AlphaBlendEnabled (inherited from Infragistics.Win.UltraControlBase) | Obsolete.
AlphaBlendMode (inherited from Infragistics.Win.UltraControlBase) |
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Appearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoSize (inherited from Control) | This property is not relevant for this class.
BackColor (inherited from Infragistics.Win.Misc.UltraGroupBox) |
BackColorInternal (inherited from Infragistics.Win.Misc.UltraGroupBox) |
BackgroundImage (inherited from Infragistics.Win.Misc.UltraGroupBox) |
BackgroundImageLayout (inherited from Infragistics.Win.UltraControlBase) |
BaseCursor (inherited from Infragistics.Win.UltraControlBase) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Infragistics.Win.Misc.UltraGroupBox) |
BorderStyleResolved (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
CaptionAlignment (inherited from Infragistics.Win.Misc.UltraGroupBox) |
CaptionAlignmentResolved (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
ComponentRole (inherited from Infragistics.Win.UltraControlBase) |
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContentAreaAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ContentPadding (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CreationFilter (inherited from Infragistics.Win.UltraControlBase) |
Cursor (inherited from Infragistics.Win.UltraControlBase) |
CursorFilter (inherited from Infragistics.Win.UltraControlBase) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DrawFilter (inherited from Infragistics.Win.UltraControlBase) |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatMode (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
HasContentAreaAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HasHeaderAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HeaderAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HeaderBorderStyle (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HeaderBorderStyleResolved (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HeaderPosition (inherited from Infragistics.Win.Misc.UltraGroupBox) |
HeaderPositionResolved (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Height (inherited from Control) | Gets or sets the height of the control.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsUpdating (inherited from Infragistics.Win.UltraControlBase) |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Infragistics.Win.UltraControlBase) |
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
StyleLibraryName (inherited from Infragistics.Win.UltraControlBase) |
StyleSetName (inherited from Infragistics.Win.UltraControlBase) |
SupportThemes (inherited from Infragistics.Win.Misc.UltraGroupBox) |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text |
TextRenderingMode (inherited from Infragistics.Win.UltraControlBase) |
ToolBarVisible |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UIElement (inherited from Infragistics.Win.Misc.UltraGroupBox) |
UseAppStyling (inherited from Infragistics.Win.UltraControlBase) |
UseFlatMode (inherited from Infragistics.Win.Misc.UltraGroupBox) |
UseFlatModeResolved (inherited from Infragistics.Win.UltraControlBase) |
UseMnemonic (inherited from Infragistics.Win.Misc.UltraGroupBox) |
UseOsThemes (inherited from Infragistics.Win.Misc.UltraGroupBox) |
UseOsThemesResolved (inherited from Infragistics.Win.UltraControlBase) |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalTextOrientation (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ViewStyle (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ViewStyleResolved (inherited from Infragistics.Win.Misc.UltraGroupBox) |
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |
WrapText (inherited from Infragistics.Win.Misc.UltraGroupBox) |

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
ControlUIElement (inherited from Infragistics.Win.Misc.UltraGroupBox) |
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Infragistics.Win.Misc.UltraGroupBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Infragistics.Win.UltraControlBase) |
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubObjectPropChangeHandler (inherited from Infragistics.Win.Misc.UltraGroupBox) |
SupportsEditorWithMask (inherited from Infragistics.Win.UltraControlBase) |
SupportsFormattedLinkEditor (inherited from Infragistics.Win.UltraControlBase) |
SuppressExpansionEvents (inherited from Infragistics.Win.Misc.UltraGroupBox) |

Protected Internal Instance Properties

DesignerChangeNotificationsDisabled (inherited from Infragistics.Win.UltraControlBase) |
HasExpansionIndicator (inherited from Infragistics.Win.Misc.UltraGroupBox) |
RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

DashCtrlWrapper.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

DashCtrlWrapper.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

DashCtrlWrapper.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

DashCtrlWrapper.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


Text Property

Aptify 5.0 Software Development Kit (SDK)

DashCtrlWrapper.Text Property

new public String Text {get;}

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


ToolBarVisible Property

Aptify 5.0 Software Development Kit (SDK)

DashCtrlWrapper.ToolBarVisible Property

public Boolean ToolBarVisible {get; set;}

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


DashCtrlWrapper Methods

The methods of the DashCtrlWrapper class are listed below. For a complete list of DashCtrlWrapper class members, see the DashCtrlWrapper Members topic.

Public Static Methods

LoadPartProperties This method is shared and will add the properties to the property collection for a given DashboardComponent

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from Infragistics.Win.UltraControlBase) |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
EndUpdate (inherited from Infragistics.Win.UltraControlBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredControlSize (inherited from Infragistics.Win.Misc.UltraGroupBox) |
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Infragistics.Win.UltraControlBase) | Overloaded.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Infragistics.Win.UltraControlBase) |
ResetAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetContentAreaAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ResetContentPadding (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetHeaderAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetInnerObject |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Infragistics.Win.UltraControlBase) |

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
CreateAccessibilityInstance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
CreateComponentRole (inherited from Infragistics.Win.Misc.UltraGroupBox) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DrawControl (inherited from Infragistics.Win.UltraControlBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetSelectionManager (inherited from Infragistics.Win.UltraControlBase) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyDesignEnvironmentOfChange (inherited from Infragistics.Win.UltraControlBase) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
NotifyPropChange (inherited from Infragistics.Win.UltraControlBase) | Overloaded.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Infragistics.Win.UltraControlBase) |
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBeginInit (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Infragistics.Win.UltraControlBase) |
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Infragistics.Win.UltraControlBase) |
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Infragistics.Win.UltraControlBase) |
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnEndInit (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Infragistics.Win.UltraControlBase) |
OnHandleCreated (inherited from Infragistics.Win.UltraControlBase) |
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Infragistics.Win.UltraControlBase) |
OnKeyPress (inherited from Infragistics.Win.UltraControlBase) |
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoadConfigInnerObject | This method is reponsible for loading and configuring the inner object within the dashboard component wrapper.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Infragistics.Win.UltraControlBase) |
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Infragistics.Win.UltraControlBase) |
OnMouseEnter (inherited from Infragistics.Win.UltraControlBase) |
OnMouseEnterElement (inherited from Infragistics.Win.UltraControlBase) |
OnMouseHover (inherited from Infragistics.Win.UltraControlBase) |
OnMouseLeave (inherited from Infragistics.Win.UltraControlBase) |
OnMouseLeaveElement (inherited from Infragistics.Win.UltraControlBase) |
OnMouseMove (inherited from Infragistics.Win.UltraControlBase) |
OnMouseUp (inherited from Infragistics.Win.UltraControlBase) |
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnOffice2007ColorSchemeChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnPaddingChanged (inherited from Control) | Raises the PaddingChanged event.
OnPaint (inherited from Infragistics.Win.UltraControlBase) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Infragistics.Win.UltraControlBase) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnPropertyChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Infragistics.Win.UltraControlBase) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSubObjectPropChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnThemeChanged (inherited from Infragistics.Win.UltraControlBase) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Infragistics.Win.UltraControlBase) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Infragistics.Win.Misc.UltraGroupBox) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshControlSize (inherited from Infragistics.Win.Misc.UltraGroupBox) |
RefreshPanel (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
ScaleCore (inherited from Control) |
ScrollControl (inherited from Infragistics.Win.UltraControlBase) |
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShouldSerializeAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ShouldSerializeContentAreaAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ShouldSerializeContentPadding (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ShouldSerializeHeaderAppearance (inherited from Infragistics.Win.Misc.UltraGroupBox) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
FocusInternal (inherited from Infragistics.Win.UltraControlBase) |
ForwardMouseMove (inherited from Infragistics.Win.UltraControlBase) |
IsPointDesignTimeActive (inherited from Infragistics.Win.UltraControlBase) |
OnAppStyleChanged (inherited from Infragistics.Win.Misc.UltraGroupBox) |
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
SetFocusToNextControl (inherited from Infragistics.Win.UltraControlBase) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


DashCtrlWrapper.Config Method

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Implements

IDashboardComponent.

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DashCtrlWrapper.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


DashCtrlWrapper.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace | DashCtrlWrapper.Dispose Overload List


DashCtrlWrapper.LoadPartProperties Method

This method is shared and will add the properties to the property collection for a given DashboardComponent

public static void LoadPartProperties(
IDashboardComponent Component,
Int64 PartID,
AptifyApplication ApplicationObject,
IAptifyDataAction DataAction
);

Parameters

Component
The component that will have its properties loaded.
PartID
The ID of the dashboard part that needs its properties loaded.
ApplicationObject
An instantiated class that is used to retrieve general system information.
DataAction
An instantiated DataAction that will be used to retrieve the properties.

Remarks

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


DashCtrlWrapper.OnLoadConfigInnerObject Method

This method is reponsible for loading and configuring the inner object within the dashboard component wrapper.

protected virtual void OnLoadConfigInnerObject();

Remarks

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


DashCtrlWrapper.SetInnerObject Method

public void SetInnerObject(
ref String& AssemblyName,
String TypeName
);

See Also

DashCtrlWrapper Class | Aptify.Framework.DigitalDashboard Namespace


DropPanel Class

Provides the target used to drop Views onto.

For a list of all members of this type, see DropPanel Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
DropPanel

public class DropPanel : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: AptifyDashboardArea (in AptifyDashboardArea.dll)

See Also

DropPanel Members | Aptify.Framework.DigitalDashboard Namespace


DropPanel Members

DropPanel overview

Public Instance Constructors

DropPanel Constructor Initializes a new instance of the DropPanel class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
Position | Returns and sets the position that will be used for the part when it is dropped.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
Draw | Draws the Drop Panel.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetHighWord |
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLowWord | Overloaded.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace


DropPanel Constructor

Initializes a new instance of the DropPanel class.

public DropPanel();

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace


DropPanel Properties

The properties of the DropPanel class are listed below. For a complete list of DropPanel class members, see the DropPanel Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
Position | Returns and sets the position that will be used for the part when it is dropped.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace


Position Property

Aptify 5.0 Software Development Kit (SDK)

DropPanel.Position Property

Returns and sets the position that will be used for the part when it is dropped.

public Int32 Position {get; set;}

Property Value

Remarks

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace


DropPanel Methods

The methods of the DropPanel class are listed below. For a complete list of DropPanel class members, see the DropPanel Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
Draw | Draws the Drop Panel.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetHighWord |
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLowWord | Overloaded.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DropPanel.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace


DropPanel.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace | DropPanel.Dispose Overload List


DropPanel.Draw Method

Draws the Drop Panel.

public void Draw(
Int32 NumberOfParts,
DashAreaStyle DashboardAreaStyle
);

Parameters

NumberOfParts
DashboardAreaStyle

Remarks

This needs to be called so we can know how many parts will be on the form.

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace


DropPanel.GetHighWord Method

public int GetHighWord(
ref Int32& pintValue
);

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace


GetLowWord Method

Aptify 5.0 Software Development Kit (SDK)

DropPanel.GetLowWord Method

Overload List

public int GetLowWord(ref Int32&);

public int GetLowWord(ref IntPtr&);

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace


DropPanel.GetLowWord Method (Int32&)

public int GetLowWord(
ref Int32& pintValue
);

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace | DropPanel.GetLowWord Overload List


DropPanel.GetLowWord Method (IntPtr&)

public int GetLowWord(
ref IntPtr& pudtValue
);

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace | DropPanel.GetLowWord Overload List


DropPanel.OnPaint Method

protected override void OnPaint(
PaintEventArgs e
);

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace


DropPanel.WndProc Method

protected override void WndProc(
ref Message& m
);

See Also

DropPanel Class | Aptify.Framework.DigitalDashboard Namespace


FadePanel Class

Provieds the fade in effect when dragging and dropping views onto a dashboard.

For a list of all members of this type, see FadePanel Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FadePanel

public class FadePanel : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: AptifyDashboardArea (in AptifyDashboardArea.dll)

See Also

FadePanel Members | Aptify.Framework.DigitalDashboard Namespace


FadePanel Members

FadePanel overview

Public Instance Constructors

FadePanel Constructor Initializes a new instance of the FadePanel class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FadeIn | Starts the fade in.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint |
OnPaintBackground |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FadePanel Class | Aptify.Framework.DigitalDashboard Namespace


FadePanel Constructor

Initializes a new instance of the FadePanel class.

public FadePanel();

See Also

FadePanel Class | Aptify.Framework.DigitalDashboard Namespace


FadePanel Properties

The properties of the FadePanel class are listed below. For a complete list of FadePanel class members, see the FadePanel Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

FadePanel Class | Aptify.Framework.DigitalDashboard Namespace


CreateParams Property

Aptify 5.0 Software Development Kit (SDK)

FadePanel.CreateParams Property

protected override CreateParams CreateParams {get;}

See Also

FadePanel Class | Aptify.Framework.DigitalDashboard Namespace


FadePanel Methods

The methods of the FadePanel class are listed below. For a complete list of FadePanel class members, see the FadePanel Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FadeIn | Starts the fade in.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint |
OnPaintBackground |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FadePanel Class | Aptify.Framework.DigitalDashboard Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

FadePanel.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

FadePanel Class | Aptify.Framework.DigitalDashboard Namespace


FadePanel.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

FadePanel Class | Aptify.Framework.DigitalDashboard Namespace | FadePanel.Dispose Overload List


FadePanel.FadeIn Method

Starts the fade in.

public void FadeIn(
Int32 NumberOfParts,
DashAreaStyle DashboardAreaStyle
);

Parameters

NumberOfParts
DashboardAreaStyle

Remarks

See Also

FadePanel Class | Aptify.Framework.DigitalDashboard Namespace


FadePanel.OnPaint Method

protected override void OnPaint(
PaintEventArgs e
);

See Also

FadePanel Class | Aptify.Framework.DigitalDashboard Namespace


FadePanel.OnPaintBackground Method

protected override void OnPaintBackground(
PaintEventArgs pevent
);

See Also

FadePanel Class | Aptify.Framework.DigitalDashboard Namespace


IDashboardArea Interface

This is the interface implemented by a class that functions as a Dashboard Area. A Dashboard Area acts as a container for Dashboard Components.

For a list of all members of this type, see IDashboardArea Members.

public interface IDashboardArea

Types that implement IDashboardArea

Type | Description
AptifyDashboardArea | This class provides a container for dashboard components.

Remarks

IDashboardArea provides an interface for components that will act as dashboard component containers in the context of the dashboard framework. It will be very unlikely that developers will need to replace or provide plug-ins for this functionality. Therefore, no sample code is provided for this interface.

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

IDashboardArea Members | Aptify.Framework.DigitalDashboard Namespace


IDashboardArea Members

IDashboardArea overview

Public Instance Properties

ID | This is set by the config method with the ID that is used to uniquely identify the Dashboard Area.
Mode | This is used by the control to determine if it should render itself in a Design Time mode or a Runtime mode.

Public Instance Methods

Config | This is the class member that will be called to initialize the area's context.
GetContainer | This returns a reference to the Container of this Area.
GetPart | This returns a reference to the dashboard part that is contained by the area at a specific index. '''
GetPartCount | This returns the current number of parts that are contained in the implemented Area.
NotifyPartChanged | Call back to the container control.
NotifyPartClosed | Call back to the container control.

See Also

IDashboardArea Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardArea Properties

The properties of the IDashboardArea interface are listed below. For a complete list of IDashboardArea interface members, see the IDashboardArea Members topic.

Public Instance Properties

ID | This is set by the config method with the ID that is used to uniquely identify the Dashboard Area.
Mode | This is used by the control to determine if it should render itself in a Design Time mode or a Runtime mode.

See Also

IDashboardArea Interface | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

IDashboardArea.ID Property

This is set by the config method with the ID that is used to uniquely identify the Dashboard Area.

Int64 ID {get;}

See Also

IDashboardArea Interface | Aptify.Framework.DigitalDashboard Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

IDashboardArea.Mode Property

This is used by the control to determine if it should render itself in a Design Time mode or a Runtime mode.

DashboardMode Mode {get; set;}

Remarks

The recommended place to add and remove controls to the component is during the set of this property.

See Also

IDashboardArea Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardArea Methods

The methods of the IDashboardArea interface are listed below. For a complete list of IDashboardArea interface members, see the IDashboardArea Members topic.

Public Instance Methods

Config | This is the class member that will be called to initialize the area's context.
GetContainer | This returns a reference to the Container of this Area.
GetPart | This returns a reference to the dashboard part that is contained by the area at a specific index. '''
GetPartCount | This returns the current number of parts that are contained in the implemented Area.
NotifyPartChanged | Call back to the container control.
NotifyPartClosed | Call back to the container control.

See Also

IDashboardArea Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardArea.Config Method

This is the class member that will be called to initialize the area's context.

void Config(
AptifyApplication ApplicationObject,
Int64 AreaID,
IDashboardContainer Container
);

Parameters

ApplicationObject
An instantiated class that is used to retrieve general system information.
AreaID
The ID of the Dashboard Area record to configure.
Container
This will contain an instantiated reference to the Dashboard container that will host this Area

Remarks

If there is a problem in this method that cannot be handled then it is wrapped in a DashboardAreaException and re-thrown.

See Also

IDashboardArea Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardArea.GetContainer Method

This returns a reference to the Container of this Area.

IDashboardContainer GetContainer();

Return Value

This returns a reference to the Container of this Area.

Remarks

See Also

IDashboardArea Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardArea.GetPart Method

This returns a reference to the dashboard part that is contained by the area at a specific index. '''

IDashboardComponent GetPart(
Int32 Index
);

Parameters

Index
This is the zero-based index for a specific part.

Return Value

This returns a reference to the dashboard part that is contained by the area at a specific index.

Remarks

If the index is less than 0 or greater than the number of parts then nothing is returned.

See Also

IDashboardArea Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardArea.GetPartCount Method

This returns the current number of parts that are contained in the implemented Area.

int GetPartCount();

Return Value

The current number of parts that are contained in the implemented Area.

See Also

IDashboardArea Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardArea.NotifyPartChanged Method

Call back to the container control.

void NotifyPartChanged(
IDashboardComponent Part
);

Parameters

Part
A reference to the part that has changed.

Remarks

When a part changes its state, then it calls the NotifyPartChanged procedure to notify its parent of the change.

See Also

IDashboardArea Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardArea.NotifyPartClosed Method

Call back to the container control.

void NotifyPartClosed(
IDashboardComponent Part
);

Parameters

Part
A reference to the part that has changed.

Remarks

When a user closes a part, the part calls the NotifyPartClosed procedure to notify its parent that the part has been closed

See Also

IDashboardArea Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardComponent Interface

The interface implemented by a class that functions as a Dashboard Component.

For a list of all members of this type, see IDashboardComponent Members.

public interface IDashboardComponent

Types that implement IDashboardComponent

Type | Description
FindCases |
HousingDashboardControl | Aptify Housing Application main dashboard control that provides a user experience for viewing housing blocks, availability, and filtering capabilities
EventHandlerFormComponent |
PendingChangesConsole |
CrystalReportViewer | This wraps the Crystal Report Viewer.
ButtonBar | A dashboard component that allows users to quickly execute common tasks through a button bar GUI.
MostRecentlyUsed | Dashboard comopnent displays the most recently used(either opened or modified) records within the system. Only entities that have enabled the MRU (via Entity Administration) will appear here as there is overhead in tracking MRU but since it is a valuable user feature the overhead maybe worth it for quite a few entity areas. Each installation of the system can configure which entities should have MRU tracking turned on/off.
MostRecentlyUsedDetails | A dashboard component that allows users to quickly access Most Recently Used Records.
ObjectRepositoryDashboard |
OutlookView |
WebBrowser |
DashCtrlWrapper | This class provides a container for user defined parts.
MultiEntityGrid | Implements a grid control for viewing/editing a variety of multi-entity relationship scenarios.
QuestionTreeAdmin |
EntityBrowser | Aptify Entity Browser - displays the content of an entity for browsing views, view folders, etc.
EntityListView | Aptify Entity List View class provides default viewing system functionality for tabular (row/column) style views.
ViewContainer | This is a view container that will dynamically load up a child view type control based on the view type of the view specified. In the event that the view type is NOT specified, the default view type of Entity List View will be used. This is the preferred class to use when displaying a view so that the user has the flexibility to drop in any view type.

Remarks

This interface is the interface that will be most likely used by developers. Developers will implement this interface to make a control accessible to the Aptify Dashboard Framework, therefore it will be very uncommon for a developer to actually call the methods and properties for this interface.

Example

Public Class SampleComponent
    Inherits UserControl
    Implements IDashboardComponent

    Private lbl As Label
    Private m_oApplication As Application.AptifyApplication
    Private m_lPartID As Long
    Private m_oArea As IDashboardArea
    Private m_oOrientation As ComponentOrientation
    Private m_oMode As DashboardMode
    Private m_oProperties As Application.AptifyProperties
    Private m_oState As ComponentState
    Public Sub New()
        MyBase.New()
        lbl = New Label
        lbl.Dock = DockStyle.Fill
        lbl.TextAlign = ContentAlignment.MiddleCenter
    End Sub

    Public Sub Config(ByVal ApplicationObject As Application.AptifyApplication, ByVal Area As IDashboardArea, ByVal PartID As Long, ByVal Orientation As ComponentOrientation) Implements IDashboardComponent.Config
        m_oApplication = ApplicationObject
        m_oArea = Area
        m_lPartID = PartID
        m_oOrientation = Orientation
        m_oMode = DashboardMode.NotSet
        m_oProperties = New Application.AptifyProperties
        m_oState = ComponentState.NotSet
    End Sub

    Public ReadOnly Property ID() As Long Implements IDashboardComponent.ID
        Get
            Return m_lPartID
        End Get
    End Property

    Public Property Mode() As DashboardMode Implements IDashboardComponent.Mode
        Get
            Return m_oMode
        End Get
        Set(ByVal Value As DashboardMode)
            Me.Controls.Clear()
            Select Case Value
                Case NotSet
                    lbl.Text = "We have not set the mode yet"
                Case DashboardRunTime
                    lbl.Text = "Hello World"
                Case DashboardDesigntime
                    lbl.Text = "Some DesignTime Message"
            End Select
            Me.Controls.Add(lbl)
            m_oMode = Value
        End Set
    End Property

    Public ReadOnly Property Properties() As Application.AptifyProperties Implements IDashboardComponent.Properties
        Get
            Return m_oproperties
        End Get
    End Property
    Public Property State() As ComponentState Implements IDashboardComponent.State
        Get
            Return m_ostate
        End Get
        Set(ByVal Value As ComponentState)
            m_oState = Value
        End Set
    End Property
End Class

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

IDashboardComponent Members | Aptify.Framework.DigitalDashboard Namespace


IDashboardComponent Members

IDashboardComponent overview

Public Instance Properties

ID | This is set by the Aptify.Framework.DigitalDashboard.IDashboardComponent.Config, with an ID that is used to uniquely identify the Dashboard Part.
Mode | This determines if the control should render itself in a Design Time mode or a Runtime mode.
Properties | This returns a reference to the Dashboard Components Input Map Properties.
State | This determines whether or not the Component is minimized.

Public Instance Methods

Config Used to Configure the Dasboard Component that implements the interface.

See Also

IDashboardComponent Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardComponent Properties

The properties of the IDashboardComponent interface are listed below. For a complete list of IDashboardComponent interface members, see the IDashboardComponent Members topic.

Public Instance Properties

ID | This is set by the Aptify.Framework.DigitalDashboard.IDashboardComponent.Config, with an ID that is used to uniquely identify the Dashboard Part.
Mode | This determines if the control should render itself in a Design Time mode or a Runtime mode.
Properties | This returns a reference to the Dashboard Components Input Map Properties.
State | This determines whether or not the Component is minimized.

See Also

IDashboardComponent Interface | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

IDashboardComponent.ID Property

This is set by the Aptify.Framework.DigitalDashboard.IDashboardComponent.Config, with an ID that is used to uniquely identify the Dashboard Part.

Int64 ID {get;}

See Also

IDashboardComponent Interface | Aptify.Framework.DigitalDashboard Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

IDashboardComponent.Mode Property

This determines if the control should render itself in a Design Time mode or a Runtime mode.

DashboardMode Mode {get; set;}

Remarks

The recommended place to add and remove controls to the component is during the set of this property.

See Also

IDashboardComponent Interface | Aptify.Framework.DigitalDashboard Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

IDashboardComponent.Properties Property

This returns a reference to the Dashboard Components Input Map Properties.

AptifyProperties Properties {get;}

Remarks

These properties are used by the implementing component to configure itself based on metadata values.

See Also

IDashboardComponent Interface | Aptify.Framework.DigitalDashboard Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

IDashboardComponent.State Property

This determines whether or not the Component is minimized.

ComponentState State {get; set;}

See Also

IDashboardComponent Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardComponent Methods

The methods of the IDashboardComponent interface are listed below. For a complete list of IDashboardComponent interface members, see the IDashboardComponent Members topic.

Public Instance Methods

Config Used to Configure the Dasboard Component that implements the interface.

See Also

IDashboardComponent Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardComponent.Config Method

Used to Configure the Dasboard Component that implements the interface.

void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Parameters

ApplicationObject
An initialized AptifyApplication object.
Area
An initialized object that implements IDashboardArea.
PartID
The Id of the DashboardPart to load.
Orientation
The on screen orientation of the component.

Remarks

If there is a problem in this method that cannot be handled then it is wrapped in a DashboardComponentException and re-thrown.

See Also

IDashboardComponent Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardConfigurationForm Interface

This interface is implemented by forms that are used to configure Areas and Parts by Aptify.

For a list of all members of this type, see IDashboardConfigurationForm Members.

public interface IDashboardConfigurationForm

Types that implement IDashboardConfigurationForm

Type | Description
DashboardAreaConfigurationForm | This is an implementation of IDashboardConfigurationForm and it is used to configure dashboard areas.
DashboardPartConfigurationForm | This is an implementation of IDashboardConfigurationForm and it is used to configure dashboard parts.

Remarks

IDashboardConfigurationForm is specific to the Aptify Framework and is not customizable outside of the framework. Therefore, no sample code is provided for this interface.

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

IDashboardConfigurationForm Members | Aptify.Framework.DigitalDashboard Namespace


IDashboardConfigurationForm Members

IDashboardConfigurationForm overview

Public Instance Properties

ID This is set by the configuration call with the ID that is used to uniquely identify the Item that the Form will configure.

Public Instance Methods

Config | Config allows the Dashboard Configuration form to be initialized with an ID, its container's ID, and an application object.
Dispose | Dispose overrides the dispose method of the form and should be called when the developer is done using the form.
ShowDialog | This causes the ConfigurationForm to display itself.

See Also

IDashboardConfigurationForm Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardConfigurationForm Properties

The properties of the IDashboardConfigurationForm interface are listed below. For a complete list of IDashboardConfigurationForm interface members, see the IDashboardConfigurationForm Members topic.

Public Instance Properties

ID This is set by the configuration call with the ID that is used to uniquely identify the Item that the Form will configure.

See Also

IDashboardConfigurationForm Interface | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

IDashboardConfigurationForm.ID Property

This is set by the configuration call with the ID that is used to uniquely identify the Item that the Form will configure.

Int64 ID {get;}

Property Value

Remarks

See Also

IDashboardConfigurationForm Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardConfigurationForm Methods

The methods of the IDashboardConfigurationForm interface are listed below. For a complete list of IDashboardConfigurationForm interface members, see the IDashboardConfigurationForm Members topic.

Public Instance Methods

Config | Config allows the Dashboard Configuration form to be initialized with an ID, its container's ID, and an application object.
Dispose | Dispose overrides the dispose method of the form and should be called when the developer is done using the form.
ShowDialog | This causes the ConfigurationForm to display itself.

See Also

IDashboardConfigurationForm Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardConfigurationForm.Config Method

Config allows the Dashboard Configuration form to be initialized with an ID, its container's ID, and an application object.

void Config(
Int64 ID,
Int64 ContainerID,
AptifyApplication ApplicationObject
);

Parameters

ID
The ID of the record that is being configured.
ContainerID
The Id of the record that acts as the container of this record.
ApplicationObject
An instantiated class that is used to retrieve general system information.

See Also

IDashboardConfigurationForm Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardConfigurationForm.Dispose Method

Dispose overrides the dispose method of the form and should be called when the developer is done using the form.

void Dispose();

Remarks

See Also

IDashboardConfigurationForm Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardConfigurationForm.ShowDialog Method

This causes the ConfigurationForm to display itself.

DialogResult ShowDialog();

Return Value

Returns the DialogResult associated with the Dialog.

Remarks

This overrides the form's ShowDialog and returns Mybase.ShowDialog

See Also

IDashboardConfigurationForm Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardContainer Interface

This is the interface implemented by a class that functions as a Dashboard Area Container.

For a list of all members of this type, see IDashboardContainer Members.

public interface IDashboardContainer

Types that implement IDashboardContainer

Type | Description
AptifyDashLayout | This control is used as a host control to display Aptify Dashboards.

Remarks

IDashboardContainer provides an interface for components that will act as dashboard area containers in the context of the dashboard framework. It will be very unlikely that developers will need to replace or provide plug-ins for this functionality. Therefore, no sample code is provided for this interface.

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

IDashboardContainer Members | Aptify.Framework.DigitalDashboard Namespace


IDashboardContainer Members

IDashboardContainer overview

Public Instance Properties

ID | This is set by the config method with the ID that is used to uniquely identify the Dashboard.
Mode | This determines if the control should render itself in a Design Time mode or a Runtime mode.
UsageScope | Determines who has access to use the dashboard.

Public Instance Methods

Config | Overloaded. This is the class member that will be called to initialize the container context.
NotifyAreaChanged | When an area changes its state then it will call the NotifyAreaChanged procedure in order to let its parent know it changed.
NotifyAreaClosed | When an Area closes then it will call the NotifyAreaClosed procedure in order to let its parent know it closed.

See Also

IDashboardContainer Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardContainer Properties

The properties of the IDashboardContainer interface are listed below. For a complete list of IDashboardContainer interface members, see the IDashboardContainer Members topic.

Public Instance Properties

ID | This is set by the config method with the ID that is used to uniquely identify the Dashboard.
Mode | This determines if the control should render itself in a Design Time mode or a Runtime mode.
UsageScope | Determines who has access to use the dashboard.

See Also

IDashboardContainer Interface | Aptify.Framework.DigitalDashboard Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

IDashboardContainer.ID Property

This is set by the config method with the ID that is used to uniquely identify the Dashboard.

Int64 ID {get;}

Property Value

Remarks

See Also

IDashboardContainer Interface | Aptify.Framework.DigitalDashboard Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

IDashboardContainer.Mode Property

This determines if the control should render itself in a Design Time mode or a Runtime mode.

DashboardMode Mode {get; set;}

Property Value

Remarks

The recommended place to add and remove controls to the component is during the set of this property.

See Also

IDashboardContainer Interface | Aptify.Framework.DigitalDashboard Namespace


UsageScope Property

Aptify 5.0 Software Development Kit (SDK)

IDashboardContainer.UsageScope Property

Determines who has access to use the dashboard.

String UsageScope {get;}

Property Value

Remarks

See Also

IDashboardContainer Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardContainer Methods

The methods of the IDashboardContainer interface are listed below. For a complete list of IDashboardContainer interface members, see the IDashboardContainer Members topic.

Public Instance Methods

Config | Overloaded. This is the class member that will be called to initialize the container context.
NotifyAreaChanged | When an area changes its state then it will call the NotifyAreaChanged procedure in order to let its parent know it changed.
NotifyAreaClosed | When an Area closes then it will call the NotifyAreaClosed procedure in order to let its parent know it closed.

See Also

IDashboardContainer Interface | Aptify.Framework.DigitalDashboard Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

IDashboardContainer.Config Method

This is the class member that will be called to initialize the container context.

Overload List

This is the class member that will be called to initialize the container context.

void Config(AptifyApplication,Int64);

This is the class member that will be called to initialize the container context.

void Config(AptifyApplication,Int64,ApplicationScope,Int64);

See Also

IDashboardContainer Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardContainer.Config Method (AptifyApplication, Int64)

This is the class member that will be called to initialize the container context.

void Config(
AptifyApplication ApplicationObject,
Int64 DashboardID
);

Parameters

ApplicationObject
An instantiated class that is used to retrieve general system information.
DashboardID
The ID of the Dashboard record to configure.

Remarks

If there is a problem in this method that cannot be handled then it is wrapped in a DashboardContainerException and re-thrown.

See Also

IDashboardContainer Interface | Aptify.Framework.DigitalDashboard Namespace | IDashboardContainer.Config Overload List


IDashboardContainer.Config Method (AptifyApplication, Int64, ApplicationScope, Int64)

This is the class member that will be called to initialize the container context.

void Config(
AptifyApplication ApplicationObject,
Int64 DashboardID,
ApplicationScope ApplicationScope,
Int64 ApplicationID
);

Parameters

ApplicationObject
An instantiated class that is used to retrieve general system information.
DashboardID
The ID of the Dashboard record to configure.
ApplicationScope
This is the scope under which the dashboard is running.
ApplicationID
This is the ID of the application that the dashboard is specific to.

Remarks

If there is a problem in this method that cannot be handled then it is wrapped in a DashboardContainerException and re-thrown.

See Also

IDashboardContainer Interface | Aptify.Framework.DigitalDashboard Namespace | IDashboardContainer.Config Overload List


IDashboardContainer.NotifyAreaChanged Method

When an area changes its state then it will call the NotifyAreaChanged procedure in order to let its parent know it changed.

void NotifyAreaChanged(
IDashboardArea Area
);

Parameters

Area
A reference to the Area that has changed.

See Also

IDashboardContainer Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardContainer.NotifyAreaClosed Method

When an Area closes then it will call the NotifyAreaClosed procedure in order to let its parent know it closed.

void NotifyAreaClosed(
IDashboardArea Area
);

Parameters

Area
A reference to the Area that has changed.

See Also

IDashboardContainer Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardPropPage Interface

This interface implemented by a user control that will act as a property page for a dashboard entity. IDashboardPropPage provides an interface for components that will act as property pages for dashboard entities.

For a list of all members of this type, see IDashboardPropPage Members.

public interface IDashboardPropPage

Types that implement IDashboardPropPage

Type | Description
EntityBulkOperationsDashboardButtonPropertiesPage |
ButtonBarProperties |
FindDlgParams |
GenericDataWizardParams | This class will provide functionality to add and run Aptify Generic Data Wizard from Dashboard
MRUProperties |
OpenFormParams |
OutlookViewProperties |
ProcessFlowParams |
ReportParams |
SwitchDashboardParams |
WebDashProps |
WizardParams |
MultiEntityGridPropertyPage | Implements a Windows UI property page for the Multi Entity Grid dashboard part
EntityListViewDashboardComponentPropertyPage |

Example

Public Class SamplePropertyPage
Inherits UserControl
Implements IDashboardPropPage

Private m_oApplication As Application.AptifyApplication
Private m_oPart As BusinessLogic.GenericEntity.AptifyGenericEntityBase

Public Sub Config(ByVal ApplicationObject As Application.AptifyApplication) Implements IDashboardPropPage.Config
    m_oApplication = ApplicationObject
End Sub

Public Sub LoadProperties(ByVal Part As BusinessLogic.GenericEntity.AptifyGenericEntityBase) Implements IDashboardPropPage.LoadProperties
    m_oPart = Part
    For Each oProp As BusinessLogic.GenericEntity.AptifyGenericEntityBase In m_oPart.SubTypes("DashboardPartInputMap")
        Select Case CStr(oProp.GetValue("InputProperty")).Trim.ToLower
            Case "backcolor"
                BackColor = Color.FromArgb(CInt(oProp.GetValue("Source")))
        End Select
    Next
End Sub

Public Sub SaveProperties() Implements IDashboardPropPage.SaveProperties
    For Each oProp As BusinessLogic.GenericEntity.AptifyGenericEntityBase In m_oPart.SubTypes("DashboardPartInputMap")
        Select Case CStr(oProp.GetValue("InputProperty")).Trim.ToLower
            Case "backcolor"
                oProp.SetValue("Source", BackColor.ToArgb)
        End Select
    Next
End Sub
End Class

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

IDashboardPropPage Members | Aptify.Framework.DigitalDashboard Namespace


IDashboardPropPage Members

IDashboardPropPage overview

Public Instance Methods

Config | Config allows the DashboardPropPage to be initialized with a ApplicationObject.
LoadProperties | This initializes the property page with the current set of properties and defaults.
SaveProperties | SaveProperties is responsible for updating the GE with the current values on the property page.

See Also

IDashboardPropPage Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardPropPage Methods

The methods of the IDashboardPropPage interface are listed below. For a complete list of IDashboardPropPage interface members, see the IDashboardPropPage Members topic.

Public Instance Methods

Config | Config allows the DashboardPropPage to be initialized with a ApplicationObject.
LoadProperties | This initializes the property page with the current set of properties and defaults.
SaveProperties | SaveProperties is responsible for updating the GE with the current values on the property page.

See Also

IDashboardPropPage Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardPropPage.Config Method

Config allows the DashboardPropPage to be initialized with a ApplicationObject.

void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject
An instantiated class that is used to retrieve general system information.

See Also

IDashboardPropPage Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardPropPage.LoadProperties Method

This initializes the property page with the current set of properties and defaults.

void LoadProperties(
AptifyGenericEntityBase Part
);

Parameters

Part
This is a GE record that contains the properties for this property page. This interface is used in many places so the Type of the GE record is not specific to this interface. The developer should be familiar with the process that they are working with.

Remarks

See Also

IDashboardPropPage Interface | Aptify.Framework.DigitalDashboard Namespace


IDashboardPropPage.SaveProperties Method

SaveProperties is responsible for updating the GE with the current values on the property page.

void SaveProperties();

Remarks

If a Property value is required and has not been provided or the value is in an invalid format, then this member should throw an exception. If an exception is thrown then the message will be displayed and the data will not be saved.

See Also

IDashboardPropPage Interface | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants Class

This class holds all of the constants used for localizing strings for the IAptifyDashboard assembly.

For a list of all members of this type, see InterfaceConstants Members.

System.Object
InterfaceConstants

public class InterfaceConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

InterfaceConstants are mainly used to get localized exception messages from an embedded resource file. The constants are just keys into the resource file. If you try a get string with a string that is not a constant then it will return the string that you passed in. GetString also accepts a parameter array of string items and it tries to do a String.Format on the string that we passed in as the key. All members of this class are Shared, therefore the class never needs to be instantiated.

Example

Dim sAssembly as String = "SomeAssembly"
Dim sType As String = "SomeType"
Dim sResult As String

sResult = InterfaceConstants.GetString(InterfaceConstants.DASHBOARD_AREA_PROPETY_PAGE,sAssembly,sType)

Throw New Exception(sResult)
...

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

InterfaceConstants Members | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants Members

InterfaceConstants overview

Public Static Fields

BASE_DASHBOARD_AREA_EXCEPTION_MESSAGE
BASE_DASHBOARD_EXCEPTION_MESSAGE
BASE_DASHBOARD_LAYOUT_EXCEPTION_MESSAGE
BASE_DASHBOARD_WRAPPER_EXCEPTION_MESSAGE
CREATE_PERSONAL_COPY_EXCEPTION_MESSAGE
DASHBOARD_AREA_PROPETY_PAGE
EXISTING_AREA_FORM_TITLE
HEIGHT_PROPORTION_MESSAGE
NEW_AREA_FORM_TITLE
WIDTH_PROPORTION_MESSAGE

Public Static Methods

GetString Overloaded. Attempts to return a localized version of the string that was provided.

Public Instance Constructors

InterfaceConstants Constructor Initializes a new instance of the InterfaceConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants Constructor

Initializes a new instance of the InterfaceConstants class.

public InterfaceConstants();

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants Fields

The fields of the InterfaceConstants class are listed below. For a complete list of InterfaceConstants class members, see the InterfaceConstants Members topic.

Public Static Fields

BASE_DASHBOARD_AREA_EXCEPTION_MESSAGE
BASE_DASHBOARD_EXCEPTION_MESSAGE
BASE_DASHBOARD_LAYOUT_EXCEPTION_MESSAGE
BASE_DASHBOARD_WRAPPER_EXCEPTION_MESSAGE
CREATE_PERSONAL_COPY_EXCEPTION_MESSAGE
DASHBOARD_AREA_PROPETY_PAGE
EXISTING_AREA_FORM_TITLE
HEIGHT_PROPORTION_MESSAGE
NEW_AREA_FORM_TITLE
WIDTH_PROPORTION_MESSAGE

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants.BASE_DASHBOARD_AREA_EXCEPTION_MESSAGE Field

public const BASE_DASHBOARD_AREA_EXCEPTION_MESSAGE BASE_DASHBOARD_AREA_EXCEPTION_MESSAGE = "BASE_DASHBOARD_AREA_EXCEPTION_MESSAGE";

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants.BASE_DASHBOARD_EXCEPTION_MESSAGE Field

public const BASE_DASHBOARD_EXCEPTION_MESSAGE BASE_DASHBOARD_EXCEPTION_MESSAGE = "BASE_DASHBOARD_EXCEPTION_MESSAGE";

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants.BASE_DASHBOARD_LAYOUT_EXCEPTION_MESSAGE Field

public const BASE_DASHBOARD_LAYOUT_EXCEPTION_MESSAGE BASE_DASHBOARD_LAYOUT_EXCEPTION_MESSAGE = "BASE_DASHBOARD_LAYOUT_EXCEPTION_MESSAGE";

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants.BASE_DASHBOARD_WRAPPER_EXCEPTION_MESSAGE Field

public const BASE_DASHBOARD_WRAPPER_EXCEPTION_MESSAGE BASE_DASHBOARD_WRAPPER_EXCEPTION_MESSAGE = "BASE_DASHBOARD_WRAPPER_EXCEPTION_MESSAGE";

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants.CREATE_PERSONAL_COPY_EXCEPTION_MESSAGE Field

public const CREATE_PERSONAL_COPY_EXCEPTION_MESSAGE CREATE_PERSONAL_COPY_EXCEPTION_MESSAGE = "CREATE_PERSONAL_COPY_EXCEPTION_MESSAGE";

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants.DASHBOARD_AREA_PROPETY_PAGE Field

public const DASHBOARD_AREA_PROPETY_PAGE DASHBOARD_AREA_PROPETY_PAGE = "DASHBOARD_AREA_PROPETY_PAGE";

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants.EXISTING_AREA_FORM_TITLE Field

public const EXISTING_AREA_FORM_TITLE EXISTING_AREA_FORM_TITLE = "EXISTING_AREA_FORM_TITLE";

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants.HEIGHT_PROPORTION_MESSAGE Field

public const HEIGHT_PROPORTION_MESSAGE HEIGHT_PROPORTION_MESSAGE = "HEIGHT_PROPORTION_MESSAGE";

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants.NEW_AREA_FORM_TITLE Field

public const NEW_AREA_FORM_TITLE NEW_AREA_FORM_TITLE = "NEW_AREA_FORM_TITLE";

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants.WIDTH_PROPORTION_MESSAGE Field

public const WIDTH_PROPORTION_MESSAGE WIDTH_PROPORTION_MESSAGE = "WIDTH_PROPORTION_MESSAGE";

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants Methods

The methods of the InterfaceConstants class are listed below. For a complete list of InterfaceConstants class members, see the InterfaceConstants Members topic.

Public Static Methods

GetString Overloaded. Attempts to return a localized version of the string that was provided.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


GetString Method

Aptify 5.0 Software Development Kit (SDK)

InterfaceConstants.GetString Method

Attempts to return a localized version of the string that was provided.

Overload List

Attempts to return a localized version of the string that was provided.

public static string GetString(String);

Attempts to return a localized version of the string that was provided.

public static string GetString(String,params String[]);

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace


InterfaceConstants.GetString Method (String)

Attempts to return a localized version of the string that was provided.

public static string GetString(
String Text
);

Parameters

Text
A string that should be localized.

Return Value

The localized version of the string.

Remarks

If no localized version of the string exists, then the original string will be returned.

Example

Windows.forms.Messagebox.Show(InterfaceConstants.GetString("HelloWorld"))

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace | InterfaceConstants.GetString Overload List


InterfaceConstants.GetString Method (String, String[])

Attempts to return a localized version of the string that was provided.

public static string GetString(
String Text,
params String[] FormatParameters
);

Parameters

Text
A string that should be localized.
FormatParameters
Values for items that should be replaced in the localized string.

Return Value

The localized version of the string.

Remarks

The localized string may be a format string. If it is then the format parameters will be used to replace the format markers.

Example

Messagebox.Show(InterfaceConstants.GetString("HelloWorld","X1"))

Messagebox.Show(InterfaceConstants.GetString("HelloWorld","X1","X2"))

Messagebox.Show(InterfaceConstants.GetString("HelloWorld",new string(){"X1","X2","X3"}))

Dim S() As String = New String() {"Hello", "Text", "What"}
Messagebox.Show(InterfaceConstants.GetString("HelloWorld",S))

See Also

InterfaceConstants Class | Aptify.Framework.DigitalDashboard Namespace | InterfaceConstants.GetString Overload List


LayoutConstants Class

For a list of all members of this type, see LayoutConstants Members.

System.Object
LayoutConstants

public class LayoutConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: AptifyDashboardLayout (in AptifyDashboardLayout.dll)

See Also

LayoutConstants Members | Aptify.Framework.DigitalDashboard Namespace


LayoutConstants Members

LayoutConstants overview

Public Static Fields

SAVE_DASHBOARD_QUESTION
SAVE_DASHBOARD_QUESTION_CULTURENAME

Public Static Methods

GetString Overloaded.

Public Instance Constructors

LayoutConstants Constructor Initializes a new instance of the LayoutConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LayoutConstants Class | Aptify.Framework.DigitalDashboard Namespace


LayoutConstants Constructor

Initializes a new instance of the LayoutConstants class.

public LayoutConstants();

See Also

LayoutConstants Class | Aptify.Framework.DigitalDashboard Namespace


LayoutConstants Fields

The fields of the LayoutConstants class are listed below. For a complete list of LayoutConstants class members, see the LayoutConstants Members topic.

Public Static Fields

SAVE_DASHBOARD_QUESTION
SAVE_DASHBOARD_QUESTION_CULTURENAME

See Also

LayoutConstants Class | Aptify.Framework.DigitalDashboard Namespace


LayoutConstants.SAVE_DASHBOARD_QUESTION Field

public const SAVE_DASHBOARD_QUESTION SAVE_DASHBOARD_QUESTION = "SAVE_DASHBOARD_QUESTION";

See Also

LayoutConstants Class | Aptify.Framework.DigitalDashboard Namespace


LayoutConstants.SAVE_DASHBOARD_QUESTION_CULTURENAME Field

public const SAVE_DASHBOARD_QUESTION_CULTURENAME SAVE_DASHBOARD_QUESTION_CULTURENAME = "SAVE_DASHBOARD_QUESTION_CULTURENAME";

See Also

LayoutConstants Class | Aptify.Framework.DigitalDashboard Namespace


LayoutConstants Methods

The methods of the LayoutConstants class are listed below. For a complete list of LayoutConstants class members, see the LayoutConstants Members topic.

Public Static Methods

GetString Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LayoutConstants Class | Aptify.Framework.DigitalDashboard Namespace


GetString Method

Aptify 5.0 Software Development Kit (SDK)

LayoutConstants.GetString Method

Overload List

public static string GetString(String);

public static string GetString(String,params String[]);

See Also

LayoutConstants Class | Aptify.Framework.DigitalDashboard Namespace


LayoutConstants.GetString Method (String)

public static string GetString(
String Text
);

See Also

LayoutConstants Class | Aptify.Framework.DigitalDashboard Namespace | LayoutConstants.GetString Overload List


LayoutConstants.GetString Method (String, String[])

public static string GetString(
String Text,
params String[] FormatParameters
);

See Also

LayoutConstants Class | Aptify.Framework.DigitalDashboard Namespace | LayoutConstants.GetString Overload List


ResizeType Enumeration

public enum ResizeType

Members

Member Name | Description
ResizeNone |
ResizeProportional |
ResizeFill |

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: IAptifyDashboard (in IAptifyDashboard.dll)

See Also

Aptify.Framework.DigitalDashboard Namespace


SelectAreaForm Class

For a list of all members of this type, see SelectAreaForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
SelectAreaForm

public class SelectAreaForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: AptifyDashboardLayout (in AptifyDashboardLayout.dll)

See Also

SelectAreaForm Members | Aptify.Framework.DigitalDashboard Namespace


SelectAreaForm Members

SelectAreaForm overview

Public Instance Constructors

SelectAreaForm Constructor Initializes a new instance of the SelectAreaForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AreaID |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SelectAreaForm Class | Aptify.Framework.DigitalDashboard Namespace


SelectAreaForm Constructor

Initializes a new instance of the SelectAreaForm class.

public SelectAreaForm();

See Also

SelectAreaForm Class | Aptify.Framework.DigitalDashboard Namespace


SelectAreaForm Properties

The properties of the SelectAreaForm class are listed below. For a complete list of SelectAreaForm class members, see the SelectAreaForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AreaID |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SelectAreaForm Class | Aptify.Framework.DigitalDashboard Namespace


AreaID Property

Aptify 5.0 Software Development Kit (SDK)

SelectAreaForm.AreaID Property

public Int64 AreaID {get;}

See Also

SelectAreaForm Class | Aptify.Framework.DigitalDashboard Namespace


SelectAreaForm Methods

The methods of the SelectAreaForm class are listed below. For a complete list of SelectAreaForm class members, see the SelectAreaForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SelectAreaForm Class | Aptify.Framework.DigitalDashboard Namespace


SelectAreaForm.Config Method

public void Config(
IAptifyDataAction DataAction,
String DMDatabase,
Int64 DashboardID,
UserCredentials UserCredential
);

See Also

SelectAreaForm Class | Aptify.Framework.DigitalDashboard Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SelectAreaForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SelectAreaForm Class | Aptify.Framework.DigitalDashboard Namespace


SelectAreaForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SelectAreaForm Class | Aptify.Framework.DigitalDashboard Namespace | SelectAreaForm.Dispose Overload List


VerticalLabel Class

For a list of all members of this type, see VerticalLabel Members.

System.Object
MarshalByRefObject
Component
Control
Label
VerticalLabel

public class VerticalLabel : Label

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: AptifyDashCtrlWrapper (in AptifyDashCtrlWrapper.dll)

See Also

VerticalLabel Members | Aptify.Framework.DigitalDashboard Namespace


VerticalLabel Members

VerticalLabel overview

Public Instance Constructors

VerticalLabel Constructor Initializes a new instance of the VerticalLabel class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoEllipsis (inherited from Label) | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the Label, denoting that the Label text extends beyond the specified length of the Label.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoSize (inherited from Label) | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Label) | Gets or sets the image rendered on the background of the control.
BackgroundImageLayout (inherited from Label) | This property is not relevant for this class.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Label) | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from Label) | Gets or sets the flat style appearance of the label control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from Label) | Gets or sets the image that is displayed on a Label.
ImageAlign (inherited from Label) | Gets or sets the alignment of an image that is displayed in the control.
ImageIndex (inherited from Label) | Gets or sets the index value of the image displayed on the Label.
ImageKey (inherited from Label) | Gets or sets the key accessor for the image in the ImageList.
ImageList (inherited from Label) | Gets or sets the ImageList that contains the images to display in the Label control.
ImeMode (inherited from Label) | Gets or sets the Input Method Editor (IME) mode supported by this control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from Label) | Gets the preferred height of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
PreferredWidth (inherited from Label) | Gets the preferred width of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Label) | Gets or sets a value indicating whether the user can tab to the Label.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Label) |
TextAlign (inherited from Label) | Gets or sets the alignment of text in the label.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseCompatibleTextRendering (inherited from Label) | Gets or sets a value that specifies whether text rendering should be compatible with previous releases of Windows Forms.
UseMnemonic (inherited from Label) | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Label) |
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Label) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AutoSizeChanged (inherited from Label) | Occurs when the value of the AutoSize property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Label) | Occurs when the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Label) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Label) | Occurs when the ImeMode property changes.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Label) | Occurs when the user presses a key while the label has focus.
KeyPress (inherited from Label) | Occurs when the user presses a key while the label has focus.
KeyUp (inherited from Label) | Occurs when the user releases a key while the label has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Label) | Occurs when the TabStop property changes.
TextAlignChanged (inherited from Label) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Label) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Label) | Gets the default Input Method Editor (IME) mode supported by this control.
DefaultMargin (inherited from Label) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Label) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
ImeModeBase (inherited from Control) |
RenderTransparent (inherited from Label) | Obsolete. Indicates whether the container control background is rendered on the Label.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
CalcImageRenderBounds (inherited from Label) | Determines the size and location of an image drawn within the Label control based on the alignment of the control.
CreateAccessibilityInstance (inherited from Label) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DrawImage (inherited from Label) | Draws an Image within the specified bounds.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Label) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Label) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Label) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Label) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Label) |
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from Label) |
OnPaint |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Label) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Label) | Raises the RightToLeftChanged event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from Label) | Raises the TextAlignChanged event.
OnTextChanged (inherited from Label) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Label) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
ScaleCore (inherited from Control) |
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Label) | Sets the specified bounds of the label.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Label) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Label) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

VerticalLabel Class | Aptify.Framework.DigitalDashboard Namespace


VerticalLabel Constructor

Initializes a new instance of the VerticalLabel class.

public VerticalLabel();

See Also

VerticalLabel Class | Aptify.Framework.DigitalDashboard Namespace


VerticalLabel Methods

The methods of the VerticalLabel class are listed below. For a complete list of VerticalLabel class members, see the VerticalLabel Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Label) |
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Label) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
CalcImageRenderBounds (inherited from Label) | Determines the size and location of an image drawn within the Label control based on the alignment of the control.
CreateAccessibilityInstance (inherited from Label) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DrawImage (inherited from Label) | Draws an Image within the specified bounds.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Label) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Label) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Label) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Label) |
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Label) |
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from Label) |
OnPaint |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Label) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Label) | Raises the RightToLeftChanged event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextAlignChanged (inherited from Label) | Raises the TextAlignChanged event.
OnTextChanged (inherited from Label) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Label) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Control) | Scales a control's location, size, padding and margin.
ScaleCore (inherited from Control) |
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Label) | Sets the specified bounds of the label.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Label) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Label) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

VerticalLabel Class | Aptify.Framework.DigitalDashboard Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

VerticalLabel.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

VerticalLabel Class | Aptify.Framework.DigitalDashboard Namespace


VerticalLabel.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

VerticalLabel Class | Aptify.Framework.DigitalDashboard Namespace | VerticalLabel.Dispose Overload List


VerticalLabel.OnPaint Method

protected override void OnPaint(
PaintEventArgs e
);

See Also

VerticalLabel Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants Class

For a list of all members of this type, see WrapperConstants Members.

System.Object
WrapperConstants

public class WrapperConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard

Assembly: AptifyDashCtrlWrapper (in AptifyDashCtrlWrapper.dll)

See Also

WrapperConstants Members | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants Members

WrapperConstants overview

Public Static Fields

EDIT_MENU_TEXT
NO_PERMISSIONS_MESSAGE
OPEN_IN_NEW_WINDOW_TEXT
PART_SPACE
REMOVE_MENU_TEXT
STANDARD_HORIZONTAL_HEADER_HEIGHT
STANDARD_VERTICAL_HEADER_HEIGHT

Public Static Methods

GetString Overloaded.

Public Instance Constructors

WrapperConstants Constructor Initializes a new instance of the WrapperConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants Constructor

Initializes a new instance of the WrapperConstants class.

public WrapperConstants();

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants Fields

The fields of the WrapperConstants class are listed below. For a complete list of WrapperConstants class members, see the WrapperConstants Members topic.

Public Static Fields

EDIT_MENU_TEXT
NO_PERMISSIONS_MESSAGE
OPEN_IN_NEW_WINDOW_TEXT
PART_SPACE
REMOVE_MENU_TEXT
STANDARD_HORIZONTAL_HEADER_HEIGHT
STANDARD_VERTICAL_HEADER_HEIGHT

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants.EDIT_MENU_TEXT Field

public const EDIT_MENU_TEXT EDIT_MENU_TEXT = "EDIT_MENU_TEXT";

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants.NO_PERMISSIONS_MESSAGE Field

public const NO_PERMISSIONS_MESSAGE NO_PERMISSIONS_MESSAGE = "NO_PERMISSIONS_MESSAGE";

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants.OPEN_IN_NEW_WINDOW_TEXT Field

public const OPEN_IN_NEW_WINDOW_TEXT OPEN_IN_NEW_WINDOW_TEXT = "OPEN_IN_NEW_WINDOW_TEXT";

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants.PART_SPACE Field

public const PART_SPACE PART_SPACE = 4;

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants.REMOVE_MENU_TEXT Field

public const REMOVE_MENU_TEXT REMOVE_MENU_TEXT = "REMOVE_MENU_TEXT";

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants.STANDARD_HORIZONTAL_HEADER_HEIGHT Field

public const STANDARD_HORIZONTAL_HEADER_HEIGHT STANDARD_HORIZONTAL_HEADER_HEIGHT = 19;

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants.STANDARD_VERTICAL_HEADER_HEIGHT Field

public const STANDARD_VERTICAL_HEADER_HEIGHT STANDARD_VERTICAL_HEADER_HEIGHT = 21;

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants Methods

The methods of the WrapperConstants class are listed below. For a complete list of WrapperConstants class members, see the WrapperConstants Members topic.

Public Static Methods

GetString Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


GetString Method

Aptify 5.0 Software Development Kit (SDK)

WrapperConstants.GetString Method

Overload List

public static string GetString(String);

public static string GetString(String,params String[]);

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace


WrapperConstants.GetString Method (String)

public static string GetString(
String Text
);

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace | WrapperConstants.GetString Overload List


WrapperConstants.GetString Method (String, String[])

public static string GetString(
String Text,
params String[] FormatParameters
);

See Also

WrapperConstants Class | Aptify.Framework.DigitalDashboard Namespace | WrapperConstants.GetString Overload List


Aptify.Framework.DigitalDashboard.Components

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.DigitalDashboard.Components Namespace

This namespace contains the objects that define the available components that a user can select for a dashboard part. This includes the Button Bar (and all of its associated Action Types), integration with Microsoft Outlook, and the Web Browser component.

Namespace hierarchy

Classes

Class | Description
AptifyFontDialog |
ButtonBar | A dashboard component that allows users to quickly execute common tasks through a button bar GUI.
ButtonBarConstants |
ButtonBarProperties |
EntityBulkOperationsStatusForm |
FindDlgParams |
GenericDataWizardParams | This class will provide functionality to add and run Aptify Generic Data Wizard from Dashboard
MostRecentlyUsed | Dashboard comopnent displays the most recently used(either opened or modified) records within the system. Only entities that have enabled the MRU (via Entity Administration) will appear here as there is overhead in tracking MRU but since it is a valuable user feature the overhead maybe worth it for quite a few entity areas. Each installation of the system can configure which entities should have MRU tracking turned on/off.
MostRecentlyUsedDetails | A dashboard component that allows users to quickly access Most Recently Used Records.
MostRecentlyUsedDetailsForm |
MRUProperties |
ObjectRepositoryDashboard |
OpenFormParams |
OutlookView |
OutlookViewProperties |
ProcessFlowParams |
ReportParams |
SwitchDashboardParams |
WebBrowser |
WebDashProps |
WizardParams |

Enumerations

Enumeration | Description
EntityDisplayMode | A dashboard component that allows users to quickly access Most Recently Used Records.


AptifyFontDialog Class

For a list of all members of this type, see AptifyFontDialog Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
AptifyFontDialog

public class AptifyFontDialog : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

AptifyFontDialog Members | Aptify.Framework.DigitalDashboard.Components Namespace


AptifyFontDialog Members

AptifyFontDialog overview

Public Instance Constructors

AptifyFontDialog Overloaded. Initializes a new instance of the AptifyFontDialog class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontName |
FontSize |
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
OK |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace


AptifyFontDialog Constructor

Initializes a new instance of the AptifyFontDialog class.

Overload List

Initializes a new instance of the AptifyFontDialog class.

public AptifyFontDialog();

public AptifyFontDialog(UserCredentials);

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace


AptifyFontDialog Constructor ()

Initializes a new instance of the AptifyFontDialog class.

public AptifyFontDialog();

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace | AptifyFontDialog Constructor Overload List


AptifyFontDialog Constructor (UserCredentials)

public AptifyFontDialog(
UserCredentials userCredentials
);

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace | AptifyFontDialog Constructor Overload List


AptifyFontDialog Properties

The properties of the AptifyFontDialog class are listed below. For a complete list of AptifyFontDialog class members, see the AptifyFontDialog Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontName |
FontSize |
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace


FontName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyFontDialog.FontName Property

public String FontName {get; set;}

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace


FontSize Property

Aptify 5.0 Software Development Kit (SDK)

AptifyFontDialog.FontSize Property

public String FontSize {get; set;}

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

AptifyFontDialog.UserCredential Property

public UserCredentials UserCredential {get; set;}

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace


AptifyFontDialog Methods

The methods of the AptifyFontDialog class are listed below. For a complete list of AptifyFontDialog class members, see the AptifyFontDialog Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
OK |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AptifyFontDialog.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace


AptifyFontDialog.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace | AptifyFontDialog.Dispose Overload List


AptifyFontDialog.OK Method

public bool OK();

See Also

AptifyFontDialog Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBar Class

A dashboard component that allows users to quickly execute common tasks through a button bar GUI.

For a list of all members of this type, see ButtonBar Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ButtonBar

public class ButtonBar : UserControl, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

ButtonBar Members | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBar Members

ButtonBar overview

Public Instance Constructors

ButtonBar Constructor Initializes a new instance of the ButtonBar class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Configures the button bar for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ButtonBar Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBar Constructor

Initializes a new instance of the ButtonBar class.

public ButtonBar();

See Also

ButtonBar Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarProperties Class

For a list of all members of this type, see ButtonBarProperties Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ButtonBarProperties

public class ButtonBarProperties : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

ButtonBarProperties Members | Aptify.Framework.DigitalDashboard.Components Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ButtonBar.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

ButtonBar Class | Aptify.Framework.DigitalDashboard.Components Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

ButtonBar.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

ButtonBar Class | Aptify.Framework.DigitalDashboard.Components Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

ButtonBar.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

ButtonBar Class | Aptify.Framework.DigitalDashboard.Components Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

ButtonBar.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

ButtonBar Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBar Methods

The methods of the ButtonBar class are listed below. For a complete list of ButtonBar class members, see the ButtonBar Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Configures the button bar for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ButtonBar Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBar.Config Method

Configures the button bar for use.

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Parameters

ApplicationObject
Area
PartID
Orientation

Implements

IDashboardComponent.

Remarks

This should be called after the button bar's Load event has fired, but before any other members have been called.

See Also

ButtonBar Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ButtonBar.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ButtonBar Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBar.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ButtonBar Class | Aptify.Framework.DigitalDashboard.Components Namespace | ButtonBar.Dispose Overload List


ButtonBarConstants Class

For a list of all members of this type, see ButtonBarConstants Members.

System.Object
ButtonBarConstants

public class ButtonBarConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

ButtonBarConstants Members | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants Members

ButtonBarConstants overview

Public Static Fields

GUI_EXCEPTION_MESSAGE
INVALID_ACTION_MESSAGE
INVALID_BULK_OPERATION_MESSAGE
INVALID_ENTITY_ID_MESSAGE
INVALID_PARAMETER_VALUE
INVALID_PROPERTIES_MESSAGE
REMOVE_BUTTON_QUESTION

Public Static Methods

GetString Overloaded.

Public Instance Constructors

ButtonBarConstants Constructor Initializes a new instance of the ButtonBarConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants Constructor

Initializes a new instance of the ButtonBarConstants class.

public ButtonBarConstants();

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants Fields

The fields of the ButtonBarConstants class are listed below. For a complete list of ButtonBarConstants class members, see the ButtonBarConstants Members topic.

Public Static Fields

GUI_EXCEPTION_MESSAGE
INVALID_ACTION_MESSAGE
INVALID_BULK_OPERATION_MESSAGE
INVALID_ENTITY_ID_MESSAGE
INVALID_PARAMETER_VALUE
INVALID_PROPERTIES_MESSAGE
REMOVE_BUTTON_QUESTION

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants.GUI_EXCEPTION_MESSAGE Field

public const GUI_EXCEPTION_MESSAGE GUI_EXCEPTION_MESSAGE = "GUI_EXCEPTION_MESSAGE";

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants.INVALID_ACTION_MESSAGE Field

public const INVALID_ACTION_MESSAGE INVALID_ACTION_MESSAGE = "INVALID_ACTION_MESSAGE";

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants.INVALID_BULK_OPERATION_MESSAGE Field

public const INVALID_BULK_OPERATION_MESSAGE INVALID_BULK_OPERATION_MESSAGE = "INVALID_BULK_OPERATION_MESSAGE";

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants.INVALID_ENTITY_ID_MESSAGE Field

public const INVALID_ENTITY_ID_MESSAGE INVALID_ENTITY_ID_MESSAGE = "INVALID_ENTITY_ID_MESSAGE";

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants.INVALID_PARAMETER_VALUE Field

public const INVALID_PARAMETER_VALUE INVALID_PARAMETER_VALUE = "INVALID_PARAMETER_VALUE";

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants.INVALID_PROPERTIES_MESSAGE Field

public const INVALID_PROPERTIES_MESSAGE INVALID_PROPERTIES_MESSAGE = "INVALID_PROPERTIES_MESSAGE";

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants.REMOVE_BUTTON_QUESTION Field

public const REMOVE_BUTTON_QUESTION REMOVE_BUTTON_QUESTION = "REMOVE_BUTTON_QUESTION";

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants Methods

The methods of the ButtonBarConstants class are listed below. For a complete list of ButtonBarConstants class members, see the ButtonBarConstants Members topic.

Public Static Methods

GetString Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


GetString Method

Aptify 5.0 Software Development Kit (SDK)

ButtonBarConstants.GetString Method

Overload List

public static string GetString(String);

public static string GetString(String,params String[]);

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarConstants.GetString Method (String)

public static string GetString(
String Text
);

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace | ButtonBarConstants.GetString Overload List


ButtonBarConstants.GetString Method (String, String[])

public static string GetString(
String Text,
params String[] FormatParameters
);

See Also

ButtonBarConstants Class | Aptify.Framework.DigitalDashboard.Components Namespace | ButtonBarConstants.GetString Overload List


ButtonBarProperties Members

ButtonBarProperties overview

Public Instance Constructors

ButtonBarProperties Constructor Initializes a new instance of the ButtonBarProperties class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ButtonBarProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarProperties Constructor

Initializes a new instance of the ButtonBarProperties class.

public ButtonBarProperties();

See Also

ButtonBarProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarProperties Methods

The methods of the ButtonBarProperties class are listed below. For a complete list of ButtonBarProperties class members, see the ButtonBarProperties Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ButtonBarProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarProperties.ApplySkin Method

protected virtual void ApplySkin();

See Also

ButtonBarProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarProperties.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

ButtonBarProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ButtonBarProperties.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ButtonBarProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarProperties.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ButtonBarProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace | ButtonBarProperties.Dispose Overload List


ButtonBarProperties.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

ButtonBarProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


ButtonBarProperties.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

ButtonBarProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


EntityBulkOperationsStatusForm Class

For a list of all members of this type, see EntityBulkOperationsStatusForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EntityBulkOperationsStatusForm

public class EntityBulkOperationsStatusForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

EntityBulkOperationsStatusForm Members | Aptify.Framework.DigitalDashboard.Components Namespace


EntityBulkOperationsStatusForm Members

EntityBulkOperationsStatusForm overview

Public Instance Constructors

EntityBulkOperationsStatusForm Constructor Initializes a new instance of the EntityBulkOperationsStatusForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
RunEntityBulkOperation | Starts running the Entity Bulk Operation Specified
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationsStatusForm Class | Aptify.Framework.DigitalDashboard.Components Namespace


EntityBulkOperationsStatusForm Constructor

Initializes a new instance of the EntityBulkOperationsStatusForm class.

public EntityBulkOperationsStatusForm();

See Also

EntityBulkOperationsStatusForm Class | Aptify.Framework.DigitalDashboard.Components Namespace


EntityBulkOperationsStatusForm Methods

The methods of the EntityBulkOperationsStatusForm class are listed below. For a complete list of EntityBulkOperationsStatusForm class members, see the EntityBulkOperationsStatusForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
RunEntityBulkOperation | Starts running the Entity Bulk Operation Specified
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationsStatusForm Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationsStatusForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EntityBulkOperationsStatusForm Class | Aptify.Framework.DigitalDashboard.Components Namespace


EntityBulkOperationsStatusForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EntityBulkOperationsStatusForm Class | Aptify.Framework.DigitalDashboard.Components Namespace | EntityBulkOperationsStatusForm.Dispose Overload List


EntityBulkOperationsStatusForm.RunEntityBulkOperation Method

Starts running the Entity Bulk Operation Specified

public void RunEntityBulkOperation(
AptifyApplication ApplicationObject,
Int64 EntityBulkOperationID,
Int64 ViewID,
params Object[] PromptValues
);

Parameters

ApplicationObject
An instantiated Application Object.
EntityBulkOperationID
The Id of the Entity Bulk Operation to run.
ViewID
The Id of the View to run the Entity Bulk Operation on.
PromptValues
An array of prompt values that should be used. This value can be nothing.

See Also

EntityBulkOperationsStatusForm Class | Aptify.Framework.DigitalDashboard.Components Namespace


EntityDisplayMode Enumeration

A dashboard component that allows users to quickly access Most Recently Used Records.

public enum EntityDisplayMode

Members

Member Name | Description
AllEntities |
Filtered |

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyMostRecentlyUsed (in AptifyMostRecentlyUsed.dll)

See Also

Aptify.Framework.DigitalDashboard.Components Namespace


FindDlgParams Class

For a list of all members of this type, see FindDlgParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FindDlgParams

public class FindDlgParams : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

FindDlgParams Members | Aptify.Framework.DigitalDashboard.Components Namespace


FindDlgParams Members

FindDlgParams overview

Public Instance Constructors

FindDlgParams Constructor Initializes a new instance of the FindDlgParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FindDlgParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


FindDlgParams Constructor

Initializes a new instance of the FindDlgParams class.

public FindDlgParams();

See Also

FindDlgParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


FindDlgParams Methods

The methods of the FindDlgParams class are listed below. For a complete list of FindDlgParams class members, see the FindDlgParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FindDlgParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


FindDlgParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

FindDlgParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

FindDlgParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

FindDlgParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


FindDlgParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

FindDlgParams Class | Aptify.Framework.DigitalDashboard.Components Namespace | FindDlgParams.Dispose Overload List


FindDlgParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

FindDlgParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


FindDlgParams.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

FindDlgParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


GenericDataWizardParams Class

This class will provide functionality to add and run Aptify Generic Data Wizard from Dashboard

For a list of all members of this type, see GenericDataWizardParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
GenericDataWizardParams

public class GenericDataWizardParams : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

GenericDataWizardParams Members | Aptify.Framework.DigitalDashboard.Components Namespace


GenericDataWizardParams Members

GenericDataWizardParams overview

Public Instance Constructors

GenericDataWizardParams Constructor Initializes a new instance of the GenericDataWizardParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AreaId |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GenericDataWizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


GenericDataWizardParams Constructor

Initializes a new instance of the GenericDataWizardParams class.

public GenericDataWizardParams();

See Also

GenericDataWizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


GenericDataWizardParams Properties

The properties of the GenericDataWizardParams class are listed below. For a complete list of GenericDataWizardParams class members, see the GenericDataWizardParams Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AreaId |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GenericDataWizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


AreaId Property

Aptify 5.0 Software Development Kit (SDK)

GenericDataWizardParams.AreaId Property

public Int64 AreaId {set;}

See Also

GenericDataWizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


GenericDataWizardParams Methods

The methods of the GenericDataWizardParams class are listed below. For a complete list of GenericDataWizardParams class members, see the GenericDataWizardParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GenericDataWizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


GenericDataWizardParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

GenericDataWizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

GenericDataWizardParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

GenericDataWizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


GenericDataWizardParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

GenericDataWizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace | GenericDataWizardParams.Dispose Overload List


GenericDataWizardParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

GenericDataWizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


GenericDataWizardParams.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

GenericDataWizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsed Class

Dashboard comopnent displays the most recently used(either opened or modified) records within the system. Only entities that have enabled the MRU (via Entity Administration) will appear here as there is overhead in tracking MRU but since it is a valuable user feature the overhead maybe worth it for quite a few entity areas. Each installation of the system can configure which entities should have MRU tracking turned on/off.

For a list of all members of this type, see MostRecentlyUsed Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
MostRecentlyUsed

public class MostRecentlyUsed : UserControl, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyMostRecentlyUsed (in AptifyMostRecentlyUsed.dll)

See Also

MostRecentlyUsed Members | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsed Members

MostRecentlyUsed overview

Public Instance Constructors

MostRecentlyUsed Constructor Initializes a new instance of the MostRecentlyUsed class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Configures the Most Recently Used component for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EntityRecordExists |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetEntityIcon | This method is responsible for returning an icon from the repository based on the entity's definition. The method will both retrieve the object from the repository as well as load it up into memory. The method employes a caching model so that entity icons are not reloaded after the first request.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetViewIcon | This method is responsible for returning an icon from the repository based on the view's definition. The method will both retrieve the object from the repository as well as load it up into memory. The method employs a caching model so that views' icons are not reloaded after the first request.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsed Constructor

Initializes a new instance of the MostRecentlyUsed class.

public MostRecentlyUsed();

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsed Properties

The properties of the MostRecentlyUsed class are listed below. For a complete list of MostRecentlyUsed class members, see the MostRecentlyUsed Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsed.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsed.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsed.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsed.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsed Methods

The methods of the MostRecentlyUsed class are listed below. For a complete list of MostRecentlyUsed class members, see the MostRecentlyUsed Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Configures the Most Recently Used component for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EntityRecordExists |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetEntityIcon | This method is responsible for returning an icon from the repository based on the entity's definition. The method will both retrieve the object from the repository as well as load it up into memory. The method employes a caching model so that entity icons are not reloaded after the first request.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetViewIcon | This method is responsible for returning an icon from the repository based on the view's definition. The method will both retrieve the object from the repository as well as load it up into memory. The method employs a caching model so that views' icons are not reloaded after the first request.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsed.Config Method

Configures the Most Recently Used component for use.

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Parameters

ApplicationObject
Area
PartID
Orientation

Implements

IDashboardComponent.

Remarks

This should be called after the control's Load event has fired, but before any other members have been called.

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsed.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsed.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace | MostRecentlyUsed.Dispose Overload List


MostRecentlyUsed.EntityRecordExists Method

protected virtual bool EntityRecordExists(
String EntityName,
Int64 RecordID
);

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsed.GetEntityIcon Method

This method is responsible for returning an icon from the repository based on the entity's definition. The method will both retrieve the object from the repository as well as load it up into memory. The method employes a caching model so that entity icons are not reloaded after the first request.

protected virtual Image GetEntityIcon(
String EntityName
);

Parameters

EntityName

Return Value

Remarks

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsed.GetViewIcon Method

This method is responsible for returning an icon from the repository based on the view's definition. The method will both retrieve the object from the repository as well as load it up into memory. The method employs a caching model so that views' icons are not reloaded after the first request.

protected virtual Image GetViewIcon(
String sRepositoryIcon
);

Parameters

sRepositoryIcon

Return Value

Remarks

See Also

MostRecentlyUsed Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetails Class

A dashboard component that allows users to quickly access Most Recently Used Records.

For a list of all members of this type, see MostRecentlyUsedDetails Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
MostRecentlyUsedDetails

public class MostRecentlyUsedDetails : UserControl, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyMostRecentlyUsed (in AptifyMostRecentlyUsed.dll)

See Also

MostRecentlyUsedDetails Members | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetails Members

MostRecentlyUsedDetails overview

Public Instance Constructors

MostRecentlyUsedDetails Constructor Initializes a new instance of the MostRecentlyUsedDetails class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Configures the Most Recently Used component for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetViewIcon | This method is responsible for returning an icon from the repository based on the view's definition. The method will both retrieve the object from the repository as well as load it up into memory. The method employes a caching model so that views' icons are not reloaded after the first request.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetails Constructor

Initializes a new instance of the MostRecentlyUsedDetails class.

public MostRecentlyUsedDetails();

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetails Properties

The properties of the MostRecentlyUsedDetails class are listed below. For a complete list of MostRecentlyUsedDetails class members, see the MostRecentlyUsedDetails Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsedDetails.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsedDetails.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsedDetails.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsedDetails.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetails Methods

The methods of the MostRecentlyUsedDetails class are listed below. For a complete list of MostRecentlyUsedDetails class members, see the MostRecentlyUsedDetails Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Configures the Most Recently Used component for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetViewIcon | This method is responsible for returning an icon from the repository based on the view's definition. The method will both retrieve the object from the repository as well as load it up into memory. The method employes a caching model so that views' icons are not reloaded after the first request.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetails.Config Method

Configures the Most Recently Used component for use.

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Parameters

ApplicationObject
Area
PartID
Orientation

Implements

IDashboardComponent.

Remarks

This should be called after the control's Load event has fired, but before any other members have been called.

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsedDetails.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetails.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace | MostRecentlyUsedDetails.Dispose Overload List


MostRecentlyUsedDetails.GetViewIcon Method

This method is responsible for returning an icon from the repository based on the view's definition. The method will both retrieve the object from the repository as well as load it up into memory. The method employes a caching model so that views' icons are not reloaded after the first request.

protected virtual int GetViewIcon(
String sRepositoryIcon
);

Parameters

sRepositoryIcon

Return Value

Remarks

See Also

MostRecentlyUsedDetails Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetailsForm Class

For a list of all members of this type, see MostRecentlyUsedDetailsForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
MostRecentlyUsedDetailsForm

public class MostRecentlyUsedDetailsForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyMostRecentlyUsed (in AptifyMostRecentlyUsed.dll)

See Also

MostRecentlyUsedDetailsForm Members | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetailsForm Members

MostRecentlyUsedDetailsForm overview

Public Instance Constructors

MostRecentlyUsedDetailsForm Constructor Initializes a new instance of the MostRecentlyUsedDetailsForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MostRecentlyUsedDetailsForm Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetailsForm Constructor

Initializes a new instance of the MostRecentlyUsedDetailsForm class.

public MostRecentlyUsedDetailsForm();

See Also

MostRecentlyUsedDetailsForm Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetailsForm Methods

The methods of the MostRecentlyUsedDetailsForm class are listed below. For a complete list of MostRecentlyUsedDetailsForm class members, see the MostRecentlyUsedDetailsForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MostRecentlyUsedDetailsForm Class | Aptify.Framework.DigitalDashboard.Components Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsedDetailsForm.Config Method

Overload List

public void Config(AptifyApplication,IDashboardArea,Int64,ComponentOrientation,EntityDisplayMode,String);

public void Config(AptifyApplication,IDashboardArea,Int64,ComponentOrientation,EntityDisplayMode,String,Boolean);

See Also

MostRecentlyUsedDetailsForm Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetailsForm.Config Method (AptifyApplication, IDashboardArea, Int64, ComponentOrientation, EntityDisplayMode, String)

public void Config(
AptifyApplication Application,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation,
EntityDisplayMode EntityMode,
String EntityFilter
);

See Also

MostRecentlyUsedDetailsForm Class | Aptify.Framework.DigitalDashboard.Components Namespace | MostRecentlyUsedDetailsForm.Config Overload List


MostRecentlyUsedDetailsForm.Config Method (AptifyApplication, IDashboardArea, Int64, ComponentOrientation, EntityDisplayMode, String, Boolean)

public void Config(
AptifyApplication Application,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation,
EntityDisplayMode EntityMode,
String EntityFilter,
Boolean IsMRUView
);

See Also

MostRecentlyUsedDetailsForm Class | Aptify.Framework.DigitalDashboard.Components Namespace | MostRecentlyUsedDetailsForm.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

MostRecentlyUsedDetailsForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

MostRecentlyUsedDetailsForm Class | Aptify.Framework.DigitalDashboard.Components Namespace


MostRecentlyUsedDetailsForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

MostRecentlyUsedDetailsForm Class | Aptify.Framework.DigitalDashboard.Components Namespace | MostRecentlyUsedDetailsForm.Dispose Overload List


MRUProperties Class

For a list of all members of this type, see MRUProperties Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
MRUProperties

public class MRUProperties : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyMostRecentlyUsed (in AptifyMostRecentlyUsed.dll)

See Also

MRUProperties Members | Aptify.Framework.DigitalDashboard.Components Namespace


MRUProperties Members

MRUProperties overview

Public Instance Constructors

MRUProperties Constructor Initializes a new instance of the MRUProperties class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MRUProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


MRUProperties Constructor

Initializes a new instance of the MRUProperties class.

public MRUProperties();

See Also

MRUProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


MRUProperties Methods

The methods of the MRUProperties class are listed below. For a complete list of MRUProperties class members, see the MRUProperties Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MRUProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


MRUProperties.ApplySkin Method

protected virtual void ApplySkin();

See Also

MRUProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


MRUProperties.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

MRUProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

MRUProperties.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

MRUProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


MRUProperties.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

MRUProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace | MRUProperties.Dispose Overload List


MRUProperties.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

MRUProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


MRUProperties.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

MRUProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard Class

For a list of all members of this type, see ObjectRepositoryDashboard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ObjectRepositoryDashboard

public class ObjectRepositoryDashboard : UserControl, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyObjectRepositoryDashboard (in AptifyObjectRepositoryDashboard.dll)

See Also

ObjectRepositoryDashboard Members | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard Members

ObjectRepositoryDashboard overview

Public Instance Constructors

ObjectRepositoryDashboard Constructor Initializes a new instance of the ObjectRepositoryDashboard class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
mnuDownloadObject_Click |
mnuDownloadObject_Popup |
mnuNew_Click |
mnuNew_Popup |
mnuOpen_Click |
mnuOpen_Popup |
mnuRefresh_Click |
mnuRefresh_Popup |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard Constructor

Initializes a new instance of the ObjectRepositoryDashboard class.

public ObjectRepositoryDashboard();

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard Properties

The properties of the ObjectRepositoryDashboard class are listed below. For a complete list of ObjectRepositoryDashboard class members, see the ObjectRepositoryDashboard Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ObjectRepositoryDashboard.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

ObjectRepositoryDashboard.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

ObjectRepositoryDashboard.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

ObjectRepositoryDashboard.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard Methods

The methods of the ObjectRepositoryDashboard class are listed below. For a complete list of ObjectRepositoryDashboard class members, see the ObjectRepositoryDashboard Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
mnuDownloadObject_Click |
mnuDownloadObject_Popup |
mnuNew_Click |
mnuNew_Popup |
mnuOpen_Click |
mnuOpen_Popup |
mnuRefresh_Click |
mnuRefresh_Popup |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard.ApplySkin Method

protected virtual void ApplySkin();

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard.Config Method

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Implements

IDashboardComponent.

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ObjectRepositoryDashboard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace | ObjectRepositoryDashboard.Dispose Overload List


ObjectRepositoryDashboard.mnuDownloadObject_Click Method

public void mnuDownloadObject_Click(
Object eventSender,
EventArgs eventArgs
);

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard.mnuDownloadObject_Popup Method

public void mnuDownloadObject_Popup(
Object eventSender,
EventArgs eventArgs
);

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard.mnuNew_Click Method

public void mnuNew_Click(
Object eventSender,
EventArgs eventArgs
);

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard.mnuNew_Popup Method

public void mnuNew_Popup(
Object eventSender,
EventArgs eventArgs
);

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard.mnuOpen_Click Method

public void mnuOpen_Click(
Object eventSender,
EventArgs eventArgs
);

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard.mnuOpen_Popup Method

public void mnuOpen_Popup(
Object eventSender,
EventArgs eventArgs
);

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard.mnuRefresh_Click Method

public void mnuRefresh_Click(
Object eventSender,
EventArgs eventArgs
);

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


ObjectRepositoryDashboard.mnuRefresh_Popup Method

public void mnuRefresh_Popup(
Object eventSender,
EventArgs eventArgs
);

See Also

ObjectRepositoryDashboard Class | Aptify.Framework.DigitalDashboard.Components Namespace


OpenFormParams Class

For a list of all members of this type, see OpenFormParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
OpenFormParams

public class OpenFormParams : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

OpenFormParams Members | Aptify.Framework.DigitalDashboard.Components Namespace


OpenFormParams Members

OpenFormParams overview

Public Instance Constructors

OpenFormParams Constructor Initializes a new instance of the OpenFormParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OpenFormParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


OpenFormParams Constructor

Initializes a new instance of the OpenFormParams class.

public OpenFormParams();

See Also

OpenFormParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


OpenFormParams Methods

The methods of the OpenFormParams class are listed below. For a complete list of OpenFormParams class members, see the OpenFormParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OpenFormParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


OpenFormParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

OpenFormParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OpenFormParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OpenFormParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


OpenFormParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OpenFormParams Class | Aptify.Framework.DigitalDashboard.Components Namespace | OpenFormParams.Dispose Overload List


OpenFormParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

OpenFormParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


OpenFormParams.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

OpenFormParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookView Class

For a list of all members of this type, see OutlookView Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
OutlookView

public class OutlookView : UserControl, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyOfficeDashboards (in AptifyOfficeDashboards.dll)

See Also

OutlookView Members | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookView Members

OutlookView overview

Public Static Fields

FOLDER_ATTRIBUTE

Public Instance Constructors

OutlookView Constructor Initializes a new instance of the OutlookView class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Folder |
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookView Constructor

Initializes a new instance of the OutlookView class.

public OutlookView();

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookView Fields

The fields of the OutlookView class are listed below. For a complete list of OutlookView class members, see the OutlookView Members topic.

Public Static Fields

FOLDER_ATTRIBUTE

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookView.FOLDER_ATTRIBUTE Field

public const FOLDER_ATTRIBUTE FOLDER_ATTRIBUTE = "Folder";

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookViewProperties Class

For a list of all members of this type, see OutlookViewProperties Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
OutlookViewProperties

public class OutlookViewProperties : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyOfficeDashboards (in AptifyOfficeDashboards.dll)

See Also

OutlookViewProperties Members | Aptify.Framework.DigitalDashboard.Components Namespace


Folder Property

Aptify 5.0 Software Development Kit (SDK)

OutlookView.Folder Property

public String Folder {get; set;}

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OutlookView.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

OutlookView.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

OutlookView.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

OutlookView.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookView Methods

The methods of the OutlookView class are listed below. For a complete list of OutlookView class members, see the OutlookView Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookView.Config Method

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Implements

IDashboardComponent.

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OutlookView.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookView.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OutlookView Class | Aptify.Framework.DigitalDashboard.Components Namespace | OutlookView.Dispose Overload List


OutlookViewProperties Members

OutlookViewProperties overview

Public Instance Constructors

OutlookViewProperties Constructor Initializes a new instance of the OutlookViewProperties class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OutlookViewProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookViewProperties Constructor

Initializes a new instance of the OutlookViewProperties class.

public OutlookViewProperties();

See Also

OutlookViewProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookViewProperties Methods

The methods of the OutlookViewProperties class are listed below. For a complete list of OutlookViewProperties class members, see the OutlookViewProperties Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OutlookViewProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookViewProperties.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

OutlookViewProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OutlookViewProperties.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OutlookViewProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookViewProperties.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OutlookViewProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace | OutlookViewProperties.Dispose Overload List


OutlookViewProperties.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

OutlookViewProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


OutlookViewProperties.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

OutlookViewProperties Class | Aptify.Framework.DigitalDashboard.Components Namespace


ProcessFlowParams Class

For a list of all members of this type, see ProcessFlowParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ProcessFlowParams

public class ProcessFlowParams : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

ProcessFlowParams Members | Aptify.Framework.DigitalDashboard.Components Namespace


ProcessFlowParams Members

ProcessFlowParams overview

Public Instance Constructors

ProcessFlowParams Constructor Initializes a new instance of the ProcessFlowParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


ProcessFlowParams Constructor

Initializes a new instance of the ProcessFlowParams class.

public ProcessFlowParams();

See Also

ProcessFlowParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


ProcessFlowParams Methods

The methods of the ProcessFlowParams class are listed below. For a complete list of ProcessFlowParams class members, see the ProcessFlowParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


ProcessFlowParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

ProcessFlowParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ProcessFlowParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


ProcessFlowParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ProcessFlowParams Class | Aptify.Framework.DigitalDashboard.Components Namespace | ProcessFlowParams.Dispose Overload List


ProcessFlowParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

ProcessFlowParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


ProcessFlowParams.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

ProcessFlowParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


ReportParams Class

For a list of all members of this type, see ReportParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ReportParams

public class ReportParams : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

ReportParams Members | Aptify.Framework.DigitalDashboard.Components Namespace


ReportParams Members

ReportParams overview

Public Instance Constructors

ReportParams Constructor Initializes a new instance of the ReportParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ReportParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


ReportParams Constructor

Initializes a new instance of the ReportParams class.

public ReportParams();

See Also

ReportParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


ReportParams Methods

The methods of the ReportParams class are listed below. For a complete list of ReportParams class members, see the ReportParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ReportParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


ReportParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

ReportParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ReportParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ReportParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


ReportParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ReportParams Class | Aptify.Framework.DigitalDashboard.Components Namespace | ReportParams.Dispose Overload List


ReportParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

ReportParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


ReportParams.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

ReportParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


SwitchDashboardParams Class

For a list of all members of this type, see SwitchDashboardParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
SwitchDashboardParams

public class SwitchDashboardParams : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

SwitchDashboardParams Members | Aptify.Framework.DigitalDashboard.Components Namespace


SwitchDashboardParams Members

SwitchDashboardParams overview

Public Instance Constructors

SwitchDashboardParams Constructor Initializes a new instance of the SwitchDashboardParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SwitchDashboardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


SwitchDashboardParams Constructor

Initializes a new instance of the SwitchDashboardParams class.

public SwitchDashboardParams();

See Also

SwitchDashboardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


SwitchDashboardParams Methods

The methods of the SwitchDashboardParams class are listed below. For a complete list of SwitchDashboardParams class members, see the SwitchDashboardParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SwitchDashboardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


SwitchDashboardParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

SwitchDashboardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SwitchDashboardParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SwitchDashboardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


SwitchDashboardParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SwitchDashboardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace | SwitchDashboardParams.Dispose Overload List


SwitchDashboardParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

SwitchDashboardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


SwitchDashboardParams.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

SwitchDashboardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebBrowser Class

For a list of all members of this type, see WebBrowser Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
WebBrowser

public class WebBrowser : UserControl, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyWebBrowserDashboard (in AptifyWebBrowserDashboard.dll)

See Also

WebBrowser Members | Aptify.Framework.DigitalDashboard.Components Namespace


WebBrowser Members

WebBrowser overview

Public Static Fields

SHOW_TOOLBAR_ATTRIBUTE
WEB_PAGE_ATTRIBUTE

Public Instance Constructors

WebBrowser Constructor Initializes a new instance of the WebBrowser class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowToolBar |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
WebPage |
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebBrowser Constructor

Initializes a new instance of the WebBrowser class.

public WebBrowser();

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebBrowser Fields

The fields of the WebBrowser class are listed below. For a complete list of WebBrowser class members, see the WebBrowser Members topic.

Public Static Fields

SHOW_TOOLBAR_ATTRIBUTE
WEB_PAGE_ATTRIBUTE

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebBrowser.SHOW_TOOLBAR_ATTRIBUTE Field

public const SHOW_TOOLBAR_ATTRIBUTE SHOW_TOOLBAR_ATTRIBUTE = "Show Toolbar";

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebBrowser.WEB_PAGE_ATTRIBUTE Field

public const WEB_PAGE_ATTRIBUTE WEB_PAGE_ATTRIBUTE = "Web Page";

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebBrowser Properties

The properties of the WebBrowser class are listed below. For a complete list of WebBrowser class members, see the WebBrowser Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowToolBar |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
WebPage |
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

WebBrowser.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

WebBrowser.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

WebBrowser.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


ShowToolBar Property

Aptify 5.0 Software Development Kit (SDK)

WebBrowser.ShowToolBar Property

public Boolean ShowToolBar {get; set;}

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

WebBrowser.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebPage Property

Aptify 5.0 Software Development Kit (SDK)

WebBrowser.WebPage Property

public String WebPage {get; set;}

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebBrowser Methods

The methods of the WebBrowser class are listed below. For a complete list of WebBrowser class members, see the WebBrowser Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebBrowser.Config Method

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Implements

IDashboardComponent.

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

WebBrowser.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebBrowser.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

WebBrowser Class | Aptify.Framework.DigitalDashboard.Components Namespace | WebBrowser.Dispose Overload List


WebDashProps Class

For a list of all members of this type, see WebDashProps Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
WebDashProps

public class WebDashProps : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyWebBrowserDashboard (in AptifyWebBrowserDashboard.dll)

See Also

WebDashProps Members | Aptify.Framework.DigitalDashboard.Components Namespace


WebDashProps Members

WebDashProps overview

Public Instance Constructors

WebDashProps Constructor Initializes a new instance of the WebDashProps class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

WebDashProps Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebDashProps Constructor

Initializes a new instance of the WebDashProps class.

public WebDashProps();

See Also

WebDashProps Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebDashProps Methods

The methods of the WebDashProps class are listed below. For a complete list of WebDashProps class members, see the WebDashProps Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

WebDashProps Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebDashProps.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

WebDashProps Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

WebDashProps.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

WebDashProps Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebDashProps.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

WebDashProps Class | Aptify.Framework.DigitalDashboard.Components Namespace | WebDashProps.Dispose Overload List


WebDashProps.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

WebDashProps Class | Aptify.Framework.DigitalDashboard.Components Namespace


WebDashProps.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

WebDashProps Class | Aptify.Framework.DigitalDashboard.Components Namespace


WizardParams Class

For a list of all members of this type, see WizardParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
WizardParams

public class WizardParams : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.DigitalDashboard.Components

Assembly: AptifyDashboardButtonBar (in AptifyDashboardButtonBar.dll)

See Also

WizardParams Members | Aptify.Framework.DigitalDashboard.Components Namespace


WizardParams Members

WizardParams overview

Public Instance Constructors

WizardParams Constructor Initializes a new instance of the WizardParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

WizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


WizardParams Constructor

Initializes a new instance of the WizardParams class.

public WizardParams();

See Also

WizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


WizardParams Methods

The methods of the WizardParams class are listed below. For a complete list of WizardParams class members, see the WizardParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

WizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


WizardParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

WizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

WizardParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

WizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


WizardParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

WizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace | WizardParams.Dispose Overload List


WizardParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

WizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


WizardParams.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

WizardParams Class | Aptify.Framework.DigitalDashboard.Components Namespace


Aptify.Framework.EntityPacker

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.EntityPacker Namespace

This namespace contains the objects related to Aptify's Entity Packer and Unpacker wizards that are used to copy entities on a source server and then install them on a target server.

Namespace hierarchy

Classes

Class | Description
AptifyEntityPackerException |
DatabaseObjectInformation |
DatabaseObjectInformationCollection |
DBObjectPackException | Thrown when a DBObject fails to Unpack.
EntityPacker |
EntityPackerAction | Provides the user interface for the standard Aptify Entity Packer Wizard.
EntityPackerGUI |
EntityUpgrade |
FieldChange |
FieldChangeCollection |
FieldDifference |
FieldDifferenceCollection |
GenericEntityBaseCollection |
InstallWizard |
SelectDBObject |
SelectEntities |
StatusForm |

Structures

Structure | Description
EntityOptions | Holds the different options that can be used when packing Entities.

Delegates

Delegate | Description
EntityPacker.ProgressEventHandler |

Enumerations

Enumeration | Description
FieldChangeType |


AptifyEntityPackerException Class

For a list of all members of this type, see AptifyEntityPackerException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyEntityPackerException
DBObjectPackException

public class AptifyEntityPackerException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.EntityPacker

Assembly: AptifyEntityPacker (in AptifyEntityPacker.dll)

See Also

AptifyEntityPackerException Members | Aptify.Framework.EntityPacker Namespace


AptifyEntityPackerException Members

AptifyEntityPackerException overview

Public Instance Constructors

AptifyEntityPackerException Overloaded. Initializes a new instance of the AptifyEntityPackerException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyEntityPackerException Overloaded. Initializes a new instance of the AptifyEntityPackerException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEntityPackerException Class | Aptify.Framework.EntityPacker Namespace


AptifyEntityPackerException Constructor

Overload List

protected AptifyEntityPackerException(SerializationInfo,StreamingContext);

public AptifyEntityPackerException(String);

public AptifyEntityPackerException(String,Exception);

See Also

AptifyEntityPackerException Class | Aptify.Framework.EntityPacker Namespace


AptifyEntityPackerException Constructor (String)

public AptifyEntityPackerException(
String Message
);

See Also

AptifyEntityPackerException Class | Aptify.Framework.EntityPacker Namespace | AptifyEntityPackerException Constructor Overload List


AptifyEntityPackerException Constructor (String, Exception)

public AptifyEntityPackerException(
String Message,
Exception InnerException
);

See Also

AptifyEntityPackerException Class | Aptify.Framework.EntityPacker Namespace | AptifyEntityPackerException Constructor Overload List


AptifyEntityPackerException Constructor (SerializationInfo, StreamingContext)

protected AptifyEntityPackerException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyEntityPackerException Class | Aptify.Framework.EntityPacker Namespace | AptifyEntityPackerException Constructor Overload List


AptifyEntityPackerException Methods

The methods of the AptifyEntityPackerException class are listed below. For a complete list of AptifyEntityPackerException class members, see the AptifyEntityPackerException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEntityPackerException Class | Aptify.Framework.EntityPacker Namespace


AptifyEntityPackerException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyEntityPackerException Class | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformation Class

For a list of all members of this type, see DatabaseObjectInformation Members.

System.Object
DatabaseObjectInformation

public class DatabaseObjectInformation : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.EntityPacker

Assembly: AptifyEntityPacker (in AptifyEntityPacker.dll)

See Also

DatabaseObjectInformation Members | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformation Members

DatabaseObjectInformation overview

Public Instance Constructors

DatabaseObjectInformation Overloaded. Initializes a new instance of the DatabaseObjectInformation class.

Public Instance Properties

BaseDatabase
Description
Name
NewSQL
OldSQL
Path
Upgrade

Public Instance Methods

Clone |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformation Constructor

Overload List

public DatabaseObjectInformation(String,String,String,String,String,String);

public DatabaseObjectInformation(String,String,String,String,String,String,Boolean);

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformation Constructor (String, String, String, String, String, String, Boolean)

public DatabaseObjectInformation(
String BaseDataBase,
String Name,
String Description,
String Path,
String NewSQL,
String OldSQL,
Boolean Upgrade
);

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace | DatabaseObjectInformation Constructor Overload List


DatabaseObjectInformation Constructor (String, String, String, String, String, String)

public DatabaseObjectInformation(
String BaseDataBase,
String Name,
String Description,
String Path,
String NewSQL,
String OldSQL
);

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace | DatabaseObjectInformation Constructor Overload List


DatabaseObjectInformation Properties

The properties of the DatabaseObjectInformation class are listed below. For a complete list of DatabaseObjectInformation class members, see the DatabaseObjectInformation Members topic.

Public Instance Properties

BaseDatabase
Description
Name
NewSQL
OldSQL
Path
Upgrade

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


BaseDatabase Property

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectInformation.BaseDatabase Property

public String BaseDatabase {get;}

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectInformation.Description Property

public String Description {get;}

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectInformation.Name Property

public String Name {get;}

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


NewSQL Property

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectInformation.NewSQL Property

public String NewSQL {get;}

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


OldSQL Property

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectInformation.OldSQL Property

public String OldSQL {get;}

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


Path Property

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectInformation.Path Property

public String Path {get;}

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


Upgrade Property

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectInformation.Upgrade Property

public Boolean Upgrade {get; set;}

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformation Methods

The methods of the DatabaseObjectInformation class are listed below. For a complete list of DatabaseObjectInformation class members, see the DatabaseObjectInformation Members topic.

Public Instance Methods

Clone |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformation.Clone Method

public object Clone();

Implements

ICloneable.

See Also

DatabaseObjectInformation Class | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformationCollection Class

For a list of all members of this type, see DatabaseObjectInformationCollection Members.

System.Object
CollectionBase
DatabaseObjectInformationCollection

public class DatabaseObjectInformationCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.EntityPacker

Assembly: AptifyEntityPacker (in AptifyEntityPacker.dll)

See Also

DatabaseObjectInformationCollection Members | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformationCollection Members

DatabaseObjectInformationCollection overview

Public Instance Constructors

DatabaseObjectInformationCollection Constructor Initializes a new instance of the DatabaseObjectInformationCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item |

Public Instance Methods

Add |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DatabaseObjectInformationCollection Class | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformationCollection Constructor

Initializes a new instance of the DatabaseObjectInformationCollection class.

public DatabaseObjectInformationCollection();

See Also

DatabaseObjectInformationCollection Class | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformationCollection Properties

The properties of the DatabaseObjectInformationCollection class are listed below. For a complete list of DatabaseObjectInformationCollection class members, see the DatabaseObjectInformationCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item |

See Also

DatabaseObjectInformationCollection Class | Aptify.Framework.EntityPacker Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectInformationCollection.Item Property

public DatabaseObjectInformation this[
Int32 index
] {get;}

See Also

DatabaseObjectInformationCollection Class | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformationCollection Methods

The methods of the DatabaseObjectInformationCollection class are listed below. For a complete list of DatabaseObjectInformationCollection class members, see the DatabaseObjectInformationCollection Members topic.

Public Instance Methods

Add |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DatabaseObjectInformationCollection Class | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformationCollection.Add Method

public void Add(
DatabaseObjectInformation doi
);

See Also

DatabaseObjectInformationCollection Class | Aptify.Framework.EntityPacker Namespace


DatabaseObjectInformationCollection.Remove Method

public void Remove(
DatabaseObjectInformation doi
);

See Also

DatabaseObjectInformationCollection Class | Aptify.Framework.EntityPacker Namespace


DBObjectPackException Class

Thrown when a DBObject fails to Unpack.

For a list of all members of this type, see DBObjectPackException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyEntityPackerException
DBObjectPackException

public class DBObjectPackException : AptifyEntityPackerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If a DBObject is generated, then we will not attempt to unpack it. If an attempt to unpack a DBObject fails, then the DBObject will be generated and the process will continue.

Requirements

Namespace: Aptify.Framework.EntityPacker

Assembly: AptifyEntityPacker (in AptifyEntityPacker.dll)

See Also

DBObjectPackException Members | Aptify.Framework.EntityPacker Namespace


DBObjectPackException Members

DBObjectPackException overview

Public Instance Constructors

DBObjectPackException Overloaded. Initializes a new instance of the DBObjectPackException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyEntityPackerException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBObjectPackException Class | Aptify.Framework.EntityPacker Namespace


DBObjectPackException Constructor

Overload List

public DBObjectPackException(String);

public DBObjectPackException(String,Exception);

See Also

DBObjectPackException Class | Aptify.Framework.EntityPacker Namespace


DBObjectPackException Constructor (String)

public DBObjectPackException(
String Message
);

See Also

DBObjectPackException Class | Aptify.Framework.EntityPacker Namespace | DBObjectPackException Constructor Overload List


DBObjectPackException Constructor (String, Exception)

public DBObjectPackException(
String Message,
Exception InnerException
);

See Also

DBObjectPackException Class | Aptify.Framework.EntityPacker Namespace | DBObjectPackException Constructor Overload List


EntityOptions Structure

Holds the different options that can be used when packing Entities.

For a list of all members of this type, see EntityOptions Members.

System.Object
ValueType
EntityOptions

public struct EntityOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.EntityPacker

Assembly: AptifyEntityPacker (in AptifyEntityPacker.dll)

See Also

EntityOptions Members | Aptify.Framework.EntityPacker Namespace


EntityOptions Members

EntityOptions overview

Public Instance Constructors

EntityOptions Constructor

Public Instance Fields

EntityID
PackFormTemplates
PackProcessFlows

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

EntityOptions Structure | Aptify.Framework.EntityPacker Namespace


EntityOptions Constructor

public EntityOptions(
Int64 EntityID,
Boolean PackFormTemplates,
Boolean PackProcessFlows
);

See Also

EntityOptions Structure | Aptify.Framework.EntityPacker Namespace


EntityOptions Fields

The fields of the EntityOptions structure are listed below. For a complete list of EntityOptions structure members, see the EntityOptions Members topic.

Public Instance Fields

EntityID
PackFormTemplates
PackProcessFlows

See Also

EntityOptions Structure | Aptify.Framework.EntityPacker Namespace


EntityOptions.EntityID Field

public EntityID EntityID;

See Also

EntityOptions Class | Aptify.Framework.EntityPacker Namespace


EntityOptions.PackFormTemplates Field

public PackFormTemplates PackFormTemplates;

See Also

EntityOptions Class | Aptify.Framework.EntityPacker Namespace


EntityOptions.PackProcessFlows Field

public PackProcessFlows PackProcessFlows;

See Also

EntityOptions Class | Aptify.Framework.EntityPacker Namespace


EntityPacker Class

For a list of all members of this type, see EntityPacker Members.

System.Object
EntityPacker

public class EntityPacker

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.EntityPacker

Assembly: AptifyEntityPacker (in AptifyEntityPacker.dll)

See Also

EntityPacker Members | Aptify.Framework.EntityPacker Namespace


EntityPacker Members

EntityPacker overview

Public Instance Constructors

EntityPacker Constructor

Public Instance Properties

UpgradeOption

Public Instance Methods

CheckWarnings |
DoUpgradeDBObjects |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNonUpgradedDBObjects |
GetType (inherited from Object) | Gets the Type of the current instance.
PackEntities | Overloaded.
PackEntity | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnPackEntities | Overloaded.
UnpackEntity | Overloaded.

Public Instance Events

Progress

Protected Instance Properties

SpecialUpgradeBehavior

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UnPackRepositoryObjects |

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker Constructor

public EntityPacker(
UserCredentials UserCredential
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker Properties

The properties of the EntityPacker class are listed below. For a complete list of EntityPacker class members, see the EntityPacker Members topic.

Public Instance Properties

UpgradeOption

Protected Instance Properties

SpecialUpgradeBehavior

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


SpecialUpgradeBehavior Property

Aptify 5.0 Software Development Kit (SDK)

EntityPacker.SpecialUpgradeBehavior Property

protected virtual Boolean SpecialUpgradeBehavior {get;}

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


UpgradeOption Property

Aptify 5.0 Software Development Kit (SDK)

EntityPacker.UpgradeOption Property

public Boolean UpgradeOption {get; set;}

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker Methods

The methods of the EntityPacker class are listed below. For a complete list of EntityPacker class members, see the EntityPacker Members topic.

Public Instance Methods

CheckWarnings |
DoUpgradeDBObjects |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNonUpgradedDBObjects |
GetType (inherited from Object) | Gets the Type of the current instance.
PackEntities | Overloaded.
PackEntity | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnPackEntities | Overloaded.
UnpackEntity | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UnPackRepositoryObjects |

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker.CheckWarnings Method

public bool CheckWarnings(
ArrayList Warnings
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker.DoUpgradeDBObjects Method

public bool DoUpgradeDBObjects(
DatabaseObjectInformationCollection ObjectInformationCollection
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker.GetNonUpgradedDBObjects Method

public bool GetNonUpgradedDBObjects(
DatabaseObjectInformationCollection ObjectInformationCollection
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


PackEntities Method

Aptify 5.0 Software Development Kit (SDK)

EntityPacker.PackEntities Method

Overload List

public bool PackEntities(EntityOptions[],String);

public bool PackEntities(EntityOptions[],String,Boolean,Boolean,Boolean);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker.PackEntities Method (EntityOptions[], String)

public bool PackEntities(
EntityOptions[] Entities,
String TargetDir
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace | EntityPacker.PackEntities Overload List


EntityPacker.PackEntities Method (EntityOptions[], String, Boolean, Boolean, Boolean)

public bool PackEntities(
EntityOptions[] Entities,
String TargetDir,
Boolean IncludeDependentEntities,
Boolean IncludeDependentDBObjects,
Boolean IncludeDataSet
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace | EntityPacker.PackEntities Overload List


PackEntity Method

Aptify 5.0 Software Development Kit (SDK)

EntityPacker.PackEntity Method

Overload List

public bool PackEntity(EntityOptions,String,Boolean,Boolean,Boolean);

public bool PackEntity(EntityOptions,String,String);

public bool PackEntity(EntityOptions,String,String,Boolean,Boolean,Boolean);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker.PackEntity Method (EntityOptions, String, Boolean, Boolean, Boolean)

public bool PackEntity(
EntityOptions EntityOptions,
String TargetDir,
Boolean IncludeDependentEntities,
Boolean IncludeDependentObjects,
Boolean IncludeDataSet
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace | EntityPacker.PackEntity Overload List


EntityPacker.PackEntity Method (EntityOptions, String, String)

public bool PackEntity(
EntityOptions EntityOptions,
String TargetDir,
String BaseDir
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace | EntityPacker.PackEntity Overload List


EntityPacker.PackEntity Method (EntityOptions, String, String, Boolean, Boolean, Boolean)

public bool PackEntity(
EntityOptions EntityOptions,
String TargetDir,
String BaseDir,
Boolean IncludeDependentEntities,
Boolean IncludeDependentObjects,
Boolean IncludeDataSet
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace | EntityPacker.PackEntity Overload List


UnPackEntities Method

Aptify 5.0 Software Development Kit (SDK)

EntityPacker.UnPackEntities Method

Overload List

public virtual bool UnPackEntities(ArrayList,String);

public virtual bool UnPackEntities(ArrayList,String,Boolean,Boolean);

public virtual bool UnPackEntities(ArrayList,String,Boolean,Boolean,Boolean);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker.UnPackEntities Method (ArrayList, String)

public virtual bool UnPackEntities(
ArrayList SourceDirs,
String BaseDatabase
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace | EntityPacker.UnPackEntities Overload List


EntityPacker.UnPackEntities Method (ArrayList, String, Boolean, Boolean)

public virtual bool UnPackEntities(
ArrayList SourceDirs,
String BaseDatabase,
Boolean IncDepEntities,
Boolean IncDepDBObjects
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace | EntityPacker.UnPackEntities Overload List


EntityPacker.UnPackEntities Method (ArrayList, String, Boolean, Boolean, Boolean)

public virtual bool UnPackEntities(
ArrayList SourceDirs,
String BaseDatabase,
Boolean IncDepEntities,
Boolean IncDepDBObjects,
Boolean SpecialUpgradeBehavior
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace | EntityPacker.UnPackEntities Overload List


UnpackEntity Method

Aptify 5.0 Software Development Kit (SDK)

EntityPacker.UnpackEntity Method

Overload List

public bool UnpackEntity(String,String,String,Boolean,Boolean,Int64);

public bool UnpackEntity(String,String,String,Boolean,Boolean,Int64,Boolean);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker.UnpackEntity Method (String, String, String, Boolean, Boolean, Int64)

public bool UnpackEntity(
String sSourceDir,
String sBaseDir,
String sBaseDatabase,
Boolean bIncDepEntities,
Boolean bIncDepDBObjects,
Int64 lParentID
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace | EntityPacker.UnpackEntity Overload List


EntityPacker.UnpackEntity Method (String, String, String, Boolean, Boolean, Int64, Boolean)

public bool UnpackEntity(
String sSourceDir,
String sBaseDir,
String sBaseDatabase,
Boolean bIncDepEntities,
Boolean bIncDepDBObjects,
Int64 lParentID,
Boolean SpecialUpgradeBehavior
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace | EntityPacker.UnpackEntity Overload List


EntityPacker.UnPackRepositoryObjects Method

protected virtual bool UnPackRepositoryObjects(
AptifyGenericEntityBase oEntity,
String sSourceDir,
Boolean SpecialUpgradeBehavior
);

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker Events

The events of the EntityPacker class are listed below. For a complete list of EntityPacker class members, see the EntityPacker Members topic.

Public Instance Events

Progress

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker.EntityPacker.ProgressEventHandler Event

public event EntityPacker.ProgressEventHandler Progress;

See Also

EntityPacker Class | Aptify.Framework.EntityPacker Namespace


EntityPacker.ProgressEventHandler Delegate

public delegate void EntityPacker.ProgressEventHandler(
Int32 PercentComplete,
String Text,
Boolean AppendText
);

Requirements

Namespace: Aptify.Framework.EntityPacker

Assembly: AptifyEntityPacker (in AptifyEntityPacker.dll)

See Also

Aptify.Framework.EntityPacker Namespace


EntityPackerAction Class

Provides the user interface for the standard Aptify Entity Packer Wizard.

For a list of all members of this type, see EntityPackerAction Members.

System.Object
EntityPackerAction

public class EntityPackerAction : IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.EntityPacker

Assembly: AptifyEntityPackerGUI (in AptifyEntityPackerGUI.dll)

See Also

EntityPackerAction Members | Aptify.Framework.EntityPacker Namespace


EntityPackerAction Members

EntityPackerAction overview

Public Instance Constructors

EntityPackerAction Overloaded. Initializes a new instance of the EntityPackerAction class.

Public Instance Methods

DisplayPackDialog | Overloaded.
DisplayUnPackDialog |
DoAction | Overloaded. Configures and Displays the Entity Packer Wizard.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace


EntityPackerAction Constructor

Initializes a new instance of the EntityPackerAction class.

Overload List

Initializes a new instance of the EntityPackerAction class.

public EntityPackerAction();

public EntityPackerAction(UserCredentials);

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace


EntityPackerAction Constructor ()

Initializes a new instance of the EntityPackerAction class.

public EntityPackerAction();

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace | EntityPackerAction Constructor Overload List


EntityPackerAction Constructor (UserCredentials)

public EntityPackerAction(
UserCredentials UserCredential
);

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace | EntityPackerAction Constructor Overload List


EntityPackerAction Methods

The methods of the EntityPackerAction class are listed below. For a complete list of EntityPackerAction class members, see the EntityPackerAction Members topic.

Public Instance Methods

DisplayPackDialog | Overloaded.
DisplayUnPackDialog |
DoAction | Overloaded. Configures and Displays the Entity Packer Wizard.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace


DisplayPackDialog Method

Aptify 5.0 Software Development Kit (SDK)

EntityPackerAction.DisplayPackDialog Method

Overload List

public void DisplayPackDialog();

public void DisplayPackDialog(ArrayList);

public void DisplayPackDialog(Int64);

public void DisplayPackDialog(Int64,ArrayList);

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace


EntityPackerAction.DisplayPackDialog Method ()

public void DisplayPackDialog();

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace | EntityPackerAction.DisplayPackDialog Overload List


EntityPackerAction.DisplayPackDialog Method (ArrayList)

public void DisplayPackDialog(
ArrayList SelectList
);

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace | EntityPackerAction.DisplayPackDialog Overload List


EntityPackerAction.DisplayPackDialog Method (Int64)

public void DisplayPackDialog(
Int64 ViewID
);

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace | EntityPackerAction.DisplayPackDialog Overload List


EntityPackerAction.DisplayPackDialog Method (Int64, ArrayList)

public void DisplayPackDialog(
Int64 ViewID,
ArrayList SelectList
);

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace | EntityPackerAction.DisplayPackDialog Overload List


EntityPackerAction.DisplayUnPackDialog Method

public void DisplayUnPackDialog();

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

EntityPackerAction.DoAction Method

Configures and Displays the Entity Packer Wizard.

Overload List

Configures and Displays the Entity Packer Wizard.

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace


EntityPackerAction.DoAction Method (AptifyApplication, Int64)

Configures and Displays the Entity Packer Wizard.

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Parameters

ApplicationObject
EntityID

Implements

IAptifyAction.

Remarks

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace | EntityPackerAction.DoAction Overload List


EntityPackerAction.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace | EntityPackerAction.DoAction Overload List


EntityPackerAction.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace | EntityPackerAction.DoAction Overload List


EntityPackerAction.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

EntityPackerAction Class | Aptify.Framework.EntityPacker Namespace | EntityPackerAction.DoAction Overload List